Page 1 of 1

"BAD_WORK_UNIT (114 = 0x72)" Error

PostPosted: Thu May 03, 2018 6:01 pm
by oliverjdent
I have Windows 10 Pro on one of my folding machines. It just updated to 1803 (OS Build 17134.1). After the update the GPU generates the following error messages:
Code: Select all
16:22:34:WU00:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" "D:/My Folding/cores/" -dir 00 -suffix 01 -version 704 -lifeline 12544 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
16:22:34:WU00:FS01:Started FahCore on PID 9876
16:22:34:WU00:FS01:Core PID:3680
16:22:34:WU00:FS01:FahCore 0x21 started
16:22:35:WU00:FS01:0x21:*********************** Log Started 2018-05-03T16:22:34Z ***********************
16:22:35:WU00:FS01:0x21:Project: 13782 (Run 764, Clone 4, Gen 180)
16:22:35:WU00:FS01:0x21:Unit: 0x000000d10002894b5a78cf12476523c7
16:22:35:WU00:FS01:0x21:CPU: 0x00000000000000000000000000000000
16:22:35:WU00:FS01:0x21:Machine: 1
16:22:35:WU00:FS01:0x21:Reading tar file core.xml
16:22:35:WU00:FS01:0x21:Reading tar file integrator.xml
16:22:35:WU00:FS01:0x21:Reading tar file state.xml
16:22:35:WU00:FS01:0x21:Reading tar file system.xml
16:22:35:WU00:FS01:0x21:Digital signatures verified
16:22:35:WU00:FS01:0x21:Folding@home GPU Core21 Folding@home Core
16:22:35:WU00:FS01:0x21:Version 0.0.18
16:22:35:WU00:FS01:0x21:ERROR:126: Bad platformId size.
16:22:35:WU00:FS01:0x21:Saving result file logfile_01.txt
16:22:35:WU00:FS01:0x21:Saving result file log.txt
16:22:35:WU00:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
16:22:35:WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
16:22:35:WU00:FS01:Sending unit results: id:00 state:SEND error:FAULTY project:13782 run:764 clone:4 gen:180 core:0x21 unit:0x000000d10002894b5a78cf12476523c7
16:22:35:WU00:FS01:Uploading 1.91KiB to
16:22:35:WU00:FS01:Connecting to
16:22:35:WU00:FS01:Upload complete
16:22:35:WU00:FS01:Server responded WORK_ACK (400)
16:22:35:WU00:FS01:Cleaning up
16:22:35:WU02:FS01:Connecting to
16:22:35:WU02:FS01:Assigned to work server
16:22:35:WU02:FS01:Requesting new work unit for slot 01: READY gpu:0:GK106 [GeForce GTX 660] from
16:22:35:WU02:FS01:Connecting to
16:22:36:WU02:FS01:Downloading 16.53MiB
16:22:39:WU02:FS01:Download complete
16:22:39:WU02:FS01:Received Unit: id:02 state:DOWNLOAD error:NO_ERROR project:11713 run:13 clone:68 gen:140 core:0x21 unit:0x000000a68ca304e75a5a522269bc17fe

My machine has the following hardware and drivers:
- Intel Core i5 4570K - It is folding just fine both before and after the Windows upgrade
= Windows 10 Pro - 1803 (OS Build 17134.1)
- 16GB RAM
- NVIDIA GeForce GTX 660
= Driver Version: 397.31

Troubleshooting Steps Taken:
a) I have reinstalled the NVIDIA drivers performing a clean install. I had noticed all of my GPUs has issues with a previous version of drivers as of Monday or Tuesday. I upgraded all machines (two Windows and one Linux) with the latest NVIDIA drivers. The GPUs (a total of three) on one Windows and one Linux machine are running fine. Only this one is having issues.
b) I have deleted the GPU from the FAH client, rebooted, and reinstalled the GPU in the configuration.
c) I have uninstalled and reinstalled the FAH client.
d) in watching the GPU "work" directory files are downloaded and promptly deleted from this directory.

Any help is greatly appreciated.

Mod edit: changed Quote tags to Code tags on log file - j

Re: "BAD_WORK_UNIT (114 = 0x72)" Error

PostPosted: Thu May 03, 2018 6:09 pm
by artoar_11
oliverjdent wrote:I have Windows 10 Pro on one of my folding machines. It just updated to 1803 (OS Build 17134.1). After the update the GPU generates the following error messages:

Reinstall the current driver with the original from the NVidia page. Clean install!

Edit: Try an older driver

Re: "BAD_WORK_UNIT (114 = 0x72)" Error

PostPosted: Fri May 04, 2018 12:44 am
by oliverjdent

Thank you for the suggestion.

While I was working on the machine that caused me to write this forum entry the second machine started throwing the same error.

I rolled both Windows machines back to 391.35 with a clean install.

Both machines are now folding without issue.

Re: "BAD_WORK_UNIT (114 = 0x72)" Error

PostPosted: Fri May 04, 2018 9:05 am
by foldy
The new nvidia 397 drivers are evil.

Re: "BAD_WORK_UNIT (114 = 0x72)" Error

PostPosted: Fri May 18, 2018 7:27 am
by bruce
OpenCL and CUDA components of driver Version 397.3x are defective, and FAH requires OpenCL. Do a clean install of least 397.55 -- or better still to 397.64.

Re: "BAD_WORK_UNIT (114 = 0x72)" Error

PostPosted: Sun May 20, 2018 11:33 pm
by Leonardo
Bruce, I had the same endless "Ready" issues with GPU folding following a clean installation of 397.31 AND 397.64 (haven't tried 397.55). The only solution for me was reinstall Nvidia 391.35 drivers, which always worked properly. Following that, I installed 397.64 WITHOUT clean install. It would appear to me that whatever was amiss for 397.31 and folding was not fixed in 397.64.