Page 1 of 1

FAHClient not launching

PostPosted: Wed Apr 01, 2020 7:45 pm
by WDSTEVE
I have installed a the Folding@Home Client but whenever I run the program no window opens.
Despite what the log says I have installed CUDA toolkit V10.2.89 and the newest NVIDIA drivers (445.75)
In the background the FAHClient.exe task stays idle and never closes. After waiting for 20 minutes I killed the task.

This is my log file:
Code: Select all
18:32:04:INFO(1):Read GPUs.txt
18:32:04:************************* Folding@home Client *************************
18:32:04:      Website: https://foldingathome.org/
18:32:04:    Copyright: (c) 2009-2018 foldingathome.org
18:32:04:       Author: Joseph Coffland <joseph@cauldrondevelopment.com>
18:32:04:         Args:
18:32:04:       Config: <none>
18:32:04:******************************** Build ********************************
18:32:04:      Version: 7.5.1
18:32:04:         Date: May 11 2018
18:32:04:         Time: 13:06:32
18:32:04:   Repository: Git
18:32:04:     Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
18:32:04:       Branch: master
18:32:04:     Compiler: Visual C++ 2008
18:32:04:      Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
18:32:04:     Platform: win32 10
18:32:04:         Bits: 32
18:32:04:         Mode: Release
18:32:04:******************************* System ********************************
18:32:04:          CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
18:32:04:       CPU ID: GenuineIntel Family 6 Model 58 Stepping 9
18:32:04:         CPUs: 8
18:32:04:       Memory: 15.95GiB
18:32:04:  Free Memory: 12.53GiB
18:32:04:      Threads: WINDOWS_THREADS
18:32:04:   OS Version: 6.2
18:32:04:  Has Battery: false
18:32:04:   On Battery: false
18:32:04:   UTC Offset: -6
18:32:04:          PID: 9280
18:32:04:          CWD: C:\Program Files (x86)\FAHClient
18:32:04:           OS: Windows 10 Home
18:32:04:      OS Arch: AMD64
18:32:04:         GPUs: 1
18:32:04:        GPU 0: Bus:1 Slot:0 Func:0 NVIDIA:7 TU117 [GeForce GTX 1650]
18:32:04:         CUDA: Not detected
18:32:04:       OpenCL: Not detected
18:32:04:Win32 Service: false
18:32:04:***********************************************************************
18:32:04:<config>
18:32:04:  <!-- Folding Slots -->
18:32:04:</config>
18:32:04:Trying to access database...
18:32:04:Successfully acquired database lock
18:32:04:Enabled folding slot 00: PAUSED cpu:6 (not configured)

Re: FAHClient not launching

PostPosted: Thu Apr 02, 2020 5:57 am
by ToeBlister
Try launching the Advanced Control/Web Control by clicking on the F@H icon on the taskbar.
I personally prefer the Advanced Control since I can make configuration changes to F@H, but YMMV.

Re: FAHClient not launching

PostPosted: Thu Apr 02, 2020 7:28 pm
by Joe_H
You have installed the F@h client and are trying to run it with it pointing to the wrong place to have work files:
Code: Select all
18:32:04:          CWD: C:\Program Files (x86)\FAHClient


How did you start FAHClient? And which options did you choose during the installation?