Latest Client/Control needs 18.4LTS or later (linux)?

Moderators: Site Moderators, PandeGroup

Latest Client/Control needs 18.4LTS or later (linux)?

Postby ProDigit » Fri Jan 04, 2019 8:11 am

I seem to have problems installing the DEB file on systems older than the 18.4 LTS release.
Multiple Linuxes based on 16.4, 17.x seem to result in a broken DEB file, or error code 1 at the end.
It does work fine for 18.4 and 19.2, as far as I've tried.

This is acually significant, as most older Linux versions, and also linux versions running on slower hardware, or trimmed down Linux versions, will not be compatible with FAH client or control package.

Older hardware may be ok, but there are a lot of people preferring to run older linux on modern hardware, because it's less bloated.
ProDigit
 
Posts: 242
Joined: Sun Dec 09, 2018 10:23 pm

Re: Latest Client/Control needs 18.4LTS or later (linux)?

Postby foldy » Fri Jan 04, 2019 8:28 am

I see the error 1 at the end of installation too. But FAH still works. Tried on Ubuntu 16 and 18
foldy
 
Posts: 1474
Joined: Sat Dec 01, 2012 3:43 pm

Re: Latest Client/Control needs 18.4LTS or later (linux)?

Postby Joe_H » Fri Jan 04, 2019 8:37 am

If you mean 18.04 LTS Ubuntu, if that works for you fine. But many people including myself have installed the current version of the client on 16.04 without running into the issues you mention.

I recall someone posting on what was needed to install on 14.04, that is the oldest version I remember being used.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 4473
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: Latest Client/Control needs 18.4LTS or later (linux)?

Postby ProDigit » Fri Jan 04, 2019 9:19 am

Strange.
I get nothing but errors, on GalliumOs (16.4 LTS), Puppy Linux (17.2), Antix Linux 16.4, Sparky Linux (not even sure on what that is based, it just says GNU),
Tiny Core (is 32 bit, and has a very tiny repository. At 50MB OS size, I didn't expect FAH to work).

EDIT: I reinstalled it, though the window froze, control now boots on Sparky Linux, but doesn't work with FireFox (will install Chrome soon).
EDIT 2: Nope. Even with Chrome it doesn't boot.

Terminal does give the message
Code: Select all
Errors were encountered while processing
    fahclient
Sub-process /usr/bin/dpkg returned an error code (1)


It's the same error I find in most linuxes below 18.4


So far the only versions I've been able to make it work on, is Lubuntu, Xubuntu, Ubuntu (18.4, 19.x); and Mate (19.2).

The error sometimes allows me to install control, but not the client.
Without client, I can't activate folding on my pc.

Also, is Google Chrome required for folding with the desktop client?
I haven't yet seen any other browser been able to load FAH Control with WUs.
ProDigit
 
Posts: 242
Joined: Sun Dec 09, 2018 10:23 pm

Re: Latest Client/Control needs 18.4LTS or later (linux)?

Postby Joe_H » Fri Jan 04, 2019 1:04 pm

There is a reason Ubuntu is listed as supported, and those variants are not. Once you get away from the mainstream distribution, what is packaged with each varies. That can be the difference between F@h working and not.

The supported versions of Linux are Debian, Mint, Ubuntu, RedHat, CentOS and Fedora. Everything else is in the unsupported category. The closer a variant is to the distribution it is based on, the more likely you will not run into problems, but you will have to ask questions about getting around problems in the forum for questions about unsupported distress of Linux.
Joe_H
Site Admin
 
Posts: 4473
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: Latest Client/Control needs 18.4LTS or later (linux)?

Postby ProDigit » Sat Jan 05, 2019 12:13 am

GalliumOs is based on xubuntu,
Xubuntu and lubuntu are based on Ubuntu.
Together with puppy, mint and antix they are all Debian based.

I'm sure it might just merely be missing a repository to install well.

Anyone measured a performance difference in folding between based Linux vs redhat, for servers?
ProDigit
 
Posts: 242
Joined: Sun Dec 09, 2018 10:23 pm

Re: Latest Client/Control needs 18.4LTS or later (linux)?

Postby ProDigit » Sat Jan 05, 2019 9:04 am

I'm testing a few linux versions also with FAH,
So for FAH, I'm basically limited to Debian or Redhat (which costs money); or one of the branches.

Lubuntu 18.10 and Debian 9.6.0 work really well, flawless. Snappy response too!
Xubuntu 18.04 works well, but you'd have to like the layout, and it feels slower than Lubuntu, but I haven't run them side by side.
Mint 19.1 feels a little slower, but looks a lot nicer. Again, no side by side comparison.
All of these are made after Ubuntu, which was made after Debian.

Debian itself runs like a dream as well!
I think a lot of it runs from RAM, rather than from SSD/HDD.


I'm still going through some Debian branches:
- Mint
- Debian
Though both work fine, I think I prefer Debian of the two.


Red hat branches:
- Red Hat
- Fedora
- Clear OS
- CentOs
- Mandriva

These red hat branches are usually made for servers.
I don't know if this does anything to folding performance; or power consumption,
But snappiness of the OS, memory usage, CPU usage during idle, and PPD score can indicate if any of these are better than Debian.

Other Operating systems that I don't think support FAH out of the box:
- Arch Linux
- FreeBSD

Sadly I haven't had any success with installing FAH on any of the smaller, leaner Linux cores.
But so far, Debian is one of my favorites!
Learning as I get along...
ProDigit
 
Posts: 242
Joined: Sun Dec 09, 2018 10:23 pm

Re: Latest Client/Control needs 18.4LTS or later (linux)?

Postby bruce » Sun Jan 06, 2019 12:39 am

Joe_H wrote:There is a reason Ubuntu is listed as supported, and those variants are not. Once you get away from the mainstream distribution, what is packaged with each varies. That can be the difference between F@h working and not.

The supported versions of Linux are Debian, Mint, Ubuntu, RedHat, CentOS and Fedora. Everything else is in the unsupported category. The closer a variant is to the distribution it is based on, the more likely you will not run into problems, but you will have to ask questions about getting around problems in the forum for questions about unsupported distress of Linux.

ProDigit wrote:I'm testing a few linux versions also with FAH,
So for FAH, I'm basically limited to Debian or Redhat (which costs money); or one of the branches.


Why?

I think you're wasting your time testing other distribution packages of Linux.

If one of the 6 supported distros happens to create a conflict with FAH's installation package, we will happily report the bug and get that installation package corrected so that it works. Where are the bug-reports that you've generated? Those six were chosen, along with Windows and Mac-OS-X, because (A) They're popular (including RedHat, in spite of it's cost) and (B) they're supportable.

This forum cannot become a support forum for unsupported distros.
bruce
 
Posts: 22447
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Latest Client/Control needs 18.4LTS or later (linux)?

Postby ProDigit » Sun Jan 06, 2019 2:28 am

I'm not asking support for other linux variants.
I'm merely trying them out, see what I like about them,and which one works best with FAH.
ProDigit
 
Posts: 242
Joined: Sun Dec 09, 2018 10:23 pm

Re: Latest Client/Control needs 18.4LTS or later (linux)?

Postby bruce » Sun Jan 06, 2019 5:00 pm

So which ones that you've tried have you eliminated as unsupportable?
bruce
 
Posts: 22447
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Latest Client/Control needs 18.4LTS or later (linux)?

Postby ProDigit » Sun Jan 06, 2019 5:55 pm

Well, that depends.
Most of them don't install well. A good hundred that is.

But I tried Sparky Linux, Puppy Linux, Tiny Core Linux, just don't install anything at all. I had issues with Fedora, so I didn't even get to install it. Many say it's an unstable version of Redhat.

I tried Redhat and FreeBSD; but both of them have no GUI, and it takes learning new commands, so I halted those two.
I'm interested in getting to know these 2 linux versions, but not for FAH, just personal interest!

I think a better question would be: "what does work outside of the 6 supported versions?"
So far, I've only tested Lubuntu and Xubuntu, and verify it works.

Debian has a 100+ derivatives:

Image
ProDigit
 
Posts: 242
Joined: Sun Dec 09, 2018 10:23 pm

Re: Latest Client/Control needs 18.4LTS or later (linux)?

Postby ProDigit » Wed Jan 16, 2019 3:24 am

I've looked at most (compatible) Linux versions in the time allotted to me on my netbook.

And it currently comes down to, running Debian, a safer, quicker, less bloated OS, with older Geforce drivers (390), or run Ubuntu/Mint, slightly more bloated, less safe OS, for the newest 417 drivers.
Not sure if the new drivers fold better than the older ones.
There is a way around it, but for beginners, I'd recommend Mint, Ubuntu, Xubuntu, or Lubuntu (Lubuntu using the least resources, Mint and Ubuntu using the most, but are somewhat easier).

For the novice, probably debian might be a good OS.


Fedora has regular issues with updates that can crash your system; I personally wouldn't recommend that one for folding.

Redhat and Centos are an operating system on their own. Not a lot of people have experience with these OS systems.
They're a pain to get to work.
Once set up properly, they might (or might not) run better, but I've ran out of time to test them any further.

Me personally, I'm going to test Lubuntu on my server.
ProDigit
 
Posts: 242
Joined: Sun Dec 09, 2018 10:23 pm

Re: Latest Client/Control needs 18.4LTS or later (linux)?

Postby bruce » Fri Jan 18, 2019 3:27 am

No, 18.04 LTS is NOT required.
I've run FAHClient as far back as 14,04 LTS.

The first issue you run into is getting the Proprietary Drivers.
bruce
 
Posts: 22447
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Latest Client/Control needs 18.4LTS or later (linux)?

Postby ProDigit » Sat Jan 19, 2019 6:14 am

Yup,you're right.
While it worked totally fine on one laptop on Mint Tessa, it totally didn't work on the other.

Code: Select all
installArchives() failed: Selecting previously unselected package libbonobo2-common.
(Reading database ...
(Reading database ... 5%%
(Reading database ... 10%%
(Reading database ... 15%%
(Reading database ... 20%%
(Reading database ... 25%%
(Reading database ... 30%%
(Reading database ... 35%%
(Reading database ... 40%%
(Reading database ... 45%%
(Reading database ... 50%%
(Reading database ... 55%%
(Reading database ... 60%%
(Reading database ... 65%%
(Reading database ... 70%%
(Reading database ... 75%%
(Reading database ... 80%%
(Reading database ... 85%%
(Reading database ... 90%%
(Reading database ... 95%%
(Reading database ... 100%%
(Reading database ... 310391 files and directories currently installed.)
Preparing to unpack .../00-libbonobo2-common_2.32.1-3_all.deb ...
Unpacking libbonobo2-common (2.32.1-3) ...
Selecting previously unselected package liborbit-2-0:amd64.
Preparing to unpack .../01-liborbit-2-0_1%%3a2.14.19-4_amd64.deb ...
Unpacking liborbit-2-0:amd64 (1:2.14.19-4) ...
Selecting previously unselected package libbonobo2-0:amd64.
Preparing to unpack .../02-libbonobo2-0_2.32.1-3_amd64.deb ...
Unpacking libbonobo2-0:amd64 (2.32.1-3) ...
Selecting previously unselected package python3-lib2to3.
Preparing to unpack .../03-python3-lib2to3_3.6.7-1~18.04_all.deb ...
Unpacking python3-lib2to3 (3.6.7-1~18.04) ...
Selecting previously unselected package python3-distutils.
Preparing to unpack .../04-python3-distutils_3.6.7-1~18.04_all.deb ...
Unpacking python3-distutils (3.6.7-1~18.04) ...
Selecting previously unselected package dh-python.
Preparing to unpack .../05-dh-python_3.20180325ubuntu2_all.deb ...
Unpacking dh-python (3.20180325ubuntu2) ...
Selecting previously unselected package libart-2.0-2:amd64.
Preparing to unpack .../06-libart-2.0-2_2.3.21-3_amd64.deb ...
Unpacking libart-2.0-2:amd64 (2.3.21-3) ...
Selecting previously unselected package libgnomevfs2-common.
Preparing to unpack .../07-libgnomevfs2-common_1%%3a2.24.4-6.1ubuntu2_amd64.deb ...
Unpacking libgnomevfs2-common (1:2.24.4-6.1ubuntu2) ...
Selecting previously unselected package libgnomevfs2-0:amd64.
Preparing to unpack .../08-libgnomevfs2-0_1%%3a2.24.4-6.1ubuntu2_amd64.deb ...
Unpacking libgnomevfs2-0:amd64 (1:2.24.4-6.1ubuntu2) ...
Selecting previously unselected package libgnome2-common.
Preparing to unpack .../09-libgnome2-common_2.32.1-6_all.deb ...
Unpacking libgnome2-common (2.32.1-6) ...
Selecting previously unselected package libgnome-2-0:amd64.
Preparing to unpack .../10-libgnome-2-0_2.32.1-6_amd64.deb ...
Unpacking libgnome-2-0:amd64 (2.32.1-6) ...
Selecting previously unselected package libgnomecanvas2-common.
Preparing to unpack .../11-libgnomecanvas2-common_2.30.3-3_all.deb ...
Unpacking libgnomecanvas2-common (2.30.3-3) ...
Selecting previously unselected package libgnomecanvas2-0:amd64.
Preparing to unpack .../12-libgnomecanvas2-0_2.30.3-3_amd64.deb ...
Unpacking libgnomecanvas2-0:amd64 (2.30.3-3) ...
Selecting previously unselected package libbonoboui2-common.
Preparing to unpack .../13-libbonoboui2-common_2.24.5-4_all.deb ...
Unpacking libbonoboui2-common (2.24.5-4) ...
Selecting previously unselected package libbonoboui2-0:amd64.
Preparing to unpack .../14-libbonoboui2-0_2.24.5-4_amd64.deb ...
Unpacking libbonoboui2-0:amd64 (2.24.5-4) ...
Selecting previously unselected package libgnomeui-common.
Preparing to unpack .../15-libgnomeui-common_2.24.5-3.2_all.deb ...
Unpacking libgnomeui-common (2.24.5-3.2) ...
Selecting previously unselected package libgnomeui-0:amd64.
Preparing to unpack .../16-libgnomeui-0_2.24.5-3.2_amd64.deb ...
Unpacking libgnomeui-0:amd64 (2.24.5-3.2) ...
Selecting previously unselected package libidl-2-0:amd64.
Preparing to unpack .../17-libidl-2-0_0.8.14-4_amd64.deb ...
Unpacking libidl-2-0:amd64 (0.8.14-4) ...
Selecting previously unselected package liborbit2:amd64.
Preparing to unpack .../18-liborbit2_1%%3a2.14.19-4_amd64.deb ...
Unpacking liborbit2:amd64 (1:2.14.19-4) ...
Selecting previously unselected package python-gconf.
Preparing to unpack .../19-python-gconf_2.28.1+dfsg-1.2_amd64.deb ...
Unpacking python-gconf (2.28.1+dfsg-1.2) ...
Selecting previously unselected package python-pyorbit.
Preparing to unpack .../20-python-pyorbit_2.24.0-7.2_amd64.deb ...
Unpacking python-pyorbit (2.24.0-7.2) ...
Selecting previously unselected package python-gnome2.
Preparing to unpack .../21-python-gnome2_2.28.1+dfsg-1.2_amd64.deb ...
Unpacking python-gnome2 (2.28.1+dfsg-1.2) ...
Setting up python-gconf (2.28.1+dfsg-1.2) ...
Setting up libart-2.0-2:amd64 (2.3.21-3) ...
Setting up libgnomeui-common (2.24.5-3.2) ...
Setting up libgnome2-common (2.32.1-6) ...
Setting up fahclient (7.5.1) ...
update-rc.d: error: no runlevel symlinks to modify, aborting!
dpkg: error processing package fahclient (--configure):
 installed fahclient package post-installation script subprocess returned error exit status 1
Processing triggers for gconf2 (3.2.6-4ubuntu1) ...
Setting up libidl-2-0:amd64 (0.8.14-4) ...
Setting up libgnomecanvas2-common (2.30.3-3) ...
Setting up libbonobo2-common (2.32.1-3) ...
Setting up libgnomevfs2-common (1:2.24.4-6.1ubuntu2) ...
Setting up libgnomecanvas2-0:amd64 (2.30.3-3) ...
Setting up libbonoboui2-common (2.24.5-4) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Setting up liborbit-2-0:amd64 (1:2.14.19-4) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Setting up python3-lib2to3 (3.6.7-1~18.04) ...
Setting up python3-distutils (3.6.7-1~18.04) ...
Setting up libgnomevfs2-0:amd64 (1:2.24.4-6.1ubuntu2) ...
Setting up liborbit2:amd64 (1:2.14.19-4) ...
Setting up libbonobo2-0:amd64 (2.32.1-3) ...
Setting up dh-python (3.20180325ubuntu2) ...
Setting up python-pyorbit (2.24.0-7.2) ...
Setting up libgnome-2-0:amd64 (2.32.1-6) ...
Setting up libbonoboui2-0:amd64 (2.24.5-4) ...
Setting up libgnomeui-0:amd64 (2.24.5-3.2) ...
Setting up python-gnome2 (2.28.1+dfsg-1.2) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Errors were encountered while processing:
 fahclient
Setting up fahclient (7.5.1) ...
update-rc.d: error: no runlevel symlinks to modify, aborting!
dpkg: error processing package fahclient (--configure):
 installed fahclient package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 fahclient


This is on an older Vaio laptop.
I don't know why fahclient gives error status 1 on one laptop, but not the other running exactly the same OS, and how it can error on one Linux, but not on the other...???
ProDigit
 
Posts: 242
Joined: Sun Dec 09, 2018 10:23 pm

Re: Latest Client/Control needs 18.4LTS or later (linux)?

Postby bruce » Sat Jan 19, 2019 11:34 pm

Probably you've installed a different collection of optional features.

What database tools are on those systems? I have NEVER seen anything like what you're reporting. When FAHClient is initialized, it does read a local database, but it takes ~0.5 seconds.
*
Code: Select all
********************** Log Started 2019-01-19T00:10:54Z ***********************
00:10:54:************************* Folding@home Client *************************
00:10:54:        Website: https://foldingathome.org/
00:10:54:      Copyright: (c) 2009-2018 foldingathome.org
00:10:54:         Author: Joseph Coffland <joseph@cauldrondevelopment.com>
00:10:54:           Args:
00:10:54:         Config: C:\users\ovies\appdata\roaming\fahclient\config.xml
00:10:54:******************************** Build ********************************
00:10:54:        Version: 7.5.1
00:10:54:           Date: May 11 2018
00:10:54:           Time: 13:06:32
00:10:54:     Repository: Git
00:10:54:       Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
00:10:54:         Branch: master
00:10:54:       Compiler: Visual C++ 2008
00:10:54:        Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
00:10:54:       Platform: win32 10
00:10:54:           Bits: 32
00:10:54:           Mode: Release
00:10:54:******************************* System ********************************
00:10:54:            CPU: AMD A8-5500 APU with Radeon(tm) HD Graphics
00:10:54:         CPU ID: AuthenticAMD Family 21 Model 16 Stepping 1
00:10:54:           CPUs: 4
00:10:54:         Memory: 3.95GiB
00:10:54:    Free Memory: 2.38GiB
00:10:54:        Threads: WINDOWS_THREADS
00:10:54:     OS Version: 6.2
00:10:54:    Has Battery: false
00:10:54:     On Battery: false
00:10:54:     UTC Offset: -8
00:10:54:            PID: 9148
00:10:54:            CWD: C:\users\ovies\appdata\roaming\fahclient
00:10:54:             OS: Windows 10 Home
00:10:54:        OS Arch: AMD64
00:10:54:           GPUs: 1
00:10:54:          GPU 0: Bus:1 Slot:0 Func:0 NVIDIA:7 GP107 [GeForce GTX 1050 Ti] 2138
00:10:54:  CUDA Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:6.1 Driver:9.2
00:10:54:OpenCL Device 1: Platform:1 Device:0 Bus:1 Slot:0 Compute:1.2 Driver:398.36
00:10:54:  Win32 Service: false
00:10:54:***********************************************************************
00:10:56:<config>
00:10:56:  <!-- HTTP Server -->
00:10:56:  <allow v='127.0.0.1,192.168.0.0/24'/>
00:10:56:
00:10:56:  <!-- Network -->
00:10:56:  <proxy v=':8080'/>
00:10:56:
00:10:56:  <!-- Remote Command Server -->
00:10:56:  <password v='*****'/>
00:10:56:
00:10:56:  <!-- User Information -->
00:10:56:  <passkey v='********************************'/>
00:10:56:  <team v='131'/>
00:10:56:  <user v='borden.b'/>
00:10:56:
00:10:56:  <!-- Work Unit Control -->
00:10:56:  <next-unit-percentage v='100'/>
00:10:56:
00:10:56:  <!-- Folding Slots -->
00:10:56:  <slot id='0' type='CPU'/>
00:10:56:  <slot id='1' type='GPU'>
00:10:56:    <client-type v='internal'/>
00:10:56:    <project-key v='141631111'/>
00:10:56:  </slot>
00:10:56:</config>
00:10:56:Trying to access database...
00:10:57:Successfully acquired database lock
00:10:57:Enabled folding slot 00: READY cpu:2
00:10:57:Enabled folding slot 01: READY gpu:0:GP107 [GeForce GTX 1050 Ti]  2138
00:10:58:WU02:FS00:Starting


See 00:10:56 - 57

Are you starting the FAHClient service with the default script?
What is your CWD?
bruce
 
Posts: 22447
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Next

Return to V7.5.1 Public Release Windows/Linux/MacOS X

Who is online

Users browsing this forum: No registered users and 2 guests

cron