Page 1 of 1

Update requested on OSX and modern GPU's

PostPosted: Sun Jan 27, 2019 7:38 pm
by osxtra
Mod note: Edited to take portions out of Code tags, removed redundant/unnecessary material

Have already read that GPU support is not enabled in OSX.

Am trying to figure out if there is any progress on that front, and if not, any workaround, or at least a better explanation than just "no, it won't work".

As OSX is really BSD under the hood, seems that it wouldn't be that much different enabling GPU support than in a Linux installation, provided the CUDA and OpenCL libraries are properly installed.

Am running High Sierra with an nVidia Titan XP. Naturally, the thought of using 3K+ GPU cores sounds better than what the CPU has to offer.

nVidia's CUDA drivers are installed and libcuda.dylib is linked to /usr/local/lib/

The native OSX OpenCL library - /System/Library/Frameworks/OpenCL.framework/OpenCL - is linked to /usr/local/lib/libOpenCL.dylib

Configuring FAHControl for the CPU works as expected. However, when attempting to configure it for the GPU, it fails, never getting any work unit assignments.

Suspect the problem is that FAHCoreWrapper is never getting called. When set for CPU the log shows:
WU01:FS01:Running FahCore: /usr/local/bin/FAHCoreWrapper "/Library/Application Support/FAHClient/cores/" -dir 01 -suffix 01 -version 705 -lifeline 18422 -checkpoint 15 -np 10

But there is no such corresponding call to the wrapper (with whatever flags would point it to the correct hardware) when using the GPU, nor anything that looks GPU related in the "" folder.

(Looked at a Linux installation too, but all "" had was a "Linux" subfolder also containing "AMD64"; then again, that could have been because the boxes I looked at doesn't have a GPU, so the necessary dependencies never got installed.)

Are there flags one could use to experiment with manually pointing it to the GPU on OSX?

If not, are there any plans to add such an option to the wrapper, or a list of what all *can* be passed to the wrapper? While you don't publish your source code, have downloaded the OpenMM code but not yet dug that far into it.

I realize OSX has a much smaller market share than WinDoze; around 15 percent of what Redmond pulls in, but hey, even Android has edged them out these days! Still - at least so far as GUI installations goes - it's over seven times what Linux controls, so doesn't make any sense why your code wouldn't have GPU support for the that platform.

FAHControl log, --print & --info from FAHClient shown below. (--print & --info results removed - redundant)

Please advise. Thanks!

PS: Since I just joined, it wouldn't let me post the log due to your website link being embedded in it. Hilarious! Even after wrapping the log in code, it still wouldn't work. Got tired of trying to figure out what it didn't like - not commercial at's. File paths pehaps?
and just wrapped the whole post. Also, time to update your copyright...

Code: Select all
FAHControl log:
*********************** Log Started 2019-01-27T15:42:52Z ***********************
15:42:52:************************* Folding@home Client *************************
15:42:52:        Website:
15:42:52:      Copyright: (c) 2009-2018
15:42:52:         Author: Joseph Coffland <>
15:42:52:           Args:
15:42:52:         Config: /Library/Application Support/FAHClient/config.xml
15:42:52:******************************** Build ********************************
15:42:52:        Version: 7.5.1
15:42:52:           Date: May 11 2018
15:42:52:           Time: 12:57:01
15:42:52:     Repository: Git
15:42:52:       Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
15:42:52:         Branch: master
15:42:52:       Compiler: GNU 4.2.1 Compatible Apple LLVM 7.3.0 (clang-703.0.31)
15:42:52:        Options: -std=gnu++98 -O3 -funroll-loops -mmacosx-version-min=10.6
15:42:52:                 -Wno-unused-local-typedefs
15:42:52:       Platform: darwin 15.6.0
15:42:52:           Bits: 64
15:42:52:           Mode: Release
15:42:52:******************************* System ********************************
15:42:52:            CPU: Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz
15:42:52:         CPU ID: GenuineIntel Family 6 Model 158 Stepping 10
15:42:52:           CPUs: 12
15:42:52:         Memory: 32.00GiB
15:42:52:    Free Memory: 16.06GiB
15:42:52:        Threads: POSIX_THREADS
15:42:52:     OS Version: 10.13
15:42:52:    Has Battery: false
15:42:52:     On Battery: false
15:42:52:     UTC Offset: -6
15:42:52:            PID: 18422
15:42:52:            CWD: /Library/Application Support/FAHClient
15:42:52:             OS: Darwin 17.7.0 x86_64
15:42:52:        OS Arch: AMD64
15:42:52:           GPUs: 1
15:42:52:          GPU 0: Bus:1 Slot:0 Func:0 NVIDIA:7 GP102 [TITAN Xp] 12150
15:42:52:  CUDA Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:6.1 Driver:10.0
15:42:52:OpenCL Device 1: Platform:0 Device:1 Bus:NA Slot:NA Compute:1.2 Driver:387.10
15:42:52:OpenCL Device 2: Platform:0 Device:2 Bus:NA Slot:NA Compute:1.2 Driver:1.2
15:42:52:  <!-- Folding Slot Configuration -->
15:42:52:  <cause v='PARKINSONS'/>
15:42:52:  <gpu v='true'/>
15:42:52:  <!-- Network -->
15:42:52:  <proxy v=':8080'/>
15:42:52:  <!-- User Information -->
15:42:52:  <passkey v='********************************'/>
15:42:52:  <team v='230319'/>
15:42:52:  <user v='osxtra'/>
15:42:52:  <!-- Folding Slots -->
15:42:52:  <slot id='1' type='CPU'/>
15:42:52:Trying to access database...
15:42:52:Successfully acquired database lock
15:42:52:Enabled folding slot 01: READY cpu:11
15:42:52:WARNING:WU01:FS01:AS lowered CPUs from 11 to 10
15:42:52:WU01:FS01:Running FahCore: /usr/local/bin/FAHCoreWrapper "/Library/Application Support/FAHClient/cores/" -dir 01 -suffix 01 -version 705 -lifeline 18422 -checkpoint 15 -np 10
15:42:52:WU01:FS01:Started FahCore on PID 18463
15:42:52:WU01:FS01:Core PID:18469
15:42:52:WU01:FS01:FahCore 0xa7 started
*********************** Log Started 2019-01-27T15:42:52Z ***********************
15:42:52:WU01:FS01:0xa7:************************** Gromacs Folding@home Core ***************************
15:42:52:WU01:FS01:0xa7:       Type: 0xa7
15:42:52:WU01:FS01:0xa7:       Core: Gromacs
15:42:52:WU01:FS01:0xa7:    Website:
15:42:52:WU01:FS01:0xa7:  Copyright: (c) 2009-2018
15:42:52:WU01:FS01:0xa7:     Author: Joseph Coffland <>
15:42:52:WU01:FS01:0xa7:       Args: -dir 01 -suffix 01 -version 705 -lifeline 18463 -checkpoint 15 -np
15:42:52:WU01:FS01:0xa7:             10
15:42:52:WU01:FS01:0xa7:     Config: <none>
15:42:52:WU01:FS01:0xa7:************************************ Build *************************************
15:42:52:WU01:FS01:0xa7:    Version: 0.0.17
15:42:52:WU01:FS01:0xa7:       Date: Apr 25 2018
15:42:52:WU01:FS01:0xa7:       Time: 10:52:35
15:42:52:WU01:FS01:0xa7: Repository: Git
15:42:52:WU01:FS01:0xa7:   Revision: fd11abfb405c921e66db1226933e9dd2d18d2acc
15:42:52:WU01:FS01:0xa7:     Branch: master
15:42:52:WU01:FS01:0xa7:   Compiler: GNU 4.2.1 Compatible Apple LLVM 7.3.0 (clang-703.0.31)
15:42:52:WU01:FS01:0xa7:    Options: -std=gnu++98 -O3 -funroll-loops -mmacosx-version-min=10.6
15:42:52:WU01:FS01:0xa7:             -Wno-unused-local-typedefs
15:42:52:WU01:FS01:0xa7:   Platform: darwin 15.6.0
15:42:52:WU01:FS01:0xa7:       Bits: 64
15:42:52:WU01:FS01:0xa7:       Mode: Release
15:42:52:WU01:FS01:0xa7:       SIMD: avx_256
15:42:52:WU01:FS01:0xa7:************************************ System ************************************
15:42:52:WU01:FS01:0xa7:        CPU: Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz
15:42:52:WU01:FS01:0xa7:     CPU ID: GenuineIntel Family 6 Model 158 Stepping 10
15:42:52:WU01:FS01:0xa7:       CPUs: 12
15:42:52:WU01:FS01:0xa7:     Memory: 32.00GiB
15:42:52:WU01:FS01:0xa7:Free Memory: 16.00GiB
15:42:52:WU01:FS01:0xa7:    Threads: POSIX_THREADS
15:42:52:WU01:FS01:0xa7: OS Version: 10.13
15:42:52:WU01:FS01:0xa7:Has Battery: false
15:42:52:WU01:FS01:0xa7: On Battery: false
15:42:52:WU01:FS01:0xa7: UTC Offset: -6
15:42:52:WU01:FS01:0xa7:        PID: 18469
15:42:52:WU01:FS01:0xa7:        CWD: /Library/Application Support/FAHClient/work
15:42:52:WU01:FS01:0xa7:         OS: Darwin 17.7.0 x86_64
15:42:52:WU01:FS01:0xa7:    OS Arch: AMD64
15:42:52:WU01:FS01:0xa7:Project: 14116 (Run 29, Clone 19, Gen 23)
15:42:52:WU01:FS01:0xa7:Unit: 0x0000001e0002894c5b8400a8124bd8c7
15:42:52:WU01:FS01:0xa7:Digital signatures verified
15:42:52:WU01:FS01:0xa7:Calling: mdrun -s frame23.tpr -o frame23.trr -cpi state.cpt -cpt 15 -nt 10
15:42:52:WU01:FS01:0xa7:Steps: first=57500000 total=2500000
15:42:53:WU01:FS01:0xa7:Completed 1853422 out of 2500000 steps (74%)
15:43:52:Adding folding slot 00: READY gpu:0:GP102 [TITAN Xp] 12150
15:43:52:Removing old file 'configs/config-20190125-165923.xml'
15:43:53:Saving configuration to config.xml
15:43:53:  <!-- Folding Slot Configuration -->
15:43:53:  <cause v='PARKINSONS'/>
15:43:53:  <gpu v='true'/>
15:43:53:  <!-- Network -->
15:43:53:  <proxy v=':8080'/>
15:43:53:  <!-- User Information -->
15:43:53:  <passkey v='********************************'/>
15:43:53:  <team v='230319'/>
15:43:53:  <user v='osxtra'/>
15:43:53:  <!-- Folding Slots -->
15:43:53:  <slot id='0' type='GPU'/>
15:43:53:WU00:FS00:Connecting to
15:43:53:WARNING:WU00:FS00:Failed to get assignment from '': No WUs available for this configuration
15:43:53:WU00:FS00:Connecting to
15:43:54:WARNING:WU00:FS00:Failed to get assignment from '': No WUs available for this configuration
15:43:54:ERROR:WU00:FS00:Exception: Could not get an assignment
15:43:54:WU00:FS00:Connecting to
15:43:54:WARNING:WU00:FS00:Failed to get assignment from '': No WUs available for this configuration
15:43:54:WU00:FS00:Connecting to
15:43:55:WARNING:WU00:FS00:Failed to get assignment from '': No WUs available for this configuration
15:43:55:ERROR:WU00:FS00:Exception: Could not get an assignment
15:43:55:WU01:FS01:0xa7:Folding@home Core Shutdown: INTERRUPTED
15:43:55:WU01:FS01:FahCore returned: INTERRUPTED (102 = 0x66)
15:43:55:WARNING:WU01:Slot ID 1 no longer exists and there are no other matching slots, dumping
15:43:55:WU01:Sending unit results: id:01 state:SEND error:DUMPED project:14116 run:29 clone:19 gen:23 core:0xa7 unit:0x0000001e0002894c5b8400a8124bd8c7
15:43:55:WU01:Connecting to
15:43:56:WU01:Server responded WORK_ACK (400)
15:43:56:WU01:Cleaning up
15:44:54:WU00:FS00:Connecting to
15:44:54:WARNING:WU00:FS00:Failed to get assignment from '': No WUs available for this configuration
15:44:54:WU00:FS00:Connecting to
15:44:55:WARNING:WU00:FS00:Failed to get assignment from '': No WUs available for this configuration
15:44:55:ERROR:WU00:FS00:Exception: Could not get an assignment
15:46:31:WU00:FS00:Connecting to
15:46:32:WARNING:WU00:FS00:Failed to get assignment from '': No WUs available for this configuration
15:46:32:WU00:FS00:Connecting to
15:46:32:WARNING:WU00:FS00:Failed to get assignment from '': No WUs available for this configuration
15:46:32:ERROR:WU00:FS00:Exception: Could not get an assignment
15:49:08:WU00:FS00:Connecting to
15:49:09:WARNING:WU00:FS00:Failed to get assignment from '': No WUs available for this configuration
15:49:09:WU00:FS00:Connecting to
15:49:09:WARNING:WU00:FS00:Failed to get assignment from '': No WUs available for this configuration
15:49:09:ERROR:WU00:FS00:Exception: Could not get an assignment
15:53:23:WU00:FS00:Connecting to
15:53:23:WARNING:WU00:FS00:Failed to get assignment from '': No WUs available for this configuration
15:53:23:WU00:FS00:Connecting to
15:53:24:WARNING:WU00:FS00:Failed to get assignment from '': No WUs available for this configuration
15:53:24:ERROR:WU00:FS00:Exception: Could not get an assignment
16:00:14:WU00:FS00:Connecting to
16:00:14:WARNING:WU00:FS00:Failed to get assignment from '': No WUs available for this configuration
16:00:14:WU00:FS00:Connecting to
16:00:15:WARNING:WU00:FS00:Failed to get assignment from '': No WUs available for this configuration
16:00:15:ERROR:WU00:FS00:Exception: Could not get an assignment

Re: Update requested on OSX and modern GPU's

PostPosted: Sun Jan 27, 2019 9:01 pm
by Joe_H
Welcome to the folding support forum.

As you have read, GPU folding is not supported on OS X. There is no way to enable it for testing purposes at all. While OS X is BSD "under the hood", that is a totally different OS development path than Linux. Even all of the BSD variants are listed as unsupported, and use of the folding client on those OS's requires installation of Linux support package(s).

The initial intent years ago when the V7 folding client first came out was to also support GPU folding on OS X. But during testing of the first folding core that would have been usable on OS X a serious bug was found in Apple's implementation of OpenCL. That bug was finally fixed by Apple and released in one of the later patches to 10.12 as I recall. But in the meantime, on the hardware level Apple had moved to most of their computers using the the IGPU on the Intel CPU's. Few systems had usable GPU's, and reopening development of a GPU folding core for OS X was not undertaken for a variety of reasons.

Recent changes by Apple on the hardware side has resulted in some renewed interest in supporting GPU folding on the Mac OS. But only interest, no word on any development resources being committed to doing so. I can keep your name in mind as someone interested in GPU folding on OS X if that changes.

To summarize, at this time there is no folding core for the client to download and process GPU folding. The assignment servers have no settings to assign a GPU WU to OS X.

osxtra wrote:Also, time to update your copyright...

Actually that is correct for the current client, it was last "published" in 2018. An updated one would get a change to that statement.

Re: Update requested on OSX and modern GPU's

PostPosted: Sun Jan 27, 2019 9:37 pm
by osxtra
Don't know enough about the internals of your code, but I do appreciate the reply. Had thought maybe I could "trick" CoreWrapper somehow by just passing it different flags.

There is supposedly a way to leverage the GPU via a Docker container. May play with that. Just hate the idea of the Titan XP going to "waste".

Take care!

Re: Update requested on OSX and modern GPU's

PostPosted: Sun Jan 27, 2019 11:19 pm
by toTOW
Don't trash the Titan Xp, just trash this shit that is a Mac (or the OS at least) ... :roll:

And you won't be able to run a GPU core on OSX since it doesn't exist for this OS. Windows or Linux are the only ways to go for GPU folding. So maybe you could try to install one of those on your Mac, or move the GPU to a PC.

Re: Update requested on OSX and modern GPU's

PostPosted: Mon Jan 28, 2019 4:24 am
by bruce
I'm not a FAH developer, so I'll have to speak in generalities -- and possibly give you a little more information.

If you examine the first page of Fah's log, you'll see a segment called ***** System ******* That's shows the result if the system detection code and describes what FAH needs to figure out about your system. That information is passed to the assignment server.

On this Windows system it looks like this:
00:59:46:******************************* System ********************************
00:59:46: CPU: Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz
00:59:46: CPU ID: GenuineIntel Family 6 Model 26 Stepping 4
00:59:46: CPUs: 8
00:59:46: Memory: 5.99GiB
00:59:46: Free Memory: 4.69GiB
00:59:46: Threads: WINDOWS_THREADS
00:59:46: OS Version: 6.1
00:59:46: Has Battery: false
00:59:46: On Battery: false
00:59:46: UTC Offset: -8
00:59:46: PID: 2320
00:59:46: CWD: C:\Users\bruce\AppData\Roaming\FAHClient
00:59:46: OS: Windows 7 Home Premium
00:59:46: OS Arch: AMD64
00:59:46: GPUs: 2
00:59:46: GPU 0: Bus:3 Slot:0 Func:0 NVIDIA:4 GM107 [GeForce GTX 750 Ti] 1306
00:59:46: GPU 1: Bus:4 Slot:0 Func:0 NVIDIA:5 GM206 [GeForce GTX 960] 2308
00:59:46: CUDA Device 0: Platform:0 Device:0 Bus:4 Slot:0 Compute:5.2 Driver:9.1
00:59:46: CUDA Device 1: Platform:0 Device:1 Bus:3 Slot:0 Compute:5.0 Driver:9.1
00:59:46:OpenCL Device 0: Platform:0 Device:0 Bus:4 Slot:0 Compute:1.2 Driver:391.35
00:59:46:OpenCL Device 1: Platform:0 Device:1 Bus:3 Slot:0 Compute:1.2 Driver:391.35
00:59:46: Win32 Service: false

Among other things, FAHClient knows what OS I"m running, the characteristics of my CPU and of each GPU. That information is passed to the Assignment Server so that it can choose FAH projects tha can run on my system and to avoid all of the projects which cannot. The WU that is assigned is then downloaded and it contains the description of the FAHCore that can be used to process it.

There are many different possible FAHCores but the active ones are addressed with a path that differentiates based on all of the previously known information. In the case of this system, the call looks like this:
Running FahCore: ....FAHCoreWrapper.exe" C:\Users\bruce\ -dir 00 -suffix 01 -version 705 -lifeline 2320 -checkpoint 15 -gpu-vendor nvidia -opencl-platform 0 -opencl-device 1 -cuda-device 1 -gpu 1

Most of the parameters you see will be passed from FAHCoreWrapper to FahCore_21. specifically, the FAHCore_21 that's designed to run on a system that supports the AMD64 instruction set and contains an NVIDIA Fermi GPU or better A linux system has copies of FAHCore_21 which are NOT in the directory ".../Win32" but rather traverse a path containing ".../Linux" Below your OSX/AMD64 directory, the path branches off into AVX or Fermi or whatever, but in the case of OSX, there are no cores that have been compiled to run on OSX except the CPU-based cores. You won't find a FAHCore_21 and I doubt that the future FAHCore_22 (in development) will be ported to OSX. During development, Each FAHCore will uncover bugs which need to be corrected before that family of FAHCores can be released, so sometimes the Linux version or the Windows version can be ready for release before the other one.

The development of FAHCores that might someday be released for the OSX subdirectories have never been developed ... except the CPU-based FAHCores, which work, and a futile attempt many years ago that wasted a lot of effort-- probably due to the numerous defects found in early versions of OpenCL for Mac -- and lack of support by Apple for correcting them.

Re: Update requested on OSX and modern GPU's

PostPosted: Mon Jan 28, 2019 5:18 am
by bruce
In the meantime, you might do some research. Check the NVIDIA support site. In the time since the first drivers were tested for your GPU on OSX, how many problems have been reported and how many have been fixed? Compare that list with length of similar lists of changes to the drivers on Windows or Linux.

Re: Update requested on OSX and modern GPU's

PostPosted: Mon Jan 28, 2019 11:54 am
by foldy
If you can run a docker container on OSX there is one from nvidia with opencl but I only know it runs on Ubuntu.

Re: Update requested on OSX and modern GPU's

PostPosted: Mon Jan 28, 2019 4:20 pm
by jtr02a
I've noticed that when I boot into OS X I show less than 50k points per day, but when I use Windows 10 via Boot Camp I get around 90k points per day. I'm on a 1 year old MacBook Pro with the top processor, and find that I have to keep booted in Win 10 when I'm not using in order to maximize processing production. It is frustrating that only Windows will process both CPU and GPU.

I am very interested in getting this fixed so I'm not having to constantly boot into Windows.

On a positive note, the latest v7.5.1 release gives me 4x+ the production in OS X that I was getting in v7.4.4 :-).

Re: Update requested on OSX and modern GPU's

PostPosted: Mon Jan 28, 2019 10:46 pm
by bruce
Are you a new donor? You have to complete 10 WUs before you can bonus points.

List some of the projects you have completed and the points-per-day on OSX and on Windows.

Post the first portions of FAH's log.

Re: Update requested on OSX and modern GPU's

PostPosted: Thu Apr 30, 2020 4:02 pm
by gchristopher
The original question still needs to be addressed I believe; I concur OpenCL is dead and done, by none other than the creators of OpenCL.

My Mac OS X MacbookPro mid 2012 machine has 4 cores and is a 2.5 Ghz core i5.
I have a practically identical vintage mac mini Late 2012 with 8 cores and is a 2.3Ghz core i7. Both are running the last version of 10.12.

The mac mini is running at 780% CPU and is using all 8 cores to the max according to activity monitor
The laptop is running at 95% only using 2 cores.

Using FAHControl, I can see in the warnings and errors for the 4 core laptop:

13:36:15:WARNING:WU00:FS00:Changed SMP threads from 1 to 4 this can cause some work units to fail
13:36:15:WARNING:WU00:FS00:AS lowered CPUs from 4 to 1

LOL on the mini I see the warning that it changed the SMP threads from 7 to 8, although CPUs were lowered from 8 to 7.

Also: activity monitor notes 3 threads running for the laptop with 4 cores and 10 threads running for the mini with 8 cores.

I figured there might be a way to force it to use more cores. Sure enough in the configure panel under slots, I saw that if I double click Folding slot "0 cpu" I can change it from -1 to a value. On the mac mini, it seems to work correctly and CPU % in activity monitor is a multiple of that and 100%.

However, on the laptop, whether I set it to 4 or 3 or 2 cpus, it always immediately knocks it back down to 1 in the error log.

So for whatever reason, the fahCore_a7 process is not allowing the 4 core i5 mac laptop to utilize all of the cores.
Both machines are running the same exact OS version.

Please let me know if you need any more information.

In theory, the mac mini should be going

Re: Update requested on OSX and modern GPU's

PostPosted: Thu Apr 30, 2020 7:56 pm
by PantherX
Welcome to the F@H Forum gchristopher,

Please note that if it started CPU folding on the system automatically before configuring it, the first WU that is downloaded will always run on a single CPU. That is what this message means:
13:36:15:WARNING:WU00:FS00:AS lowered CPUs from 4 to 1

Once that WU has finished folding, the next WU assigned will use 4 CPUs assuming you have set the CPU value to 4.

Re: Update requested on OSX and modern GPU's

PostPosted: Fri May 01, 2020 7:28 am
by gchristopher
PantherX- thanks for the response!

I think this is incorrect. I am seeing instantaneous CPU % changes when I change the # cores on the mac mini (see above, and attached screen shots). So if I set it to 4 on the mini, cpu usage immediately goes down to 400% and I can see it in the CPU monitor too. ... i.png?dl=0 ... i.png?dl=0
Right now it says I have 7 hours left (I'm not currently seeing the % updates at the moment though which is a little bit strange). I do see the config change in the log output which I think is good.

One thing for sure: The "-1" cores (autodetect) value worked perfectly on the mac mini and not on the laptop, so the core selection scheme seems off.

Note: I tried to find any other logs using the console application and looking around but I did not find any. Let me know if you need more information; I'll let you know what I see in 8 hours

Re: Update requested on OSX and modern GPU's

PostPosted: Fri May 01, 2020 7:39 am
by Joe_H
Yes, this applies if the WU was downloaded when the CPU:8 setting was in place. If the WU had been downloaded at the setting of 4, then you would be able to reduce the setting to lower, but not increase it to 8.

On the laptop, the WU was downloaded with a setting of 1 core, no matter what you do the client will not increase the CPU core count higher. However the next WU will download and run at the CPU setting in place at the time it is requested and downloaded.

As for locating the log files, please read this section of the Welcome topic that pertains to macOS and logs - viewtopic.php?f=61&t=26036#p327414.

Re: Update requested on OSX and modern GPU's

PostPosted: Fri May 01, 2020 9:25 am
by gchristopher
Right on- OK. I'll let you know what happens tomorrow.

Re: Update requested on OSX and modern GPU's

PostPosted: Fri May 01, 2020 11:37 pm
by gchristopher
Got through the WU and everything switched to 4 cores. Thanks-

It might warrant a note somewhere. The behavior is not clear about waiting for a WU to complete before increasing the # cores but not true for decreasing and I certainly am seeing a lot of posts like this one that the Macs are running slower than when running on bootcamp. There is at least a mild detection scheme bug here where -1 does not bring all the cores online for some models (mine is MacBookPro9,2 - not exactly a spring chicken but plenty fast).

Thanks again.