fah and Fedora 31

Moderators: Site Moderators, FAHC Science Team

fah and Fedora 31

Postby Oppie » Fri Mar 20, 2020 3:28 am

rpm -Uv fahclient-7.5.1-1.x86_64.rpm
error: Failed dependencies:
libcrypto.so.10()(64bit) is needed by fahclient-7.5.1-1.x86_64
libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit) is needed by fahclient-7.5.1-1.x86_64
libcrypto.so.10(libcrypto.so.10)(64bit) is needed by fahclient-7.5.1-1.x86_64
libssl.so.10()(64bit) is needed by fahclient-7.5.1-1.x86_64
libssl.so.10(libssl.so.10)(64bit) is needed by fahclient-7.5.1-1.x86_64
[oppie@guardian ~]$ locate libcrypto.so
/usr/lib64/.libcrypto.so.1.1.1d.hmac
/usr/lib64/.libcrypto.so.1.1.hmac
/usr/lib64/libcrypto.so
/usr/lib64/libcrypto.so.1.1
/usr/lib64/libcrypto.so.1.1.1d
/var/lib/flatpak/runtime/org.fedoraproject.Platform/x86_64/f30/bfa9cd100ffc6e8623c017b5e7ab3ab047188bc852d204a5b719e44a545e0272/files/lib64/.libcrypto.so.1.1.1d.hmac
/var/lib/flatpak/runtime/org.fedoraproject.Platform/x86_64/f30/bfa9cd100ffc6e8623c017b5e7ab3ab047188bc852d204a5b719e44a545e0272/files/lib64/.libcrypto.so.1.1.hmac
/var/lib/flatpak/runtime/org.fedoraproject.Platform/x86_64/f30/bfa9cd100ffc6e8623c017b5e7ab3ab047188bc852d204a5b719e44a545e0272/files/lib64/libcrypto.so.1.1
/var/lib/flatpak/runtime/org.fedoraproject.Platform/x86_64/f30/bfa9cd100ffc6e8623c017b5e7ab3ab047188bc852d204a5b719e44a545e0272/files/lib64/libcrypto.so.1.1.1d

Can you make a binary that uses the recent libraries?
Oppie
 
Posts: 5
Joined: Wed Mar 11, 2020 6:39 pm

Re: fah and Fedora 31

Postby Oppie » Fri Mar 20, 2020 3:31 am

[oppie@guardian ~]$ locate libssl.so
/usr/lib64/.libssl.so.1.1.1d.hmac
/usr/lib64/.libssl.so.1.1.hmac
/usr/lib64/libssl.so
/usr/lib64/libssl.so.1.1
/usr/lib64/libssl.so.1.1.1d
/var/lib/flatpak/runtime/org.fedoraproject.Platform/x86_64/f30/bfa9cd100ffc6e8623c017b5e7ab3ab047188bc852d204a5b719e44a545e0272/files/lib64/.libssl.so.1.1.1d.hmac
/var/lib/flatpak/runtime/org.fedoraproject.Platform/x86_64/f30/bfa9cd100ffc6e8623c017b5e7ab3ab047188bc852d204a5b719e44a545e0272/files/lib64/.libssl.so.1.1.hmac
/var/lib/flatpak/runtime/org.fedoraproject.Platform/x86_64/f30/bfa9cd100ffc6e8623c017b5e7ab3ab047188bc852d204a5b719e44a545e0272/files/lib64/libssl.so.1.1
/var/lib/flatpak/runtime/org.fedoraproject.Platform/x86_64/f30/bfa9cd100ffc6e8623c017b5e7ab3ab047188bc852d204a5b719e44a545e0272/files/lib64/libssl.so.1.1.1d
[oppie@guardian ~]$
Oppie
 
Posts: 5
Joined: Wed Mar 11, 2020 6:39 pm

Re: fah and Fedora 31

Postby Oppie » Fri Mar 20, 2020 3:32 am

I believe there was a bug in the previous version.
You need to update openssl.
Oppie
 
Posts: 5
Joined: Wed Mar 11, 2020 6:39 pm

Re: fah and Fedora 31

Postby borkinson » Fri Mar 20, 2020 8:17 am

Hi there. I had the same issue on CentOS 8 and came here to gripe and look for help. I figured it out while typing up a reply. Turns out you may just need to install a package! I installed the fahclient rpm with GNOME Software on Fedora 31, and I think that it took care of this dependency issue for me (not sure).

However, on CentOS 8.1 I had the same problem as you (headless, no GNOME Software). fahclient seems to rely on the compat-openssl10 package, so run this:

sudo dnf install compat-openssl10

After that, I was able to successfully install the client and run it with sudo (I got an error that said the client couldn't start when I installed it, as it seems to try to run it immediately after install). I ran it from /usr/bin/:

sudo /usr/bin/FAHClient --myflags --blahblah

Hope that helps!
borkinson
 
Posts: 3
Joined: Fri Mar 20, 2020 7:57 am

Re: fah and Fedora 31

Postby Joe_H » Fri Mar 20, 2020 3:53 pm

I have not been able to keep all the extras needed with recent releases of the various Linux distros, there have been posts that on some recent ones the user defined to run FAHClient needs to be added to the video group, and on the most recent releases to the render group. This may just apply if you are trying to do GPU folding, have not had time to fully follow. That my be connected with your issue of the client not running after install. Normally the client is run with no privileges beyond regular user privileges.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 6608
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: fah and Fedora 31

Postby borkinson » Fri Mar 20, 2020 7:48 pm

Joe_H wrote:Normally the client is run with no privileges beyond regular user privileges.


Alright I'll look into that. I _would_ prefer to run without root :) .

Sounds like you do some of the work for this project, thank you for your efforts.
borkinson
 
Posts: 3
Joined: Fri Mar 20, 2020 7:57 am

Re: fah and Fedora 31

Postby Joe_H » Fri Mar 20, 2020 8:11 pm

I just volunteer to be a moderator and admin on this forum, sometimes have time to do some testing for the project as well.

I also should stop and proofread my posts a bit more, that should have said "I have not been able to keep up with all of...". The client was coded to be able to run on a variety of older Linux's to versions current at the time of its release. But the speed at which new requirements have been imposed by later versions has kept increasing. They had a major rewrite of the client in progress that would have addressed many of these issues, but that was not due out for many months. Now it is on hold for the the all out response related to this virus.
Joe_H
Site Admin
 
Posts: 6608
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: fah and Fedora 31

Postby borkinson » Fri Mar 20, 2020 8:45 pm

Well every bit of effort counts (that's what I tell my dual-core laptop running fah lol).

I may end up figuring that one out for centos 8.1 and I'll report back what I had to do to run rootless if I get some solid info from testing.
borkinson
 
Posts: 3
Joined: Fri Mar 20, 2020 7:57 am


Return to V7.5.1 Public Release Windows/Linux/MacOS X

Who is online

Users browsing this forum: No registered users and 2 guests

cron