Linux Installation Dependencies, Problems

Moderators: Site Moderators, FAHC Science Team

Linux Installation Dependencies, Problems

Postby webmanoffesto » Wed Mar 25, 2020 6:47 pm

I'm on a 64 bit Ubuntu 16 laptop. I'm having trouble installing.
When I go to client.foldingathomeDOTorg/ FAH seem to not be working. Even with "allow unsafe scripts" the page just blinks, but doesn't show any useful information.
Below are some dependency errors I got while attempting install.
How do I resolve these?

Code: Select all
tom@tom-HP-ProBook-450-G3:~$ sudo apt-get -f install fahcontrol
Reading package lists... Done
Building dependency tree       
Reading state information... Done
fahcontrol is already the newest version (7.4.4-1).
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 fahcontrol : Depends: python-support (>= 0.90.0) but it is not installable
              Depends: python-gnome2 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
tom@tom-HP-ProBook-450-G3:~$ sudo apt-get -f install python-gnome2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 fahcontrol : Depends: python-support (>= 0.90.0) but it is not installable
 python-gnome2 : Depends: python-gconf (= 2.28.1+dfsg-1.1) but it is not going to be installed
                 Depends: python-pyorbit (>= 2.0.1-4) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
tom@tom-HP-ProBook-450-G3:~$

webmanoffesto
 
Posts: 1
Joined: Wed Mar 25, 2020 6:34 pm

Re: Linux Installation Dependencies, Problems

Postby mesa » Wed Mar 25, 2020 11:22 pm

I had an issue just like this earlier today. All I did was clear out the browser cache and it stopped blinking.
mesa
 
Posts: 1
Joined: Wed Mar 25, 2020 11:18 pm

Re: Linux Installation Dependencies, Problems

Postby Claus_Christensen » Fri Mar 27, 2020 2:51 pm

I had the same problem when installing fahcontrol on a 64 bit laptop running Netrunner, a derivative of Debian. I seems, that I can use dh-python in stead of python-support (which does not exist in the Debian archives). However, python-gnome2 seems to be a package specific to Ubuntu - at least I could not find it in the Debian stable archives.
Claus_Christensen
 
Posts: 1
Joined: Fri Mar 27, 2020 2:26 pm

Re: Linux Installation Dependencies, Problems

Postby Frogging101 » Fri Mar 27, 2020 5:20 pm

7.4.4 is an old version. Download the latest (7.5.1) from here: https://foldingathome.org/start-folding/
Frogging101
 
Posts: 66
Joined: Wed Mar 25, 2020 3:39 am
Location: Canada

Re: Linux Installation Dependencies, Problems

Postby mad_martn » Sat Mar 28, 2020 7:44 pm

doesn't work with the latest version as well on Debian (testing), i could install dh-python but python-gnome2 is not available

Code: Select all
root@vogon:~/fah# dpkg -i fahcontrol_7.5.1-1_all.deb
Vormals nicht ausgewähltes Paket fahcontrol wird gewählt.
(Lese Datenbank ... 231933 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von fahcontrol_7.5.1-1_all.deb ...
Entpacken von fahcontrol (7.5.1-1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von fahcontrol:
 fahcontrol hängt ab von python-gnome2; aber:
  Paket python-gnome2 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes fahcontrol (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Trigger für mime-support (3.64) werden verarbeitet ...
Trigger für desktop-file-utils (0.24-1) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 fahcontrol
root@vogon:~/fah# uname -a
Linux vogon 5.4.0-4-amd64 #1 SMP Debian 5.4.19-1 (2020-02-13) x86_64 GNU/Linux
mad_martn
 
Posts: 21
Joined: Sat Mar 28, 2020 7:34 pm

Re: Linux Installation Dependencies, Problems

Postby JeSuisFlaneur » Sat Mar 28, 2020 10:34 pm

See here for how to workaround the python problem. I'm as far as the FAHControl working, but I'm still not online. Like due to my lack of computer nerdness. viewtopic.php?f=61&t=32463
JeSuisFlaneur
 
Posts: 8
Joined: Tue Mar 24, 2020 10:51 pm

Re: Linux Installation Dependencies, Problems

Postby gnutux95 » Mon Mar 30, 2020 10:58 am

Hello guys,
I confirme with the 7.4.4 a problem with Debian GNU/Linux bullseye/sid and fahcontrol.
fahcontrol_7.4.4-1_all.deb

I will test with the new version .

Thank you.

Regards,
gnutux95
gnutux95
 
Posts: 7
Joined: Mon Mar 30, 2020 10:46 am
Location: France

Re: Linux Installation Dependencies, Problems

Postby mad_martn » Mon Mar 30, 2020 3:04 pm

btw. current fahcontrol 7.5.1-1 doesn't install on Debian buster/stable either caused by the same dependencies problem
mad_martn
 
Posts: 21
Joined: Sat Mar 28, 2020 7:34 pm

Re: Linux Installation Dependencies, Problems

Postby ipkh » Mon Mar 30, 2020 7:17 pm

I can personally attest to installing the clients on Ubuntu 18.04 derivatives. There is a guide over at the evga forums on linux installs that has some very good guidance.
ipkh
 
Posts: 153
Joined: Thu Jul 16, 2015 3:03 pm

Re: Linux Installation Dependencies, Problems

Postby mad_martn » Mon Mar 30, 2020 8:39 pm

no guidance needed, just a fahcontrol package with dependencies that can be met. It is no user error, its wrong dependencies in the fahcontrol deb package
mad_martn
 
Posts: 21
Joined: Sat Mar 28, 2020 7:34 pm

Re: Linux Installation Dependencies, Problems

Postby Joe_H » Mon Mar 30, 2020 10:04 pm

mad_martn wrote:no guidance needed, just a fahcontrol package with dependencies that can be met. It is no user error, its wrong dependencies in the fahcontrol deb package

You are welcome to post fixes as part of a problem report on the GitHub space for F@h. FAHControl is open source, the developer can choose which fixes to incorporate into a future version after the COVID-19 response is over. You would be joining some others who have already volunteered to look at that source.

The current client was released 2 years ago, it does not get constant updates. The dependencies used were what would be available on a variety of Linux releases current then, and recent LTS versions. A new version of the client was planned for testing later this year or next year, currently on hold until after COVID-19. F@h has limited software development resources, the developer (singular) who handles the client and server software, plus a few other things, has been directed to concentrate on getting more servers setup and into service.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 6526
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: Linux Installation Dependencies, Problems

Postby mad_martn » Mon Mar 30, 2020 10:44 pm

sorry i didn't know about circumstances, fahclient installs and is working as well as fahviewer so i guess i don't miss that much going without fahcontrol anyway?
mad_martn
 
Posts: 21
Joined: Sat Mar 28, 2020 7:34 pm

Re: Linux Installation Dependencies, Problems

Postby gnutux95 » Wed Apr 01, 2020 4:27 pm

I have some problem with FAHControl even in the new version in 7.5.1 on the Debian sid/bulleye

I have several computer. 2 on Debian sid/bulleye.
The package FAHControl is not happy :)
But On one computer it is install and I can launch the console, but not for the other.
If I put apt --fix-broken install it removes the packet.
Everything is working except i can't launch FAHControl :/
To prevent the hardware higher temp, I put a cpulimit and i have a crontab to check it and fix it every minute to control the cpu load share.

Intersting things on Fedora 31, FAHControl can't be launched, I think the python code is compatible for 2.7 but not for 3.7 that is the problem.

Rq : it is shame to build a repository for each, we could do it to easy support and release the version and keep into the current version for the Linux distribution.

Regards,
gnutux95
 
Posts: 7
Joined: Mon Mar 30, 2020 10:46 am
Location: France

Re: Linux Installation Dependencies, Problems

Postby ArianMohlmann » Thu Apr 02, 2020 7:51 am

python2 seems to work,

Change first line of /usr/bin/FAHControl

Requires root privileges to do so.
First line add 2 after python

#!/usr/bin/python2
ArianMohlmann
 
Posts: 15
Joined: Thu Apr 02, 2020 7:39 am

Re: Linux Installation Dependencies, Problems

Postby pr0ti3n » Thu Apr 02, 2020 11:10 am

gnutux95 wrote:I have some problem with FAHControl even in the new version in 7.5.1 on the Debian sid/bulleye


I've found on Debian 10 and above if you git clone the f@h git repo for fah-control


cd to that directory and run:

Code: Select all
python setup.py build


Code: Select all
sudo python setup.py install


I had no problems. :D
Image
User avatar
pr0ti3n
 
Posts: 16
Joined: Wed Apr 01, 2020 3:31 am
Location: @homefolding

Next

Return to V7.5.1 Public Release Windows/Linux/MacOS X

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron