GPU Slot has gone away

Moderators: Site Moderators, FAHC Science Team

GPU Slot has gone away

Postby chuck132 » Sun May 17, 2020 7:48 pm

For two weeks, I have been successfully folding on my GPU. After installing the latest Ubuntu security patch, I have
been unable to get a GPU slot. I am running Ubuntu 20.04 LTS on a Ryzen 3700X.

The GPU is:
NVIDIA Corporation: TU106 [GeForce RTX 2060 SUPER]
Using NVIDIA driver metapackage from nvidia-driver-440 (proprietary, tested)

FAH sees the GPU. In the System Info tab is says:
GPUs 1
GPU 0 Bus:8 Slot:0 Func:0 NVIDIA:7 TU106 [GeForce RTX 2060 Super]
CUDA Device 0 Platform:0 Device:0 Bus:8 Slot:0 Compute:7.5 Driver:10.2

When I try to add a GPU slot using gpu-index of -1 or 0, then OK, then Save, no GPU slot is added and no error message is given.
chuck132
 
Posts: 5
Joined: Sat May 16, 2020 8:01 am

Re: GPU Slot has gone away

Postby PantherX » Sun May 17, 2020 8:26 pm

Welcome to the F@H Forum chuck132,

Can you please post the log file? Ensure you include the first 100 lines which will inform us of what the system configuration is and what the client settings are. If you require guidance, please view this topic: viewtopic.php?f=24&t=26036

Also, have you installed the OpenCL package?
ETA:
Now ↞ Very Soon ↔ Soon ↔ Soon-ish ↔ Not Soon ↠ End Of Time

Welcome To The F@H Support Forum Ӂ Troubleshooting Bad WUs Ӂ Troubleshooting Server Connectivity Issues
User avatar
PantherX
Site Moderator
 
Posts: 6345
Joined: Wed Dec 23, 2009 10:33 am
Location: Land Of The Long White Cloud

Re: GPU Slot has gone away

Postby MeeLee » Sun May 17, 2020 8:37 pm

If it was blacklisted before because of a bad overclock, it's best to just restart the pc, and reset the GPU back to stock.
Also verify if it's working properly in Windows, by testing with a graphics benchmark
MeeLee
 
Posts: 932
Joined: Tue Feb 19, 2019 11:16 pm

Re: GPU Slot has gone away

Postby chuck132 » Sun May 17, 2020 8:47 pm

Here are the first 100 lines of the log file:
Code: Select all
*********************** Log Started 2020-05-16T07:15:58Z ***********************
07:15:58:Trying to access database...
07:15:58:Successfully acquired database lock
07:15:59:Downloading GPUs.txt from assign1.foldingathome.org:80
07:15:59:Connecting to assign1.foldingathome.org:80
07:15:59:Read GPUs.txt
07:15:59:FS00:Set client configured
07:15:59:Enabled folding slot 00: READY cpu:15
07:15:59:****************************** FAHClient ******************************
07:15:59:      Version: 7.6.13
07:15:59:       Author: Joseph Coffland <joseph@cauldrondevelopment.com>
07:15:59:    Copyright: 2020 foldingathome.org
07:15:59:     Homepage: https://foldingathome.org/
07:15:59:         Date: Apr 28 2020
07:15:59:         Time: 04:20:16
07:15:59:     Revision: 5a652817f46116b6e135503af97f18e094414e3b
07:15:59:       Branch: master
07:15:59:     Compiler: GNU 8.3.0
07:15:59:      Options: -std=c++11 -ffunction-sections -fdata-sections -O3 -funroll-loops
07:15:59:               -fno-pie
07:15:59:     Platform: linux2 4.19.0-5-amd64
07:15:59:         Bits: 64
07:15:59:         Mode: Release
07:15:59:         Args: --child /etc/fahclient/config.xml --run-as fahclient
07:15:59:               --pid-file=/var/run/fahclient.pid --daemon
07:15:59:       Config: /etc/fahclient/config.xml
07:15:59:******************************** CBang ********************************
07:15:59:         Date: Apr 25 2020
07:15:59:         Time: 00:07:53
07:15:59:     Revision: ea081a3b3b0f4a37c4d0440b4f1bc184197c7797
07:15:59:       Branch: master
07:15:59:     Compiler: GNU 8.3.0
07:15:59:      Options: -std=c++11 -ffunction-sections -fdata-sections -O3 -funroll-loops
07:15:59:               -fno-pie -fPIC
07:15:59:     Platform: linux2 4.19.0-5-amd64
07:15:59:         Bits: 64
07:15:59:         Mode: Release
07:15:59:******************************* System ********************************
07:15:59:          CPU: AMD Ryzen 7 3700X 8-Core Processor
07:15:59:       CPU ID: AuthenticAMD Family 23 Model 113 Stepping 0
07:15:59:         CPUs: 16
07:15:59:       Memory: 31.29GiB
07:15:59:  Free Memory: 17.61GiB
07:15:59:      Threads: POSIX_THREADS
07:15:59:   OS Version: 5.4
07:15:59:  Has Battery: false
07:15:59:   On Battery: false
07:15:59:   UTC Offset: -4
07:15:59:          PID: 56409
07:15:59:          CWD: /var/lib/fahclient
07:15:59:           OS: Linux 5.4.0-29-generic x86_64
07:15:59:      OS Arch: AMD64
07:15:59:         GPUs: 1
07:15:59:        GPU 0: Bus:8 Slot:0 Func:0 NVIDIA:7 TU106 [GeForce RTX 2060 Super]
07:15:59:CUDA Device 0: Platform:0 Device:0 Bus:8 Slot:0 Compute:7.5 Driver:10.2
07:15:59:       OpenCL: Not detected: Failed to open dynamic library 'libOpenCL.so':
07:15:59:               libOpenCL.so: cannot open shared object file: No such file or
07:15:59:               directory
07:15:59:******************************* libFAH ********************************
07:15:59:         Date: Apr 15 2020
07:15:59:         Time: 21:43:24
07:15:59:     Revision: 216968bc7025029c841ed6e36e81a03a316890d3
07:15:59:       Branch: master
07:15:59:     Compiler: GNU 8.3.0
07:15:59:      Options: -std=c++11 -ffunction-sections -fdata-sections -O3 -funroll-loops
07:15:59:               -fno-pie
07:15:59:     Platform: linux2 4.19.0-5-amd64
07:15:59:         Bits: 64
07:15:59:         Mode: Release
07:15:59:***********************************************************************
07:15:59:<config>
07:15:59:  <!-- Client Control -->
07:15:59:  <fold-anon v='true'/>
07:15:59:
07:15:59:  <!-- Folding Slot Configuration -->
07:15:59:  <gpu v='false'/>
07:15:59:
07:15:59:  <!-- User Information -->
07:15:59:  <user v='CKQuadro'/>
07:15:59:
07:15:59:  <!-- Folding Slots -->
07:15:59:  <slot id='0' type='CPU'/>
07:15:59:</config>
07:15:59:WU00:FS00:Connecting to assign1.foldingathome.org:80
07:16:00:WU00:FS00:Connecting to assign1.foldingathome.org:80
07:16:01:WU00:FS00:Assigned to work server 3.21.157.11
07:16:01:WU00:FS00:Requesting new work unit for slot 00: READY cpu:15 from 3.21.157.11
07:16:01:WU00:FS00:Connecting to 3.21.157.11:8080
07:16:01:WU00:FS00:Downloading 2.83MiB
07:16:02:WU00:FS00:Download complete
07:16:02:WU00:FS00:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:14802 run:673 clone:0 gen:14 core:0xa7 unit:0x0000000e03159d0b5eb1817af797707e
07:16:02:WU00:FS00:Downloading core from http://cores.foldingathome.org/v7/lin/64bit/avx/Core_a7.fah
07:16:02:WU00:FS00:Connecting to cores.foldingathome.org:80
07:16:02:WU00:FS00:FahCore a7: Downloading 8.91MiB
07:16:06:WU00:FS00:FahCore a7: Download complete
07:16:07:WU00:FS00:Valid core signature
07:16:07:WU00:FS00:Unpacked 20.97MiB to cores/cores.foldingathome.org/v7/lin/64bit/avx/Core_a7.fah/FahCore_a7
07:16:07:WU00:FS00:Starting
07:16:07:WU00:FS00:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/cores.foldingathome.org/v7/lin/64bit/avx/Core_a7.fah/FahCore_a7 -dir 00 -suffix 01 -version 706 -lifeline 56409 -checkpoint 15 -np 15
07:16:07:WU00:FS00:Started FahCore on PID 56518


I have not installed OpenCL, but it was not installed when the GPU slot was working either. I did try installing CUDA but that did not help.

Thanks


Thanks
chuck132
 
Posts: 5
Joined: Sat May 16, 2020 8:01 am

Re: GPU Slot has gone away

Postby chuck132 » Sun May 17, 2020 8:51 pm

Also, this is a Gigabyte Windforce OC 8G model of the RTX 2060 Super. It is factory overclocked and I have not changed the settings.
chuck132
 
Posts: 5
Joined: Sat May 16, 2020 8:01 am

Re: GPU Slot has gone away

Postby bruce » Sun May 17, 2020 11:04 pm

If you were on Windows, I'd tell you to install the drivers directly from nVidia because OpenCL is included with them. When you're on Linux, it's a different story. You DO need to install the proprietary drivers AND you do need to install OpenCL. It's possible (but unliekly) that they were included with your distro. but FAH won't run without them.

(sudo apt install ocl-icd-opencl-dev)
bruce
 
Posts: 19697
Joined: Thu Nov 29, 2007 11:13 pm
Location: So. Cal.

Re: GPU Slot has gone away

Postby PantherX » Mon May 18, 2020 1:44 am

This message indicated that the client has detected a usable GPU:
07:15:59: GPUs: 1

This message informs what the GPU detected is:
07:15:59: GPU 0: Bus:8 Slot:0 Func:0 NVIDIA:7 TU106 [GeForce RTX 2060 Super]

This message only applies to Nvidia GPUs and tells what driver version it is:
07:15:59:CUDA Device 0: Platform:0 Device:0 Bus:8 Slot:0 Compute:7.5 Driver:10.2

This message applies to AMD/Nvidia and tells what the OpenCL version is
07:15:59: OpenCL: Not detected: Failed to open dynamic library 'libOpenCL.so':
07:15:59: libOpenCL.so: cannot open shared object file: No such file or
07:15:59: directory

In your case, it "fails" at the last message and bruce has the solution.

Also, I think that this needs to be changed to true once the OpenCL package is installed which will allow the creation of GPU Slot:
07:15:59: <gpu v='false'/>

BTW, I have noticed that you're not using a passkey. It is recommended to use one due to security reasons and bonus points. Here's an article for you to review and make an informed decision: https://foldingathome.org/support/faq/points/passkey/
User avatar
PantherX
Site Moderator
 
Posts: 6345
Joined: Wed Dec 23, 2009 10:33 am
Location: Land Of The Long White Cloud

Re: GPU Slot has gone away

Postby chuck132 » Mon May 18, 2020 8:59 pm

>>This message only applies to Nvidia GPUs and tells what driver version it is:
>>07:15:59:CUDA Device 0: Platform:0 Device:0 Bus:8 Slot:0 Compute:7.5 Driver:10.2

I installed the CUDA driver only after it stopped working in a failed attempt to fix it. When it was working, it only had the NVIDIA driver and no CUDA and no OpenCL.

NVIDIA driver is: "NVIDIA driver metapackage from nvidia-driver-440 (proprietary, tested)"

Not sure why I have to install OpenCL since it was not installed when the GPU slot was working. There seem to be many versions of OpenCL and I am not sure which one to install. Must be compatible with Ubuntu 20.04.
I tried installing nvidia-opencl-icd-340 which seemed to install OK. It insisted on uninstalling CUDA. FAHClient does not seem to see it:
"OpenCL Not detected: clGetPlatformIDs() returned -1001"
chuck132
 
Posts: 5
Joined: Sat May 16, 2020 8:01 am

Re: GPU Slot has gone away

Postby PantherX » Mon May 18, 2020 9:44 pm

From what I have read, this seems to the OpenCL package on Linux which has worked for AMD/Nvidia GPUs:
sudo apt install ocl-icd-opencl-dev

The only explanation as to why you were able to fold with only Nvidia proprietary drivers is Linux is magical and does it's own thing :lol: Someone with more Linux experience than myself might be able to explain it better :)
User avatar
PantherX
Site Moderator
 
Posts: 6345
Joined: Wed Dec 23, 2009 10:33 am
Location: Land Of The Long White Cloud

Re: GPU Slot has gone away

Postby chuck132 » Tue May 26, 2020 8:51 pm

So I gave up on Ubuntu. Could not get GPU to work in anything after installing security update. I switch over to Windows and it seems to be folding fine with the GPU.
chuck132
 
Posts: 5
Joined: Sat May 16, 2020 8:01 am

Re: GPU Slot has gone away

Postby MeeLee » Wed May 27, 2020 12:38 am

When you install a new kernel, you will have to reinstall the drivers.
Nvidia drivers modify the kernel.
If you've installed the drivers via sudo apt, uninstall your .deb files by doing:
Sudo apt purge Nvidia*

Then install the .run files (less problems); you have to do:
1- Download the Nvidia .run files, eg: in your downloads folder.
2- Make the .run file executable,
3- Boot into grub, and select 'recovery'
4- Click to Enable networking (just to be safe), and go into shell mode (before GUI)
5- Once you're in the terminal (aka: Shell/ Linux DOS mode), go to the download folder, and type "sudo ./NVIDIAdriverversion.run"
You can do this by typing "sudo N" and then press the 'tab' key, to autocomplete the right file name.
6- Go through the process, if it crashes or fails, redo the process. Don't install 32 bit libraries. But the rest of the popups, just enable, overwrite and confirm.
7- Reboot the PC, your drivers should work now.
MeeLee
 
Posts: 932
Joined: Tue Feb 19, 2019 11:16 pm


Return to V7.5.1 Public Release Windows/Linux/MacOS X

Who is online

Users browsing this forum: No registered users and 1 guest

cron