GPU [Not Folding - Mint 20.04 LTS]

Moderators: Site Moderators, FAHC Science Team

GPU [Not Folding - Mint 20.04 LTS]

Postby JamesMcCann » Sat Jul 18, 2020 8:51 pm

Hi can you add TU106 [GeForce RTX 2060 SUPER] ASUS
but my GPU shows on the programme its FahCore is 0x22 it is waiting on a FahCore Run and it is just waiting on The ETA of 24 hours 00 mins but it keeps jumping from job to job in this condition
can you help please

VendorID:DeviceID:PCI Bus:PCI Slot:PCI function:Vendor Name:Description
0x8086:0x2020:0:0:0:Intel Corporation:
0x8086:0x2021:0:4:0:Intel Corporation:
0x8086:0x2021:0:4:1:Intel Corporation:
0x8086:0x2021:0:4:2:Intel Corporation:
0x8086:0x2021:0:4:3:Intel Corporation:
0x8086:0x2021:0:4:4:Intel Corporation:
0x8086:0x2021:0:4:5:Intel Corporation:
0x8086:0x2021:0:4:6:Intel Corporation:
0x8086:0x2021:0:4:7:Intel Corporation:
0x8086:0x2024:0:5:0:Intel Corporation:
0x8086:0x2025:0:5:2:Intel Corporation:
0x8086:0x2026:0:5:4:Intel Corporation:
0x8086:0x2014:0:8:0:Intel Corporation:
0x8086:0x2015:0:8:1:Intel Corporation:
0x8086:0x2016:0:8:2:Intel Corporation:
0x8086:0xa2af:0:20:0:Intel Corporation:
0x8086:0xa2b1:0:20:2:Intel Corporation:
0x8086:0xa2ba:0:22:0:Intel Corporation:
0x8086:0xa282:0:23:0:Intel Corporation:
0x8086:0xa2e7:0:27:0:Intel Corporation:
0x8086:0xa2eb:0:27:4:Intel Corporation:
0x8086:0xa290:0:28:0:Intel Corporation:
0x8086:0xa294:0:28:4:Intel Corporation:
0x8086:0xa2d2:0:31:0:Intel Corporation:
0x8086:0xa2a1:0:31:2:Intel Corporation:
0x8086:0xa2f0:0:31:3:Intel Corporation:
0x8086:0xa2a3:0:31:4:Intel Corporation:
0x8086:0x15b8:0:31:6:Intel Corporation:
Segmentation fault (core dumped)
JamesMcCann
 
Posts: 5
Joined: Sat Jul 18, 2020 8:18 pm

Re: GPU

Postby Joe_H » Sat Jul 18, 2020 9:02 pm

Please post the first 100-200 lines of your log. Directions for locating the log and posting its contents are here - viewtopic.php?f=61&t=26036.

Based on you mentioning that Core_22 is shown as running, this GPU is already added as one of the three different Device ID numbers for a 2060 Super GPU in the GPUs.txt file. If the WU is not running, the slot cn be waiting for your system to be idle, no user input detected from keyboard, mouse, etc.

If the runs just keep ending with an error, you may be running on just the MS Windows Update drivers. You will need to download drivers from nVidia to support your 2060 Super which includes the OpenCL support that MS leaves out.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 6608
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: GPU

Postby bruce » Sun Jul 19, 2020 12:42 am

The information you posed about devices 0x8086:0x....0:Intel Corporation... is not useful so we're ignoring it. The Intel IGPs are not supported at this time.

Additional information about the Segmentation fault (core dumped) will probably be useful. Please post that segment of FAH's log along with the portion mentione above.
bruce
 
Posts: 20010
Joined: Thu Nov 29, 2007 11:13 pm
Location: So. Cal.

Re: GPU

Postby JamesMcCann » Sun Jul 19, 2020 4:18 am

Hi I am running it on Linux mint 20.04 LTS if that helps
JamesMcCann
 
Posts: 5
Joined: Sat Jul 18, 2020 8:18 pm

Re: GPU

Postby JamesMcCann » Sun Jul 19, 2020 4:56 am

Code: Select all
*********************** Log Started 2020-07-19T03:39:50Z ***********************
03:39:50:Trying to access database...
03:39:50:Successfully acquired database lock
03:39:50:Read GPUs.txt
03:39:50:Enabled folding slot 00: PAUSED cpu:10 (by user)
03:39:50:Enabled folding slot 01: PAUSED gpu:0:TU106 [GeForce RTX 2060 SUPER] (by user)
03:39:50:****************************** FAHClient ******************************
03:39:50:      Version: 7.6.13
03:39:50:       Author: Joseph Coffland <joseph@cauldrondevelopment.com>
03:39:50:    Copyright: 2020 foldingathome.org
03:39:50:     Homepage: https://foldingathome.org/
03:39:50:         Date: Apr 28 2020
03:39:50:         Time: 04:20:16
03:39:50:     Revision: 5a652817f46116b6e135503af97f18e094414e3b
03:39:50:       Branch: master
03:39:50:     Compiler: GNU 8.3.0
03:39:50:      Options: -std=c++11 -ffunction-sections -fdata-sections -O3 -funroll-loops
03:39:50:               -fno-pie
03:39:50:     Platform: linux2 4.19.0-5-amd64
03:39:50:         Bits: 64
03:39:50:         Mode: Release
03:39:50:         Args: --child /etc/fahclient/config.xml --run-as fahclient
03:39:50:               --pid-file=/var/run/fahclient.pid --daemon
03:39:50:       Config: /etc/fahclient/config.xml
03:39:50:******************************** CBang ********************************
03:39:50:         Date: Apr 25 2020
03:39:50:         Time: 00:07:53
03:39:50:     Revision: ea081a3b3b0f4a37c4d0440b4f1bc184197c7797
03:39:50:       Branch: master
03:39:50:     Compiler: GNU 8.3.0
03:39:50:      Options: -std=c++11 -ffunction-sections -fdata-sections -O3 -funroll-loops
03:39:50:               -fno-pie -fPIC
03:39:50:     Platform: linux2 4.19.0-5-amd64
03:39:50:         Bits: 64
03:39:50:         Mode: Release
03:39:50:******************************* System ********************************
03:39:50:          CPU: Intel(R) Core(TM) i7-7800X CPU @ 3.50GHz
03:39:50:       CPU ID: GenuineIntel Family 6 Model 85 Stepping 4
03:39:50:         CPUs: 12
03:39:50:       Memory: 62.51GiB
03:39:50:  Free Memory: 61.59GiB
03:39:50:      Threads: POSIX_THREADS
03:39:50:   OS Version: 5.4
03:39:50:  Has Battery: false
03:39:50:   On Battery: false
03:39:50:   UTC Offset: 1
03:39:50:          PID: 1725
03:39:50:          CWD: /var/lib/fahclient
03:39:50:           OS: Linux 5.4.0-40-generic x86_64
03:39:50:      OS Arch: AMD64
03:39:50:         GPUs: 1
03:39:50:        GPU 0: Bus:101 Slot:0 Func:0 NVIDIA:7 TU106 [GeForce RTX 2060 SUPER]
03:39:50:CUDA Device 0: Platform:0 Device:0 Bus:101 Slot:0 Compute:7.5 Driver:10.2
03:39:50:       OpenCL: Not detected: Failed to open dynamic library 'libOpenCL.so':
03:39:50:               libOpenCL.so: cannot open shared object file: No such file or
03:39:50:               directory
03:39:50:******************************* libFAH ********************************
03:39:50:         Date: Apr 15 2020
03:39:50:         Time: 21:43:24
03:39:50:     Revision: 216968bc7025029c841ed6e36e81a03a316890d3
03:39:50:       Branch: master
03:39:50:     Compiler: GNU 8.3.0
03:39:50:      Options: -std=c++11 -ffunction-sections -fdata-sections -O3 -funroll-loops
03:39:50:               -fno-pie
03:39:50:     Platform: linux2 4.19.0-5-amd64
03:39:50:         Bits: 64
03:39:50:         Mode: Release
03:39:50:***********************************************************************
03:39:50:<config>
03:39:50:  <!-- Client Control -->
03:39:50:  <fold-anon v='true'/>
03:39:50:
03:39:50:  <!-- Folding Slot Configuration -->
03:39:50:  <cause v='COVID_19'/>
03:39:50:  <gpu v='false'/>
03:39:50:
03:39:50:  <!-- Network -->
03:39:50:  <proxy v=':8080'/>
03:39:50:
03:39:50:  <!-- Slot Control -->
03:39:50:  <pause-on-battery v='false'/>
03:39:50:
03:39:50:  <!-- User Information -->
03:39:50:  <passkey v='*****'/>
03:39:50:  <user v='JamesMcCann'/>
03:39:50:
03:39:50:  <!-- Folding Slots -->
03:39:50:  <slot id='0' type='CPU'>
03:39:50:    <paused v='true'/>
03:39:50:  </slot>
03:39:50:  <slot id='1' type='GPU'>
03:39:50:    <paused v='true'/>
03:39:50:  </slot>
03:39:50:</config>
03:39:50:WU02:FS00:Sending unit results: id:02 state:SEND error:NO_ERROR project:13851 run:0 clone:9436 gen:264 core:0xa7 unit:0x00000136287234c95e72ea5df609a646
03:39:50:WU02:FS00:Uploading 2.51MiB to 40.114.52.201
03:39:50:WU02:FS00:Connecting to 40.114.52.201:8080
03:39:50:WARNING:WU02:FS00:WorkServer connection failed on port 8080 trying 80
03:39:50:WU02:FS00:Connecting to 40.114.52.201:80
03:39:51:WARNING:WU02:FS00:Exception: Failed to send results to work server: Transfer failed
03:39:51:WU02:FS00:Trying to send results to collection server
03:39:51:WU02:FS00:Uploading 2.51MiB to 52.224.109.74
03:39:51:WU02:FS00:Connecting to 52.224.109.74:8080
03:39:51:WARNING:WU02:FS00:WorkServer connection failed on port 8080 trying 80
03:39:51:WU02:FS00:Connecting to 52.224.109.74:80
03:39:52:ERROR:WU02:FS00:Exception: Failed to connect to 52.224.109.74:80: Connection refused
03:39:52:WU02:FS00:Sending unit results: id:02 state:SEND error:NO_ERROR project:13851 run:0 clone:9436 gen:264 core:0xa7 unit:0x00000136287234c95e72ea5df609a646
03:39:52:WU02:FS00:Uploading 2.51MiB to 40.114.52.201
03:39:52:WU02:FS00:Connecting to 40.114.52.201:8080
03:39:52:WARNING:WU02:FS00:WorkServer connection failed on port 8080 trying 80
03:39:52:WU02:FS00:Connecting to 40.114.52.201:80
03:39:53:WARNING:WU02:FS00:Exception: Failed to send results to work server: Failed to connect to 40.114.52.201:80: Connection refused
03:39:53:WU02:FS00:Trying to send results to collection server
03:39:53:WU02:FS00:Uploading 2.51MiB to 52.224.109.74
03:39:53:WU02:FS00:Connecting to 52.224.109.74:8080
03:39:53:WARNING:WU02:FS00:WorkServer connection failed on port 8080 trying 80
03:39:53:WU02:FS00:Connecting to 52.224.109.74:80
03:39:53:ERROR:WU02:FS00:Exception: Failed to connect to 52.224.109.74:80: Connection refused
03:40:52:WU02:FS00:Sending unit results: id:02 state:SEND error:NO_ERROR project:13851 run:0 clone:9436 gen:264 core:0xa7 unit:0x00000136287234c95e72ea5df609a646
03:40:52:WU02:FS00:Uploading 2.51MiB to 40.114.52.201
03:40:52:WU02:FS00:Connecting to 40.114.52.201:8080
03:40:52:WARNING:WU02:FS00:WorkServer connection failed on port 8080 trying 80
03:40:52:WU02:FS00:Connecting to 40.114.52.201:80
03:40:52:WARNING:WU02:FS00:Exception: Failed to send results to work server: Failed to connect to 40.114.52.201:80: Connection refused
03:40:52:WU02:FS00:Trying to send results to collection server
03:40:52:WU02:FS00:Uploading 2.51MiB to 52.224.109.74
03:40:52:WU02:FS00:Connecting to 52.224.109.74:8080
03:40:52:WARNING:WU02:FS00:WorkServer connection failed on port 8080 trying 80
03:40:52:WU02:FS00:Connecting to 52.224.109.74:80
03:40:53:ERROR:WU02:FS00:Exception: Failed to connect to 52.224.109.74:80: Connection refused
03:41:01:FS00:Unpaused
03:41:01:FS01:Unpaused
03:41:01:WU01:FS01:Starting
03:41:01:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, make sure the OpenCL driver is installed or try setting 'opencl-index' manually
03:41:01:WU00:FS00:Starting
03:41:01:WU00:FS00:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/cores.foldingathome.org/lin/64bit-avx-256/a7-0.0.19/Core_a7.fah/FahCore_a7 -dir 00 -suffix 01 -version 706 -lifeline 1725 -checkpoint 15 -np 10
03:41:01:WU00:FS00:Started FahCore on PID 3039
03:41:01:WU00:FS00:Core PID:3043
03:41:01:WU00:FS00:FahCore 0xa7 started
03:41:01:WU01:FS01:Starting
03:41:01:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, make sure the OpenCL driver is installed or try setting 'opencl-index' manually
03:41:01:WU00:FS00:0xa7:*********************** Log Started 2020-07-19T03:41:01Z ***********************
03:41:01:WU00:FS00:0xa7:************************** Gromacs Folding@home Core ***************************
03:41:01:WU00:FS00:0xa7:       Type: 0xa7
03:41:01:WU00:FS00:0xa7:       Core: Gromacs
03:41:01:WU00:FS00:0xa7:       Args: -dir 00 -suffix 01 -version 706 -lifeline 3039 -checkpoint 15 -np
03:41:01:WU00:FS00:0xa7:             10
03:41:01:WU00:FS00:0xa7:************************************ CBang *************************************
03:41:01:WU00:FS00:0xa7:       Date: Nov 27 2019
03:41:01:WU00:FS00:0xa7:       Time: 11:26:54
03:41:01:WU00:FS00:0xa7:   Revision: d25803215b59272441049dfa05a0a9bf7a6e3c48
03:41:01:WU00:FS00:0xa7:     Branch: master
03:41:01:WU00:FS00:0xa7:   Compiler: GNU 8.3.0
03:41:01:WU00:FS00:0xa7:    Options: -std=c++11 -ffunction-sections -fdata-sections -O3 -funroll-loops
03:41:01:WU00:FS00:0xa7:             -fno-pie -fPIC
03:41:01:WU00:FS00:0xa7:   Platform: linux2 4.19.0-5-amd64
03:41:01:WU00:FS00:0xa7:       Bits: 64
03:41:01:WU00:FS00:0xa7:       Mode: Release
03:41:01:WU00:FS00:0xa7:************************************ System ************************************
03:41:01:WU00:FS00:0xa7:        CPU: Intel(R) Core(TM) i7-7800X CPU @ 3.50GHz
03:41:01:WU00:FS00:0xa7:     CPU ID: GenuineIntel Family 6 Model 85 Stepping 4
03:41:01:WU00:FS00:0xa7:       CPUs: 12
03:41:01:WU00:FS00:0xa7:     Memory: 62.51GiB
03:41:01:WU00:FS00:0xa7:Free Memory: 60.03GiB
03:41:01:WU00:FS00:0xa7:    Threads: POSIX_THREADS
03:41:01:WU00:FS00:0xa7: OS Version: 5.4
03:41:01:WU00:FS00:0xa7:Has Battery: false
03:41:01:WU00:FS00:0xa7: On Battery: false
03:41:01:WU00:FS00:0xa7: UTC Offset: 1
03:41:01:WU00:FS00:0xa7:        PID: 3043
03:41:01:WU00:FS00:0xa7:        CWD: /var/lib/fahclient/work
03:41:01:WU00:FS00:0xa7:******************************** Build - libFAH ********************************
03:41:01:WU00:FS00:0xa7:    Version: 0.0.19
03:41:01:WU00:FS00:0xa7:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
03:41:01:WU00:FS00:0xa7:  Copyright: 2019 foldingathome.org
03:41:01:WU00:FS00:0xa7:   Homepage: https://foldingathome.org/
03:41:01:WU00:FS00:0xa7:       Date: Nov 26 2019
03:41:01:WU00:FS00:0xa7:       Time: 00:41:42
03:41:01:WU00:FS00:0xa7:   Revision: d5b5c747532224f986b7cd02c968ed9a20c16d6e
03:41:01:WU00:FS00:0xa7:     Branch: master
03:41:01:WU00:FS00:0xa7:   Compiler: GNU 8.3.0
03:41:01:WU00:FS00:0xa7:    Options: -std=c++11 -ffunction-sections -fdata-sections -O3 -funroll-loops
03:41:01:WU00:FS00:0xa7:             -fno-pie
03:41:01:WU00:FS00:0xa7:   Platform: linux2 4.19.0-5-amd64
03:41:01:WU00:FS00:0xa7:       Bits: 64
03:41:01:WU00:FS00:0xa7:       Mode: Release
03:41:01:WU00:FS00:0xa7:************************************ Build *************************************
03:41:01:WU00:FS00:0xa7:       SIMD: avx_256
03:41:01:WU00:FS00:0xa7:********************************************************************************
03:41:01:WU00:FS00:0xa7:Project: 13794 (Run 8, Clone 333, Gen 16)
03:41:01:WU00:FS00:0xa7:Unit: 0x000000150002894c5dae0b31ae0f4e29
03:41:01:WU00:FS00:0xa7:Digital signatures verified
03:41:01:WU00:FS00:0xa7:Calling: mdrun -s frame16.tpr -o frame16.trr -cpi state.cpt -cpt 15 -nt 10
03:41:01:WU00:FS00:0xa7:Steps: first=40000000 total=2500000
03:41:02:WU00:FS00:0xa7:Completed 2316822 out of 2500000 steps (92%)
03:41:51:WU00:FS00:0xa7:Completed 2325000 out of 2500000 steps (93%)
03:41:52:Removing old file 'configs/config-20200713-151705.xml'
03:41:52:Saving configuration to /etc/fahclient/config.xml
03:41:52:<config>
03:41:52:  <!-- Client Control -->
03:41:52:  <fold-anon v='true'/>
03:41:52:
03:41:52:  <!-- Folding Slot Configuration -->
03:41:52:  <cause v='COVID_19'/>
03:41:52:  <gpu v='false'/>
03:41:52:
03:41:52:  <!-- Network -->
03:41:52:  <proxy v=':8080'/>
03:41:52:
03:41:52:  <!-- Slot Control -->
03:41:52:  <pause-on-battery v='false'/>
03:41:52:
03:41:52:  <!-- User Information -->
03:41:52:  <passkey v='*****'/>
03:41:52:  <user v='JamesMcCann'/>
03:41:52:
03:41:52:  <!-- Folding Slots -->
03:41:52:  <slot id='0' type='CPU'/>
03:41:52:  <slot id='1' type='GPU'/>
03:41:52:</config>
03:41:52:WU02:FS00:Sending unit results: id:02 state:SEND error:NO_ERROR project:13851 run:0 clone:9436 gen:264 core:0xa7 unit:0x00000136287234c95e72ea5df609a646
03:41:52:WU02:FS00:Uploading 2.51MiB to 40.114.52.201
03:41:52:WU02:FS00:Connecting to 40.114.52.201:8080
03:41:52:WARNING:WU02:FS00:WorkServer connection failed on port 8080 trying 80
03:41:52:WU02:FS00:Connecting to 40.114.52.201:80
03:41:52:WARNING:WU02:FS00:Exception: Failed to send results to work server: Failed to connect to 40.114.52.201:80: Connection refused
03:41:52:WU02:FS00:Trying to send results to collection server
03:41:52:WU02:FS00:Uploading 2.51MiB to 52.224.109.74
03:41:52:WU02:FS00:Connecting to 52.224.109.74:8080
03:41:52:WARNING:WU02:FS00:WorkServer connection failed on port 8080 trying 80
03:41:52:WU02:FS00:Connecting to 52.224.109.74:80
03:41:53:ERROR:WU02:FS00:Exception: Failed to connect to 52.224.109.74:80: Connection refused
03:42:01:WU01:FS01:Starting
03:42:01:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, make sure the OpenCL driver is installed or try setting 'opencl-index' manually
03:43:29:WU02:FS00:Sending unit results: id:02 state:SEND error:NO_ERROR project:13851 run:0 clone:9436 gen:264 core:0xa7 unit:0x00000136287234c95e72ea5df609a646
03:43:29:WU02:FS00:Uploading 2.51MiB to 40.114.52.201
03:43:29:WU02:FS00:Connecting to 40.114.52.201:8080
03:43:30:WARNING:WU02:FS00:WorkServer connection failed on port 8080 trying 80
03:43:30:WU02:FS00:Connecting to 40.114.52.201:80
03:43:30:WARNING:WU02:FS00:Exception: Failed to send results to work server: Failed to connect to 40.114.52.201:80: Connection refused
03:43:30:WU02:FS00:Trying to send results to collection server
03:43:30:WU02:FS00:Uploading 2.51MiB to 52.224.109.74
03:43:30:WU02:FS00:Connecting to 52.224.109.74:8080
03:43:30:WARNING:WU02:FS00:WorkServer connection failed on port 8080 trying 80
03:43:30:WU02:FS00:Connecting to 52.224.109.74:80
03:43:30:ERROR:WU02:FS00:Exception: Failed to connect to 52.224.109.74:80: Connection refused
03:43:38:WU01:FS01:Starting
03:43:38:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, make sure the OpenCL driver is installed or try setting 'opencl-index' manually
03:44:14:WU00:FS00:0xa7:Completed 2350000 out of 2500000 steps (94%)
03:46:07:WU02:FS00:Sending unit results: id:02 state:SEND error:NO_ERROR project:13851 run:0 clone:9436 gen:264 core:0xa7 unit:0x00000136287234c95e72ea5df609a646
03:46:07:WU02:FS00:Uploading 2.51MiB to 40.114.52.201
03:46:07:WU02:FS00:Connecting to 40.114.52.201:8080
03:46:07:WARNING:WU02:FS00:WorkServer connection failed on port 8080 trying 80
03:46:07:WU02:FS00:Connecting to 40.114.52.201:80
03:46:07:WARNING:WU02:FS00:Exception: Failed to send results to work server: Failed to connect to 40.114.52.201:80: Connection refused
03:46:07:WU02:FS00:Trying to send results to collection server
03:46:07:WU02:FS00:Uploading 2.51MiB to 52.224.109.74
03:46:07:WU02:FS00:Connecting to 52.224.109.74:8080
03:46:07:WARNING:WU02:FS00:WorkServer connection failed on port 8080 trying 80
03:46:07:WU02:FS00:Connecting to 52.224.109.74:80
03:46:07:ERROR:WU02:FS00:Exception: Failed to connect to 52.224.109.74:80: Connection refused
03:46:16:WU01:FS01:Starting
03:46:16:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, make sure the OpenCL driver is installed or try setting 'opencl-index' manually
03:46:35:WU00:FS00:0xa7:Completed 2375000 out of 2500000 steps (95%)
03:48:57:WU00:FS00:0xa7:Completed 2400000 out of 2500000 steps (96%)
03:50:21:WU02:FS00:Sending unit results: id:02 state:SEND error:NO_ERROR project:13851 run:0 clone:9436 gen:264 core:0xa7 unit:0x00000136287234c95e72ea5df609a646
03:50:21:WU02:FS00:Uploading 2.51MiB to 40.114.52.201
03:50:21:WU02:FS00:Connecting to 40.114.52.201:8080
03:50:21:WARNING:WU02:FS00:WorkServer connection failed on port 8080 trying 80
03:50:21:WU02:FS00:Connecting to 40.114.52.201:80
03:50:21:WARNING:WU02:FS00:Exception: Failed to send results to work server: Failed to connect to 40.114.52.201:80: Connection refused
03:50:21:WU02:FS00:Trying to send results to collection server
03:50:21:WU02:FS00:Uploading 2.51MiB to 52.224.109.74
03:50:21:WU02:FS00:Connecting to 52.224.109.74:8080
03:50:21:WARNING:WU02:FS00:WorkServer connection failed on port 8080 trying 80
03:50:21:WU02:FS00:Connecting to 52.224.109.74:80
03:50:22:ERROR:WU02:FS00:Exception: Failed to connect to 52.224.109.74:80: Connection refused
03:50:30:WU01:FS01:Starting
03:50:30:ERROR:WU01:FS01:Failed to start core: OpenCL device matching slot 1 not found, make sure the OpenCL driver is installed or try setting 'opencl-index' manually
03:50:30:WU01:FS01:Sending unit results: id:01 state:SEND error:FAILED project:11761 run:0 clone:7595 gen:96 core:0x22 unit:0x000000b280fccb0a5e70019689e8ed1f
03:50:30:WU01:FS01:Connecting to 128.252.203.10:8080
03:50:31:WU01:FS01:Server responded WORK_ACK (400)
03:50:31:WU01:FS01:Cleaning up
03:50:31:WU03:FS01:Connecting to assign1.foldingathome.org:80
03:50:31:WU03:FS01:Assigned to work server 140.163.4.241
03:50:31:WU03:FS01:Requesting new work unit for slot 01: READY gpu:0:TU106 [GeForce RTX 2060 SUPER] from 140.163.4.241
03:50:31:WU03:FS01:Connecting to 140.163.4.241:8080
03:50:43:WU03:FS01:Downloading 7.85MiB
03:50:48:WU03:FS01:Download complete
03:50:48:WU03:FS01:Received Unit: id:03 state:DOWNLOAD error:NO_ERROR project:11744 run:0 clone:3606 gen:108 core:0x22 unit:0x000000af8ca304f15e69ee08d31b0aec
03:50:48:WU03:FS01:Starting
03:50:48:ERROR:WU03:FS01:Failed to start core: OpenCL device matching slot 1 not found, make sure the OpenCL driver is installed or try setting 'opencl-index' manually
03:50:48:WU03:FS01:Starting
03:50:48:ERROR:WU03:FS01:Failed to start core: OpenCL device matching slot 1 not found, make sure the OpenCL driver is installed or try setting 'opencl-index' manually
03:51:18:WU00:FS00:0xa7:Completed 2425000 out of 2500000 steps (97%)
03:51:48:WU03:FS01:Starting
03:51:48:ERROR:WU03:FS01:Failed to start core: OpenCL device matching slot 1 not found, make sure the OpenCL driver is installed or try setting 'opencl-index' manually
03:53:25:WU03:FS01:Starting
03:53:25:ERROR:WU03:FS01:Failed to start core: OpenCL device matching slot 1 not found, make sure the OpenCL driver is installed or try setting 'opencl-index' manually
03:53:39:WU00:FS00:0xa7:Completed 2450000 out of 2500000 steps (98%)
Last edited by Joe_H on Sun Jul 19, 2020 5:38 am, edited 1 time in total.
Reason: added Code tags to log
JamesMcCann
 
Posts: 5
Joined: Sat Jul 18, 2020 8:18 pm

Re: GPU

Postby Joe_H » Sun Jul 19, 2020 5:52 am

Part of the error messages are pointing to an incomplete install of support for OpenCL. For Linux you need the nVidia proprietary drivers and OpenCL support installed and the OpenCL dev kit. The user that FAHClient and the rest of the processes runs under may need to be added to the video and possibly the render groups as well.
Joe_H
Site Admin
 
Posts: 6608
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: GPU [Not Folding - Mint 20.04 LTS]

Postby JamesMcCann » Tue Jul 21, 2020 2:29 am

hi Joe how would i go about doing that will i need to install the nvidia drivers form there website
JamesMcCann
 
Posts: 5
Joined: Sat Jul 18, 2020 8:18 pm

Re: GPU [Not Folding - Mint 20.04 LTS]

Postby gunnarre » Tue Jul 21, 2020 6:45 am

Since you're running Linux Mint, it can be enough to install those proprietary drivers with Linux Mint's own driver install tool. You might already have them on your system.

First try this:

Install some OpenCL development files from ocl-icd-opencl-dev, either using synaptic or
Code: Select all
sudo apt install ocl-icd-opencl-dev

Add fahclient to the video and render groups:
Code: Select all
sudo adduser fahclient video
sudo adduser fahclient render

Make a file called /etc/systemd/system/FAHClient.service
and put this in the file:
Code: Select all
[Unit]
Description=Folding@Home Client
After=network.target

[Service]
Type=simple
ExecStart=/usr/bin/FAHClient /etc/fahclient/config.xml --pid-file=/var/run/fahclient/fahclient.pid --daemon
PIDFile=/var/run/fahclient/fahclient.pid
User=fahclient
RuntimeDirectory=fahclient
WorkingDirectory=~

[Install]
WantedBy=multi-user.target


Then run
Code: Select all
sudo systemctl enable FAHClient.service
sudo systemctl restart FAHClient.service

Now look if the GPU is found. If it still doesn't work, then you probably don't have the correct driver. Try.
Code: Select all
sudo ubuntu-drivers autoinstall
sudo  systemctl restart FAHClient.service


If that doesn't work either, it's time to look at https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html to install Nvidia's CUDA toolkit.
Image
gunnarre
 
Posts: 181
Joined: Sun May 24, 2020 8:23 pm
Location: Norway

Re: GPU [Not Folding - Mint 20.04 LTS]

Postby JamesMcCann » Wed Jul 22, 2020 2:33 pm

how do you make a file what is the processes in Linux mint and how do i execute it as i fave made this folder in the location of etc/systemd/system/FAHClient.service
and then i just put it in as root and then made a file to execute called FHAClient.service with the contents of
[Unit]
Description=Folding@Home Client
After=network.target

[Service]
Type=simple
ExecStart=/usr/bin/FAHClient /etc/fahclient/config.xml --pid-file=/var/run/fahclient/fahclient.pid --daemon
PIDFile=/var/run/fahclient/fahclient.pid
User=fahclient
RuntimeDirectory=fahclient
WorkingDirectory=~

[Install]
WantedBy=multi-user.target

but it will not work can anyone help as i have the Nvidia drivers of 440 installed it is the recommended one

thanks
james
JamesMcCann
 
Posts: 5
Joined: Sat Jul 18, 2020 8:18 pm

Re: GPU [Not Folding - Mint 20.04 LTS]

Postby gunnarre » Wed Jul 22, 2020 3:38 pm

That FAHClient.service file is a service start-up file which supersedes the regular init.d file.
You can make that file with for example
Code: Select all
sudo pico /etc/systemd/system/FAHClient.service

paste the code, and then press Ctrl-o Enter Ctrl-x
Make sure there are no line feeds in this one, it is one long line:
Code: Select all
ExecStart=/usr/bin/FAHClient /etc/fahclient/config.xml --pid-file=/var/run/fahclient/fahclient.pid --daemon


Test it by running the command
Code: Select all
sudo systemctl restart FAHClient.service

if it worked, make sure to enable it on bootup:
Code: Select all
sudo systemctl enable FAHClient.service


What is the ouput of the command
Code: Select all
groups fahclient
gunnarre
 
Posts: 181
Joined: Sun May 24, 2020 8:23 pm
Location: Norway

Re: GPU [Not Folding - Mint 20.04 LTS]

Postby chabgood » Thu Jul 23, 2020 1:30 am

chmod +x file_name will make a file executable.
Image
chabgood
 
Posts: 71
Joined: Wed Mar 29, 2017 8:59 pm
Location: Austin Tx.

Re: GPU [Not Folding - Mint 20.04 LTS]

Postby MeeLee » Thu Jul 23, 2020 1:49 am

@Chabgood, why would you 'mutilate' Linux in that way?

Like, why is this even necessary?:
Code: Select all
Add fahclient to the video and render groups:
CODE: SELECT ALL
sudo adduser fahclient video
sudo adduser fahclient render


All you need to do is install the Nvidia drivers and opencl drivers, and set GPU to true in advanced.

If you're running multiple (Nvidia) GPUs, I wouldn't even try the included .deb files, and install from the .run files instead.
It gets better compatibility with everything...
MeeLee
 
Posts: 1097
Joined: Tue Feb 19, 2019 11:16 pm

Re: GPU [Not Folding - Mint 20.04 LTS]

Postby chabgood » Thu Jul 23, 2020 3:18 pm

That is a standard command to make a file executable.
chabgood
 
Posts: 71
Joined: Wed Mar 29, 2017 8:59 pm
Location: Austin Tx.

Re: GPU [Not Folding - Mint 20.04 LTS]

Postby Joe_H » Thu Jul 23, 2020 4:38 pm

MeeLee wrote:Like, why is this even necessary?:
Code: Select all
Add fahclient to the video and render groups:
sudo adduser fahclient video
sudo adduser fahclient render



Some newer versions of Linux require that the user the client runs under - fahclient - be a member of the video group and possibly the render group for it to access the video subsystem and be abe to do GPU processing. Without that membership the workaround is to run under root, not the best alternative.

Sometime in the future the installer for the client should have that as part of its creation of the fahclient user. But for now the installer was created at a time that Ubuntu 16.04 was the current LTS release, so is missing requirements added in later versions and the distributions that are offshoots from them.
Joe_H
Site Admin
 
Posts: 6608
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: GPU [Not Folding - Mint 20.04 LTS]

Postby ajm » Thu Jul 23, 2020 5:23 pm

I have had that issue only with an AMD card. I was able to fold on Ubuntu 18.04 with a Nvidia card without changing the group or do anything more than install Nvidia drivers and the opencl dev package. That hassle with permissions/groups began only while trying to fold with a 5700 XT.
ajm
 
Posts: 619
Joined: Sat Mar 21, 2020 6:22 am
Location: Lucerne, Switzerland

Next

Return to V7.6.x Public Release Windows/Linux/MacOS X

Who is online

Users browsing this forum: No registered users and 4 guests

cron