HFM.NET - Monitoring Application for Folding@Home v7

This forum contains information about 3rd party applications which may be of use to those who run the FAH client and one place where you might be able to get help when using one of those apps.

Moderator: Site Moderators

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby nibbs » Tue Jan 26, 2010 7:20 pm

Hey there,

I just wanted to thank you very much for that tool. I've been using FahMon for a long time now. As many users before me, I switched due to the bonus-system applied with the new A3-core.

After a bit struggle with the refreshing-cycles and my ftp-URL i copied from FahMon (had to set the cycle to 1 minute and discard the ":21" behind the URL) the tool is now working like a charm.

What I like the most, is the much more detailed web-page that is been generated as I'm away from home most of the time and now can check the folding progress very good.

So, thanks a lot! :e)
Image
User avatar
nibbs
 
Posts: 7
Joined: Fri Dec 28, 2007 1:38 pm
Location: Germany, Berlin

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby bruce » Thu Jan 28, 2010 3:57 am

patonb wrote:I'm talking about 5783 & 5785 as i posted in my original post.

I had both fahmon running, and hfm running, as i had just installed hfm. Fahmon read all 5 of my clients fine, unit, pts and ppd.

hfm only had 2, and the 3 new gpu units were 0's even in the pts place. I manually updated the psummary 8 times in half hour, and no change.

I'm really trying to figuree out how hfm works for future updates.

Edit.... If they aren't in psummery, why do=es now both moinitors have the information?


The psummary data is updated dynamically so if a project is available for a while and then the server goes down or for some other reason the project is suspended, the data will no longer appear on-line. I think that FahMon stores the information locally so it keeps it even after the project has finished. (HFM may or may not do the same thing.) In any case, you won't have the information in HFM unless you update the data at a time when the project is showing in psummary.
bruce
 
Posts: 19400
Joined: Thu Nov 29, 2007 11:13 pm
Location: So. Cal.

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby patonb » Thu Jan 28, 2010 5:02 pm

Thanks Bruce, that'd be a good explination.
WooHoo = L5639 @ 3.3Ghz Evga SR-2 6x2gb Corsair XMS3 CM 212+ Corsair 1050hx Blackhawk Ultra EVGA 560ti

Foldie = i7 950@ 4.0Ghz x58a-ud3r 216-216 @ 850/2000 3x2gb OCZ Gold NH-u12 Heatsink Corsair hx520 Antec 900
patonb
 
Posts: 348
Joined: Thu Oct 23, 2008 3:42 am

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby AZBrandon » Thu Jan 28, 2010 7:45 pm

I just installed hfm.net two days ago and it worked fine up until some time last night. Now it shows my client as stopped, 00%, 0PPD, etc, although it correctly shows how long ago it started working on the WU. In the preview window (the one F8 shows) it clearly shows that it's running just fine. How can it display the log just fine by hitting F8, yet think that it's not running. I've tried stopping/starting HFM, deleting and re-creating the client in HFM, but nothing fixes it.
AZBrandon
 
Posts: 38
Joined: Sat Jan 17, 2009 2:43 am

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby bruce » Thu Jan 28, 2010 7:53 pm

AZBrandon wrote:I just installed hfm.net two days ago and it worked fine up until some time last night. Now it shows my client as stopped, 00%, 0PPD, etc, although it correctly shows how long ago it started working on the WU. In the preview window (the one F8 shows) it clearly shows that it's running just fine. How can it display the log just fine by hitting F8, yet think that it's not running. I've tried stopping/starting HFM, deleting and re-creating the client in HFM, but nothing fixes it.


Which WU is running?
Which type of filesystem is FAH running on?
Is the FAH client on the same machine as HFM, or is there a network mount of some kind?
bruce
 
Posts: 19400
Joined: Thu Nov 29, 2007 11:13 pm
Location: So. Cal.

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby AZBrandon » Thu Jan 28, 2010 8:40 pm

bruce wrote:
AZBrandon wrote:I just installed hfm.net two days ago and it worked fine up until some time last night. Now it shows my client as stopped, 00%, 0PPD, etc, although it correctly shows how long ago it started working on the WU. In the preview window (the one F8 shows) it clearly shows that it's running just fine. How can it display the log just fine by hitting F8, yet think that it's not running. I've tried stopping/starting HFM, deleting and re-creating the client in HFM, but nothing fixes it.


Which WU is running?
Which type of filesystem is FAH running on?
Is the FAH client on the same machine as HFM, or is there a network mount of some kind?


1) P6012
2) Ubuntu 9.04, whatever the default FS is. (EXT2? EXT3?)
3) HFM is on a windows host, FAH is on the linux host with a network mount.

So the odd part is that everything shows up just fine, and HFM correctly identifies the WU type, credit, core, download time, and will display the whole log when you hit F8. It just doesn't calculate the % complete, and thus doesn't know the PPD or ETA. It's a pretty goofy condition, to see HFM load all the WU information, and even display the log correctly, but then not do any calculations about the completion.
AZBrandon
 
Posts: 38
Joined: Sat Jan 17, 2009 2:43 am

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby patonb » Thu Jan 28, 2010 9:22 pm

Yha, thats my issue with hfm too... its wonky.... fahmon, while less info, just worked easily.
patonb
 
Posts: 348
Joined: Thu Oct 23, 2008 3:42 am

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby ChasR » Thu Jan 28, 2010 11:39 pm

The developer has been working on a fix. The false hangs may be related to cosmetic issues in the Project: line of the WU log preventing parsing the data from the log. Asynchronous clocks might cause the problem as well.
Image
User avatar
ChasR
 
Posts: 402
Joined: Sun Dec 02, 2007 6:36 am
Location: Atlanta, GA

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby AZBrandon » Fri Jan 29, 2010 6:04 am

Thanks ChasR, once I got a new WU, it was back to reporting all information again. Seems to be something that may work or fail based on WU, but hey - good to hear the developer still updates the code. It seemed like fahmon was pretty much abandoned at this point.
AZBrandon
 
Posts: 38
Joined: Sat Jan 17, 2009 2:43 am

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby ChasR » Fri Jan 29, 2010 6:48 am

Harlam recently fixed a "false hung" bug in the Linux SMP client caused by a truncated Project line. Unfortunately the logs of different clients aren't written exactly the same so all may not be fixed. Be sure you stay up with the latest release. Harlam has been making tweaks about every two weeks.
The current version is: Current Version: 0.4.8 - Revision 121 - Beta
One of the fixes is:Fixed: Issue 136 - Problem with SMP Clients reporting Hung when the Project string in the FAHlog file is crippled.
Link to the latest version: http://code.google.com/p/hfm-net/
User avatar
ChasR
 
Posts: 402
Joined: Sun Dec 02, 2007 6:36 am
Location: Atlanta, GA

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby AZBrandon » Fri Jan 29, 2010 5:08 pm

0.4.8 Revision 121 is what I already have actually. The good news is that it works more often than it fails, so that much is good!
AZBrandon
 
Posts: 38
Joined: Sat Jan 17, 2009 2:43 am

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby Zagen30 » Sun Jan 31, 2010 4:43 am

Forgive me if this has been mentioned before- I did look to see if anyone else had reported it and didn't find anything.

HFM can get confused if the client starts up and tries to send a previously completed WU. For instance, earlier today my GPU client wouldn't send a WU, and this is what happened when I started the client up next:

Code: Select all
--- Opening Log file [January 31 01:57:21 UTC]


# Windows GPU Console Edition #################################################
###############################################################################

                       Folding@Home Client Version 6.23

                          http://folding.stanford.edu

###############################################################################
###############################################################################

Launch directory: C:\Users\Kyle\F@h GPU
Executable: C:\Users\Kyle\F@h GPU\Folding@home-Win32-GPU.exe


[01:57:21] - Ask before connecting: No
[01:57:21] - User name: Zagen30 (Team 46301)
[01:57:21] - User ID: xxxxxxxxxxxxxxxxxxx
[01:57:21] - Machine ID: 2
[01:57:21]
[01:57:21] Loaded queue successfully.
[01:57:21]
[01:57:21] + Processing work unit
[01:57:21] Core required: FahCore_11.exe
[01:57:21] Core found.
[01:57:21] Project: 5767 (Run 1, Clone 31, Gen 1963)
[01:57:21] Working on queue slot 00 [January 31 01:57:21 UTC]
[01:57:21] - Read packet limit of 540015616... [01:57:21] + Working ...
Set to 524286976.


[01:57:21] + Attempting to send results [January 31 01:57:21 UTC]
[01:57:21]
[01:57:21] *------------------------------*
[01:57:21] Folding@Home GPU Core
[01:57:21] Version 1.31 (Tue Sep 15 10:57:42 PDT 2009)
[01:57:21]
[01:57:21] Compiler  : Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 14.00.50727.762 for 80x86
[01:57:21] Build host: amoeba
[01:57:21] Board Type: Nvidia
[01:57:21] Core      :
[01:57:21] Preparing to commence simulation
[01:57:21] - Looking at optimizations...
[01:57:21] - Files status OK
[01:57:21] - Expanded 64941 -> 344387 (decompressed 530.3 percent)
[01:57:21] Called DecompressByteArray: compressed_data_size=64941 data_size=344387, decompressed_data_size=344387 diff=0
[01:57:21] - Digital signature verified
[01:57:21]
[01:57:21] Project: 5781 (Run 2, Clone 700, Gen 2)
[01:57:21]
[01:57:21] Assembly optimizations on if available.
[01:57:21] Entering M.D.
[01:57:22] - Couldn't send HTTP request to server
[01:57:22] + Could not connect to Work Server (results)
[01:57:22]     (171.67.108.11:8080)
[01:57:22] + Retrying using alternative port
[01:57:23] - Couldn't send HTTP request to server
[01:57:23] + Could not connect to Work Server (results)
[01:57:23]     (171.67.108.11:80)
[01:57:23] - Error: Could not transmit unit 09 (completed January 31) to work server.
[01:57:23] - Read packet limit of 540015616... Set to 524286976.


[01:57:23] + Attempting to send results [January 31 01:57:23 UTC]
[01:57:25] + Results successfully sent
[01:57:25] Thank you for your contribution to Folding@Home.
[01:57:25] + Number of Units Completed: 1994

[01:57:25]   Successfully sent unit 09 to Collection server.
[01:57:27] Tpr hash work/wudata_00.tpr:  2511757856 2907143072 4045132744 2698427497 2563811677
[01:57:27]
[01:57:27] Calling fah_main args: 14 usage=100
[01:57:27]
[01:57:27] Working on Great Red Owns Many ACres of Sand
[01:57:28] Client config found, loading data.
[01:57:28] Starting GUI Server
[01:58:47] Completed 1%
[02:00:06] Completed 2%
[02:01:25] Completed 3%
[02:02:43] Completed 4%
[02:04:02] Completed 5%


The 5767 was the one that had already been completed, and the client was working on the 5781. HFM thought that the client was doing a 5767, and as such the PPD calculation was way off (of course, since the low 5780's aren't in the psummary, it now tells me I'm getting 0 PPD, but that's not HFM's fault). I unfortunately didn't get a screenshot.

*EDIT*

After checking the Google group Harlam has, it seems he already knows about this bug.
Last edited by Zagen30 on Sun Jan 31, 2010 8:49 pm, edited 1 time in total.
Image
Zagen30
 
Posts: 823
Joined: Tue Mar 25, 2008 1:45 am

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby geokilla » Sun Jan 31, 2010 4:51 am

For some reason, HFM.NET can't detect the client type, Core, and PPD on my GPU. Any fix? It was working before.
Intel Core i5-3570K @ 4.2Ghz @ 1.16V (CPU-Z + LinX)
Gigabyte Z77X-UD5H F16K BIOS
ASUS RX570 Strix Gaming 4GB 1300/1750
Kingston HyperX DDR3 8GB @ DDR-1600
Corsair AX750
Samsung 860 EVO 500GB and Western Digital Red 3TB
geokilla
 
Posts: 57
Joined: Sun Mar 08, 2009 5:36 am
Location: Toronto, Canada

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby Zagen30 » Sun Jan 31, 2010 12:08 pm

geokilla wrote:For some reason, HFM.NET can't detect the client type, Core, and PPD on my GPU. Any fix? It was working before.


It's probably because it's one of the 783-point Nvidia WUs (project 5781/82/83/84/85/86, I believe) that doesn't show up on psummary. HFM apparently doesn't cache project information, so if a project isn't currently in psummary, HFM has no idea what it is.

If it's not because of that, then I have no idea.
Zagen30
 
Posts: 823
Joined: Tue Mar 25, 2008 1:45 am

Re: HFM.NET - Client Monitoring Application for Folding@Home

Postby patonb » Sun Jan 31, 2010 5:22 pm

See, FaHmon has those values.... Thats what boggels me...

It must have been added, fahmon d/l it, tthen it removed from the summery maybe..
patonb
 
Posts: 348
Joined: Thu Oct 23, 2008 3:42 am

PreviousNext

Return to 3rd party contributed software

Who is online

Users browsing this forum: No registered users and 1 guest

cron