Suggestion: Create a news broadcast app for FAH

Moderators: Site Moderators, PandeGroup

Suggestion: Create a news broadcast app for FAH

Postby andrewtheart » Sat Nov 26, 2016 9:23 pm

I'm sure this has been brought up a few times, but -

Don't you think it would make sense for the FAH client app to notify the end-user whether the GPU they just upgraded to will prevent them from folding?

If there was a message in the UI stating "FAH is currently only known to work with the following NVIDIA GEFORCE driver revisions ", I may not have made the upgrade. But as it stands, I did, and now I'm going to have to downgrade from 375.xx to the prior version (probably 373)
andrewtheart
 
Posts: 26
Joined: Wed Jul 13, 2011 12:02 pm
Location: Texas, USA

Re: WARNING ! Do not upgrade to 375.xx drivers.

Postby bruce » Sat Nov 26, 2016 10:08 pm

andrewtheart wrote:Don't you think it would make sense for the FAH client app to notify the end-user whether the GPU they just upgraded to will prevent them from folding?


The official notification was published on Oct 27 in the Stanford Blog -- and here and on FB. I recommend you check the official Blog occasionally.

The client does not contain code for a broadcast notification system, but your welcome to recommend a parallel system that Donors can run to notify them when the Blog is updated..
bruce
 
Posts: 22236
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: WARNING ! Do not upgrade to 375.xx drivers.

Postby SteveWillis » Sun Nov 27, 2016 12:34 am

If there was a message in the UI stating "FAH is currently only known to work with the following NVIDIA GEFORCE driver revisions ", I may not have made the upgrade. But as it stands, I did, and now I'm going to have to downgrade from 375.xx to the prior version (probably 373)


On my Linux system that takes about 15 minutes and is a piece of cake once you know how.
Image

1080 and 1080TI GPUs on Linux Mint
SteveWillis
 
Posts: 410
Joined: Fri Apr 15, 2016 12:42 am

Re: WARNING ! Do not upgrade to 375.xx drivers.

Postby SombraGuerrero » Sun Nov 27, 2016 3:46 am

andrewtheart wrote:I'm sure this has been brought up a few times, but -

Don't you think it would make sense for the FAH client app to notify the end-user whether the GPU they just upgraded to will prevent them from folding?

If there was a message in the UI stating "FAH is currently only known to work with the following NVIDIA GEFORCE driver revisions ", I may not have made the upgrade. But as it stands, I did, and now I'm going to have to downgrade from 375.xx to the prior version (probably 373)

If this were a true client-side limitation. that would be a valid recourse. Since it is a break in Nvidia's tweaks to their OpenCL implementation, however, it should not be the client's responsibility to announce a break to users. As mentioned a little earlier, the fact that these same drivers are breaking other applications as well clearly absolves FAH of any responsibility here.
SombraGuerrero
 
Posts: 105
Joined: Mon Mar 16, 2009 3:06 am

Re: WARNING ! Do not upgrade to 375.xx drivers.

Postby andrewtheart » Sun Nov 27, 2016 5:13 am

IMO It is FAH's responsibility to notify the end user of a "break in Nvidia's tweaks to their OpenCL implementation" if they want to maximize folding.
andrewtheart
 
Posts: 26
Joined: Wed Jul 13, 2011 12:02 pm
Location: Texas, USA

Re: WARNING ! Do not upgrade to 375.xx drivers.

Postby SombraGuerrero » Sun Nov 27, 2016 5:18 am

andrewtheart wrote:IMO It is FAH's responsibility to notify the end user of a "break in Nvidia's tweaks to their OpenCL implementation" if they want to maximize folding.

Yes, which is why they post it elsewhere, but unless it is expected to be a long term problem with their software, they should not be expected to code around something over which they have no control.
SombraGuerrero
 
Posts: 105
Joined: Mon Mar 16, 2009 3:06 am

Re: WARNING ! Do not upgrade to 375.xx drivers.

Postby andrewtheart » Sun Nov 27, 2016 5:19 am

bruce wrote:The official notification was published on Oct 27 in the Stanford Blog -- and here and on FB. I recommend you check the official Blog occasionally.

The client does not contain code for a broadcast notification.


So what I'm suggesting is a broadcast system be implemented in the FAH client code and it sends these notifcatons (maybe from sources like folding.stanford.edu).
Have the message expire after x days, or whatever.
andrewtheart
 
Posts: 26
Joined: Wed Jul 13, 2011 12:02 pm
Location: Texas, USA

Re: WARNING ! Do not upgrade to 375.xx drivers.

Postby andrewtheart » Sun Nov 27, 2016 5:24 am

SombraGuerrero wrote:
andrewtheart wrote:IMO It is FAH's responsibility to notify the end user of a "break in Nvidia's tweaks to their OpenCL implementation" if they want to maximize folding.

Yes, which is why they post it elsewhere, but unless it is expected to be a long term problem with their software, they should not be expected to code around something over which they have no control.

You cannot expect great compliance regarding people remembering to open up that web page before every graphics driver update.
If that is today's solution, it is suboptimal and should be rethought.
andrewtheart
 
Posts: 26
Joined: Wed Jul 13, 2011 12:02 pm
Location: Texas, USA

suggestion Create a news broadcast app for FAH

Postby SombraGuerrero » Sun Nov 27, 2016 5:41 am

It's one of those things that turns into a very deep rabbit hole. If you don't draw the line somewhere, you'll never stop tweaking your application in a futile attempt to please everyone. Plus, the FAH team has made it very clear that integrity of the results is very important, this being a scientific application. Constant code changes, no matter how minor, introduce the risk of regression. I would surmise that in the eyes of most of the FAH team, they would rather not have people successfully fold at all until their environments are adjusted, than have the servers bombarded with compromised results.
SombraGuerrero
 
Posts: 105
Joined: Mon Mar 16, 2009 3:06 am

Re: WARNING ! Do not upgrade to 375.xx drivers.

Postby foldy » Sun Nov 27, 2016 8:48 am

A broadcast system would be helpful in such situations. The fah client could request "news" once a day or hour. The news could include warnings regarding a driver or windows update or announce a new FahCore which may be a little instable initially or when cpu core=7 makes problems. The advantage over websites is the donor could see this e.g. as notification on FahControl and does not need to call websites occasionally yourself. Maybe the broadcast messages could even be managed by foldingforum admins.

But this request should be posted on foldingathome reddit, I will.
Last edited by foldy on Sun Nov 27, 2016 9:04 am, edited 1 time in total.
foldy
 
Posts: 1420
Joined: Sat Dec 01, 2012 3:43 pm

Re: WARNING ! Do not upgrade to 375.xx drivers.

Postby SombraGuerrero » Sun Nov 27, 2016 8:53 am

Now THAT is an infrastructure I can get behind. Anything that can be built once and then maintained outside of the core application, yes!
SombraGuerrero
 
Posts: 105
Joined: Mon Mar 16, 2009 3:06 am

Re: WARNING ! Do not upgrade to 375.xx drivers.

Postby foldy » Sun Nov 27, 2016 9:02 am

foldy
 
Posts: 1420
Joined: Sat Dec 01, 2012 3:43 pm

Re: Suggestion: Create a news broadcast app for FAH

Postby bruce » Sun Nov 27, 2016 3:25 pm

Thanks, foldy.

As has been stated many times, this is a support forum and we have to operate within the constraints of today's version of the FAH system.
The right place for suggestions is reddit, where Donors can vote for popular suggestions and FAH administrators might read/respond to them.

Topic closed.
bruce
 
Posts: 22236
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.


Return to Discussions of General-FAH topics

Who is online

Users browsing this forum: No registered users and 1 guest

cron