Screen Saver not showing proteins folded by GPU

Moderators: Site Moderators, PandeGroup

Screen Saver not showing proteins folded by GPU

Postby mrobson83 » Sat Jun 16, 2018 7:14 am

I currently fold every now and then using two overclocked Asus ROG Strix GTX 1080Ti's. Back when I only had a single GPU, I'd fold on both my GPU and CPU (i7 8700k OC'd to 5.2GHz), but this set up stressed my CPU enough to cause crashes on days where my room would get a little too warm. But since I now exclusively fold on my two GPU's, I get a lot more done with lower temps overall with NO crashing. My main question is, why won't the protein viewer show proteins being folded on my GPU(s)? It would only show the CPU-folded proteins in the screen saver before and I'd like to leave my computer on to get more work done without any screen burn or turning the screen off.

Is there a way to get the screensaver/protein viewer to display the proteins being folded on my GPU's? I apologize in advance if there is already a thread where this has been answered.

In the event some asks, my setup is as follows:

Corsair750D Airflow Edition case
Corsair HX1000i PSU
Asus Maximus X Hero Z370 mobo
32GB of G.skill DDR4 ram @ 4266MHz (though the mobo only supports up to 4133MHz)
Two Samsung 1TB 960 EVO's (one main and one for storage)
Two Asus ROG Strix GTX 1080Ti's (both OC'd to 2GHz+)
Alphacool Eisbaer 360mm radiator with 6 EX Furious EVO fans @ 3000rpm (3 push, 3 pull, inside the top of the case. I don't mind their noise level since I'm not usually in the room during long runs on Prime95)
Three Corsair 140mm RGB fans (two intake-front, one exhaust-rear)
Two Corsair 120mm (two intake-bottom)
Two other generic 120mm fans postioned to aid in cooling the GPU's down
One 200mm BitFenix case fan modded into the plexiglass side panel to suck hot air from the GPU's out the side.

All in all, my CPU never really breaches 70C when factoring on prime95 and my GPU's have never gotten above 55C when folding while overclocked.
mrobson83
 
Posts: 1
Joined: Sat Jun 16, 2018 6:48 am

Re: Screen Saver not showing proteins folded by GPU

Postby bruce » Sat Jun 16, 2018 9:28 pm

The problems with the screensaver and with FAHViewer have been reported previously. I was under the impression that the fix for it was going to be incorporated into the new V7.5.1 client but apparently it was not. Unfortunately I have no further information.

While prime95 is commonly used to stress CPUs, it doesn't stress the FPU/SSE/AVX sections of the CPU like a number of other benchmarks do. As it turns out, FAHCore_A7 does pretty good at heating a CPU to it's maximum though there are popular utilities that also do a pretty good job. (Then you'd have to figure out how to get rid of that extra heat.)
bruce
 
Posts: 22441
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Screen Saver not showing proteins folded by GPU

Postby Scally » Thu Aug 02, 2018 3:02 pm

I've noticed this issue too. Do you have any info to share on the possible fix at this point, Bruce? I hope you don't mind my asking.
Scally
 
Posts: 1
Joined: Thu Jul 26, 2018 9:38 am

Re: Screen Saver not showing proteins folded by GPU

Postby bruce » Thu Aug 02, 2018 7:29 pm

Scally wrote:I hope you don't mind my asking.

We don't mind at all. That's why we're here.

This has been reported previously but Development needs to get involved and I don't have any useful information about their backlog (other than "long") or what priority will apply to this issue.

I tend to lump the problems with the screensaver and with FAHViewer in the same category because much of the code is shared -- while each may have their own problems which need to be handled separately.
bruce
 
Posts: 22441
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Screen Saver not showing proteins folded by GPU

Postby bruce » Thu Aug 02, 2018 8:11 pm

I just installed FAHViewer on Linux. Using the VIEWER button in FAHClient, it does seem to display the current WU 00, Using the "h" command brings up the help menu. Using the "[" and the "]" commands does seem to switch me to other active proteins ... but those commands don't seem to be consistent.

Running FAHViewer in stand-alone mode seems to work provided I change directories to one of the directories inside of (fahdata)/work

I'm not on a Windows system right now so I can't tell you anything about that.

It's my assumption that the screensaver does pretty much the same thing .... you have to be in the appropriate directory for it to work. Assuming you have more than one slot, there would have to be a way to specify WHICH of the active WUs should be displayed, and since over time- than number changes, it's not simple. (This would need to be confirmed plus if we can be more specific, it's more likely to be fixed.

I strongly encourage others to do additional testing and report their findings.
Things are a lot more likely to get fixed sooner if we can provide additional information beyond a simple "doesn't work" report.
bruce
 
Posts: 22441
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Screen Saver not showing proteins folded by GPU

Postby bruce » Thu Aug 02, 2018 8:23 pm

Here is the first of the tickets against screensaver,
https://github.com/FoldingAtHome/fah-issues/issues/1253
bruce
 
Posts: 22441
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Screen Saver not showing proteins folded by GPU

Postby JimF » Fri Aug 03, 2018 4:36 pm

Not that this is directly at issue, but the viewer works OK for me on Ubuntu 16.04 and 18.04, though I have only CPU or GPU running on each machine.

However, I thought I would mention that to install "fahviewer_7.5.1_amd64.deb", I must first enable Ubuntu Software "Community-maintained free and open-source software (universe)"
I normally disable those updates after a point.
JimF
 
Posts: 483
Joined: Thu Jan 21, 2010 2:03 pm

Re: Screen Saver not showing proteins folded by GPU

Postby bruce » Fri Aug 03, 2018 4:50 pm

@JimF
With two slots, I presume that the change WU keys (] and [) work fine, switching to the other image after a short delay. While the slot numbers are invariant, the active WUs will be two of WU00, WU01, or WU02. Does the "direction" that you have to choose when switching WUs match the order of the slots or the order of the WUs? What happens when the WU you're viewing is uploaded and is no longer present?

(I suppose if a completed WU fails to upload promptly or if both slots happen to finish at the same time, you could actually get a WU03. Not that it matters.)
bruce
 
Posts: 22441
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Screen Saver not showing proteins folded by GPU

Postby JimF » Fri Aug 03, 2018 8:22 pm

Well let me try to clarify. I normally run only a CPU work unit OR a GPU work unit on each of my Ubuntu machines, but not both.

However, just for fun, I fired up my GTX 750 Ti on my i7-8700 Ubuntu 18.04 machine, where I normally run Folding on only the CPU. But running both the CPU and GPU slots does not appear to be a problem with the viewer. That is, when I right-click on the CPU slot, the viewer shows the 0xa7 CPU work unit OK, and similarly when I click on the GPU slot, I see the 0x21 GPU work unit OK (not a dummy according to the info shown). But I can't get the "[" and the "]" commands to do anything. That may be because I am viewing the i7-8700 machine over the LAN using the X11 server on the Ubuntu end and TightVNC on the Win7 end, and it may not pass those commands, or they may just not work.

It may help that I am using the latest Nvidia drivers (396.45), and the latest Linux 4.15.0-29 kernel with all the libraries updated. I will have to check the uploaded work units later, if I can catch them.
JimF
 
Posts: 483
Joined: Thu Jan 21, 2010 2:03 pm

Re: Screen Saver not showing proteins folded by GPU

Postby JimF » Fri Aug 03, 2018 10:50 pm

bruce wrote:What happens when the WU you're viewing is uploaded and is no longer present?

No problem on the CPU work unit. The viewer just continues with the new WU.
JimF
 
Posts: 483
Joined: Thu Jan 21, 2010 2:03 pm


Return to Discussions of General-FAH topics

Who is online

Users browsing this forum: No registered users and 2 guests

cron