Page 1 of 1

Can't open Advanced Control—cx_Freeze: Python error?

PostPosted: Sat Apr 18, 2020 7:07 pm
by GoldStar135
Hi all,
I recently joined the F@h community a couple weeks ago. I decided to dust off an old Windows Vista PC (Dell XPS 435mt) to add to the folding my laptop does. It works well enough, but whenever I try to open Advanced Control, all I see is this error message:

Image

I've been getting this message with 7.5.1, so I tried downloading the new 7.6.9 release today, but it still shows up. I've tried restarting/uninstalling and reinstalling F@h a bunch as well. I was wondering if any of you have any idea how to fix this? Web control works fine, but I'd really like if I could open up advanced control. I've also tried googling, but I didn't find any working solutions.

Below are some specs of the PC:
CPU: Intel Core i7-920
GPU: ATI Radeon 4670 (doesn't show up in the folding client)
OS: Windows Vista 64bit SP2

Thanks in advance!

Re: Can't open Advanced Control—cx_Freeze: Python error?

PostPosted: Sat Apr 18, 2020 9:54 pm
by Joe_H
I don't know if the F@h client software will still run on Vista, but if it will you probably need a number of updates for it to work. Specifically you would be looking for an update that upgraded Python for Windows Vista.

Edit: Probably only need the runtime, not a full Python install.

Re: Can't open Advanced Control—cx_Freeze: Python error?

PostPosted: Sat Apr 18, 2020 10:01 pm
by bruce
According to Microsoft, Windows 7 is no longer supported but FAH still runs on it. Vista is not supported and does not run.

Re: Can't open Advanced Control—cx_Freeze: Python error?

PostPosted: Sat Apr 18, 2020 11:02 pm
by PantherX
Welcome to the F@H Forum GoldStar135,

May I suggest that you reload the system Ubuntu (https://ubuntu.com/download/desktop) or Mint (https://www.linuxmint.com/download.php) and then setup CPU folding? Ubuntu/Mint have a nice GUI and you can navigate it easily.

Please note that your GPU doesn't support OpenCL 1.2 or Double Precision so can't fold: https://www.techpowerup.com/gpu-specs/r ... -4670.c234

Re: Can't open Advanced Control—cx_Freeze: Python error?

PostPosted: Fri Jun 26, 2020 4:29 pm
by Scott_AU
bruce wrote:According to Microsoft, Windows 7 is no longer supported but FAH still runs on it. Vista is not supported and does not run.

To help me better understand (I am not a python coder) is FAH release using GTK+2 or GTK+3 and PyGTK or pygobject. The error message implies GTK+2 I was poking around to see if it is a library component that I can replace.

Re: Can't open Advanced Control—cx_Freeze: Python error?

PostPosted: Fri Jun 26, 2020 7:28 pm
by Joe_H
My understanding is that FAHControl uses Python 2.7. Work is being done to convert it to Python 3, but that will be coming out with a later version.

Re: Can't open Advanced Control—cx_Freeze: Python error?

PostPosted: Sat Jun 27, 2020 5:42 pm
by Scott_AU
Joe_H wrote:My understanding is that FAHControl uses Python 2.7. Work is being done to convert it to Python 3, but that will be coming out with a later version.
Yes, and is it using PyGTK (supports GTK 2) or pyGObject (supports GTK 2 and 3) bindings? Which GTK library is used? I need that info to do research on "cx_freeze".

bruce wrote:Vista is not supported and does not run.
I assume you mean FAHclient "does not run" on Vista, but have done 28 work units so far, so not sure what you mean.

Re: Can't open Advanced Control—cx_Freeze: Python error?

PostPosted: Sat Jun 27, 2020 6:22 pm
by bruce
Oops. I mean FAH does not run on Windows XP. It's been a long time since I used either one.

Re: Can't open Advanced Control—cx_Freeze: Python error?

PostPosted: Sat Jun 27, 2020 8:31 pm
by Joe_H
Not sure what GTK library is being used, think it might be the first. FAHControl is open source, perhaps you can determine which is in the released version from its GitHub site - https://github.com/FoldingAtHome/fah-control.