Could not get IP address for assign4.stanford.edu

Moderators: Site Moderators, PandeGroup

Could not get IP address for assign4.stanford.edu

Postby orion456 » Thu Jul 13, 2017 3:47 pm

I am having trouble with a few machines, some A4s some GPUs that cant find the server anymore.

I have tried rebooting, deleting the cores and work and testing the wifi which works perfectly for a simple firefox search.

Any ideas?

Code: Select all

*********************** Log Started 2017-07-11T18:03:42Z ***********************
18:03:42:************************* Folding@home Client *************************
18:03:42:      Website: http://folding.stanford.edu/
18:03:42:    Copyright: (c) 2009-2016 Stanford University
18:03:42:       Author: Joseph Coffland <joseph@cauldrondevelopment.com>
18:03:42:         Args: --child --lifeline 2702 /etc/fahclient/config.xml --run-as
18:03:42:               fahclient --pid-file=/var/run/fahclient.pid --daemon
18:03:42:       Config: /etc/fahclient/config.xml
18:03:42:******************************** Build ********************************
18:03:42:      Version: 7.4.16
18:03:42:         Date: Jan 6 2017
18:03:42:         Time: 08:08:33
18:03:42:   Repository: Git
18:03:42:     Revision: e12187cbb0bd6937c067b9749af011374563b7b9
18:03:42:       Branch: master
18:03:42:     Compiler: GNU 4.9.2
18:03:42:      Options: -std=gnu++98 -O3 -funroll-loops -ffast-math -mfpmath=sse
18:03:42:               -fno-unsafe-math-optimizations -msse2
18:03:42:     Platform: linux2 4.8.0-2-amd64
18:03:42:         Bits: 64
18:03:42:         Mode: Release
18:03:42:******************************* System ********************************
18:03:42:          CPU: Intel(R) Xeon(R) CPU W3520 @ 2.67GHz
18:03:42:       CPU ID: GenuineIntel Family 6 Model 26 Stepping 5
18:03:42:         CPUs: 8
18:03:42:       Memory: 5.83GiB
18:03:42:  Free Memory: 4.17GiB
18:03:42:      Threads: POSIX_THREADS
18:03:42:   OS Version: 4.4
18:03:42:  Has Battery: false
18:03:42:   On Battery: false
18:03:42:   UTC Offset: -5
18:03:42:          PID: 2704
18:03:42:          CWD: /var/lib/fahclient
18:03:42:           OS: Linux 4.4.0-83-generic x86_64
18:03:42:      OS Arch: AMD64
18:03:42:         GPUs: 1
18:03:42:        GPU 0: Bus:3 Slot:0 Func:0 NVIDIA:5 GM204 [GeForce GTX 970]
18:03:42:CUDA Device 0: Platform:0 Device:0 Bus:3 Slot:0 Compute:5.2 Driver:8.0
18:03:42:       OpenCL: Not detected: Failed to open dynamic library 'libOpenCL.so':
18:03:42:               libOpenCL.so: cannot open shared object file: No such file or
18:03:42:               directory
18:03:42:***********************************************************************
18:03:42:<config>
18:03:42:  <!-- Client Control -->
18:03:42:  <fold-anon v='true'/>
18:03:42:
18:03:42:  <!-- Folding Core -->
18:03:42:  <core-priority v='low'/>
18:03:42:
18:03:42:  <!-- Folding Slot Configuration -->
18:03:42:  <gpu v='false'/>
18:03:42:
18:03:42:  <!-- Network -->
18:03:42:  <proxy v=':8080'/>
18:03:42:
18:03:42:  <!-- Slot Control -->
18:03:42:  <pause-on-battery v='false'/>
18:03:42:  <power v='full'/>
18:03:42:
18:03:42:  <!-- User Information -->
18:03:42:  <passkey v='********************************'/>
18:03:42:  <team v='32'/>
18:03:42:  <user v='orion456'/>
18:03:42:
18:03:42:  <!-- Folding Slots -->
18:03:42:  <slot id='0' type='CPU'>
18:03:42:    <cpus v='6'/>
18:03:42:  </slot>
18:03:42:  <slot id='1' type='GPU'/>
18:03:42:</config>
18:03:42:Switching to user fahclient
18:03:42:Trying to access database...
18:03:42:Upgrading database schema from version 13 to 14
18:03:42:Successfully acquired database lock
18:03:42:Enabled folding slot 00: READY cpu:6
18:03:42:Enabled folding slot 01: READY gpu:0:GM204 [GeForce GTX 970]
18:03:42:WU01:FS00:Starting
18:03:42:WU01:FS00:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/fahwebx.stanford.edu/cores/Linux/AMD64/Core_a4.fah/FahCore_a4 -dir 01 -suffix 01 -version 704 -lifeline 2704 -checkpoint 15 -np 6
18:03:42:WU01:FS00:Started FahCore on PID 2714
18:03:42:WU01:FS00:Core PID:2718
18:03:42:WU01:FS00:FahCore 0xa4 started
18:03:43:WU01:FS00:0xa4:
18:03:43:WU01:FS00:0xa4:*------------------------------*
18:03:43:WU01:FS00:0xa4:Folding@Home Gromacs GB Core
18:03:43:WU01:FS00:0xa4:Version 2.27 (Dec. 15, 2010)
18:03:43:WU01:FS00:0xa4:
18:03:43:WU01:FS00:0xa4:Preparing to commence simulation
18:03:43:WU01:FS00:0xa4:- Looking at optimizations...
18:03:43:WU01:FS00:0xa4:- Files status OK
18:03:43:WU01:FS00:0xa4:- Expanded 1128760 -> 2619636 (decompressed 232.0 percent)
18:03:43:WU01:FS00:0xa4:Called DecompressByteArray: compressed_data_size=1128760 data_size=2619636, decompressed_data_size=2619636 diff=0
18:03:43:WU01:FS00:0xa4:- Digital signature verified
18:03:43:WU01:FS00:0xa4:
18:03:43:WU01:FS00:0xa4:Project: 8635 (Run 1, Clone 129, Gen 72)
18:03:43:WU01:FS00:0xa4:
18:03:43:WU01:FS00:0xa4:Assembly optimizations on if available.
18:03:43:WU01:FS00:0xa4:Entering M.D.
18:03:48:WU01:FS00:0xa4:Using Gromacs checkpoints
18:03:49:WU01:FS00:0xa4:Resuming from checkpoint
18:03:49:WU01:FS00:0xa4:Verified 01/wudata_01.log
18:03:49:WU01:FS00:0xa4:Verified 01/wudata_01.trr
18:03:49:WU01:FS00:0xa4:Verified 01/wudata_01.xtc
18:03:49:WU01:FS00:0xa4:Verified 01/wudata_01.edr
18:03:49:WU01:FS00:0xa4:Completed 296920 out of 1250000 steps  (23%)
18:03:52:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
18:04:02:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
18:04:02:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
18:04:02:ERROR:WU00:FS01:Exception: Could not get an assignment
18:04:13:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
18:04:23:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
18:04:23:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
18:04:23:ERROR:WU00:FS01:Exception: Could not get an assignment
18:04:42:FS00:Paused
18:04:42:FS01:Paused
18:04:42:FS00:Shutting core down
18:04:42:WU01:FS00:FahCore returned: INTERRUPTED (102 = 0x66)
18:04:43:Removing old file 'configs/config-20160324-220443.xml'
18:04:43:Saving configuration to /etc/fahclient/config.xml
18:04:43:<config>
18:04:43:  <!-- Client Control -->
18:04:43:  <fold-anon v='true'/>
18:04:43:
18:04:43:  <!-- Folding Core -->
18:04:43:  <core-priority v='low'/>
18:04:43:
18:04:43:  <!-- Folding Slot Configuration -->
18:04:43:  <gpu v='false'/>
18:04:43:
18:04:43:  <!-- Network -->
18:04:43:  <proxy v=':8080'/>
18:04:43:
18:04:43:  <!-- Slot Control -->
18:04:43:  <pause-on-battery v='false'/>
18:04:43:  <power v='full'/>
18:04:43:
18:04:43:  <!-- User Information -->
18:04:43:  <passkey v='********************************'/>
18:04:43:  <team v='32'/>
18:04:43:  <user v='orion456'/>
18:04:43:
18:04:43:  <!-- Folding Slots -->
18:04:43:  <slot id='0' type='CPU'>
18:04:43:    <cpus v='6'/>
18:04:43:    <paused v='true'/>
18:04:43:  </slot>
18:04:43:  <slot id='1' type='GPU'>
18:04:43:    <paused v='true'/>
18:04:43:  </slot>
18:04:43:</config>
18:04:43:FS00:Unpaused
18:04:43:FS00:Finishing
18:04:43:FS01:Unpaused
18:04:43:FS01:Finishing
18:04:43:WU01:FS00:Starting
18:04:43:WU01:FS00:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/fahwebx.stanford.edu/cores/Linux/AMD64/Core_a4.fah/FahCore_a4 -dir 01 -suffix 01 -version 704 -lifeline 2704 -checkpoint 15 -np 6
18:04:43:WU01:FS00:Started FahCore on PID 2860
18:04:43:WU01:FS00:Core PID:2864
18:04:43:WU01:FS00:FahCore 0xa4 started
18:04:43:WU01:FS00:0xa4:
18:04:43:WU01:FS00:0xa4:*------------------------------*
18:04:43:WU01:FS00:0xa4:Folding@Home Gromacs GB Core
18:04:43:WU01:FS00:0xa4:Version 2.27 (Dec. 15, 2010)
18:04:43:WU01:FS00:0xa4:
18:04:43:WU01:FS00:0xa4:Preparing to commence simulation
18:04:43:WU01:FS00:0xa4:- Looking at optimizations...
18:04:43:WU01:FS00:0xa4:- Files status OK
18:04:43:WU01:FS00:0xa4:- Expanded 1128760 -> 2619636 (decompressed 232.0 percent)
18:04:43:WU01:FS00:0xa4:Called DecompressByteArray: compressed_data_size=1128760 data_size=2619636, decompressed_data_size=2619636 diff=0
18:04:43:WU01:FS00:0xa4:- Digital signature verified
18:04:43:WU01:FS00:0xa4:
18:04:43:WU01:FS00:0xa4:Project: 8635 (Run 1, Clone 129, Gen 72)
18:04:43:WU01:FS00:0xa4:
18:04:43:WU01:FS00:0xa4:Assembly optimizations on if available.
18:04:43:WU01:FS00:0xa4:Entering M.D.
18:04:49:WU01:FS00:0xa4:Using Gromacs checkpoints
18:04:49:WU01:FS00:0xa4:Resuming from checkpoint
18:04:50:WU01:FS00:0xa4:Verified 01/wudata_01.log
18:04:50:WU01:FS00:0xa4:Verified 01/wudata_01.trr
18:04:50:WU01:FS00:0xa4:Verified 01/wudata_01.xtc
18:04:50:WU01:FS00:0xa4:Verified 01/wudata_01.edr
18:04:50:WU01:FS00:0xa4:Completed 296920 out of 1250000 steps  (23%)
18:05:13:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
18:05:23:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
18:05:23:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
18:05:23:ERROR:WU00:FS01:Exception: Could not get an assignment
18:05:44:Removing old file 'configs/config-20160324-220508.xml'
18:05:44:Saving configuration to /etc/fahclient/config.xml
18:05:44:<config>
18:05:44:  <!-- Client Control -->
18:05:44:  <fold-anon v='true'/>
18:05:44:
18:05:44:  <!-- Folding Core -->
18:05:44:  <core-priority v='low'/>
18:05:44:
18:05:44:  <!-- Folding Slot Configuration -->
18:05:44:  <gpu v='false'/>
18:05:44:
18:05:44:  <!-- Network -->
18:05:44:  <proxy v=':8080'/>
18:05:44:
18:05:44:  <!-- Slot Control -->
18:05:44:  <pause-on-battery v='false'/>
18:05:44:  <power v='full'/>
18:05:44:
18:05:44:  <!-- User Information -->
18:05:44:  <passkey v='********************************'/>
18:05:44:  <team v='32'/>
18:05:44:  <user v='orion456'/>
18:05:44:
18:05:44:  <!-- Folding Slots -->
18:05:44:  <slot id='0' type='CPU'>
18:05:44:    <cpus v='6'/>
18:05:44:  </slot>
18:05:44:  <slot id='1' type='GPU'/>
18:05:44:</config>
18:06:19:WU01:FS00:0xa4:Completed 300000 out of 1250000 steps  (24%)
18:06:50:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
18:07:00:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
18:07:00:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
18:07:00:ERROR:WU00:FS01:Exception: Could not get an assignment
18:09:27:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
18:09:37:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
18:09:37:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
18:09:37:ERROR:WU00:FS01:Exception: Could not get an assignment
18:12:21:WU01:FS00:0xa4:Completed 312500 out of 1250000 steps  (25%)
18:13:41:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
18:13:51:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
18:13:51:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
18:13:51:ERROR:WU00:FS01:Exception: Could not get an assignment
18:18:18:WU01:FS00:0xa4:Completed 325000 out of 1250000 steps  (26%)
18:20:33:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
18:20:43:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
18:20:43:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
18:20:43:ERROR:WU00:FS01:Exception: Could not get an assignment
18:24:04:WU01:FS00:0xa4:Completed 337500 out of 1250000 steps  (27%)
18:29:51:WU01:FS00:0xa4:Completed 350000 out of 1250000 steps  (28%)
18:31:38:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
18:31:48:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
18:31:48:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
18:31:48:ERROR:WU00:FS01:Exception: Could not get an assignment
18:35:45:WU01:FS00:0xa4:Completed 362500 out of 1250000 steps  (29%)
18:41:29:WU01:FS00:0xa4:Completed 375000 out of 1250000 steps  (30%)
18:47:23:WU01:FS00:0xa4:Completed 387500 out of 1250000 steps  (31%)
18:49:35:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
18:49:45:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
18:49:45:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
18:49:45:ERROR:WU00:FS01:Exception: Could not get an assignment
18:53:08:WU01:FS00:0xa4:Completed 400000 out of 1250000 steps  (32%)
18:58:50:WU01:FS00:0xa4:Completed 412500 out of 1250000 steps  (33%)
19:04:32:WU01:FS00:0xa4:Completed 425000 out of 1250000 steps  (34%)
19:10:18:WU01:FS00:0xa4:Completed 437500 out of 1250000 steps  (35%)
19:16:00:WU01:FS00:0xa4:Completed 450000 out of 1250000 steps  (36%)
19:18:37:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
19:18:47:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
19:18:47:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
19:18:47:ERROR:WU00:FS01:Exception: Could not get an assignment
19:21:42:WU01:FS00:0xa4:Completed 462500 out of 1250000 steps  (37%)
19:27:31:WU01:FS00:0xa4:Completed 475000 out of 1250000 steps  (38%)
19:33:12:WU01:FS00:0xa4:Completed 487500 out of 1250000 steps  (39%)
19:38:55:WU01:FS00:0xa4:Completed 500000 out of 1250000 steps  (40%)
19:44:39:WU01:FS00:0xa4:Completed 512500 out of 1250000 steps  (41%)
19:50:23:WU01:FS00:0xa4:Completed 525000 out of 1250000 steps  (42%)
19:56:14:WU01:FS00:0xa4:Completed 537500 out of 1250000 steps  (43%)
20:01:58:WU01:FS00:0xa4:Completed 550000 out of 1250000 steps  (44%)
20:05:36:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
20:05:46:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
20:05:46:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
20:05:46:ERROR:WU00:FS01:Exception: Could not get an assignment
20:07:43:WU01:FS00:0xa4:Completed 562500 out of 1250000 steps  (45%)
20:13:31:WU01:FS00:0xa4:Completed 575000 out of 1250000 steps  (46%)
20:19:18:WU01:FS00:0xa4:Completed 587500 out of 1250000 steps  (47%)
20:25:03:WU01:FS00:0xa4:Completed 600000 out of 1250000 steps  (48%)
20:28:19:FS00:Paused
20:28:19:FS01:Paused
20:28:19:FS00:Shutting core down
20:28:20:FS00:Unpaused
20:28:20:FS00:Finishing
20:28:20:FS01:Unpaused
20:28:20:FS01:Finishing
20:28:24:WU01:FS00:0xa4:Client no longer detected. Shutting down core.
20:28:24:WU01:FS00:0xa4:
20:28:24:WU01:FS00:0xa4:Folding@home Core Shutdown: CLIENT_DIED
20:28:31:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
20:28:41:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
20:28:41:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
20:28:41:ERROR:WU00:FS01:Exception: Could not get an assignment
20:28:41:WU01:FS00:FahCore returned: INTERRUPTED (102 = 0x66)
20:28:41:WU01:FS00:Starting
20:28:41:WU01:FS00:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/fahwebx.stanford.edu/cores/Linux/AMD64/Core_a4.fah/FahCore_a4 -dir 01 -suffix 01 -version 704 -lifeline 2704 -checkpoint 15 -np 6
20:28:41:WU01:FS00:Started FahCore on PID 3261
20:28:41:WU01:FS00:Core PID:3265
20:28:41:WU01:FS00:FahCore 0xa4 started
20:28:42:WU01:FS00:0xa4:
20:28:42:WU01:FS00:0xa4:*------------------------------*
20:28:42:WU01:FS00:0xa4:Folding@Home Gromacs GB Core
20:28:42:WU01:FS00:0xa4:Version 2.27 (Dec. 15, 2010)
20:28:42:WU01:FS00:0xa4:
20:28:42:WU01:FS00:0xa4:Preparing to commence simulation
20:28:42:WU01:FS00:0xa4:- Looking at optimizations...
20:28:42:WU01:FS00:0xa4:- Files status OK
20:28:42:WU01:FS00:0xa4:- Expanded 1128760 -> 2619636 (decompressed 232.0 percent)
20:28:42:WU01:FS00:0xa4:Called DecompressByteArray: compressed_data_size=1128760 data_size=2619636, decompressed_data_size=2619636 diff=0
20:28:42:WU01:FS00:0xa4:- Digital signature verified
20:28:42:WU01:FS00:0xa4:
20:28:42:WU01:FS00:0xa4:Project: 8635 (Run 1, Clone 129, Gen 72)
20:28:42:WU01:FS00:0xa4:
20:28:42:WU01:FS00:0xa4:Assembly optimizations on if available.
20:28:42:WU01:FS00:0xa4:Entering M.D.
20:28:42:ERROR:Send error: 32: Broken pipe
20:28:47:WU01:FS00:0xa4:Using Gromacs checkpoints
20:28:48:WU01:FS00:0xa4:Resuming from checkpoint
20:28:48:WU01:FS00:0xa4:Verified 01/wudata_01.log
20:28:48:WU01:FS00:0xa4:Verified 01/wudata_01.trr
20:28:48:WU01:FS00:0xa4:Verified 01/wudata_01.xtc
20:28:48:WU01:FS00:0xa4:Verified 01/wudata_01.edr
20:28:48:WU01:FS00:0xa4:Completed 588690 out of 1250000 steps  (47%)
20:30:08:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
20:30:18:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
20:30:18:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
20:30:18:ERROR:WU00:FS01:Exception: Could not get an assignment
20:32:45:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
20:32:55:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known


22:29:05:ERROR:WU00:FS01:Exception: Could not get an assignment
****Could not get IP address for assign4.stanford.edu: Name or service not known*************************** Date: 2017-07-13 *******************************
03:29:28:ERROR:WU02:FS00:Exception: Could not get IP address for assign3.stanford.edu: Name or service not known
03:29:38:ERROR:WU02:FS00:Exception: Could not get IP address for assign4.stanford.edu: Name or service not known
03:29:38:WARNING:WU02:FS00:Exception: Failed to find any IP addresses for assignment servers
03:29:38:ERROR:WU02:FS00:Exception: Could not get an assignment
04:28:56:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
04:29:06:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
04:29:06:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
04:29:06:ERROR:WU00:FS01:Exception: Could not get an assignment
******************************* Date: 2017-07-13 *******************************
09:29:28:ERROR:WU02:FS00:Exception: Could not get IP address for assign3.stanford.edu: Name or service not known
09:29:38:ERROR:WU02:FS00:Exception: Could not get IP address for assign4.stanford.edu: Name or service not known
09:29:38:WARNING:WU02:FS00:Exception: Failed to find any IP addresses for assignment servers
09:29:38:ERROR:WU02:FS00:Exception: Could not get an assignment
10:28:56:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU.stanford.edu: Name or service not known
10:29:06:ERROR:WU00:FS01:Exception: Could not get IP address for assign-GPU2.stanford.edu: Name or service not known
10:29:06:WARNING:WU00:FS01:Exception: Failed to find any IP addresses for assignment servers
10:29:06:ERROR:WU00:FS01:Exception: Could not get an assignment
******************************* Date: 2017-07-13 *******************************
15:29:28:ERROR:WU02:FS00:Exception: Could not get IP address for assign3.stanford.edu: Name or service not known
15:29:38:ERROR:WU02:FS00:Exception: Could not get IP address for assign4.stanford.edu: Name or service not known
15:29:38:WARNING:WU02:FS00:Exception: Failed to find any IP addresses for assignment servers
15:29:38:ERROR:WU02:FS00:Exception: Could not get an assignment

orion456
 
Posts: 39
Joined: Wed Jun 25, 2008 6:25 am

Re: Could not get IP address for assign4.stanford.edu: Name

Postby JimboPalmer » Thu Jul 13, 2017 4:05 pm

Unrelated to your obvious issue (which strikes me as a network problem in your network, can you describe it?) It looks like you need the latest driver from Nvidia to fold on your GPU.

a4 is a CPU core. You have OpenCL issues preventing GPU folding, this is often from using third party drivers. (If you can't use true Nvidia drivers, you might as well delete the GPU slot and set CPUs back to 8)
Tsar of all the Rushers
I tried to remain childlike, all I achieved was childish.
A friend to those who want no friends
JimboPalmer
 
Posts: 524
Joined: Mon Feb 16, 2009 4:12 am
Location: Greenwood MS USA

Re: Could not get IP address for assign4.stanford.edu: Name

Postby orion456 » Thu Jul 13, 2017 4:10 pm

JimboPalmer wrote:Unrelated to your obvious issue (which strikes me as a network problem in your network, can you describe it?) It looks like you need the latest driver from Nvidia to fold on your GPU.

a4 is a CPU core. You have OpenCL issues preventing GPU folding, this is often from using third party drivers. (If you can't use true Nvidia drivers, you might as well delete the GPU slot and set CPUs back to 8)


It was folding fine before and Nvidia drivers were installed and then suddenly stopped working, could this be an update issue with Ubuntu 16.04?

I also have a machine that is only CPU folding and it also can't get updates - again it is an Ubuntu 16.04 machine.
orion456
 
Posts: 39
Joined: Wed Jun 25, 2008 6:25 am

Re: OpenCL drivers are not present

Postby bruce » Thu Jul 13, 2017 4:38 pm

It is most definitely a problem with the drivers or their installation.
GPU folding can not proceed unless support for OpenCL is available
This feature is normally provided if you get your drivers directly from AMD or from NVidia (as applicable) and often omitted if drivers from other sources are used.

18:03:42: OpenCL: Not detected: Failed to open dynamic library 'libOpenCL.so':
18:03:42: libOpenCL.so: cannot open shared object file: No such file or
18:03:42: directory


I'm changing the title of this topic to better reflect your problem.
bruce
 
Posts: 21416
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: OpenCL drivers are not present.

Postby orion456 » Thu Jul 13, 2017 6:35 pm

Some how the system is obviously corrupt, how do I reinstall the nvidia drivers and opencl ?
orion456
 
Posts: 39
Joined: Wed Jun 25, 2008 6:25 am

Re: OpenCL drivers are not present.

Postby bruce » Thu Jul 13, 2017 7:46 pm

The system is probably not corrupt ... you're probably using the default GPU drivers supplied with your distro.

For information on the drivers, visit nvida.com or ati.com or search the on-line resources for proprietary drivers for your distro. Also, beware: if your Desktop (GUI) is running when you install the drivers, you will corrupt them.

In my case (Ubuntu), I've been able to find repackaged proprietary drivers which contain the necessary steps to disable my GUI, install the drivers, and re-enable the GUI. If you're running
a "server" version of your distro (Text-only, without a GUI), this is not a problem.
bruce
 
Posts: 21416
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: OpenCL drivers are not present.

Postby orion456 » Fri Jul 14, 2017 3:19 pm

bruce wrote:The system is probably not corrupt ... you're probably using the default GPU drivers supplied with your distro.



As I said earlier, my machines doing pure CPU folding have also stopped getting WUs. The connection is working for other sites, any idea why not FAH?

Code: Select all
*********************** Log Started 2017-07-14T15:14:14Z ***********************
15:14:14:************************* Folding@home Client *************************
15:14:14:    Website: http://folding.stanford.edu/
15:14:14:  Copyright: (c) 2009-2016 Stanford University
15:14:14:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
15:14:14:       Args: --child --lifeline 1344 /etc/fahclient/config.xml --run-as
15:14:14:             fahclient --pid-file=/var/run/fahclient.pid --daemon
15:14:14:     Config: /etc/fahclient/config.xml
15:14:14:******************************** Build ********************************
15:14:14:    Version: 7.4.15
15:14:14:       Date: Aug 17 2016
15:14:14:       Time: 04:33:43
15:14:14: Repository: Git
15:14:14:   Revision: 4f3e0e25571a9f691719f0c273739294bde517dd
15:14:14:     Branch: master
15:14:14:   Compiler: GNU 4.8.5
15:14:14:    Options: -std=gnu++98 -O3 -funroll-loops -ffast-math -mfpmath=sse
15:14:14:             -fno-unsafe-math-optimizations -msse2
15:14:14:   Platform: linux2 4.6.0-1-amd64
15:14:14:       Bits: 64
15:14:14:       Mode: Release
15:14:14:******************************* System ********************************
15:14:14:        CPU: Intel(R) Core(TM) i7 CPU X 980 @ 3.33GHz
15:14:14:     CPU ID: GenuineIntel Family 6 Model 44 Stepping 2
15:14:14:       CPUs: 12
15:14:14:     Memory: 5.82GiB
15:14:14:Free Memory: 5.33GiB
15:14:14:    Threads: POSIX_THREADS
15:14:14: OS Version: 4.4
15:14:14:Has Battery: false
15:14:14: On Battery: false
15:14:14: UTC Offset: -5
15:14:14:        PID: 1346
15:14:14:        CWD: /var/lib/fahclient
15:14:14:         OS: Linux 4.4.0-83-generic x86_64
15:14:14:    OS Arch: AMD64
15:14:14:       GPUs: 1
15:14:14:      GPU 0: Bus:3 Slot:0 ATI:4 ManhattanP [Radeon HD 6230]
15:14:14:       CUDA: Not detected
15:14:14:     OpenCL: Not detected
15:14:14:***********************************************************************
15:14:14:<config>
15:14:14:  <!-- Client Control -->
15:14:14:  <fold-anon v='true'/>
15:14:14:
15:14:14:  <!-- Folding Slot Configuration -->
15:14:14:  <gpu v='false'/>
15:14:14:
15:14:14:  <!-- Network -->
15:14:14:  <proxy v=':8080'/>
15:14:14:
15:14:14:  <!-- Slot Control -->
15:14:14:  <power v='full'/>
15:14:14:
15:14:14:  <!-- User Information -->
15:14:14:  <passkey v='********************************'/>
15:14:14:  <team v='32'/>
15:14:14:  <user v='orion456'/>
15:14:14:
15:14:14:  <!-- Folding Slots -->
15:14:14:  <slot id='0' type='CPU'/>
15:14:14:</config>
15:14:14:Switching to user fahclient
15:14:14:Trying to access database...
15:14:14:Successfully acquired database lock
15:14:14:Enabled folding slot 00: READY cpu:12
15:14:23:ERROR:WU00:FS00:Exception: Could not get IP address for assign3.stanford.edu: Name or service not known
15:14:33:ERROR:WU00:FS00:Exception: Could not get IP address for assign4.stanford.edu: Name or service not known
15:14:33:WARNING:WU00:FS00:Exception: Failed to find any IP addresses for assignment servers
15:14:33:ERROR:WU00:FS00:Exception: Could not get an assignment
15:14:43:ERROR:WU00:FS00:Exception: Could not get IP address for assign3.stanford.edu: Name or service not known
15:14:53:ERROR:WU00:FS00:Exception: Could not get IP address for assign4.stanford.edu: Name or service not known
15:14:53:WARNING:WU00:FS00:Exception: Failed to find any IP addresses for assignment servers
15:14:53:ERROR:WU00:FS00:Exception: Could not get an assignment
15:15:43:ERROR:WU00:FS00:Exception: Could not get IP address for assign3.stanford.edu: Name or service not known
15:15:53:ERROR:WU00:FS00:Exception: Could not get IP address for assign4.stanford.edu: Name or service not known
15:15:53:WARNING:WU00:FS00:Exception: Failed to find any IP addresses for assignment servers
15:15:53:ERROR:WU00:FS00:Exception: Could not get an assignment

orion456
 
Posts: 39
Joined: Wed Jun 25, 2008 6:25 am

Re: Could not get IP address for assign4.stanford.edu: Name

Postby JimboPalmer » Fri Jul 14, 2017 5:46 pm

JimboPalmer wrote:Your obvious issue (which strikes me as a network problem in your network, can you describe it?)

I missed the part where you described your network.
JimboPalmer
 
Posts: 524
Joined: Mon Feb 16, 2009 4:12 am
Location: Greenwood MS USA

Re: Could not get IP address for assign4.stanford.edu: Name

Postby orion456 » Fri Jul 14, 2017 7:30 pm

JimboPalmer wrote:
JimboPalmer wrote:Your obvious issue (which strikes me as a network problem in your network, can you describe it?)

I missed the part where you described your network.


I am hooked up to a 8 plug switch that is connected directly to a central building router that I have no control over.

So far as I can tell, the internet is working since it answers firefox without problems and lets me write this.
orion456
 
Posts: 39
Joined: Wed Jun 25, 2008 6:25 am

Re: Could not get IP address for assign4.stanford.edu

Postby bruce » Fri Jul 14, 2017 7:53 pm

OK. My mistake. I put the title back.

Post the output from "ifconfig"

Your router should be delivering a DNS service that identifies assign*.stanford.edu. You should be able to add an alternate DNS service without access to the router.

From my DNS service:
assign.stanford.edu 171.67.108.45 (and assign3)
assign2.stanford.edu 171.64.65.35 (and assign4)

Are you able to open http://171.67.108.45 and/or http://171.64.65.35 ?
Are you able to open http://171.67.108.45:8080 and/or http://171.64.65.35:8080 ?
(You should get banner pages saying "Assignment Server")
bruce
 
Posts: 21416
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Could not get IP address for assign4.stanford.edu

Postby orion456 » Mon Jul 17, 2017 5:20 pm

Yes I get a banner page from each of the address you listed.

How would I add a dns service to ubuntu and which address should I try?

Is it safe to post the output from ifconfig. it seems to contain IP addresses which I assume
are directly connect to something close to me.
orion456
 
Posts: 39
Joined: Wed Jun 25, 2008 6:25 am

Re: Could not get IP address for assign4.stanford.edu

Postby orion456 » Mon Jul 17, 2017 6:46 pm

Ok I moved my machine to a known good network connection that is working for another machine and I got the following result. The opencl is now resolved by updating from the Ubuntu website, the server is now recognized by it still fails.

Code: Select all
*********************** Log Started 2017-07-17T18:43:13Z ***********************
18:43:13:************************* Folding@home Client *************************
18:43:13:        Website: http://folding.stanford.edu/
18:43:13:      Copyright: (c) 2009-2016 Stanford University
18:43:13:         Author: Joseph Coffland <joseph@cauldrondevelopment.com>
18:43:13:           Args: --child --lifeline 1397 /etc/fahclient/config.xml --run-as
18:43:13:                 fahclient --pid-file=/var/run/fahclient.pid --daemon
18:43:13:         Config: /etc/fahclient/config.xml
18:43:13:******************************** Build ********************************
18:43:13:        Version: 7.4.16
18:43:13:           Date: Jan 6 2017
18:43:13:           Time: 08:08:33
18:43:13:     Repository: Git
18:43:13:       Revision: e12187cbb0bd6937c067b9749af011374563b7b9
18:43:13:         Branch: master
18:43:13:       Compiler: GNU 4.9.2
18:43:13:        Options: -std=gnu++98 -O3 -funroll-loops -ffast-math -mfpmath=sse
18:43:13:                 -fno-unsafe-math-optimizations -msse2
18:43:13:       Platform: linux2 4.8.0-2-amd64
18:43:13:           Bits: 64
18:43:13:           Mode: Release
18:43:13:******************************* System ********************************
18:43:13:            CPU: Intel(R) Xeon(R) CPU W3520 @ 2.67GHz
18:43:13:         CPU ID: GenuineIntel Family 6 Model 26 Stepping 5
18:43:13:           CPUs: 8
18:43:13:         Memory: 5.82GiB
18:43:13:    Free Memory: 5.23GiB
18:43:13:        Threads: POSIX_THREADS
18:43:13:     OS Version: 4.8
18:43:13:    Has Battery: false
18:43:13:     On Battery: false
18:43:13:     UTC Offset: -5
18:43:13:            PID: 1399
18:43:13:            CWD: /var/lib/fahclient
18:43:13:             OS: Linux 4.8.0-58-generic x86_64
18:43:13:        OS Arch: AMD64
18:43:13:           GPUs: 1
18:43:13:          GPU 0: Bus:3 Slot:0 Func:0 NVIDIA:5 GM204 [GeForce GTX 970]
18:43:13:  CUDA Device 0: Platform:0 Device:0 Bus:3 Slot:0 Compute:5.2 Driver:8.0
18:43:13:OpenCL Device 0: Platform:0 Device:0 Bus:3 Slot:0 Compute:1.2 Driver:375.66
18:43:13:***********************************************************************
18:43:13:<config>
18:43:13:  <!-- Client Control -->
18:43:13:  <fold-anon v='true'/>
18:43:13:
18:43:13:  <!-- Network -->
18:43:13:  <proxy v='171.64.65.35:8080'/>
18:43:13:  <proxy-enable v='true'/>
18:43:13:
18:43:13:  <!-- Slot Control -->
18:43:13:  <power v='full'/>
18:43:13:
18:43:13:  <!-- User Information -->
18:43:13:  <passkey v='********************************'/>
18:43:13:  <team v='32'/>
18:43:13:  <user v='orion456'/>
18:43:13:
18:43:13:  <!-- Folding Slots -->
18:43:13:  <slot id='0' type='CPU'/>
18:43:13:  <slot id='1' type='GPU'/>
18:43:13:</config>
18:43:13:Switching to user fahclient
18:43:13:Trying to access database...
18:43:13:Successfully acquired database lock
18:43:13:Enabled folding slot 00: READY cpu:7
18:43:13:Enabled folding slot 01: READY gpu:0:GM204 [GeForce GTX 970]
18:43:14:WU00:FS00:Connecting to 171.64.65.35:8080
18:43:14:WU01:FS01:Connecting to 171.64.65.35:8080
18:43:14:WU01:FS01:Assigned to work server 140.163.4.242
18:43:14:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GM204 [GeForce GTX 970] from 140.163.4.242
18:43:14:WU01:FS01:Connecting to 171.64.65.35:8080
18:43:14:WU00:FS00:Assigned to work server 171.67.108.158
18:43:14:WU00:FS00:Requesting new work unit for slot 00: READY cpu:7 from 171.67.108.158
18:43:14:WU00:FS00:Connecting to 171.64.65.35:8080
18:43:15:ERROR:WU01:FS01:Exception: 10001: Server responded: HTTP_INTERNAL_SERVER_ERROR
18:43:15:ERROR:WU00:FS00:Exception: 10001: Server responded: HTTP_INTERNAL_SERVER_ERROR
18:43:15:WU01:FS01:Connecting to 171.64.65.35:8080
18:43:15:WU00:FS00:Connecting to 171.64.65.35:8080
18:43:16:WU01:FS01:Assigned to work server 140.163.4.245
18:43:16:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GM204 [GeForce GTX 970] from 140.163.4.245
18:43:16:WU01:FS01:Connecting to 171.64.65.35:8080
18:43:16:WU00:FS00:Assigned to work server 171.67.108.158
18:43:16:WU00:FS00:Requesting new work unit for slot 00: READY cpu:7 from 171.67.108.158
18:43:16:WU00:FS00:Connecting to 171.64.65.35:8080
18:43:16:ERROR:WU01:FS01:Exception: 10001: Server responded: HTTP_INTERNAL_SERVER_ERROR
18:43:16:ERROR:WU00:FS00:Exception: 10001: Server responded: HTTP_INTERNAL_SERVER_ERROR

orion456
 
Posts: 39
Joined: Wed Jun 25, 2008 6:25 am

Re: Could not get IP address for assign4.stanford.edu

Postby orion456 » Mon Jul 17, 2017 7:15 pm

Ok the issue seems to be client 4.4.16 because reinstalling client 4.4.4 and the system is folding properly.
orion456
 
Posts: 39
Joined: Wed Jun 25, 2008 6:25 am

Re: Could not get IP address for assign4.stanford.edu

Postby bruce » Mon Jul 17, 2017 7:21 pm

HTTP_INTERNAL_SERVER_ERROR indicates there is a problem at the server.
I don't think it has anything to do with your client. You probably just got assigned to a different server.
http://140.163.4.242 still fails for me.

The owner of that server has been notified.
bruce
 
Posts: 21416
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Could not get IP address for assign4.stanford.edu

Postby orion456 » Tue Jul 18, 2017 6:50 pm

Ok, you were right, my DNS was malfunctioning. Switching to a different DNS solved that problem.

Downloading a new version of OpenCL fixed the missing OpenCL problem.

Fixing missing python2 fixed the remaining problems.

Alll is working now.....thanks for your help.
orion456
 
Posts: 39
Joined: Wed Jun 25, 2008 6:25 am

Next

Return to Issues with a specific server

Who is online

Users browsing this forum: No registered users and 2 guests

cron