WARNING:WU01:FS00:Server did not like results, dumping

Moderators: Site Moderators, PandeGroup

WARNING:WU01:FS00:Server did not like results, dumping

Postby ifolder » Sat Aug 26, 2017 10:08 pm

I got all my GPU WUs rejected with the same pattern.
How that "Server did not like results, dumping"???
Why dumping?

Moreover all the computers got frozen afterwards. I had to switch OFF/ON the power to have them reboot.
The computers rebooted and started downloading new WUs but the old dumped ones were lost. No more upload attempt.
That's about half million points lost...

Code: Select all
11:30:43:WU00:FS00:Connecting to 171.67.108.45:80
11:30:44:WU00:FS00:Assigned to work server 140.163.4.232
11:30:44:WU00:FS00:Requesting new work unit for slot 00: RUNNING gpu:0:GP102 [GeForce GTX 1080 Ti] 11380 from 140.163.4.232
11:30:44:WU00:FS00:Connecting to 140.163.4.232:8080
11:30:44:WU01:FS00:0x21:Saving result file logfile_01.txt
11:30:44:WU01:FS00:0x21:Saving result file checkpointState.xml
11:30:44:WU01:FS00:0x21:Saving result file checkpt.crc
11:30:44:WU01:FS00:0x21:Saving result file log.txt
11:30:44:WU01:FS00:0x21:Saving result file positions.xtc
11:30:44:ERROR:WU00:FS00:Exception: Server did not assign work unit
11:30:44:WU01:FS00:0x21:Folding@home Core Shutdown: FINISHED_UNIT
11:30:45:WU01:FS00:FahCore returned: FINISHED_UNIT (100 = 0x64)
11:30:45:WU01:FS00:Sending unit results: id:01 state:SEND error:NO_ERROR project:11409 run:150 clone:5 gen:47 core:0x21 unit:0x000000388ca304e95987376aea006a55
11:30:45:WU01:FS00:Uploading 19.85MiB to 140.163.4.233
11:30:45:WU01:FS00:Connecting to 140.163.4.233:8080
11:30:45:WU00:FS00:Connecting to 171.67.108.45:80
11:30:45:WU00:FS00:Assigned to work server 140.163.4.233
11:30:45:WU00:FS00:Requesting new work unit for slot 00: READY gpu:0:GP102 [GeForce GTX 1080 Ti] 11380 from 140.163.4.233
11:30:45:WU00:FS00:Connecting to 140.163.4.233:8080
11:30:46:WU00:FS00:Downloading 26.13MiB
11:30:51:WU01:FS00:Upload 9.76%
11:30:52:WU00:FS00:Download 10.28%
11:30:57:WU01:FS00:Upload 25.51%
11:30:58:WU00:FS00:Download 22.48%
11:31:03:WU01:FS00:Upload 36.84%
11:31:04:WU00:FS00:Download 33.49%
11:31:10:WU01:FS00:Upload 45.98%
11:31:10:WARNING:WU01:FS00:Exception: Failed to send results to work server: Transfer failed
11:31:10:WU01:FS00:Trying to send results to collection server
11:31:10:WU01:FS00:Uploading 19.85MiB to 171.67.108.46
11:31:10:WU01:FS00:Connecting to 171.67.108.46:8080
11:31:16:WU01:FS00:Upload 9.45%
11:31:22:WU01:FS00:Upload 26.77%
11:31:28:WU01:FS00:Upload 42.20%
11:31:34:WU01:FS00:Upload 55.74%
11:31:40:WU01:FS00:Upload 71.48%
11:31:46:WU01:FS00:Upload 85.02%
11:31:54:WU01:FS00:Upload complete
11:31:54:WU01:FS00:Server responded WORK_QUIT (404)
11:31:54:WARNING:WU01:FS00:Server did not like results, dumping
11:31:54:WU01:FS00:Cleaning up


Code: Select all
13:41:35:WU01:FS00:Connecting to 171.67.108.45:80
13:41:36:WU00:FS00:0x21:Saving result file logfile_01.txt
13:41:36:WU00:FS00:0x21:Saving result file checkpointState.xml
13:41:36:WU00:FS00:0x21:Saving result file checkpt.crc
13:41:36:WU00:FS00:0x21:Saving result file log.txt
13:41:36:WU00:FS00:0x21:Saving result file positions.xtc
13:41:36:WU00:FS00:0x21:Folding@home Core Shutdown: FINISHED_UNIT
13:41:36:WU01:FS00:Assigned to work server 171.67.108.157
13:41:36:WU01:FS00:Requesting new work unit for slot 00: RUNNING gpu:0:GP102 [GeForce GTX 1080 Ti] 11380 from 171.67.108.157
13:41:36:WU01:FS00:Connecting to 171.67.108.157:8080
13:41:36:WU00:FS00:FahCore returned: FINISHED_UNIT (100 = 0x64)
13:41:36:WU00:FS00:Sending unit results: id:00 state:SEND error:NO_ERROR project:11409 run:264 clone:2 gen:46 core:0x21 unit:0x000000368ca304e959778428e02aa5a1
13:41:36:WU00:FS00:Uploading 19.89MiB to 140.163.4.233
13:41:36:WU00:FS00:Connecting to 140.163.4.233:8080
13:41:37:WU01:FS00:Downloading 5.17MiB
13:41:42:WU00:FS00:Upload 4.40%
13:41:43:WU01:FS00:Download 37.48%
13:41:49:WU01:FS00:Download 83.43%
13:41:52:WU00:FS00:Upload 12.88%
13:41:52:WARNING:WU00:FS00:Exception: Failed to send results to work server: Transfer failed
13:41:52:WU00:FS00:Trying to send results to collection server
13:41:52:WU00:FS00:Uploading 19.89MiB to 171.67.108.46
13:41:52:WU00:FS00:Connecting to 171.67.108.46:8080
13:41:58:WU00:FS00:Upload 4.71%
13:42:04:WU00:FS00:Upload 17.28%
13:42:12:WU00:FS00:Upload 26.08%
13:42:20:WU00:FS00:Upload 32.67%
13:42:26:WU00:FS00:Upload 41.78%
13:42:33:WU00:FS00:Upload 50.58%
13:42:39:WU00:FS00:Upload 55.29%
13:42:45:WU00:FS00:Upload 59.69%
13:42:52:WU00:FS00:Upload 66.29%
13:42:58:WU00:FS00:Upload 70.69%
13:43:05:WU00:FS00:Upload 75.40%
13:43:11:WU00:FS00:Upload 82.00%
13:43:21:WU00:FS00:Upload 86.40%
13:43:27:WU00:FS00:Upload 88.60%
13:43:35:WU00:FS00:Upload 93.31%
13:43:43:WU00:FS00:Upload 97.71%
13:43:53:WU00:FS00:Upload complete
13:43:53:WU00:FS00:Server responded WORK_QUIT (404)
13:43:53:WARNING:WU00:FS00:Server did not like results, dumping
13:43:53:WU00:FS00:Cleaning up
ifolder
 
Posts: 47
Joined: Sat Sep 19, 2015 12:44 pm

Re: WARNING:WU01:FS00:Server did not like results, dumping

Postby bruce » Sun Aug 27, 2017 12:43 am

The message "did not like" can be caused by several conditions. The most common one is when the server rejects a corrupt WU, no matter how or why the corruption occurred.

Most, but not all, problems are a result of local hardware issues.For example, it's possible to overclock or overheat a system right to the critical point at which there are small calculation errors which are not big enough to crash the system. The fact that your hardware was then frozen suggests that something was wrong on your end.

Some problems may occur during transmission or at the server's end, but there's no way to tell the difference ... only the final result. It's interesting to note that there was a problem with both the initial upload attempt to the Work Server and the second attempt to the Collection Server.

Once a corrupt WU gets the "did not like" message, it is always discarded and reassigned to someone else who can produce a successful completion.

What GPU and what driver version are you using?
Were there any indications of problems while those particular WUs were being processed?
bruce
 
Posts: 21276
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: WARNING:WU01:FS00:Server did not like results, dumping

Postby ifolder » Sun Aug 27, 2017 10:19 am

GPUs are neither overclocked nor overheating (<65°C).
I use NVIDIA driver v381.22. GPUs are 1080Ti
Everything worked fine for weeks and suddenly all the 3 computers (having different brands of GPUs and different MB & CPUs) have this issue at the same time...

According to the logs, FAHClient finished the WU, started uploading the WU, failed sending the WU, tried to upload it to the collection server, succeeded to do so but the WU was rejected.
And then FAHClient hangs (no more trying to download a new WU or do whatever).
queue-info shows FAHCLient stays in DOWNLOAD mode but nextattempt stays at 0.00s.
And if I issue it the shutdown command to FAHClient through telnet it refuses to quit (nothing happens).

And if I issue sudo halt -p through ssh, the PC doesn't shut down, I have to manually switch OFF and ON the power.
FAHClient manages to crash Linux?

The problem continues. I found this this morning:

Code: Select all
08:02:51:WU02:FS01:0x21:Completed 6250000 out of 6250000 steps (100%)
08:02:52:WU02:FS01:0x21:Saving result file logfile_01.txt
08:02:52:WU02:FS01:0x21:Saving result file checkpointState.xml
08:02:52:WU02:FS01:0x21:Saving result file checkpt.crc
08:02:52:WU02:FS01:0x21:Saving result file log.txt
08:02:52:WU02:FS01:0x21:Saving result file positions.xtc
08:02:52:WU02:FS01:0x21:Folding@home Core Shutdown: FINISHED_UNIT
08:02:52:WU00:FS01:Connecting to 171.67.108.45:80
08:02:52:WU02:FS01:FahCore returned: FINISHED_UNIT (100 = 0x64)
08:02:52:WU02:FS01:Sending unit results: id:02 state:SEND error:NO_ERROR project:9414 run:356 clone:0 gen:368 core:0x21 unit:0x000001b5ab436c9d585e0692a42d0d2e
08:02:52:WU02:FS01:Uploading 7.76MiB to 171.67.108.157
08:02:52:WU02:FS01:Connecting to 171.67.108.157:8080
08:02:53:WU00:FS01:Assigned to work server 171.67.108.157
08:02:53:WU00:FS01:Requesting new work unit for slot 01: READY gpu:1:GP102 [GeForce GTX 1080 Ti] 11380 from 171.67.108.157
08:02:53:WU00:FS01:Connecting to 171.67.108.157:8080
08:02:54:WU00:FS01:Downloading 5.15MiB
08:02:58:WU02:FS01:Upload 12.08%
08:03:00:WU00:FS01:Download 40.06%
08:03:04:WU02:FS01:Upload 17.72%
08:03:04:WARNING:WU02:FS01:Exception: Failed to send results to work server: Transfer failed
08:03:04:WU02:FS01:Trying to send results to collection server
08:03:04:WU02:FS01:Uploading 7.76MiB to 171.67.108.46
08:03:04:WU02:FS01:Connecting to 171.67.108.46:8080
08:03:10:WU02:FS01:Upload 23.35%
08:03:16:WU02:FS01:Upload 54.76%
08:03:22:WU02:FS01:Upload 80.53%
08:03:27:WU02:FS01:Upload complete
08:03:27:WU02:FS01:Server responded WORK_QUIT (404)
08:03:27:WARNING:WU02:FS01:Server did not like results, dumping
08:03:27:WU02:FS01:Cleaning up


Code: Select all
04:16:43:WU00:FS00:0x21:Completed 5000000 out of 5000000 steps (100%)
04:16:44:WU00:FS00:0x21:Saving result file logfile_01.txt
04:16:44:WU00:FS00:0x21:Saving result file checkpointState.xml
04:16:44:WU00:FS00:0x21:Saving result file checkpt.crc
04:16:44:WU00:FS00:0x21:Saving result file log.txt
04:16:44:WU00:FS00:0x21:Saving result file positions.xtc
04:16:44:WU00:FS00:0x21:Folding@home Core Shutdown: FINISHED_UNIT
04:16:44:WU01:FS00:Connecting to 171.67.108.45:80
04:16:44:WU00:FS00:FahCore returned: FINISHED_UNIT (100 = 0x64)
04:16:44:WU00:FS00:Sending unit results: id:00 state:SEND error:NO_ERROR project:11807 run:0 clone:282 gen:187 core:0x21 unit:0x000000c68ca304e8582b71b5f139aaf6
04:16:44:WU00:FS00:Uploading 7.13MiB to 140.163.4.232
04:16:44:WU00:FS00:Connecting to 140.163.4.232:8080
04:16:45:WU01:FS00:Assigned to work server 140.163.4.233
04:16:45:WU01:FS00:Requesting new work unit for slot 00: READY gpu:0:GP102 [GeForce GTX 1080 Ti] 11380 from 140.163.4.233
04:16:45:WU01:FS00:Connecting to 140.163.4.233:8080
04:16:46:WU01:FS00:Downloading 26.91MiB
04:16:50:WU00:FS00:Upload 56.99%
04:16:53:WARNING:WU00:FS00:Exception: Failed to send results to work server: Transfer failed
04:16:53:WU00:FS00:Trying to send results to collection server
04:16:53:WU00:FS00:Uploading 7.13MiB to 171.67.108.46
04:16:53:WU00:FS00:Connecting to 171.67.108.46:8080
04:16:59:WU00:FS00:Upload 65.76%
04:17:02:WU00:FS00:Upload complete
04:17:02:WU00:FS00:Server responded WORK_QUIT (404)
04:17:02:WARNING:WU00:FS00:Server did not like results, dumping
04:17:02:WU00:FS00:Cleaning up
ifolder
 
Posts: 47
Joined: Sat Sep 19, 2015 12:44 pm

Re: WARNING:WU01:FS00:Server did not like results, dumping

Postby SteveWillis » Sun Aug 27, 2017 1:23 pm

Since it happens on three different computers I would be looking at network or internet problems.
Image
My thanks to my very indulgent wife
http://folding.extremeoverclocking.com/user_summary.php?s=&u=712804

3 AMD Linux rigs 3, 4, and 5 GPUs 7 X GTX 1080, 5 X GTX 1080 TI
SteveWillis
 
Posts: 215
Joined: Fri Apr 15, 2016 12:42 am

Re: WARNING:WU01:FS00:Server did not like results, dumping

Postby ifolder » Sun Aug 27, 2017 2:45 pm

There is some problem with the download part of FAHClient.
Below the download froze at 21% and the slot stayed there while the other slot on the same computer finished folding, uploaded the data and correctly downloaded a new WU.
And issuing shutdown to FAHClient doesn't work. Part of it is frozen.
Should a network or internet problem freeze FAHClient???

Code: Select all
14:00:28:WU02:FS00:0x21:Folding@home Core Shutdown: FINISHED_UNIT
14:00:28:WU02:FS00:FahCore returned: FINISHED_UNIT (100 = 0x64)
14:00:28:WU02:FS00:Sending unit results: id:02 state:SEND error:NO_ERROR project:9414 run:2035 clone:0 gen:67 core:0x21 unit:0x00000055ab436c9d585e069f453ae9a3
14:00:28:WU02:FS00:Uploading 7.77MiB to 171.67.108.157
14:00:28:WU02:FS00:Connecting to 171.67.108.157:8080
14:00:28:WU00:FS00:Assigned to work server 140.163.4.233
14:00:28:WU00:FS00:Requesting new work unit for slot 00: READY gpu:0:GP102 [GeForce GTX 1080 Ti] 11380 from 140.163.4.233
14:00:28:WU00:FS00:Connecting to 140.163.4.233:8080
14:00:29:WU00:FS00:Downloading 26.13MiB
14:00:35:WU00:FS00:Download 2.39%
14:00:36:WU02:FS00:Upload 19.31%
14:00:41:WU00:FS00:Download 4.07%
14:00:43:WU02:FS00:Upload 44.25%
14:00:47:WU00:FS00:Download 6.22%
14:00:49:WU02:FS00:Upload 85.29%
14:00:53:WU00:FS00:Download 8.37%
14:00:55:WU02:FS00:Upload complete
14:00:55:WU02:FS00:Server responded WORK_ACK (400)
14:00:55:WU02:FS00:Final credit estimate, 52628.00 points
14:00:55:WU02:FS00:Cleaning up
14:00:59:WU00:FS00:Download 10.29%
14:01:00:WU01:FS01:0x21:Completed 4050000 out of 5000000 steps (81%)
14:01:05:WU00:FS00:Download 12.68%
14:01:11:WU00:FS00:Download 16.27%
14:01:17:WU00:FS00:Download 21.05%
14:02:39:WU01:FS01:0x21:Completed 4100000 out of 5000000 steps (82%)
14:04:20:WU01:FS01:0x21:Completed 4150000 out of 5000000 steps (83%)
14:05:59:WU01:FS01:0x21:Completed 4200000 out of 5000000 steps (84%)
14:07:38:WU01:FS01:0x21:Completed 4250000 out of 5000000 steps (85%)
14:09:18:WU01:FS01:0x21:Completed 4300000 out of 5000000 steps (86%)
14:10:57:WU01:FS01:0x21:Completed 4350000 out of 5000000 steps (87%)
14:12:38:WU01:FS01:0x21:Completed 4400000 out of 5000000 steps (88%)
14:14:17:WU01:FS01:0x21:Completed 4450000 out of 5000000 steps (89%)
14:15:56:WU01:FS01:0x21:Completed 4500000 out of 5000000 steps (90%)


I rebooted the computer and got again a freezing download:

Code: Select all
14:51:29:WU02:FS01:0x21:*********************** Log Started 2017-08-27T14:51:29Z ***********************
14:51:29:WU02:FS01:0x21:Project: 9431 (Run 74, Clone 1, Gen 291)
14:51:29:WU02:FS01:0x21:Unit: 0x0000015bab436c9d586fdd344eef242b
14:51:29:WU02:FS01:0x21:CPU: 0x00000000000000000000000000000000
14:51:29:WU02:FS01:0x21:Machine: 1
14:51:29:WU02:FS01:0x21:Digital signatures verified
14:51:29:WU02:FS01:0x21:Folding@home GPU Core21 Folding@home Core
14:51:29:WU02:FS01:0x21:Version 0.0.18
14:51:29:WU02:FS01:0x21:  Found a checkpoint file
14:51:30:WU00:FS00:Assigned to work server 171.67.108.157
14:51:30:WU00:FS00:Requesting new work unit for slot 00: READY gpu:0:GP102 [GeForce GTX 1080 Ti] 11380 from 171.67.108.157
14:51:30:WU00:FS00:Connecting to 171.67.108.157:8080
14:51:31:WU02:FS01:0x21:Completed 1000000 out of 6250000 steps (16%)
14:51:31:WU02:FS01:0x21:Temperature control disabled. Requirements: single Nvidia GPU, tmax must be < 110 and twait >= 900
14:51:31:WU00:FS00:Downloading 5.17MiB
14:52:22:WU02:FS01:0x21:Completed 1062500 out of 6250000 steps (17%)
14:53:12:WU02:FS01:0x21:Completed 1125000 out of 6250000 steps (18%)
14:54:03:WU02:FS01:0x21:Completed 1187500 out of 6250000 steps (19%)
14:54:54:WU02:FS01:0x21:Completed 1250000 out of 6250000 steps (20%)
14:55:45:WU02:FS01:0x21:Completed 1312500 out of 6250000 steps (21%)
ifolder
 
Posts: 47
Joined: Sat Sep 19, 2015 12:44 pm

Re: WARNING:WU01:FS00:Server did not like results, dumping

Postby ifolder » Mon Aug 28, 2017 11:04 am

The problem continues...

Analysing the logs there is a recurring pattern.
Once a WU is finished FAHClient starts to Download a new WU and then starts uploading the finished WU.
Then there is a problem (probably network or Internet as suggested by SteveWillis; moreover this is the only thing I changed recently).
The Download thread inside FAHClient freezes.
The Upload Fails.
FAHClient successfully uploads the WU to the collection server.
But the collection server doesn't like the results and dumps the WU.
Then the faulty slot of FAHClient stays frozen and forbids FAHClient to quit if it receives the shutdown command through telnet. Also kill -1 ... kill -9 don't manage to terminate FAHClient. Which explains why halt -p also can't shutdown linux and it requires manual OFF/ON.

My intuition is that there are 2 problems you have to solve:

1) Implement non-blocking sockets in FAHClient with a timeout/recovery mechanism to make it robust to network problems
2) Fix the collection server that systematically doesn't like the results and therefore wastes the work done by folders
ifolder
 
Posts: 47
Joined: Sat Sep 19, 2015 12:44 pm

Re: WARNING:WU01:FS00:Server did not like results, dumping

Postby ifolder » Tue Aug 29, 2017 4:21 pm

I switched back to the old internet connection (which is better) and there is no more FAHClient hangs.

I think this confirms my previous message.

1) FAHClient is not robust to lousy internet connection and it partially hangs the computer when the connection fails in the middle of a transmission.

2) There is a bug in the Collection Server as it systematically rejects the WUs sent by FAHClient once the connection failed (or the bug is inside FAHClient which sends crap to the collection server).

Knowing that big GPU WUs can take hours and up to one day to fold on some GPUs, it's extremely annoying to have all that work dumped because of bugs...
Last edited by ifolder on Tue Aug 29, 2017 4:29 pm, edited 1 time in total.
ifolder
 
Posts: 47
Joined: Sat Sep 19, 2015 12:44 pm

Re: WARNING:WU01:FS00:Server did not like results, dumping

Postby ifolder » Tue Aug 29, 2017 4:27 pm

bruce wrote:It's interesting to note that there was a problem with both the initial upload attempt to the Work Server and the second attempt to the Collection Server.


Yes, the internet connection being lousy there were several problems.
But FAHClient finally upploaded the WU to the Collection Server which rejected it. And did so systematically during the weekend.

bruce wrote:Once a corrupt WU gets the "did not like" message, it is always discarded and reassigned to someone else who can produce a successful completion.


Well, shouldn't a retry be done instead? Would PG so easily dump the WU if PG was paying the electricity required to fold that WU (for hours)?
ifolder
 
Posts: 47
Joined: Sat Sep 19, 2015 12:44 pm

Re: WARNING:WU01:FS00:Server did not like results, dumping

Postby SteveWillis » Tue Aug 29, 2017 6:08 pm

Just curious as to the difference between your new (bad) internet and your old (good) internet.
SteveWillis
 
Posts: 215
Joined: Fri Apr 15, 2016 12:42 am

Re: WARNING:WU01:FS00:Server did not like results, dumping

Postby ifolder » Tue Aug 29, 2017 8:00 pm

SteveWillis wrote:Just curious as to the difference between your new (bad) internet and your old (good) internet.


Two different 4G GSM providers.

The problem is that now I'm mainly getting large WUs (25MiB+) so I've eaten almost all my monthly "data bundle" from the "good" one and I have to switch to the "lousy" one to finish the month...
So yesterday I could switch back to the good one to do the test.
I'll therefore have to switch back soon to the lousy one and I'll have to do that little game every month so I'm annoyed FAHClient hangs because it's not robust to network failure AND eventually the Collection Server systematically dumps my work and makes me lose millions of points because of some bug somewhere.

Hope they'll do something...

By the way, I'm also wondering if the WUs and the result of folding are compressed prior to upload/download? If not it would be a great thing to do so...
ifolder
 
Posts: 47
Joined: Sat Sep 19, 2015 12:44 pm

Re: WARNING:WU01:FS00:Server did not like results, dumping

Postby Joe_H » Tue Aug 29, 2017 9:23 pm

ifolder wrote:By the way, I'm also wondering if the WUs and the result of folding are compressed prior to upload/download? If not it would be a great thing to do so...

Yes, they are compressed as part of the packaging up to be uploaded, and the downloaded WU is compressed. There are messages after the download as part of the processing core startup.

From the number of network errors you are seeing with your second provider, I suspect it is dropping packets - especially acknowledgement packets. Using the http/https protocol that is bad for data transmission. Where you would just reloada web page if you saw something not loaded, data transmission requires a bit more reliability.

The client does try to take care of re-sending data or re-requesting it, but there are limits. The public beta 7.4.16 is improved over the prior full release 7.4.4 version, but even it will lose connections under bad network conditions.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 3813
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: WARNING:WU01:FS00:Server did not like results, dumping

Postby foldy » Wed Aug 30, 2017 8:52 am

ifolder wrote:The problem is that now I'm mainly getting large WUs (25MiB+) so I've eaten almost all my monthly "data bundle"

Maybe try setting the fah client extra option "max-packet-size=small" to reduce data usage?
foldy
 
Posts: 911
Joined: Sat Dec 01, 2012 3:43 pm

Re: WARNING:WU01:FS00:Server did not like results, dumping

Postby bruce » Thu Aug 31, 2017 1:50 am

The max-packet-size has been a topic of discussion for FAH's development team. The named sizes were defined long, long ago, when WUs were all pretty small compared to the work being done today. After several projects were released which would not assign to clients running the default value, they considered redefining what small/normal/big means but that's tricky since it means getting everybody to update their client -- and the release of 7.4.16+ is languishing without progress.

max-packet-size also accepts numerical values. (At least they're unambiguous) ... but unless the project configuration on the server has a defined value, we'll need to bug the PI to set a value that the assignment process can process. Let me know how well this works for you.
bruce
 
Posts: 21276
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.


Return to Issues with a specific server

Who is online

Users browsing this forum: No registered users and 1 guest

cron