and - Empty work server...

Moderators: Site Moderators, PandeGroup

Re: and - Empty work server

Postby Joe_H » Sat Nov 25, 2017 5:16 pm

There are two different memory limitations that use of 32-bit Windows imposes. First, it allows access to a maximum of 4 GB of RAM by the system. Second, that imposes the same 4 GB limit on the address space, which is split by default on Windows to 2 GB reserved for the kernel and 2 GB to a process. So what the AS is looking at is not 3.24 GB of RAM, but that 32-bit is imposing a 2 GB limit on a process.

That 2 GB limit on a process is an issue at specific times during the running of the GPU core. First is during the initialization, the core has to map the positions of all the atoms and their initial motion vectors to 3-D space. With the larger WU's for Core_21 having over 200k atoms, people have reported use of over 2 GB for the VM size of the core during this operation. The second high usage of of memory is during the periodic checkpoints and validation of the WU progress on the CPU. In between the core will be using less memory as it is just moving data to and back from the GPU. I forget if there is a way to get a report on the maximum VM size of a Windows process, but that peak value is important here.

I may have got some of the details a little off, and some people may bring up a boot flag that can have 32-bit Windows change the split for kernel and process space, but that is essentially how running 32-bit Windows affects the ability to run large GPU assignments. The boot flag would raise the process limit to 3 GB, but PG can't depend on it being used as most people will have a default installation.

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Site Admin
Posts: 4013
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: and - Empty work server

Postby bruce » Sat Nov 25, 2017 8:40 pm

The AS makes assignments based on how the Project Owner has configured his projects. Unfortunately I don't have a way to determine which projects have been restricted to 64-bit but it's probably most of them -- simply based on the fact that's the the way his projects were tested.

FAH did announce that 32-bit Linux was not longer supported. I have not seen a similar announcement about 32-bit Windows but they don't do a lot of testing to select which projects might actually produce trouble-free performance on 32-bit Windows. Is it just the OS that's restricted to 32-bit ... i.e.- does you hardware support 64-bit? Upgrading would probably be a good idea.
Posts: 21107
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: and - Empty work server

Postby toTOW » Sun Nov 26, 2017 3:06 pm

I agree with bruce ... 64 bits has become the norm now, and since it can run 32 bits code, there's no good reason to keep a 32 bits OS ...
Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.

FAH-Addict : latest news, tests and reviews about Folding@Home project.

User avatar
Site Moderator
Posts: 8372
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France

Re: and - Empty work server

Postby Gary480six » Sun Nov 26, 2017 3:21 pm

The 32-bit version of Windows 7 was a free copy somebody gave me. Who knew that seven years later - that would bite me in the butt? :lol:

Thanks again to everyone for all the Really useful information about this issue.
Posts: 67
Joined: Mon Jan 21, 2008 6:42 pm

Re: and - Empty work server

Postby STFC9F22 » Mon Nov 27, 2017 8:59 pm

FYI: Whilst there might be an issue with 32-bit systems it is presumably not the root cause as my system was running Windows 10 Home 64-bit with 16GB RAM when I raised the issue.
Posts: 16
Joined: Fri Jul 06, 2012 7:14 pm

Re: and - Empty work server

Postby bruce » Tue Nov 28, 2017 7:49 pm

Understood. I am aware of three problems which bothered us over the holiday. All are being worked on (or may have been solved) but I doubt that all repairs have been successfully completed.
> 32-bit Windows is having trouble with A7 WUs.
> The points server was not publishing up-tp-date stats.
> Temple University has had of-again/on-again problems with their servers.

{As always, there might be brief periods where no assignments can be found for your particular configuration but those issues generally resolve themselves after a few retries to download new WUs. The common exception to that is if you're running the V7.4.4 with a configuration that specifies a prime number of CPUs (such as 7) which you must reconfigure.]

If your problem is NOT one of these, please make a complete report of your problem in a new topic.
Posts: 21107
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: and - Empty work server

Postby suprleg » Thu Nov 30, 2017 8:20 pm

I think you've hit the nail squarely on the head, this issue seems to me to be more an OS related issue than anything else. So I guess my question would be will this win32bit problem be addressed or are we stuck, shy of upgrading the systems to 64bit? Seems like the tail wagging the dog in so much as my GPU folds at 1-2 minutes a frame with 0x21 wu's....changing a simple parameter or filter to a layman doesn't seem overly difficult...
User avatar
Posts: 39
Joined: Thu Apr 26, 2012 8:30 pm

Re: and - Empty work server

Postby bruce » Thu Nov 30, 2017 9:19 pm

AVX2 is NOT supported on WInXP/VIsta. Support was added to Win7 with SP1 -- and, if that support is like most MS new features, it may have required additional patches after SP1.

It's not really clear whether the degree of support is related to a 32-bit/64-bit bifurcation.
Posts: 21107
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: and - Empty work server

Postby STFC9F22 » Wed Feb 14, 2018 4:16 pm

bruce wrote:I have seen rare instances where port 80 didn't work, but port 8080 always works unless the AS is off-line entirely -- though sometimes they' have been blocked by the local networking security settings.

Having been crunching GPUGrid tasks for a while it seems that they currently have far more GPU resource available than work, so I have tried again to get Folding@Home working.

Firstly I tried the client as it was and got the same “Empty work server assignment” messages from port 80. Next I tried uninstalling the 7.4.4 client (without removing data) and reinstalling – again I had exactly the same issue. Finally I tried uninstalling the client and its data and carried out a clean installation (of 7.4.4) – this time I picked up a CPU and a GPU workunit immediately although I notice from the log (below) that assignment server connection was via port 8080.

Code: Select all
*********************** Log Started 2018-02-14T11:03:05Z ***********************
11:03:05:************************* Folding@home Client *************************
11:03:05:      Website: http://folding.stanford.edu/
11:03:05:    Copyright: (c) 2009-2014 Stanford University
11:03:05:       Author: Joseph Coffland <joseph@cauldrondevelopment.com>
11:03:05:         Args: --open-web-control
11:03:05:       Config: <none>
11:03:05:******************************** Build ********************************
11:03:05:      Version: 7.4.4
11:03:05:         Date: Mar 4 2014
11:03:05:         Time: 20:26:54
11:03:05:      SVN Rev: 4130
11:03:05:       Branch: fah/trunk/client
11:03:05:     Compiler: Intel(R) C++ MSVC 1500 mode 1200
11:03:05:      Options: /TP /nologo /EHa /Qdiag-disable:4297,4103,1786,279 /Ox -arch:SSE
11:03:05:               /QaxSSE2,SSE3,SSSE3,SSE4.1,SSE4.2 /Qopenmp /Qrestrict /MT /Qmkl
11:03:05:     Platform: win32 XP
11:03:05:         Bits: 32
11:03:05:         Mode: Release
11:03:05:******************************* System ********************************
11:03:05:          CPU: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
11:03:05:       CPU ID: GenuineIntel Family 6 Model 60 Stepping 3
11:03:05:         CPUs: 8
11:03:05:       Memory: 15.86GiB
11:03:05:  Free Memory: 12.94GiB
11:03:05:      Threads: WINDOWS_THREADS
11:03:05:   OS Version: 6.2
11:03:05:  Has Battery: false
11:03:05:   On Battery: false
11:03:05:   UTC Offset: 0
11:03:05:          PID: 14184
11:03:05:          CWD: C:/Users/Malcolm/AppData/Roaming/FAHClient
11:03:05:           OS: Windows 10 Home
11:03:05:      OS Arch: AMD64
11:03:05:         GPUs: 1
11:03:05:        GPU 0: UNSUPPORTED: NV3 [PCI]
11:03:05:         CUDA: 6.1
11:03:05:  CUDA Driver: 9010
11:03:05:Win32 Service: false
11:03:05:  <!-- Folding Slots -->
11:03:05:Connecting to assign-GPU.stanford.edu:80
11:03:06:Updated GPUs.txt
11:03:06:Read GPUs.txt
11:03:06:Trying to access database...
11:03:06:Successfully acquired database lock
11:03:06:Enabled folding slot 00: PAUSED cpu:6 (not configured)
11:03:06:Enabled folding slot 01: PAUSED gpu:0:GP104 [GeForce GTX 1070] 6463 (not configured)
11:03:10:13: Web connection
11:04:07:Saving configuration to config.xml
11:04:07:  <!-- Folding Slots -->
11:04:07:  <slot id='0' type='CPU'/>
11:04:07:  <slot id='1' type='GPU'/>
11:04:07:Set client configured
11:04:07:WU00:FS00:Connecting to
11:04:07:WU01:FS01:Connecting to
11:04:08:WU00:FS00:Connecting to
11:04:08:WU01:FS01:Connecting to
11:04:08:WU00:FS00:Assigned to work server
11:04:08:WU00:FS00:Requesting new work unit for slot 00: READY cpu:6 from
11:04:08:WU00:FS00:Connecting to
11:04:09:WU01:FS01:Assigned to work server
11:04:09:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GP104 [GeForce GTX 1070] 6463 from
11:04:09:WU01:FS01:Connecting to
11:04:09:ERROR:WU00:FS00:Exception: Server did not assign work unit
11:04:09:WU00:FS00:Connecting to
11:04:10:WU00:FS00:Assigned to work server
11:04:10:WU00:FS00:Requesting new work unit for slot 00: READY cpu:6 from
11:04:10:WU00:FS00:Connecting to
11:04:10:WU01:FS01:Downloading 8.88MiB
11:04:11:WU00:FS00:Downloading 807.01KiB
11:04:14:WU00:FS00:Download complete
11:04:15:WU00:FS00:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:9035 run:273 clone:2 gen:1602 core:0xa4 unit:0x000006c6ab436c9e56982e9cfd067032
11:04:15:WU00:FS00:Downloading core from http://fahwebx.stanford.edu/cores/Win32/AMD64/Core_a4.fah
11:04:15:WU00:FS00:Connecting to fahwebx.stanford.edu:80
11:04:15:WU00:FS00:FahCore a4: Downloading 2.89MiB
11:04:16:WU01:FS01:Download 39.41%
11:04:21:WU00:FS00:FahCore a4: 86.57%
11:04:21:WU00:FS00:FahCore a4: Download complete
11:04:21:WU00:FS00:Valid core signature
11:04:22:WU00:FS00:Unpacked 9.59MiB to cores/fahwebx.stanford.edu/cores/Win32/AMD64/Core_a4.fah/FahCore_a4.exe
11:04:22:WU00:FS00:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:/Users/Malcolm/AppData/Roaming/FAHClient/cores/fahwebx.stanford.edu/cores/Win32/AMD64/Core_a4.fah/FahCore_a4.exe -dir 00 -suffix 01 -version 704 -lifeline 14184 -checkpoint 15 -np 6
11:04:22:WU01:FS01:Download 68.98%
11:04:22:WU00:FS00:Started FahCore on PID 7940
11:04:22:WU00:FS00:Core PID:6912
11:04:22:WU00:FS00:FahCore 0xa4 started
11:04:22:WU00:FS00:0xa4:Folding@Home Gromacs GB Core
11:04:22:WU00:FS00:0xa4:Version 2.27 (Dec. 15, 2010)
11:04:22:WU00:FS00:0xa4:Preparing to commence simulation
11:04:22:WU00:FS00:0xa4:- Looking at optimizations...
11:04:23:WU00:FS00:0xa4:- Created dyn
11:04:23:WU00:FS00:0xa4:- Files status OK
11:04:23:WU00:FS00:0xa4:- Expanded 825868 -> 1402156 (decompressed 169.7 percent)
11:04:23:WU00:FS00:0xa4:Called DecompressByteArray: compressed_data_size=825868 data_size=1402156, decompressed_data_size=1402156 diff=0
11:04:23:WU00:FS00:0xa4:- Digital signature verified
11:04:23:WU00:FS00:0xa4:Project: 9035 (Run 273, Clone 2, Gen 1602)
11:04:23:WU00:FS00:0xa4:Assembly optimizations on if available.
11:04:23:WU00:FS00:0xa4:Entering M.D.
11:04:28:WU01:FS01:Download 91.50%
11:04:28:WU00:FS00:0xa4:Mapping NT from 6 to 6
11:04:28:WU00:FS00:0xa4:Completed 0 out of 250000 steps  (0%)
11:04:29:WU01:FS01:Download complete
11:04:29:WU01:FS01:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:9431 run:1429 clone:1 gen:688 core:0x21 unit:0x00000336ab436c9d586fdd3f0a59f582
11:04:29:WU01:FS01:Downloading core from http://fahwebx.stanford.edu/cores/Win32/AMD64/NVIDIA/Fermi/Core_21.fah
11:04:29:WU01:FS01:Connecting to fahwebx.stanford.edu:80
11:04:29:WU01:FS01:FahCore 21: Downloading 3.47MiB
11:04:34:WU01:FS01:FahCore 21: Download complete
11:04:34:WU01:FS01:Valid core signature
11:04:34:WU01:FS01:Unpacked 11.80MiB to cores/fahwebx.stanford.edu/cores/Win32/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21.exe
11:04:34:WU01:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:/Users/Malcolm/AppData/Roaming/FAHClient/cores/fahwebx.stanford.edu/cores/Win32/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21.exe -dir 01 -suffix 01 -version 704 -lifeline 14184 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
11:04:34:WU01:FS01:Started FahCore on PID 6080
11:04:34:WU01:FS01:Core PID:1404
11:04:34:WU01:FS01:FahCore 0x21 started
11:04:35:WU01:FS01:0x21:*********************** Log Started 2018-02-14T11:04:35Z ***********************
11:04:35:WU01:FS01:0x21:Project: 9431 (Run 1429, Clone 1, Gen 688)
11:04:35:WU01:FS01:0x21:Unit: 0x00000336ab436c9d586fdd3f0a59f582
11:04:35:WU01:FS01:0x21:CPU: 0x00000000000000000000000000000000
11:04:35:WU01:FS01:0x21:Machine: 1
11:04:35:WU01:FS01:0x21:Reading tar file core.xml
11:04:35:WU01:FS01:0x21:Reading tar file integrator.xml
11:04:35:WU01:FS01:0x21:Reading tar file state.xml
11:04:35:WU01:FS01:0x21:Reading tar file system.xml
11:04:35:WU01:FS01:0x21:Digital signatures verified
11:04:35:WU01:FS01:0x21:Folding@home GPU Core21 Folding@home Core
11:04:35:WU01:FS01:0x21:Version 0.0.18
11:04:42:WU01:FS01:0x21:Completed 0 out of 6250000 steps (0%)
11:04:42:WU01:FS01:0x21:Temperature control disabled. Requirements: single Nvidia GPU, tmax must be < 110 and twait >= 900

I have since set the FAHControl preferences and configuration back to the values I had when it was failing to collect assignments (to process GPU work units only) and have so far downloaded two GPU work units although in both cases the log shows that the assignment sever connection was via port 80 (log extract from the first of these below).

Code: Select all
13:53:33:Saving configuration to config.xml
13:53:33:  <!-- Folding Core -->
13:53:33:  <checkpoint v='30'/>
13:53:33:  <!-- Network -->
13:53:33:  <proxy v=':8080'/>
13:53:33:  <!-- User Information -->
13:53:33:  <passkey v='********************************'/>
13:53:33:  <user v='STFC9F22'/>
13:53:33:  <!-- Folding Slots -->
13:53:33:  <slot id='1' type='GPU'>
13:53:33:    <next-unit-percentage v='100'/>
13:53:33:    <pause-on-start v='true'/>
13:53:33:  </slot>
13:54:31:Saving configuration to config.xml
13:54:31:  <!-- Folding Core -->
13:54:31:  <checkpoint v='30'/>
13:54:31:  <!-- Network -->
13:54:31:  <proxy v=':8080'/>
13:54:31:  <!-- User Information -->
13:54:31:  <passkey v='********************************'/>
13:54:31:  <user v='STFC9F22'/>
13:54:31:  <!-- Folding Slots -->
13:54:31:  <slot id='1' type='GPU'>
13:54:31:    <next-unit-percentage v='100'/>
13:54:31:    <pause-on-start v='true'/>
13:54:31:  </slot>
14:05:55:WU00:FS01:Connecting to
14:05:56:WU00:FS01:Assigned to work server
14:05:56:WU00:FS01:Requesting new work unit for slot 01: READY gpu:0:GP104 [GeForce GTX 1070] 6463 from
14:05:56:WU00:FS01:Connecting to
14:05:57:WU00:FS01:Downloading 8.89MiB
14:06:03:WU00:FS01:Download 52.75%
14:06:07:WU00:FS01:Download complete
14:06:07:WU00:FS01:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:9431 run:1169 clone:1 gen:395 core:0x21 unit:0x000001deab436c9d586fdd3d6df61317
14:06:07:WU00:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:/Users/Malcolm/AppData/Roaming/FAHClient/cores/fahwebx.stanford.edu/cores/Win32/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21.exe -dir 00 -suffix 01 -version 704 -lifeline 8536 -checkpoint 30 -gpu 0 -gpu-vendor nvidia
14:06:07:WU00:FS01:Started FahCore on PID 6696
14:06:08:WU00:FS01:Core PID:10548
14:06:08:WU00:FS01:FahCore 0x21 started
14:06:09:WU00:FS01:0x21:*********************** Log Started 2018-02-14T14:06:08Z ***********************
14:06:09:WU00:FS01:0x21:Project: 9431 (Run 1169, Clone 1, Gen 395)
14:06:09:WU00:FS01:0x21:Unit: 0x000001deab436c9d586fdd3d6df61317
14:06:09:WU00:FS01:0x21:CPU: 0x00000000000000000000000000000000
14:06:09:WU00:FS01:0x21:Machine: 1
14:06:09:WU00:FS01:0x21:Reading tar file core.xml
14:06:09:WU00:FS01:0x21:Reading tar file integrator.xml
14:06:09:WU00:FS01:0x21:Reading tar file state.xml
14:06:09:WU00:FS01:0x21:Reading tar file system.xml
14:06:09:WU00:FS01:0x21:Digital signatures verified
14:06:09:WU00:FS01:0x21:Folding@home GPU Core21 Folding@home Core
14:06:09:WU00:FS01:0x21:Version 0.0.18
14:06:12:WU00:FS01:0x21:Completed 0 out of 6250000 steps (0%)
14:06:12:WU00:FS01:0x21:Temperature control disabled. Requirements: single Nvidia GPU, tmax must be < 110 and twait >= 900

Anyway, regardless of whether the root cause in some way relates to port 80, it seem for me (running Win 10 Home 64-bit) a clean install of the 7.4.4 client has resolved the problem.
Posts: 16
Joined: Fri Jul 06, 2012 7:14 pm


Return to Issues with a specific server

Who is online

Users browsing this forum: No registered users and 2 guests