stats not updating

Moderators: Site Moderators, FAHC Science Team

Re: stats not updating

Postby EOC_Jason » Sun Feb 16, 2020 4:56 am

Yep, I noticed that too... I'm guessing the guys are doing some DB work... If it's still not updating by morning I'll shoot them an email to see if I can get an ETA....
EOC_Jason
 
Posts: 10
Joined: Wed Feb 10, 2010 4:15 pm
Location: USA

Statistics show Bad gateway

Postby der_eismann » Tue Mar 03, 2020 5:15 pm

Hey everyone,
after reading the call for help regarding corona I joined the project, but it seems that not every part of the web presence is as fresh as the blog. The donor and team statistics are all showing a bad gateway.

This also breaks the web interface, as the following links are returning bad gateways as well:
https://apps.foldingathome.org/project- ... sion=7.5.1
https://apps.foldingathome.org/stats.py ... 3251805880

Will this be fixed anytime soon?
der_eismann
 
Posts: 2
Joined: Tue Mar 03, 2020 5:00 pm

Re: Statistics show Bad gateway

Postby Joe_H » Tue Mar 03, 2020 5:27 pm

Welcome to the folding support forum.

I have second hand information that some work was going to be done on the stats database, but do not have exact times this was to occur. If this does not clear up later, please post details. You might also need to clear browser cache.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 6540
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: Statistics show Bad gateway

Postby der_eismann » Tue Mar 03, 2020 5:29 pm

Thanks for the welcome!

What kind of details do you need? You can execute
Code: Select all
curl 'https://stats.foldingathome.org/api/donors'
, it always returns a 502.
der_eismann
 
Posts: 2
Joined: Tue Mar 03, 2020 5:00 pm

Re: Statistics show Bad gateway

Postby tulanebarandgrill » Tue Mar 03, 2020 9:31 pm

It's definitely not his browser cache. I see this issue from multiple clients in geographically diverse locations.

The error is either "bad gateway" or "gateway timeout" every time accessing stats.foldingathome.org.

PT
- TulaneBaG
tulanebarandgrill
 
Posts: 29
Joined: Thu Nov 16, 2017 3:57 pm

Re: stats not updating

Postby snapshot » Wed Mar 04, 2020 12:09 am

Yup, still giving 'Bad Gateway'.
User avatar
snapshot
 
Posts: 132
Joined: Thu Apr 09, 2009 8:25 pm
Location: Wiltshire, UK

Re: stats not updating

Postby jstressman » Wed Mar 04, 2020 2:55 am

Nothing dynamic is working on the stats website outside of the static portions of the pages. "Bad Gateway" errors everywhere.

The /api/donors page, for example, gives

> 502 Bad Gateway
> nginx/1.14.2
jstressman
 
Posts: 2
Joined: Mon Feb 10, 2020 4:10 am

Re: stats not updating

Postby drougnor » Wed Mar 04, 2020 7:24 am

Usually, when something like this happens, it's the flat files that get hit, but this time, it's ONLY the Teams flat file that is suffering. The User's flat file is updating normally, but the Teams file hasn't been properly updated since the 3am update on Feb 3rd.
drougnor
 
Posts: 139
Joined: Tue Dec 29, 2009 3:21 am

Re: stats not updating

Postby hamba » Wed Mar 04, 2020 3:50 pm

Still bad gateway for me too , started folding because of the coronavirus initiative.

I suppose the WU's still get submitted as they are different servers ? Just the database is not working to collect all points together and show in a list?
hamba
 
Posts: 7
Joined: Wed Mar 04, 2020 3:49 pm

Re: stats not updating

Postby Joe_H » Wed Mar 04, 2020 4:51 pm

The problems are with the server that acts as a frontend for the database. So WU's are still being entered into the database, just some of the reports that get pulled from the database are not working at this time.
Joe_H
Site Admin
 
Posts: 6540
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: stats not updating

Postby hamba » Wed Mar 04, 2020 4:54 pm

Joe_H wrote:The problems are with the server that acts as a frontend for the database. So WU's are still being entered into the database, just some of the reports that get pulled from the database are not working at this time.


Ah good, thought so , seeing all the different servers for collection and work.

So I can leave it running without worrying too much.
hamba
 
Posts: 7
Joined: Wed Mar 04, 2020 3:49 pm

Re: stats not updating

Postby bruce » Thu Mar 05, 2020 2:55 am

hamba wrote:So I can leave it running without worrying too much.


Yes. It will catch up in time and there's nothing you can do anyway to either help or hurt that situation.
bruce
 
Posts: 19844
Joined: Thu Nov 29, 2007 11:13 pm
Location: So. Cal.

Re: stats not updating

Postby jstressman » Thu Mar 05, 2020 3:36 am

Seems to be working again. :)
jstressman
 
Posts: 2
Joined: Mon Feb 10, 2020 4:10 am

Re: stats not updating

Postby MacGyver » Fri Mar 13, 2020 6:05 pm

Joe_H wrote:The problems are with the server that acts as a frontend for the database. So WU's are still being entered into the database, just some of the reports that get pulled from the database are not working at this time.


I noticed a problem under https://foldingforum.org/viewtopic.php?f=61&t=32283. Is there any chance the performance report is also compiled from the affected parts of that server? :|
MacGyver
 
Posts: 17
Joined: Sat Jan 04, 2020 11:50 am

Re: stats not updating

Postby Ken_g6 » Wed Mar 18, 2020 3:49 am

502 Bad Gateway is back. :(
Ken_g6
 
Posts: 17
Joined: Sat Dec 26, 2009 10:23 pm

PreviousNext

Return to Issues with a specific server

Who is online

Users browsing this forum: No registered users and 1 guest

cron