Failed WU's

Moderators: Site Moderators, PandeGroup

Failed WU's

Postby [Ars] For Caitlin » Tue Nov 14, 2017 6:11 pm

I just returned to Folding, so I'm not sure if we are supposed to report these here or not.

05:33:49:WU00:FS00:FahCore 0xa7 started
05:33:50:WARNING:WU00:FS00:FahCore returned: FAILED_2 (1 = 0x1)
05:33:50:WARNING:WU00:FS00:Too many errors, failing
05:33:50:WU00:FS00:Sending unit results: id:00 state:SEND error:FAILED project:8200 run:5 clone:48 gen:74 core:0xa7 unit:0x00000059868b340258ed3e6674b921d0

12:08:26:WU00:FS00:FahCore 0xa7 started
12:08:27:WARNING:WU00:FS00:FahCore returned: FAILED_2 (1 = 0x1)
12:08:27:WARNING:WU00:FS00:Too many errors, failing
12:08:27:WU00:FS00:Sending unit results: id:00 state:SEND error:FAILED project:13703 run:6 clone:31 gen:9 core:0xa7 unit:0x000000150002894b59bff5d0743720c4

12:11:30:WU01:FS00:FahCore 0xa7 started
12:11:31:WARNING:WU01:FS00:FahCore returned: FAILED_2 (1 = 0x1)
12:11:31:WARNING:WU01:FS00:Too many errors, failing
12:11:31:WU01:FS00:Sending unit results: id:01 state:SEND error:FAILED project:13705 run:1 clone:35 gen:17 core:0xa7 unit:0x000000200002894b59bff58df041aeb0
[Ars] For Caitlin
 
Posts: 46
Joined: Sun Jan 06, 2008 11:06 pm

Re: Failed WU's

Postby [Ars] For Caitlin » Tue Nov 14, 2017 6:29 pm

Just realized this is a core issue, not a WU issue. I'll troubleshoot my glibc.
[Ars] For Caitlin
 
Posts: 46
Joined: Sun Jan 06, 2008 11:06 pm

Re: Failed WU's

Postby Joe_H » Tue Nov 14, 2017 6:35 pm

The first and third WU's have been successfully completed by others, so aren't bad WU's. The second WU only has the one failure entry in the database so far.

Could you supply more information about your system? What is needed is mostly show in the beginning of the log file with the system info and configuration settings. It is possible you are running at a thread count that may need to be excluded and was not determined to be a problem during initial and beta testing of the projects.

Edit: Since I posted the second WU has also been returned after being successfully processed.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 3896
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: Failed WU's

Postby [Ars] For Caitlin » Tue Nov 14, 2017 7:13 pm

From what I am gleaning from the forum, core a_7 doesn't work on my version of linux (RHEL 6.9)

*********************** Log Started 2017-11-11T19:52:30Z ***********************
19:52:30:************************* Folding@home Client *************************
19:52:30: Copyright: (c) 2009-2014 Stanford University
19:52:30: Author: Joseph Coffland <joseph@cauldrondevelopment.com>
19:52:30: Args: --child --lifeline 25024 /etc/fahclient/config.xml --run-as
19:52:30: fahclient --pid-file=/var/run/fahclient.pid --daemon
19:52:30: Config: /etc/fahclient/config.xml
19:52:30:******************************** Build ********************************
19:52:30: Version: 7.4.4
19:52:30: Date: Mar 4 2014
19:52:30: Time: 12:01:17
19:52:30: SVN Rev: 4130
19:52:30: Branch: fah/trunk/client
19:52:30: Compiler: GNU 4.1.2 20080704 (Red Hat 4.1.2-46)
19:52:30: Options: -std=gnu++98 -O3 -funroll-loops -mfpmath=sse -ffast-math
19:52:30: -fno-unsafe-math-optimizations -msse2
19:52:30: Platform: linux2 2.6.18-164.11.1.el5
19:52:30: Bits: 64
19:52:30: Mode: Release
19:52:30:******************************* System ********************************
19:52:30: CPU: Intel(R) Core(TM) i5-2540M CPU @ 2.60GHz
19:52:30: CPU ID: GenuineIntel Family 6 Model 42 Stepping 7
19:52:30: CPUs: 4
19:52:30: Memory: 7.70GiB
19:52:30:Free Memory: 2.87GiB
19:52:30: Threads: POSIX_THREADS
19:52:30: OS Version: 2.6
19:52:30:Has Battery: true
19:52:30: On Battery: false
19:52:30: UTC Offset: -5
19:52:30: PID: 25026
19:52:30: CWD: /var/lib/fahclient
19:52:30: OS: Linux 2.6.32-696.10.2.el6.x86_64 x86_64
19:52:30: OS Arch: AMD64
19:52:30: GPUs: 1
19:52:30: GPU 0: NVIDIA:2 GF108 [Quadro NVS 4200M]
19:52:30: CUDA: Not detected
19:52:30:***********************************************************************

[user@oc1715481268 Core_a7.fah]$ ./FahCore_a7
./FahCore_a7: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./FahCore_a7)
./FahCore_a7: /lib64/libc.so.6: version `GLIBC_2.17' not found (required by ./FahCore_a7)
./FahCore_a7: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./FahCore_a7)
[user@oc1715481268 Core_a7.fah]$ rpm -qa | grep glibc
glibc-devel-2.12-1.209.el6_9.2.x86_64
glibc-common-2.12-1.209.el6_9.2.x86_64
compat-glibc-headers-2.5-46.2.x86_64
glibc-headers-2.12-1.209.el6_9.2.x86_64
glibc-2.12-1.209.el6_9.2.i686
glibc-2.12-1.209.el6_9.2.x86_64
compat-glibc-2.5-46.2.x86_64
[Ars] For Caitlin
 
Posts: 46
Joined: Sun Jan 06, 2008 11:06 pm

Re: Failed WU's

Postby Joe_H » Wed Nov 15, 2017 7:02 pm

I asked the developer what the dependencies are for the current A7 core. To support older versions of linux the core has minimum requirements of glib version 2.17 and glibc++ version 3.4.15. Which versions of those are installed on your system running RHEL 6.9?
Joe_H
Site Admin
 
Posts: 3896
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: Failed WU's

Postby [Ars] For Caitlin » Thu Nov 16, 2017 6:26 pm

I'm currently at 2.12. I plan on migrating to RHEL 7 soon, but in the meantime I have firewalled off the a7 work unit servers, so I won't be getting any more a7 work units on this box.
[Ars] For Caitlin
 
Posts: 46
Joined: Sun Jan 06, 2008 11:06 pm

Re: Failed WU's

Postby Joe_H » Thu Nov 16, 2017 7:16 pm

You can also update just the glibc package on version 6, I have seen descriptions on how to do so. But not having a server, I have not done one of these updates.
Joe_H
Site Admin
 
Posts: 3896
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA


Return to Issues with a specific WU

Who is online

Users browsing this forum: No registered users and 2 guests

cron