see A3 Bug - Oddity with Ubuntu 10.04 SMP / CPU core usage

Moderators: Site Moderators, PandeGroup

see A3 Bug - Oddity with Ubuntu 10.04 SMP / CPU core usage

Postby noorman » Wed Jun 23, 2010 12:24 pm

.

I 've managed to install the SMP Client on my new Ubuntu 10.04 Desktop install.

I installed and configured the nscd as proposed and it works.

Had a problem with the Client config, but I think that is related to me using -verbosity 9 in the config command line ...
Figured that out by following the install guide to the letter and succeeding.

Now when the Client was able to download, unpack and succesfully verify the a3 Core, it got also a P6012 to work on, and I look for and find a System Monitor.
But when I opened that and its Resources Tab, I find not all 8 threads being used at 100% !
Only 6 threads are indicating 100%, 2 others are varying between 0 and 20% ... :e?: :shock:

Has anyone an explanation for this behavior ?

In the FaH window also did appear a message (not long after the start of effective Folding)

NOTE: Turning on dynamic load balancing


Is this normal ?
Why then would it show a problem with this load balancing ?
Do I need to alter the Config and allow the affinity lock (Default setting as I understand it) ??


.
Last edited by noorman on Wed Jun 23, 2010 9:54 pm, edited 1 time in total.
- stopped Linux SMP w. HT on i7-860@3.5 GHz
....................................
Folded since 10-06-04 till 09-2010
User avatar
noorman
 
Posts: 548
Joined: Sun Dec 02, 2007 2:26 pm
Location: Belgium, near the International Sea-Port of Antwerp

Re: Oddity with Ubuntu 10.04 SMP Folding CPU core usage

Postby noorman » Wed Jun 23, 2010 2:55 pm

.

Tried it myself; altering the Affinity setting didn't do anything for the Thread usage; it was still 6x at 100% and twice at between 0 and 20% ???

For a P6012 that gave a very bad TPF figure; about 10 mins, while I did about 4 mins per frame in Win-SMP !

What 's wrong here ?

.
User avatar
noorman
 
Posts: 548
Joined: Sun Dec 02, 2007 2:26 pm
Location: Belgium, near the International Sea-Port of Antwerp

Re: Oddity with Ubuntu 10.04 SMP Folding CPU core usage

Postby toTOW » Wed Jun 23, 2010 9:26 pm

It is related to this, isn't it : viewtopic.php?f=44&t=13324 ?
Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.

FAH-Addict : latest news, tests and reviews about Folding@Home project.

Image
User avatar
toTOW
Site Moderator
 
Posts: 8514
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France

Re: Oddity with Ubuntu 10.04 SMP Folding CPU core usage

Postby noorman » Wed Jun 23, 2010 9:32 pm

toTOW wrote:It is related to this, isn't it : viewtopic.php?f=44&t=13324 ?
.

It indeed seems that way; I will report in that thread / missed that one :oops:

thanks

.
User avatar
noorman
 
Posts: 548
Joined: Sun Dec 02, 2007 2:26 pm
Location: Belgium, near the International Sea-Port of Antwerp

Re: see A3 Bug - Oddity with Ubuntu 10.04 SMP / CPU core usage

Postby 7im » Wed Jun 23, 2010 11:25 pm

What version of the a3 fahcore do you have? If not v2.22, it should be. And should help.
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.
User avatar
7im
 
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Location: Arizona

Re: see A3 Bug - Oddity with Ubuntu 10.04 SMP / CPU core usage

Postby noorman » Wed Jun 23, 2010 11:28 pm

7im wrote:What version of the a3 fahcore do you have? If not v2.22, it should be. And should help.
.


Can't check that right now (dual boot setup), but since it downloaded that Core today, it must have been the new 2.22 version (I guess)


.
User avatar
noorman
 
Posts: 548
Joined: Sun Dec 02, 2007 2:26 pm
Location: Belgium, near the International Sea-Port of Antwerp


Return to Linux CPU V6 Client

Who is online

Users browsing this forum: No registered users and 1 guest

cron