Old linux version - won't run

Post here if you have issues with the Linux 5.0x client.

Moderators: Site Moderators, PandeGroup

Old linux version - won't run

Postby bohemian » Thu Mar 20, 2008 1:32 am

I have several older Linux boxes I could run folding on, but it won't work.

I have tried FAH504-Linux.exe, but when I run it this happens:
Loaded queue successfully.
+ Benchmarking ...

+ Processing work unit
Core required: FahCore_81.exe
Core found.
Working on Unit 01
+ Working ...


Then it immediately quits. After doing this, in the process list there is a process with the CMD name FAH504-Linux.exe and a child with the same name, but they don't actually do anything - ie CPU usage is zero. I've even let it run for a few days, but no work is being written.

Here is some info about my Linux version:
uname -a: Linux mybox 2.2.17-14 #7 SMP Tue Apr 15 12:55:29 EST 2003 i686 unknown
dmesg | head -1: IBM Model: SERVERAID Rev: 1.0
cat /proc/version: Linux version 2.2.17-14 (me@mybox) (gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #7 SMP Tue Apr 15 12:55:29 EST 2003

Does anyone know what I can do to get it working?

btw, upgrading or modifying my Linux installs is not an option.
bohemian
 
Posts: 1
Joined: Thu Mar 20, 2008 1:19 am

Re: Old linux version - won't run

Postby smoking2000 » Thu Mar 20, 2008 6:52 am

Holy crap, Linux kernel 2.2 is really old! What do they run, Debian Potato or something?

Most likely the libc installed on your systems is too old too whereby the FAH client cannot reliably work because it was compiled against a more modern release.

Missing gcc v2, or more recent, libraries may be a problem too.

Since upgrading the boxes is not an option, I don't think you have any other choice than to not fold on those boxes.
User avatar
smoking2000
 
Posts: 571
Joined: Mon Dec 03, 2007 6:20 am
Location: Amsterdam

Re: Old linux version - won't run

Postby v00d00 » Thu Mar 20, 2008 7:04 pm

Try Seti or one of the other DC projects available.
Image
User avatar
v00d00
 
Posts: 421
Joined: Sun Dec 02, 2007 4:53 am
Location: In the UK

Re: Old linux version - won't run

Postby Beberg » Thu Mar 20, 2008 9:54 pm

Those are some VERY old boxes, so their likely performance will be very low.

They also look like your work's file servers based on the model, so running F@h on them is probably not the best of ideas, as they may not tolerate the load all that well.
User avatar
Beberg
Pande Group Member
 
Posts: 566
Joined: Sat Dec 01, 2007 9:05 pm
Location: Stanford


Return to Linux Uniprocessor Client v5.0x

Who is online

Users browsing this forum: No registered users and 1 guest

cron