I need to connect wireless before I can fold!

Post here if you have issues with the Linux 5.0x client.

Moderators: Site Moderators, PandeGroup

I need to connect wireless before I can fold!

Postby jheil » Wed Jan 23, 2008 4:52 am

I have no way to connect this thing on a wired connection. I installed ndiswrapper 1.51 from the sourceforge website. I installed the broadcom bcmwl5 driver for my broadbom bcm4303 chipset on my linksys wmp11.

I am logged on as root in Ubuntu 7.10)

I am getting the message in the terminal after entering "ndiswrapper -l" saying "bcmwl5: driver installed (correct PCI ID) device present (alternate driver: bcm43xx)

When I go to enter the command: "modpost ndiswrapper" nothing happens. wlan0 is not present in iwconfig. Before with the ubuntu pakage I would get an error when I entered modpost ndiswrapper (according to the ubuntu wiki that is a bug they need to work out).

So, I am no longer getting the error but I am not getting wlan0 to initialize. Do I need to change to a specific directory and enter modpost ndiswrapper?

I know this isn't directly related, but the only real thing I plan on doing with this machine is backing up files and folding, and you can't fold w/o an internet connection. Any help would be much appreciated.

Cheers,
John

I don't know if it matters, but its a prescott core at 3 ghz. Windows SP2 had some problems with it.
User avatar
jheil
 
Posts: 35
Joined: Fri Dec 28, 2007 1:36 am
Location: Kitchener - Waterloo Ontario

Re: I need to connect wireless before I can fold!

Postby jheil » Wed Jan 23, 2008 4:30 pm

I posted this here hoping I might get an easy answer, but I'm still working on it. I'm not the only one trying this, so the ubuntu forums have plenty of material on this. I'll keep this thread updated just incase any people who want to set up a linux folding machine have the same problem.

apparently you had to enter the commands (when logged in as user):

sudo modprobe ndiswrapper
and
sudo ndiswrapper -m

It says creating the alias wlan0.

However, when I type iwconfig I see eth1 has the info of my adapter associated with it, and that wlan0 is not present. I still have not yet been able to connect. the system/administrator/wireless setup menu does not have eth1 listed under devices.

Well, if I get this figured out actually installing FAH linux client shouldn't be a problem.
User avatar
jheil
 
Posts: 35
Joined: Fri Dec 28, 2007 1:36 am
Location: Kitchener - Waterloo Ontario

Re: I need to connect wireless before I can fold!

Postby jheil » Wed Jan 23, 2008 11:14 pm

I managed to get it working. So time to install FAH. Typing this from ubuntu.

I just had to manually enter my access point info in to the network manager and restart.

Apparently ubuntu 7.10 also has the drivers included, but the firmware has to be extracted from a windows driver using fwcutter. So for anyone with a broadcom 43xx chipset wireless device you can get it to work.

To any moderator out there. If you feel this is irrelevant feel free to delete the thread.

Cheers,
John
User avatar
jheil
 
Posts: 35
Joined: Fri Dec 28, 2007 1:36 am
Location: Kitchener - Waterloo Ontario


Return to Linux Uniprocessor Client v5.0x

Who is online

Users browsing this forum: No registered users and 2 guests

cron