NANs detected on GPU

Moderators: Site Moderators, PandeGroup

Re: NANs detected on GPU

Postby bruce » Tue Jun 28, 2011 2:41 am

NaN stands for Not a Number. It's the result of certain arithmetic operations which create meaningless values such as dividing by zero. From a practical standpoint, it means either the software is defective or the hardware is defective -- and there's a really high probability that your GPU is not functioning correctly.

I'd reduce the overclocking (if any) and make sure it's not overheating. I'd also run diagnostics on it to see if it needs to be returned to the vendor.

A certain percentage of WUs are unstable and can produce NaNs, too. They should be rare, however, so the first question to ask is whether you've seen several WUs like that or just one. Also, if you report the Project/Run/Clone/Gen numbers we can look up the WU to see if others are also having trouble with it or if someone else has finished it.
bruce
 
Posts: 21286
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: NANs detected on GPU

Postby Rayline TWB » Sat Jul 02, 2011 6:19 pm

Thanks Bruce for explaining the NANs..:-).
The Project/Run/Clone/Gen info can be found in my previous post (inside the spolier tag).
My rig is neither overclocked nor underclocked and not experiencing any overheating problems.

However, I let my rig stay off for 2 days (as I was in Milan doing some work), and when I got back I turned the computer on again after these 2 days of shutdown and it just folded like nothing had ever happened.
I don't know why, since turning it off and on earlier did nothing to correct the problem - and I tried that 2-3 times. But hey, I'm just happy it all works out just fine now. The magic of computers I guess.....
Only the good can tell good from bad
User avatar
Rayline TWB
 
Posts: 16
Joined: Mon Nov 08, 2010 10:19 pm
Location: Norway

Re: NANs detected on GPU

Postby bruce » Sun Jul 03, 2011 11:27 am

Both Project: 6800 (Run 19285, Clone 0, Gen 37) and Project: 6801 (Run 5216, Clone 0, Gen 52) were successfully completed by someone else.
bruce
 
Posts: 21286
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: NANs detected on GPU

Postby jamez20 » Sat Aug 27, 2011 4:44 pm

NaN actually means "Not A Number". It is used to indicate some form of error in calculations.
See http://en.wikipedia.org/wiki/NaN for additional information.

I'm experiencing the same problem on my computer, you'll find my specs at the bottom.
One strange thing I found out is that it folded fine while I was doing other stuff (I was using VirtualBox and VLC Media Player at the same time), actually COMPLETED a unit without error, and then started EUE-ing right from the start of the following units. I didn't reset the computer or anything, I just re-started F@H a couple minutes later, and it worked again!

I will have to run some more tests, but it seems that on my end it always crashes right after a unit has been completed, never in the middle of one.

Using Windows Vista Ultimate 64-bits with official NVIDIA driver 280.26.
CPU: AMD Phenom II X4 940
Memory: 8 GB DDR2-1066 G. Skill (4x2GB)
MB: ASUS M4N82 Deluxe
GPU: BFG GeForce GTX 285 OC
HD: 3x WD Caviar Black 640GB (RAID 0)
Sound: ASUS Xonar HDAV1.3
Optical: LG GGW-H20L
Power: Corsair TX750

Mod Edit: Removed Code Tags - PantherX
jamez20
 
Posts: 1
Joined: Sat Aug 27, 2011 4:11 pm

Previous

Return to General GPU client issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron