ATI 5970 Catalyst 9.12 forcegpu ati_r700

Moderators: mhouston, Site Moderators, PandeGroup

ATI 5970 Catalyst 9.12 forcegpu ati_r700

Postby pfv » Tue Dec 22, 2009 3:42 pm

Hi
Got a brand new AI 5970 2 weeks ago.
At that time I installed the 9.12 beta, used the dll trick (aticalcl and aticalrt from the ATI install dir -> amdcalcl amccalrt etc.), set the forcegpu ati_r700 parameter in my shortcut. and the client worked on one core.
I saw this weeked that AMD had released the new 9.12, so I installed it, went through te dll trick, and when the client started, got a major core error, shutdown...
So I removed the force gpu and got the "GPU not supported" message this time.
Then I reverted to the 9.16beta dll in the folding directories and it is working again.
There are a couple of interesting things:
I actually have a 4870 as well in the rig and got the same symptoms (I performed the same actions on both cards).
total I have 3 GPU clients running (-gpu 0, -gpu 1, -gpu 2 parameters for each respective startup parameter)
the other interesting thing is that before upgrading from 9.12beta to 9.12 (OS not the folding dll) the 3rd client wasn't able to use the 5970 's 2nd core. the ATI ccc was showing 0% utilisation (could have been a bug in ccc 9.12 beta not reporting GPU usage correctly, but I have no way to verify). Anyway, that configuration was allowing me to get an extra 1000ppd.
After installing catalyst 9.12 (and use the 9.12beta dlls in the folding folders), the 2nd GPU in the 5870 is now used and that gives me 2000+ppd instead of 1000.

Anyone got a similar situation?
Any idea of what's going on with the catalyst 9.12 drivers?

I also set FLUSH_Interval at 300,didn' see a change in perf. any objection with this value?
CAL_NO_FLUSH=1
CAL_PRE_FLUSH=1
BROOK_YIELD=1

I have 2 other clients running on the computer: smp and simple cpu, and the CPU usage is hovering around 92%
pfv
 
Posts: 84
Joined: Tue Jan 22, 2008 12:01 am

Re: ATI 5970 Catalyst 9.12 forcegpu ati_r700

Postby pfv » Tue Dec 22, 2009 3:43 pm

PS: I made few searches on this forum on catalyst 9.12 but I couldn't find a similar topic
pfv
 
Posts: 84
Joined: Tue Jan 22, 2008 12:01 am

Re: ATI 5970 Catalyst 9.12 forcegpu ati_r700

Postby Athlonite » Tue Dec 22, 2009 11:14 pm

yeah i got a 5770 and am having the same problem i get these errors
mdrun_gpu returned
[14:07:29] NANs detected on GPU

[19:19:48] mdrun_gpu returned
[19:19:48] Nonzero force sum on GPU

what the hell :eo looks like i'm going to have to give up on F@H untill GPU3 comes out :twisted:
Asus M23A32MVP-Deluxe AMD Phenom II x4 940BE @ 3.41GHz
2xCorsair Dominator twin2x2048 PC8500C5D DDR2-1066MHz 5-5-5-15 CL2
2x HIS ATI Radeon HD5770Fan 1GB @ 940/1275
SilverStone RV02B-W case & ST75F-P 750W full modular PSU
Windows7 X64
Athlonite
 
Posts: 89
Joined: Fri Dec 18, 2009 12:52 am
Location: Napier, NZ

Re: ATI 5970 Catalyst 9.12 forcegpu ati_r700

Postby pfv » Wed Dec 23, 2009 12:24 am

I was getting this error message when I was using the 9.12 dll
Code: Select all
[15:17:10] - Calling '.\FahCore_11.exe -dir work/ -suffix 02 -priority 96 -checkpoint 18 -verbose -lifeline 3652 -version 623'

[15:17:14] CoreStatus = FFFFFFF6 (-10)
[15:17:14] Client-core communications error: ERROR 0xfffffff6
[15:17:14] This is a sign of more serious problems, shutting down.
pfv
 
Posts: 84
Joined: Tue Jan 22, 2008 12:01 am

Re: ATI 5970 Catalyst 9.12 forcegpu ati_r700

Postby toTOW » Wed Dec 23, 2009 1:22 am

CoreStatus = FFFFFFF6 (-10) means that CAL can't initialize ... maybe a driver or DLLs issue ?
Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.

FAH-Addict : latest news, tests and reviews about Folding@Home project.

Image
User avatar
toTOW
Site Moderator
 
Posts: 8329
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France

Re: ATI 5970 Catalyst 9.12 forcegpu ati_r700

Postby Grandpa_01 » Wed Dec 23, 2009 2:04 am

Athlonite wrote:yeah i got a 5770 and am having the same problem i get these errors
mdrun_gpu returned
[14:07:29] NANs detected on GPU

[19:19:48] mdrun_gpu returned
[19:19:48] Nonzero force sum on GPU

what the hell :eo looks like i'm going to have to give up on F@H untill GPU3 comes out :twisted:

Try these settings.

BROOK_YIELD = 2
CAL_NO_FLUSH = 0
CAL_PRE_FLUSH = 1
FLUSH_INTERVAL = start at 128 and go up from there if it works.
Image
2 - SM H8QGi-F AMD 6xxx=112 cores @ 3.2 & 3.9Ghz
5 - SM X9QRI-f+ Intel 4650 = 320 cores @ 3.15Ghz
2 - I7 980X 4.4Ghz 2-GTX680
1 - 2700k 4.4Ghz GTX680
Total = 464 cores folding
User avatar
Grandpa_01
 
Posts: 1757
Joined: Wed Mar 04, 2009 7:36 am

Re: ATI 5970 Catalyst 9.12 forcegpu ati_r700

Postby pfv » Wed Dec 23, 2009 6:38 am

toTOW wrote:CoreStatus = FFFFFFF6 (-10) means that CAL can't initialize ... maybe a driver or DLLs issue ?


I figured that much, that's why I revered to the 9.12beta dlls.
I'm hoping to get some input from the AMD/ATI developer see what would have changed between the 9.12 beta and 9.12 GA Dlls. Bug? Change of architecture?
pfv
 
Posts: 84
Joined: Tue Jan 22, 2008 12:01 am

Re: ATI 5970 Catalyst 9.12 forcegpu ati_r700

Postby bruce » Mon Oct 17, 2011 8:33 pm

Have you tried it without overclocking and without the environment variables? Those settings might be pushing the GPU beyond the stable range.
bruce
 
Posts: 20828
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.


Return to ATI specific issues

Who is online

Users browsing this forum: No registered users and 4 guests

cron