HD 4xxx gpu's still getting wu's? {So far, yes}

Moderators: mhouston, Site Moderators, PandeGroup

HD 4xxx gpu's still getting wu's? {So far, yes}

Postby hootis » Fri Oct 28, 2011 2:10 pm

With the release of the new gpu clients, i was wondering if older clients with the core_11 are still receiving work units. I have been out of the scene a long time, and don't have access to a machine right now. Just wonder if the core 11 wu's still exist or for how much longer?
Things yet to materialize.
hootis
 
Posts: 152
Joined: Fri Nov 27, 2009 3:34 am

Re: HD 4xxx gpu's still getting wu's?

Postby Zagen30 » Fri Oct 28, 2011 4:40 pm

Yes, they are. Just the other day someone was wondering why they were only getting 511-point WUs.

I remember when core 16 was released Dr. Pande said that core 11 support would be kept until at least September. Obviously it's almost November, but I haven't seen any news about deprecation so far. Whenever they do announce the end of core 11 projects, there'll still be a few months before they're gone for good.
Image
Zagen30
 
Posts: 1589
Joined: Tue Mar 25, 2008 12:45 am

Re: HD 4xxx gpu's still getting wu's?

Postby amdfan404 » Thu Nov 10, 2011 2:11 am

Yes, I'm still getting them: viewtopic.php?f=51&t=17825&p=198766#p198766
Image
amdfan404
 
Posts: 22
Joined: Thu Mar 18, 2010 3:40 am

Re: HD 4xxx gpu's still getting wu's? {So far, yes}

Postby hamstrings » Fri Feb 24, 2012 6:10 am

Today I've noticed my FAH client was no longer getting WUs for my Radeon 4670. Is this a temporary lull in work, or has the 4xxx GPU client been discontinued?

Code: Select all
[05:13:03] + Attempting to get work packet
[05:13:03] - Will indicate memory of 4094 MB
[05:13:03] - Connecting to assignment server
[05:13:03] Connecting to http://assign-GPU.stanford.edu:8080/
[05:13:03] Posted data.
[05:13:03] Initial: 0000; + No appropriate work server was available; will try a
gain in a bit.
[05:13:03] + Couldn't get work instructions.
[05:13:03] - Attempt #19  to get work failed, and no other work to do.
Waiting before retry.
hamstrings
 
Posts: 6
Joined: Sun Nov 27, 2011 5:45 pm

Re: HD 4xxx gpu's still getting wu's? {So far, yes}

Postby GreyWhiskers » Fri Feb 24, 2012 8:24 am

Same here.
Server stats for 171.64.65.102, the one server that's been handling the Core 11 ATI WUs, shows it went from "FULL" to "ACCEPT" at 10AM PST today, 23 Feb. Still has some 13932 WU Available.

The ACCEPT means it's accepting results back from clients, but not handing out any new ones.

Doesn't necessarily mean that PG is pulling the plug on these old ATI GPUs. We'll have to await for a formal announcement.

For me, it was the ATI4670 AGP card that got me into folding almost 2 years ago. For about 9 months, the lion's share of my points were from these Core 11 WUs.
User avatar
GreyWhiskers
 
Posts: 767
Joined: Mon Oct 25, 2010 5:57 am
Location: Saratoga, California USA

Re: HD 4xxx gpu's still getting wu's? {So far, yes}

Postby MtM » Fri Feb 24, 2012 8:41 am

heh the one time you're lucky with a slow card: it has still allmost a full day work to do :mrgreen:
MtM
 
Posts: 3054
Joined: Fri Jun 27, 2008 2:20 pm
Location: The Netherlands

Re: HD 4xxx gpu's still getting wu's? {So far, yes}

Postby GreyWhiskers » Fri Feb 24, 2012 4:22 pm

The Psummary page is no longer listing the Core 11 projects 573x and 5716.

Dr. Pande did announce the impending demise of support for the Brook language ATI Core 11 almost a year ago. Maybe the time is now. But, we did have almost seven months of folding on this old hardware beyond the 1 Sept 2011 deplenishment date in the announcement.


MARCH 15, 2011
FAH Support for ATI GPUs

We have been working to improve our support for AMD/ATI GPUs. AMD/ATI originally supported the Brook language for GPU programming, but has since moved to OpenCL, dropping support for Brook. This means that in order for FAH to support ATI GPUs, we have had to rewrite our ATI GPU core in OpenCL. This has been a huge undertaking, but is coming to fruition (check out http://simtk.org/home/openmm for details and a change log with progress updates). Due to ATI's decision to drop Brook in lieu of OpenCL, new FAH ATI GPU core development can only be done in OpenCL and thus can only run on GPUs which ATI supports with OpenCL.

We want to give ATI donors a heads up that ATI does not support all of its GPUs with OpenCL (the series 3xxx are not supported and the series 4xxx does not have sufficient OpenCL support for efficient FAH calculations). For the short term, we will support both the older (Brook coded) ATI core 11, and the newer (OpenCL coded) ATI core 16, but we cannot support the Brook-based core for much longer. We plan to support ATI core 11 until September 1, 2011 (hopefully longer, but we want to get this on donors' radars). Closing support for a given platform is never a popular decision, but in this case, we have no choice due to the lack of vendor support of that platform.

The good news is that ATI's support for OpenCL is very strong and we're excited about our new ATI openCL core (core 16), which is undergoing testing right now. ATI core 16 will be publicly released after the v7 client is released, as the core needs the new client.
Last edited by GreyWhiskers on Sat Feb 25, 2012 1:28 am, edited 1 time in total.
User avatar
GreyWhiskers
 
Posts: 767
Joined: Mon Oct 25, 2010 5:57 am
Location: Saratoga, California USA

Re: HD 4xxx gpu's still getting wu's? {So far, yes}

Postby PantherX » Sat Feb 25, 2012 12:52 am

Since there isn't any blog post, I think that the WU shortage was a server issue which I believe might have been resolved (viewtopic.php?f=18&t=20905).
ETA:
Now ↞ Very Soon ↔ Soon ↔ Soon-ish ↔ Not Soon ↠ End Of Time

Welcome To The F@H Support Forum Ӂ Chrome Folding App (Beta) Ӂ Troubleshooting "Bad WUs" Ӂ Troubleshooting Server Connectivity Issues
User avatar
PantherX
Site Moderator
 
Posts: 6321
Joined: Wed Dec 23, 2009 9:33 am

Re: HD 4xxx gpu's still getting wu's? {So far, yes}

Postby JonazzDJ » Sat Feb 25, 2012 2:13 pm

I'm folding a 5769 WU right now, so core 11 is still up and running.
JonazzDJ
 
Posts: 186
Joined: Sun Jan 17, 2010 2:08 pm

Re: HD 4xxx gpu's still getting wu's? {So far, yes}

Postby GreyWhiskers » Sat Feb 25, 2012 8:30 pm

I just received a new core 11 WU - WU00:FS01:0x11:Project: 4724 (Run 4, Clone 313, Gen 1). The forum is 6.23 Windows GPU client, ATI specific issues. I'm actually running this under v7, but this seemed the closest forum for the topic.

As others have mentioned, this is the first new core 11 project for what seems like years - and there is a whole series of them Project 4724. Finally something new, and thankfully, something to continue folding with my old ATI 4760 AGP bus GPU.

4724 171.64.65.103 p4724_fip35_ww_domain 544 2.00 3.00 177.00 100 GROGPU2 Description densign 0.00


A couple of observations on that project

- This server seems to be still running old server software - the v7 GUI doesn't get the project info, so doesn't even show credit, and thus doesn't compute ppd.
- I'm not sure how these were benchmarked, but I'm getting far lower ppd than almost two years worth of p573x WUs when I manually compute ppd from TPF and the credit from Psummary.
----- 4724 TPF: 4:39, credit: 177; est PPD: 552
----- 573x and 5716 TPF: 6:30; credit 511; est ppd: 1132
User avatar
GreyWhiskers
 
Posts: 767
Joined: Mon Oct 25, 2010 5:57 am
Location: Saratoga, California USA

Re: HD 4xxx gpu's still getting wu's? {So far, yes}

Postby MtM » Sat Feb 25, 2012 8:42 pm

I'm getting about 340ppd on a hd4350, tpf 21 minutes :?: AGP bus hurting here?
MtM
 
Posts: 3054
Joined: Fri Jun 27, 2008 2:20 pm
Location: The Netherlands

Re: HD 4xxx gpu's still getting wu's? {So far, yes}

Postby GreyWhiskers » Sat Feb 25, 2012 10:20 pm

Seems the new projects like 4724 may be CPU limited. I paused the Core a4 uniprocessor, which coexisted very well with the previous 511 point 573x WUs, and the TPF for the 4724 dropped almost in half from 4:39 to 2:23, giving an estimated 1069 PPD.

I looked at the Windows task manager with both Core 11 and Core a4 running, and see that Core 11 is taking many more CPU cycles than the previous projects - it's running most of the time at 44-48%, almost an entire thread. Previously, Core 11 took about 35% on the 511 point WUs. Without the interference from the a4 uniprocessor slot, core 11 CPU utilization is now riding 49-50% most of the time, per Windows task manager.

This behavior is reminiscent of the 384-point 574x WUs that were available to the Core 11 ATI cards prior to Nov 2010. I remember when I was getting a mix of the 511 point and 384 point WUs, that running a uniprocessor materially slowed down the core 11 GPU when the smaller 384 point WUs were running, materially affecting the ppd. The larger 511 point WUs were almost unaffected by the background uniprocessor WU.

So - on my system, the AGP bus GPU can get maybe 1100 ppd, while the uniprocessor adds at most 150-200 ppd (usually less). With this new class of smaller core 11 WUs, the higher net utilization for the computer is running GPU only.

BTW, my hardware is an HPa475c Pent 4 HT 3.2 GHz - single cpu two threads - 2 GB memory - and the ATI 4670 AGP bus GPU.

re: the AGP bus. The same AGP bus GPU has had almost two years worth of the old that got pretty consistently 1132 or so ppd - essentially two WUs per day. And, up till Nov 2010, we were getting 384-point 574x WUs that had even better performance at ~1500 ppd.

The HD4670 was the highest-performing, so far as I know, AGP bus GPU. I got mine from HIS, who has an excellent cooling system for their card. And, I'm still running with the July 2010 AMD/ATI Catalyst drivers I started with.
User avatar
GreyWhiskers
 
Posts: 767
Joined: Mon Oct 25, 2010 5:57 am
Location: Saratoga, California USA

Re: HD 4xxx gpu's still getting wu's? {So far, yes}

Postby toTOW » Sun Feb 26, 2012 3:11 pm

p47xx are the oldest project that have been released for ATI ... they are small proteins (only 544 atoms), so they will need quite a fair amount of CPU to feed the GPU.

Also, since all these projects are using core 11 for ATI, you might want to set the environment variables to optimize the CPU usage : http://en.fah-addict.net/articles/artic ... iables.php
Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.

FAH-Addict : latest news, tests and reviews about Folding@Home project.

Image
User avatar
toTOW
Site Moderator
 
Posts: 8499
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France

Re: HD 4xxx gpu's still getting wu's? {So far, yes}

Postby MtM » Wed Feb 29, 2012 7:51 am

I retired my hd4350... got me a net increase of 5k in points due to my smp no longer being bottle necked :lol:
MtM
 
Posts: 3054
Joined: Fri Jun 27, 2008 2:20 pm
Location: The Netherlands

Re: HD 4xxx gpu's still getting wu's? {So far, yes}

Postby bruce » Wed Feb 29, 2012 4:03 pm

MtM wrote:I retired my hd4350... got me a net increase of 5k in points due to my smp no longer being bottle necked :lol:


Did your smp client/slot remain set to the maximum the whole time?

I've got a HD5xxx which tends to bottleneck SMP the same way, but if I change the default SMP 4 on a quad to SMP 3, the PPD from the HD5xxx exceeds the loss of points due to slowing SMP:4 to SMP:3. (If you count power costs, it's not a very economical way to do it, though.)

With it's lower productivity, the HD 4xxx won't be as productive as the HD 5xxx, so this comparison probably doesn't apply to your situation, but the idea of configuring smp:4 and then only letting it use 3 cores is always a bad idea.
bruce
 
Posts: 21679
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Next

Return to ATI specific issues

Who is online

Users browsing this forum: Yandex [Bot] and 1 guest

cron