Lagging cursor nVidia GT220

Moderators: slegrand, Site Moderators, PandeGroup

Lagging cursor nVidia GT220

Postby howardsternisbatman » Tue Dec 13, 2011 10:54 pm

Hello,

I'm experiencing the laggy cursor problem and after trying different drivers old/new and currently v 280.26 and the environement variable FAH_GPU_IDLE, Aero is enabled.

I am here asking for help. Any thoughts?

Windows 7 64-bit Home Premium
AMD IIx6
8GB RAM
nVidia GT 220

GPU client 6.41r2

I am also running the CPU client with no issues.

Babbabooey to y'all
howardsternisbatman
 
Posts: 2
Joined: Tue Dec 13, 2011 10:45 pm

Re: Lagging cursor nVidia GT220

Postby Jesse_V » Wed Dec 14, 2011 12:31 am

Hi howardsternisbatman (LOL!) and welcome to the F@h support forum.

Perhaps someone else can give you more technical advice but my thoughts are that perhaps you just don't have a powerful enough GPU for F@h. Protein folding makes heavy use of GPU shaders and since your GPU came out on October 12, 2009 it may not have enough power. Unlike CPUs, GPUs have difficulty with priority processing, meaning that all things being equal it tries to do the one that has the highest priority first. Things are pretty serial. F@h's GPU cores divide the WU into tiny subpieces for the GPU to do, so it does a small set of calculations, becomes available for other processing, and then gets another tiny set of F@h calculations again. I suspect that your problem comes from the fact that your GPU cannot complete one of these bursts fast enough, resulting in a noticeable delay before the GPU becomes available for non-F@h work, causing your mouse and whatnot to lag. I'm running a 240m, and sometimes I have the same problem especially when the machine hasn't restarted for a week. :) So my thoughts are to just run F@h on your CPU so that you don't have these problems. But we'd appreciate your contributions so I'm hoping someone else has a workable solution for you. :D
Pen tester at Cigital/Synopsys
User avatar
Jesse_V
 
Posts: 2773
Joined: Mon Jul 18, 2011 4:44 am
Location: USA

Re: Lagging cursor nVidia GT220

Postby bruce » Wed Dec 14, 2011 1:11 am

Welcome to foldingforum.org, howardsternisbatman.

Expanding slightly on what Jesse-V has said, NVidia did not provide any settings that allow you to adjust GPU responsiveness vs. FAH throughput. The GPU processes work on a first-come-first-served basis. The drivers do not incorporate the idea of priority so it's not possible for a request to update the screen can jump to the front of the line when there are other things like FAH waiting to be processed. Your operating system DOES have the concept of priority, so the Uniprocessor and SMP processor versions of FAH are designed to run at extremely low priority so they never delay other requests for CPU resources.

While there is no guaranteed solution, there are a couple things you can try.

First, try changing your OS settings to disable screen acceleration or perhaps at some intermediate setting. In WIndows, there are several settings with the default probably being set at maximum acceleration. At the minimum setting, the GPU is ignored and the CPU processes the graphics. When FAH is processing a GPU assignment, the GPU is unusually busy, whereas the CPU is perfectly capable of rendering most standard screens -- including cursor movements so unaccelerated can be much quicker than accelerated. What this might do to games or to video is unknown, so you'll have to experiment a bit.

Various versions of the NVidia drivers have made some improvements in this area, but I don't know which ones work better or worse than other versions.

You can try adjusting the processing setting downward from 100% in the FAH client. That's not directly related, but it sometimes can slow up the generation of new GPU work enough that screen updates get through faster.

See also viewtopic.php?f=15&t=20241
bruce
 
Posts: 20837
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Lagging cursor nVidia GT220

Postby howardsternisbatman » Wed Dec 14, 2011 6:18 pm

thank you for your responses. I'll fumble around a little more with what you have suggested and report back. If nothing helps I'll just try and get in to the habit of pausing the GPU folding when I need to, mostly this system is on idling so perhaps it won't be too bad. Eventually I'll get another card so this will be a thing of the past.

Babbabooey to'yall
howardsternisbatman
 
Posts: 2
Joined: Tue Dec 13, 2011 10:45 pm

Re: Lagging cursor nVidia GT220

Postby domboy » Wed Dec 21, 2011 1:59 pm

I've also seen this with my GT 220, but on XP 64-bit. In Windows 7 64-bit with Areo enabled the problem went away for me. I forget what drivers I've used, but I recently upgraded to them to what was currently available as of two weeks ago and still didn't have this issue. I don't run the CPU/SMP client in the Windows 7 machine, so I don't know if that makes any difference (and I suspect not since nVidia GPUs use very little CPU cycles), but I did when it was in the XP machine.

But yes, when it was in my XP machine I'd just stop the client if I needed to use it. It may be just a little GPU, but I usually get ~2200 PPD folding with it. I don't think that's too bad considering what I used to get with ATI's low end GPUs, something like 250 PPD.
domboy
 
Posts: 137
Joined: Thu Oct 02, 2008 1:42 pm
Location: Wilmington NC

Re: Lagging cursor nVidia GT220

Postby bruce » Wed Dec 21, 2011 7:17 pm

domboy wrote:... with Areo enabled ...
Thanks. That's a good point and I forgot that one. It's really important. It should be ahead of disabling screen acceleration but both will help.
bruce
 
Posts: 20837
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Lagging cursor nVidia GT220

Postby user123 » Thu Jan 12, 2012 5:14 am

I know it's irritating to have your cursor lag on the Windows desktop when folding.

Does this 'laggy cursor in desktop' problem affect PCs using GPUs to fold under Windows XP?
user123
 
Posts: 30
Joined: Wed Jan 11, 2012 1:20 pm

Re: Lagging cursor nVidia GT220

Postby PantherX » Thu Jan 12, 2012 9:35 am

From what I have read, the desktop lag depends mostly on the type of GPU. The version of Driver installed might play a small role in it but am not sure. It has appeared in Windows XP, Windows Vista and also Windows 7. If the GPU is a low end one, then the desktop lag is apparent. If it's a high end one, then not so much. I was able to fold on my GPU and work without desktop lag in 2010 but from 2011, this wasn't possible. My GTX 260 and Windows 7 64 bit remained the same. The only thing that varied was the WUs assigned and the Driver. My best guess is that the Driver is more optimized and the WUs are larger than before hence my GPU is being used to its full potential. I normally fold on my GPU when I am not working on my system.
ETA:
Now ↞ Very Soon ↔ Soon ↔ Soon-ish ↔ Not Soon ↠ End Of Time

Welcome To The F@H Support Forum Ӂ Chrome Folding App (Beta) Ӂ Troubleshooting "Bad WUs" Ӂ Troubleshooting Server Connectivity Issues
User avatar
PantherX
Site Moderator
 
Posts: 6321
Joined: Wed Dec 23, 2009 9:33 am

Re: Lagging cursor nVidia GT220

Postby k1net1cs » Thu Feb 23, 2012 9:29 pm

The new GPU projects (30xx?) really lag the system with a 560 Ti.
The i5-2500K @4.4GHz, 16GB RAM and Vertex 2 on my system don't seem to mean much when those projects are running.
I'm on Win7 Home Premium 64-bit.
I mostly work on my laptop, though, so I don't mind that much.
k1net1cs
 
Posts: 11
Joined: Mon Nov 14, 2011 4:50 pm

Re: Lagging cursor nVidia GT220

Postby bruce » Fri Feb 24, 2012 6:10 am

Did you upgrade your drivers? I think the old ones worked better.
bruce
 
Posts: 20837
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.


Return to NVIDIA specific issues

Who is online

Users browsing this forum: No registered users and 2 guests

cron