Cuda 3.0 beta RUNNING

Moderators: slegrand, Site Moderators, PandeGroup

Cuda 3.0 beta RUNNING

Postby Viper666 » Thu Nov 19, 2009 6:19 am

It seems to work as in its running but I dunno how stable yet.




http://forums.nvidia.com/index.php?showtopic=149959


Suse 11.2
Last edited by Viper666 on Fri Nov 20, 2009 4:42 am, edited 1 time in total.
ImageImage
Powered by AMD and Open SUSe 11.2 ----The New servers have nothing to do with fixing the stats problem !
User avatar
Viper666
 
Posts: 222
Joined: Fri Dec 14, 2007 9:57 pm

Re: Cuda 3.0 beta

Postby toTOW » Thu Nov 19, 2009 10:55 am

With current version of the Wine wrapper, it will probably not work on Linux : the wrapper only work with 180.xx drivers.

On windows, it's a different story ... and as mentioned here, we don't know how it will work/perform ... of course, any feedback is welcome.
Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.

FAH-Addict : latest news, tests and reviews about Folding@Home project.

Image
User avatar
toTOW
Site Moderator
 
Posts: 8329
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France

Re: Cuda 3.0 beta

Postby Viper666 » Fri Nov 20, 2009 4:39 am

toTOW WHAT PArt of my post where I said I have it running didnt you understand!!!!!!!!!!!!!! I HAVE IT RUNNING!!!!!!!!!!!!!!!!!!!!!!!! On suse 11.2 with a 2.6.31 kernel


Would pictures help? LMAO
http://img97.imageshack.us/img97/9789/screenshotdnb.jpg


see driver version ?
User avatar
Viper666
 
Posts: 222
Joined: Fri Dec 14, 2007 9:57 pm

Re: Cuda 3.0 beta RUNNING

Postby toTOW » Fri Nov 20, 2009 10:48 am

Huh ? Surprising ...

Could you post a how to, or what you did (different from viewtopic.php?f=54&t=6793) to make it work ? Which wrapper did you use ?
User avatar
toTOW
Site Moderator
 
Posts: 8329
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France

Re: Cuda 3.0 beta RUNNING

Postby biodoc » Sat Nov 21, 2009 1:20 pm

Just started folding again. :)

The 195.17 beta driver works for me too. 8-)

I followed the installation guide http://gpu2.twomurs.com/index.php?title=Linux

Ubuntu 9.04
wine version 1.1.33
32-bit cuda toolkit ver 2.3
wrapper version 2.1 from the above link

Stats for GTX295 (single PCB)

Project : 5772
Core : GPUv2 Gromacs
Frames : 100
Credit : 353


-- GTX295_1 --

Min. Time / Frame : 40s - 7624.80 ppd
Avg. Time / Frame : 40s - 7624.80 ppd
Cur. Time / Frame : 44s - 6931.64 ppd
R3F. Time / Frame : 44s - 6931.64 ppd
Eff. Time / Frame : 41s - 7438.83 ppd

Project : 5769
Core : GPUv2 Gromacs
Frames : 100
Credit : 353

-- GTX295_2 --

Min. Time / Frame : 40s - 7624.80 ppd
Avg. Time / Frame : 40s - 7624.80 ppd
Cur. Time / Frame : 40s - 7624.80 ppd
R3F. Time / Frame : 40s - 7624.80 ppd
Eff. Time / Frame : 40s - 7624.80 ppd/code]
User avatar
biodoc
 
Posts: 53
Joined: Sun Jan 06, 2008 10:15 am

Re: Cuda 3.0 beta RUNNING

Postby tonic » Sun Nov 22, 2009 3:17 am

Just installed Cuda 3.0 (64bit driver/32bit toolkit) on a fresh Ubuntu 9.10 AMD64 install. GPU client seems to run fine using the guide here: viewtopic.php?f=54&t=6793 substituting the two installations for the newer versions.
Image
tonic
 
Posts: 133
Joined: Sat Aug 02, 2008 4:05 am
Location: Seattle, WA

Re: Cuda 3.0 beta RUNNING

Postby Hyperlife » Mon Nov 23, 2009 4:48 pm

Thanks for the heads up on this. I will need to do some testing myself and edit my headless folding guide.
Image
User avatar
Hyperlife
 
Posts: 438
Joined: Sun Dec 02, 2007 7:38 am

Re: Cuda 3.0 beta RUNNING

Postby tonic » Mon Nov 23, 2009 9:07 pm

It seems that the driver listed in the headless guide won't install on Ubuntu 9.10 with all of the latest updates. It's possible it was something specific to my system, but I don't think so. I think you may HAVE to use the Cuda 3.0 drivers with 9.1 and the latest kernel.
tonic
 
Posts: 133
Joined: Sat Aug 02, 2008 4:05 am
Location: Seattle, WA

Re: Cuda 3.0 beta RUNNING

Postby smoking2000 » Tue Nov 24, 2009 6:23 am

Ubuntu 9.10 uses Linux kernel 2.6.31 with which the Nvidia 180.60 drivers are no longer compatible (without the patch mentioned elsewhere). So, yes, you have to use CUDA 3.0 on Ubuntu 9.10 if you want to run the GPU client.
User avatar
smoking2000
 
Posts: 571
Joined: Mon Dec 03, 2007 6:20 am
Location: Amsterdam

Re: Cuda 3.0 beta RUNNING

Postby andromeda » Tue Nov 24, 2009 8:00 pm

I just grabbed NVIDIA-Linux-x86_64-195.22-pkg2.run from the beta driver site and it is running with Cuda 2.0 drivers on my 2.6.31/SLAMD64 box, doing about 3800ppd on a 627 atom protein project (5728) with a 9600GT at 675MHz core, 55C load GPU temp in a SFF box, no noticeable impact on X11 interface under xfce nor any fan spinup on the video card. I stopped Linux GPU folding when the mainline video drivers broke but this latest one looks like it might put it back in action.
User avatar
andromeda
 
Posts: 20
Joined: Thu Jul 17, 2008 11:06 pm

Re: Cuda 3.0 beta RUNNING

Postby P5-133XL » Tue Nov 24, 2009 8:19 pm

What I would like to know is if there is a folding performance difference between old CUDA and new CUDA?
Image
P5-133XL
 
Posts: 4034
Joined: Sun Dec 02, 2007 4:36 am
Location: Salem. OR USA

Re: Cuda 3.0 beta RUNNING

Postby willmore » Tue Nov 24, 2009 10:31 pm

It seems to work here for Fedora 12. I've also had to install the older 32 bit toolkit from the howto as this new toolkit doesn't provide '2.0' libraries.

I guess we'll see if it keeps working.

Cheers!
Image
willmore
 
Posts: 16
Joined: Wed Oct 15, 2008 7:26 pm

Re: Cuda 3.0 beta RUNNING

Postby willmore » Wed Nov 25, 2009 12:12 am

Okay, it's running, but it's very slow. I'm going to hunt around for any 'usual suspects' for then it's running too slow. Looks like 1/3 normal speed. If anyone has suggestions to save me time, feel free to PM or post.

Cheers!
willmore
 
Posts: 16
Joined: Wed Oct 15, 2008 7:26 pm

Re: Cuda 3.0 beta RUNNING

Postby willmore » Wed Nov 25, 2009 12:34 am

Okay, an update. There is another CPU using task running--at a good nice level. Stopping it causes F@H to take up 33% of the CPU, but it does run at full speed. This is for a Core_11 WU. I'm pretty sure it didn't do that before, so this seems like a new issue with the CUDA 3.0 driver and the 2.0 utilities and the revision two wrapper.

Now, with the explicit 'nice' removed and the background task started up again, Core_11 is taking 12% of the CPU. That's better, but it still seems a bit high. Oh, performance is unaffected, it seems. The background task has slowed a little--about 15% which accounts for the loss of 12% CPU plus having the caches messed with.

For now, I'll call this 'working', but I'd like to see the CPU usage go down a bit. Any suggestions on that front are still welcome.

Cheers!
willmore
 
Posts: 16
Joined: Wed Oct 15, 2008 7:26 pm

Re: Cuda 3.0 beta RUNNING

Postby andromeda » Wed Nov 25, 2009 4:01 am

FahCore_11.exe has always pulled 10-12% CPU under wine since the linux port was first hatched/optimized, sounds about normal. I don't nice anything and it is running 10-12% CPU, 3800 PPD feeding a 9600GT. This latest driver seems really smooth... user interface in X11 is still lightning fast under full GPU load... earlier drivers used to make X11 sluggish but this new one seems to have addressed that issue.
User avatar
andromeda
 
Posts: 20
Joined: Thu Jul 17, 2008 11:06 pm

Next

Return to unOfficial Linux GPU (WINE wrapper) (3rd party support)

Who is online

Users browsing this forum: No registered users and 1 guest

cron