GPU2 in Ubuntu v10.04

Moderators: slegrand, Site Moderators, PandeGroup

GPU2 in Ubuntu v10.04

Postby zodac » Mon May 31, 2010 12:09 am

Right, got it working... almost. I ran the config, then I get this error as soon as it downloaded FahCore_11:

Image

Anyone know what I need to do to get it working?
Image
zodac
 
Posts: 124
Joined: Wed Mar 03, 2010 11:17 pm

Re: GPU2 in Ubuntu v10.04

Postby Shelnutt2 » Mon May 31, 2010 1:50 am

You need you install the cuda toolkit, http://www.nvidia.com/object/thankyou_l ... tu9.04.run . After you download and run that file then you should be good to go :)
OCforums, T32

Linux Lober!
Shelnutt2
 
Posts: 150
Joined: Sun Dec 02, 2007 5:37 pm

Re: GPU2 in Ubuntu v10.04

Postby jimerickson » Mon May 31, 2010 2:33 am

nvm
jimerickson
 
Posts: 680
Joined: Tue May 27, 2008 11:56 pm
Location: ames, iowa

Re: GPU2 in Ubuntu v10.04

Postby zodac » Mon May 31, 2010 7:01 pm

Shelnutt2 wrote:You need you install the cuda toolkit, http://www.nvidia.com/object/thankyou_l ... tu9.04.run . After you download and run that file then you should be good to go :)


Ok, I was using 3.0 beforehand. I installed this version, and now I get this error:

Image
zodac
 
Posts: 124
Joined: Wed Mar 03, 2010 11:17 pm

Re: GPU2 in Ubuntu v10.04

Postby pholcman » Tue Jun 01, 2010 8:40 pm

Driver 195.36.15 from UBU repo
Toolkit 2.3 32-bit
Wine v1.1.42 (wine 1.2)
GPU's are GT240.

And working like a charm :D
Image
pholcman
 
Posts: 8
Joined: Sun Mar 29, 2009 2:06 pm
Location: Wadowice, Poland

Re: GPU2 in Ubuntu v10.04

Postby zodac » Tue Jun 01, 2010 9:10 pm

I'm using the "Current" drivers from the Hardware Drivers screen.
Using the Toolkit linked earlier (same one I think)
Whichever wine was included in the install.
9800GT.

Not working like a charm. :/
zodac
 
Posts: 124
Joined: Wed Mar 03, 2010 11:17 pm

Re: GPU2 in Ubuntu v10.04

Postby Sidicas » Tue Jun 01, 2010 11:30 pm

Please follow the steps from step #10 onward..
http://foldingforum.org/viewtopic.php?f=54&t=6793
Sidicas
 
Posts: 232
Joined: Sun Feb 17, 2008 4:46 pm

Re: GPU2 in Ubuntu v10.04

Postby zodac » Wed Jun 02, 2010 12:04 am

Righto, I'll look into doing that tomorrow. :)
zodac
 
Posts: 124
Joined: Wed Mar 03, 2010 11:17 pm

Re: GPU2 in Ubuntu v10.04

Postby powerarmour » Wed Jun 02, 2010 8:17 am

As said above, use the Cuda 2.3 toolkit and the latest 195.36.15 driver from the repo, works fine for me :)
Image
powerarmour
 
Posts: 169
Joined: Wed Oct 29, 2008 1:00 am
Location: Surrey, UK

Re: GPU2 in Ubuntu v10.04

Postby Blasphemous Cannibal » Sun Jun 20, 2010 10:54 pm

I'm having trouble running on my main card but it works fine on the secondary card. I can't work out what's going wrong. The client runs on the main card but with massive slow down. Any suggestions would be appreciated.
Blasphemous Cannibal
 
Posts: 135
Joined: Wed Oct 28, 2009 11:20 pm

Re: GPU2 in Ubuntu v10.04

Postby Sidicas » Mon Jun 21, 2010 2:06 pm

Be more specific about your hardware...
Sidicas
 
Posts: 232
Joined: Sun Feb 17, 2008 4:46 pm

Re: GPU2 in Ubuntu v10.04

Postby Blasphemous Cannibal » Mon Jun 21, 2010 6:17 pm

P45, Q6600 & 2x GTX260 216's.

I used to to have the 260's folding on Ubuntu 9.04 with the 180.60 driver but been using Windows for a while.

I think I may have messed up at bit when I copied the client folders. but basically I followed the headless guide from step 10. Using the latest Nvidia repo, the 2.3 Toolkit & the WINE version from the Ubuntu repo which is the same as recommended in this thread.

I did run in trouble with the Wine wrapper, the link in the guide failed so I used a link from the 'new v2.1 wrapper imminent' thread, the newer version - http://www.hyperchronos.org/cudart.dll.so.

I'm using the -GPU 0 & -GPU 1 flags but as I said last night the primary card was running very slowly. Going to have another go & will report back. The only reason I've switched back to Linux is due to the new A3 WUs performing so poorly using the 2.19 core. Now the Windows core has also been updated I'd be better back on the dark side for the GPU's & CPU combined but it would be nice to have both setups available.
Blasphemous Cannibal
 
Posts: 135
Joined: Wed Oct 28, 2009 11:20 pm

Re: GPU2 in Ubuntu v10.04

Postby Blasphemous Cannibal » Mon Jun 21, 2010 7:17 pm

Looks like it was just the SMP client priority. Is there anyway way to strike a happy balance like in Windows? I used to use nice when I was using 9.04 but I've forgotten how. Or is it just a problem with this distro?
Blasphemous Cannibal
 
Posts: 135
Joined: Wed Oct 28, 2009 11:20 pm

Re: GPU2 in Ubuntu v10.04

Postby Sidicas » Tue Jun 22, 2010 12:42 pm

Try the newer GPU3 wrapper...
The GPU3 wrapper I wrote is a little more aggressive at keeping the GPUs busy... Also shelnutt2 wrote a GPU3 wrapper that lets you set exactly how aggressive you want it to keep the GPU busy with an environment variable..
Sidicas
 
Posts: 232
Joined: Sun Feb 17, 2008 4:46 pm

Re: GPU2 in Ubuntu v10.04

Postby Sidicas » Tue Jun 22, 2010 12:47 pm

Code: Select all
    sudo renice -15 $$
    wine ./Folding@home-Win32-GPU.exe -forcegpu nvidia_g80 

This will make sure your GPU client doesn't get starved of cycles and will work without actually running the application as root.. As root, you're telling anything the terminal launches should be high priority regardless of the user account launching the application.. So be careful with that..

. I know a lot of people were logging in as root and just starting the whole thing up with high priority (nice -15....) .. Don't do that... Shouldn't be running things as root unless it's an absolute last resort.. The above sudo renice command allows you to run it at higher priority while having the restricted permissions of the user account logged in which I believe is the best way to do it.

Also, AFAIK.. Wine gets angry when you try to run it as root and will block by default to prevent you from shooting yourself in the foot..
Sidicas
 
Posts: 232
Joined: Sun Feb 17, 2008 4:46 pm


Return to unOfficial Linux GPU (WINE wrapper) (3rd party support)

Who is online

Users browsing this forum: No registered users and 1 guest

cron