SMP Folding @ 50% to 7% = 0 Progress?!

Moderators: Site Moderators, PandeGroup

SMP Folding @ 50% to 7% = 0 Progress?!

Postby geokilla » Thu Oct 13, 2011 10:08 pm

I have my SMP client folding at 50% to 75% because lately, me botting in RuneScape requires 25% to 50% CPU overhead. However with the A3 core chugging along at 50% to 75% CPU usage, my TPF is over 2 hours. What the hell?! Is there a way to fix this? How can a 25% to 50% drop in CPU resources result in such a huge drop in TPF? Even my old Athlon X2 can fold better than this.
Intel Core i5-3570K @ 4.2Ghz @ 1.16V (CPU-Z + LinX)
Gigabyte Z77X-UD5H F14 BIOS
XFX 7950 Double D 3GB (TDKC); VDCC @ 1.125VDCC 1000/1500
Kingston HyperX DDR3 8GB @ DDR-1333
Corsair AX750
Samsung 840 Pro 128GB and Western Digital Black 1TB + Misc HDD
geokilla
 
Posts: 157
Joined: Sun Mar 08, 2009 4:36 am
Location: Toronto, Canada

Re: SMP Folding @ 50% to 7% = 0 Progress?!

Postby P5-133XL » Thu Oct 13, 2011 10:24 pm

The SMP client does not lose performance linearly when an external application uses some CPU. Rather, the client needs to keep each thread (one per core) synchronized with each other. So if an outside application uses a single core exclusively, then for that core the SMP client backs off because it is a very low priority and wants your applications to run without interruption. But because that one thread is not running and the other threads must remain synchronized they just end up waiting for the missing thread to start running again before they also get to start running again. Hence the drastic slowdown.

The solution is to specify fewer threads/cores using the -smp # where # stands for how many threads are to run in the additional parameters section of the config. The second, alternative solution is to run multiple uniprocessor folding clients where if one client is hindered it won't affect the others.

If you choose to go the multiple uniprocessor clients, you might find that running the beta v7 client to be easier than setting up multiple v6 clients.
Image
P5-133XL
 
Posts: 4034
Joined: Sun Dec 02, 2007 4:36 am
Location: Salem. OR USA

Re: SMP Folding @ 50% to 7% = 0 Progress?!

Postby P5-133XL » Thu Oct 13, 2011 10:32 pm

P.S. My answer is limited to the smp issue you spoke of here. I have no solution, beyond what I said there, to your earlier GPU question issue.
P5-133XL
 
Posts: 4034
Joined: Sun Dec 02, 2007 4:36 am
Location: Salem. OR USA

Re: SMP Folding @ 50% to 7% = 0 Progress?!

Postby geokilla » Fri Oct 14, 2011 12:14 am

Reducing the number of cores by using -smp 3 flag doesn't help. Been one hour now and still 0 progress. Also doesn't explain why my sister's Phenom II can manage to have a TPF of around 11 minutes while she plays her Facebook games or MapleStory. Those games use at the very least 25% of CPU overhead, just like my bots in RuneScape.
geokilla
 
Posts: 157
Joined: Sun Mar 08, 2009 4:36 am
Location: Toronto, Canada

Re: SMP Folding @ 50% to 7% = 0 Progress?!

Postby gwildperson » Fri Oct 14, 2011 8:09 pm

How did you set -smp 3? Does FAH run at 75% whether RuneScape is running or not? If FAH still wants 100% when nothing else is running, then you didn't set -smp 3 correctly.
gwildperson
 
Posts: 726
Joined: Tue Dec 04, 2007 8:36 pm

Re: SMP Folding @ 50% to 7% = 0 Progress?!

Postby geokilla » Sat Oct 15, 2011 2:01 am

gwildperson wrote:How did you set -smp 3? Does FAH run at 75% whether RuneScape is running or not? If FAH still wants 100% when nothing else is running, then you didn't set -smp 3 correctly.

I managed to fix it and set up -smp 3 correctly. However it's weird that performances doesn't drop linearly when RuneScape is botting, while it drops semi-linearly when my sister plays her Facebook games and MapleStory.

I think I'm going to try the v7 client and see if it changes anything.
geokilla
 
Posts: 157
Joined: Sun Mar 08, 2009 4:36 am
Location: Toronto, Canada

Re: SMP Folding @ 50% to 7% = 0 Progress?!

Postby k1wi » Sat Oct 15, 2011 3:52 am

It is possible that RuneScape uses a significant amount floating point operations while Facebook games consume a lot of integer operations (potentially even offloaded to a GPU), but I don't have any AMD systems so that is speculation.
k1wi
 
Posts: 1152
Joined: Tue Sep 22, 2009 10:48 pm

Re: SMP Folding @ 50% to 7% = 0 Progress?!

Postby trikychase » Sat Dec 31, 2011 3:15 am

okay so AMD Phenom with multicpus dont work with runescape very well try going into task manager then processes then find the runescape jagexlauncher then right click it then click affinity then select 1 cpu thats what fixed mine i have same processer as you
trikychase
 
Posts: 1
Joined: Sat Dec 31, 2011 3:12 am


Return to V6.34Beta SMP2 with passkey [Not Bigadv]

Who is online

Users browsing this forum: No registered users and 2 guests

cron