Continious FILE_IO_ERROR since this morning

Moderators: Site Moderators, PandeGroup

Continious FILE_IO_ERROR since this morning

Postby De Berghut » Sat May 19, 2012 12:52 pm

Hi folks,

as almost every day in the past few years I get up and turn on the computer on my way to breakfast. GPU started, uniclient started, and smp client started.. All went fine as usual except for the smp client. Since this morning i'm having nothing but this:

Code: Select all
# Windows SMP Console Edition #################################################
###############################################################################

                       Folding@Home Client Version 6.34

                          http://folding.stanford.edu

###############################################################################
###############################################################################

Launch directory: H:\Folding@Home\Client 6.x\SMP Small
Executable: H:\Folding@Home\Client 6.x\SMP Small\fah.exe
Arguments: -smp 6 -pause

[12:44:03] - Ask before connecting: No
[12:44:03] - User name: Steven_De_Backer (Team 83781)
[12:44:03] - User ID: 32BEE69A185CC886
[12:44:03] - Machine ID: 2
[12:44:03]
[12:44:04] Loaded queue successfully.
[12:44:04]
[12:44:04] + Processing work unit
[12:44:04] Core required: FahCore_a3.exe
[12:44:04] Core found.
[12:44:04] Working on queue slot 02 [May 19 12:44:04 UTC]
[12:44:04] + Working ...
[12:44:04]
[12:44:04] *------------------------------*
[12:44:04] Folding@Home Gromacs SMP Core
[12:44:04] Version 2.27 (Dec. 15, 2010)
[12:44:04]
[12:44:04] Preparing to commence simulation
[12:44:04] - Looking at optimizations...
[12:44:04] - Created dyn
[12:44:04] - Files status OK
[12:44:04] Couldn't Decompress
[12:44:04] Called DecompressByteArray: compressed_data_size=0 data_size=0, decompressed_data_size=0 diff=0
[12:44:04] -Error: Couldn't update checksum variables
[12:44:04] Error: Could not open work file
[12:44:04]
[12:44:04] Folding@home Core Shutdown: FILE_IO_ERROR
[12:44:08] CoreStatus = 75 (117)
[12:44:10] Error opening or reading from a file.
[12:44:10] Deleting current work unit & continuing...
[12:44:14] - Preparing to get new work unit...
[12:44:14] Cleaning up work directory


I've done a complete check-disk in the meanwhile, turned of antivirus, cleaned up the whole directory except for the client-file and the config-file, but it seems like all that didn't help a thing. I don't really get it, i didn't change anything last night, all was business as usual, checkdisk did not find any issues.
I'd be really grateful on a hint :shock:
Some side-info: running on a i7 920 with P6T Deluxe Asus mainboard, windows 7 pro x64, uniclient works fine, other programs running on the same HDD work fine, still i seem to be missing out on something... :( i've checked the forum and fahwiki but didn't find anything yet that explains the problem or helps me to solve it :( (or i simply passed over it).
Computers never do what you want them to, only what you tell them to do...
User avatar
De Berghut
 
Posts: 109
Joined: Fri Jun 27, 2008 1:19 am
Location: Belgium

Re: Continious FILE_IO_ERROR since this morning

Postby bollix47 » Sat May 19, 2012 1:09 pm

Could be just a bad WU but without the PRCG numbers it's not possible to check.

Any hints here:

http://fahwiki.net/index.php/CoreStatus_codes#75

"These errors indicate an I/O hardware problem or perhaps an AV program preventing FAH from writing/reading certain work files. "
bollix47
 
Posts: 3323
Joined: Sun Dec 02, 2007 5:04 am
Location: Canada

Re: Continious FILE_IO_ERROR since this morning

Postby De Berghut » Sat May 19, 2012 1:25 pm

Thank you for the hints, but as i said, i already checked fahwiki ;)
The only PRCG i can get is from the WU last i got, with HFM, in the logs no PRCG's are shown.. Anyway, what i get in HFM now is:
project 7500, Run 0, Clone 34, Gen 488.
I've had quite a bunch of I/O errors since this morning, not one WU i get works, so i'm afraid the problem is situated here somewhere in my computer.. :s I've stopped the client in the meanwhile so i don't cause too much of damage anymore..
User avatar
De Berghut
 
Posts: 109
Joined: Fri Jun 27, 2008 1:19 am
Location: Belgium

Re: Continious FILE_IO_ERROR since this morning

Postby bollix47 » Sat May 19, 2012 1:51 pm

You could try deleting queue.dat, unitinfo.txt and the contents of the work folder. Then change the MachineID to a different but unique number from 1-9. If it's just a bad WU that should solve the problem. Otherwise, it might indicate that it's something on your end.

Also, what Anti-Virus software are you using?
bollix47
 
Posts: 3323
Joined: Sun Dec 02, 2007 5:04 am
Location: Canada

Re: Continious FILE_IO_ERROR since this morning

Postby De Berghut » Sat May 19, 2012 2:32 pm

Lol, i don't get it :D

Well, this morning i already deleted the whole working folder and all other files (except clientexec. & config).
now i did it again on your advise, but also changed the machine ID as you suggested. I don't see why & how, but it seems to have worked :o it's folding again :!:
Do you have any idea why this ID-thing seems to have been the key? :?: cause it really doesn't make sense to me :D
Thanks dude ;)
User avatar
De Berghut
 
Posts: 109
Joined: Fri Jun 27, 2008 1:19 am
Location: Belgium

Re: Continious FILE_IO_ERROR since this morning

Postby bollix47 » Sat May 19, 2012 2:40 pm

Basically, the server will keep sending the same WU to the same client until it times out, shuts down or gets a successful completion. By changing the MachineID the client is no longer identified as the same client that was processing the possibly bad WU so the server sends you a new WU.
bollix47
 
Posts: 3323
Joined: Sun Dec 02, 2007 5:04 am
Location: Canada

Re: Continious FILE_IO_ERROR since this morning

Postby De Berghut » Sat May 19, 2012 3:26 pm

Hmm, but shouldn't I haven gotten a different WU after every error? As far as I can see my clients responds to the FAH-server and sends it back in order to get a new WU. Certainly after I deleted all files 3 times and I had quite a bunch of the IO-Errors in a row... Or do I still keep getting the same WU again?
But thanks again dude ;) First time I had this problem without being able to solve it.
User avatar
De Berghut
 
Posts: 109
Joined: Fri Jun 27, 2008 1:19 am
Location: Belgium

Re: Continious FILE_IO_ERROR since this morning

Postby bollix47 » Sat May 19, 2012 3:58 pm

The server has a record of which WU went to a client. If it doesn't get the WU back and the same client requests a WU it will usually get the exact same WU again until it's successful or at least gets a partial return or a manual intervention like changing the MachineId takes place. Your log shows nothing was returned to the server so it keeps sending the same WU.

[12:44:10] Deleting current work unit & continuing...


The v7 client appears to handle this situation better than v6 but even with v6 this type of problem is fairly rare. The client will usually move on or shut down after a certain number of failures. Also, the version of software being used on the server probably plays a role when this happens.
bollix47
 
Posts: 3323
Joined: Sun Dec 02, 2007 5:04 am
Location: Canada

Re: Continious FILE_IO_ERROR since this morning

Postby De Berghut » Sat May 19, 2012 4:09 pm

ooh i see :o now it figures... :idea:
Thx for the clear answer, one never stops learning :)
User avatar
De Berghut
 
Posts: 109
Joined: Fri Jun 27, 2008 1:19 am
Location: Belgium


Return to V6.34Beta SMP2 with passkey [Not Bigadv]

Who is online

Users browsing this forum: No registered users and 2 guests

cron