error: 10053 when using viewer

If you're new to FAH and need help getting started or you have very basic questions, start here.

Moderators: Site Moderators, PandeGroup

error: 10053 when using viewer

Postby Tsunoda » Wed Oct 31, 2018 3:59 pm

hi, i recently started folding and i have no idea what im doing wrong to get this error.
Basically as it states when i use the viewer it will show me the demo connection : Trying and snapshot running from 1 - 4 when i look in the log i see;
15:54:25:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:54:40:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:54:56:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:55:12:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:55:28:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:55:44:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:56:00:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:56:16:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:56:32:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:56:48:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:57:04:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:57:20:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:57:36:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:57:47:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:58:03:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:58:19:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:58:35:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:58:51:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.

if i close the viewer it stops.
Tsunoda
 
Posts: 3
Joined: Wed Oct 31, 2018 3:52 pm

Re: error: 10053 when using viewer

Postby bruce » Wed Oct 31, 2018 5:15 pm

Which version of FAHClient are you running and which OS? ((You didn't post the top 100 lines of your log.)
bruce
 
Posts: 22127
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: error: 10053 when using viewer

Postby toTOW » Wed Oct 31, 2018 11:11 pm

I see the same on my Windows 10 machines ...

It's been years since I last saw the viewer to display something else than the demo protein ...
Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.

FAH-Addict : latest news, tests and reviews about Folding@Home project.

Image
User avatar
toTOW
Site Moderator
 
Posts: 8643
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France

Re: error: 10053 when using viewer

Postby Tsunoda » Wed Oct 31, 2018 11:33 pm

windows 10;

Code: Select all
*********************** Log Started 2018-10-31T23:32:27Z ***********************
23:32:27:************************* Folding@home Client *************************
23:32:27:        Website: https://foldingathome.org/
23:32:27:      Copyright: (c) 2009-2018 foldingathome.org
23:32:27:         Author: Joseph Coffland <joseph@cauldrondevelopment.com>
23:32:27:           Args: --open-web-control
23:32:27:         Config: C:\Users\CLang\AppData\Roaming\FAHClient\config.xml
23:32:27:******************************** Build ********************************
23:32:27:        Version: 7.5.1
23:32:27:           Date: May 11 2018
23:32:27:           Time: 13:06:32
23:32:27:     Repository: Git
23:32:27:       Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
23:32:27:         Branch: master
23:32:27:       Compiler: Visual C++ 2008
23:32:27:        Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
23:32:27:       Platform: win32 10
23:32:27:           Bits: 32
23:32:27:           Mode: Release
23:32:27:******************************* System ********************************
23:32:27:            CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
23:32:27:         CPU ID: GenuineIntel Family 6 Model 94 Stepping 3
23:32:27:           CPUs: 8
23:32:27:         Memory: 15.94GiB
23:32:27:    Free Memory: 10.53GiB
23:32:27:        Threads: WINDOWS_THREADS
23:32:27:     OS Version: 6.2
23:32:27:    Has Battery: false
23:32:27:     On Battery: false
23:32:27:     UTC Offset: 0
23:32:27:            PID: 3020
23:32:27:            CWD: C:\Users\CLang\AppData\Roaming\FAHClient
23:32:27:             OS: Windows 10 Enterprise
23:32:27:        OS Arch: AMD64
23:32:27:           GPUs: 1
23:32:27:          GPU 0: Bus:1 Slot:0 Func:0 NVIDIA:7 GP102 [GeForce GTX 1080 Ti] 11380
23:32:27:  CUDA Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:6.1 Driver:10.0
23:32:27:OpenCL Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:1.2 Driver:416.34
23:32:27:  Win32 Service: false
23:32:27:***********************************************************************
23:32:27:<config>
23:32:27:  <!-- Folding Slot Configuration -->
23:32:27:  <cause v='CANCER'/>
23:32:27:
23:32:27:  <!-- Network -->
23:32:27:  <proxy v=':8080'/>
23:32:27:
23:32:27:  <!-- Slot Control -->
23:32:27:  <power v='light'/>
23:32:27:
23:32:27:  <!-- User Information -->
23:32:27:  <passkey v='********************************'/>
23:32:27:  <team v='223518'/>
23:32:27:  <user v='Tsunoda'/>
23:32:27:
23:32:27:  <!-- Folding Slots -->
23:32:27:  <slot id='0' type='CPU'/>
23:32:27:  <slot id='1' type='GPU'/>
23:32:27:</config>
23:32:27:Trying to access database...
23:32:27:Successfully acquired database lock
23:32:27:Enabled folding slot 00: READY cpu:3
23:32:27:Enabled folding slot 01: PAUSED gpu:0:GP102 [GeForce GTX 1080 Ti] 11380 (waiting for idle)
23:32:27:WU00:FS00:Starting
23:32:27:WU00:FS00:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\CLang\AppData\Roaming\FAHClient\cores/cores.foldingathome.org/Win32/AMD64/AVX/Core_a7.fah/FahCore_a7.exe -dir 00 -suffix 01 -version 705 -lifeline 3020 -checkpoint 15 -np 3
23:32:27:WU00:FS00:Started FahCore on PID 15604
23:32:27:WU00:FS00:Core PID:12492
23:32:27:WU00:FS00:FahCore 0xa7 started
23:32:28:WU00:FS00:0xa7:*********************** Log Started 2018-10-31T23:32:27Z ***********************
23:32:28:WU00:FS00:0xa7:************************** Gromacs Folding@home Core ***************************
23:32:28:WU00:FS00:0xa7:       Type: 0xa7
23:32:28:WU00:FS00:0xa7:       Core: Gromacs
23:32:28:WU00:FS00:0xa7:    Website: https://foldingathome.org/
23:32:28:WU00:FS00:0xa7:  Copyright: (c) 2009-2018 foldingathome.org
23:32:28:WU00:FS00:0xa7:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
23:32:28:WU00:FS00:0xa7:       Args: -dir 00 -suffix 01 -version 705 -lifeline 15604 -checkpoint 15 -np
23:32:28:WU00:FS00:0xa7:             3
23:32:28:WU00:FS00:0xa7:     Config: <none>
23:32:28:WU00:FS00:0xa7:************************************ Build *************************************
23:32:28:WU00:FS00:0xa7:    Version: 0.0.17
23:32:28:WU00:FS00:0xa7:       Date: Apr 27 2018
23:32:28:WU00:FS00:0xa7:       Time: 16:19:36
23:32:28:WU00:FS00:0xa7: Repository: Git
23:32:28:WU00:FS00:0xa7:   Revision: 21359963583d09ec2063ef946399441c4df4ccd7
23:32:28:WU00:FS00:0xa7:     Branch: master
23:32:28:WU00:FS00:0xa7:   Compiler: Visual C++ 2008
23:32:28:WU00:FS00:0xa7:    Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
23:32:28:WU00:FS00:0xa7:   Platform: win32 10
23:32:28:WU00:FS00:0xa7:       Bits: 64
23:32:28:WU00:FS00:0xa7:       Mode: Release
23:32:28:WU00:FS00:0xa7:       SIMD: avx_256
23:32:28:WU00:FS00:0xa7:************************************ System ************************************
23:32:28:WU00:FS00:0xa7:        CPU: Unknown
23:32:28:WU00:FS00:0xa7:     CPU ID:
23:32:28:WU00:FS00:0xa7:       CPUs: 8
23:32:28:WU00:FS00:0xa7:     Memory: 15.94GiB
23:32:28:WU00:FS00:0xa7:Free Memory: 10.52GiB
23:32:28:WU00:FS00:0xa7:    Threads: WINDOWS_THREADS
23:32:28:WU00:FS00:0xa7: OS Version: 6.2
23:32:28:WU00:FS00:0xa7:Has Battery: false
23:32:28:WU00:FS00:0xa7: On Battery: false
23:32:28:WU00:FS00:0xa7: UTC Offset: 0
23:32:28:WU00:FS00:0xa7:        PID: 12492
23:32:28:WU00:FS00:0xa7:        CWD: C:\Users\CLang\AppData\Roaming\FAHClient\work
23:32:28:WU00:FS00:0xa7:         OS: Windows 10 Pro
23:32:28:WU00:FS00:0xa7:    OS Arch: AMD64
23:32:28:WU00:FS00:0xa7:********************************************************************************
23:32:28:WU00:FS00:0xa7:Project: 13809 (Run 0, Clone 57, Gen 316)
23:32:28:WU00:FS00:0xa7:Unit: 0x0000017c80fccb025a9190cf13b47938
23:32:28:WU00:FS00:0xa7:Digital signatures verified
23:32:28:WU00:FS00:0xa7:Calling: mdrun -s frame316.tpr -o frame316.trr -x frame316.xtc -cpi state.cpt -cpt 15 -nt 3
23:32:28:WU00:FS00:0xa7:Steps: first=79000000 total=250000
23:32:30:WU00:FS00:0xa7:Completed 155400 out of 250000 steps (62%)
23:32:37:ERROR:Receive error: 10054: An existing connection was forcibly closed by the remote host.
23:32:53:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
23:33:09:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
ect
Tsunoda
 
Posts: 3
Joined: Wed Oct 31, 2018 3:52 pm

Re: error: 10053 when using viewer

Postby Joe_H » Thu Nov 01, 2018 1:22 am

toTOW wrote:I see the same on my Windows 10 machines ...

It's been years since I last saw the viewer to display something else than the demo protein ...

So far almost all A7 WU's will display for me. GPU WU's do not, and that is on the list of things to be fixed sometime. Support for displaying A4 WU's was removed sometime during the development of the current version from the previous full release, 7.4.4.

Tsunoda wrote:15:54:25:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.

Do you have firewall or other anti-malware software enabled on your system? FAHViewer needs to make a local network connection over 127.0.0.1 as I recall. If that is being blocked, then you will get that type of message. I don't have a desktop client in front of me at the moment, so I can't check which local addresses and ports are used for FAHViewer.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 4393
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: error: 10053 when using viewer

Postby Tsunoda » Sat Nov 03, 2018 4:15 pm

Joe_H wrote:
toTOW wrote:I see the same on my Windows 10 machines ...

It's been years since I last saw the viewer to display something else than the demo protein ...

So far almost all A7 WU's will display for me. GPU WU's do not, and that is on the list of things to be fixed sometime. Support for displaying A4 WU's was removed sometime during the development of the current version from the previouds full release, 7.4.4.

Tsunoda wrote:15:54:25:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.

Do you have firewall or other anti-malware software enabled on your system? FAHViewer needs to make a local network connection over 127.0.0.1 as I recall. If that is being blocked, then you will get that type of message. I don't have a desktop client in front of me at the moment, so I can't check which local addresses and ports are used for FAHViewer.


I do have a firewall though I suspected the same thing though it made no difference.
Tsunoda
 
Posts: 3
Joined: Wed Oct 31, 2018 3:52 pm

Re: error: 10053 when using viewer

Postby mastercb » Sat Feb 09, 2019 9:36 pm

After trying several solitions without sucess (deactivationg antivirus, setting the viewer allowed for firewall ...), I found the final solution:

i just copied an old version (7.4.4) of the viewer into the FAH Program (7.5.1) directory an the viewer works perfect (it's "online" connected and shows the current folding protein and the "live" status infos). :D

Hope it helps for you, too.
mastercb
 
Posts: 2
Joined: Sat Feb 09, 2019 9:29 pm

Re: error: 10053 when using viewer

Postby rplate » Sun Feb 24, 2019 11:33 pm

mastercb wrote:After trying several solitions without sucess (deactivationg antivirus, setting the viewer allowed for firewall ...), I found the final solution:

i just copied an old version (7.4.4) of the viewer into the FAH Program (7.5.1) directory an the viewer works perfect (it's "online" connected and shows the current folding protein and the "live" status infos). :D

Hope it helps for you, too.


Hey mastercb, where did you find an old version of the Viewer? I'd like to try this solution on my machine.
rplate
 
Posts: 5
Joined: Mon Jan 07, 2013 4:22 am

Re: error: 10053 when using viewer

Postby mastercb » Mon Feb 25, 2019 4:16 pm

Unfortunately it is not possible to post attachments in this board. I do not know, if it would be allowed to upload the file to an external hosting-service due to copyright.
Perhaps, you can find an "old installer" of version 7.4.4. somewhere on the FAH-website.
mastercb
 
Posts: 2
Joined: Sat Feb 09, 2019 9:29 pm

Re: error: 10053 when using viewer

Postby foldy » Mon Feb 25, 2019 5:13 pm

I can connect with old FahViewer 7.4.4 to new FahClient 7.5.1 to a GPU unit but do not see the 3D object.
foldy
 
Posts: 1372
Joined: Sat Dec 01, 2012 3:43 pm

Re: error: 10053 when using viewer

Postby bruce » Mon Feb 25, 2019 5:40 pm

7.4.4 put the 3D opjects in 2 different places depending on the FAHCore. The viewer could find only some of them. This was supposedly resolved in 7.5.1.

I'm not sure what 10053 means.
bruce
 
Posts: 22127
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: error: 10053 when using viewer

Postby Joe_H » Mon Feb 25, 2019 7:29 pm

As I recall, the 7.4.4 viewer did not have the ability to view GPU WU's. The 7.5.1 one could in theory, but the GPU cores are not set up currently to deliver the needed information to FAHViewer.

For CPU WU's I don't recall the 7.4.4 version being able to display A7 WU's, just those from A4 projects. One of the intermediate versions between 7.4.4 and 7.5.1 added the ability to display A7 WU's, but the code for showing A4 ones was removed.

So trying to display a GPU WU is not going to work. For CPU WU's I have had no issues displaying A7 projects with the 7.5.1 FAHViewer.

As for getting older versions of the client, there is a link at the bottom of the Beta page - https://foldingathome.org/beta/. Not all versions are present, but a number of them are.
Joe_H
Site Admin
 
Posts: 4393
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: error: 10053 when using viewer

Postby bruce » Mon Feb 25, 2019 8:57 pm

ALL FAHCores should put the viewer data in the same location and the Viewer should look there. It sounds like A7 is putting it in the "right place" and A4 was not updated to match. Where is _21 (and _22) putting it?
bruce
 
Posts: 22127
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: error: 10053 when using viewer

Postby Joe_H » Mon Feb 25, 2019 10:51 pm

From what I understood, the A4 core used a kludge to output data for the viewer, it does not put out viewer frames the same way the A7 core does. Since A4 was last updated many years ago, not expecting it to be.

There was some information on what needed to be done to get the GPU cores generating usable data for FAHViewer some time ago, but unfortunately I don't recall the details. Would have to check with the developers to find out the current state of progress for them.
Joe_H
Site Admin
 
Posts: 4393
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: error: 10053 when using viewer

Postby toTOW » Tue Feb 26, 2019 9:14 pm

The only way I found to be able to use the viewer with GPU core was to use ChristianVirtual's wrapper : https://github.com/ChristianVirtual/FAH ... Trajectory

It's been years since I last saw a real protein drawn natively by the viewer ... :(
User avatar
toTOW
Site Moderator
 
Posts: 8643
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France


Return to New Donors start here

Who is online

Users browsing this forum: No registered users and 1 guest

cron