FAH will not connect properly

If you're new to FAH and need help getting started or you have very basic questions, start here.

Moderators: Site Moderators, PandeGroup

Re: FAH will not connect properly

Postby Lingon » Wed Apr 10, 2019 9:11 am

bruce wrote:Please post the top page or two of FAHlog.log showing the hardware that FAHClient detects. That will probably will help us resolve your issue.

Have you installed the proprietary GPU drivers directly from AMD? ... and rebooted after changing the drivers?


As far as I understood it from my last endeavour into Ubuntu-based desktop OSs on my main machine is that there is no more proprietary AMD drivers for it any more (fglrx) and that the main driver for AMD is now the open source one. I could of course be wrong; but unlike a few years ago, I can no longer switch between the open source and the proprietary drivers in the driver manager, as no option to do so appears.

Regarding the FAHlog.log, you did not specify where to find it. After some searching online, I was manage to locate this page https://foldingathome.org/faqs/installa ... locations/ which tells me to look inside /var/lib/fahclient. However, this folder, while existing, is completely empty.

foldy wrote:I just learned on Linux Ubuntu and Mint there is a new command systemctl
Code: Select all
sudo systemctl start FAHClient


This spat out the following response:

Code: Select all
Job for FAHClient.service failed because the control process exited with error code.
See "systemctl status FAHClient.service" and "journalctl -xe" for details.



Gave me:

Code: Select all
● FAHClient.service - LSB: Folding@home Client
   Loaded: loaded (/etc/init.d/FAHClient; generated)
   Active: failed (Result: exit-code) since Wed 2019-04-10 10:50:39 CEST; 24s ag
     Docs: man:systemd-sysv-generator(8)
  Process: 3358 ExecStart=/etc/init.d/FAHClient start (code=exited, status=1/FAI

apr 10 10:50:38 MintHost systemd[1]: Starting LSB: Folding@home Client...
apr 10 10:50:39 MintHost FAHClient[3358]: Starting fahclient ... FAIL
apr 10 10:50:39 MintHost systemd[1]: FAHClient.service: Control process exited,
apr 10 10:50:39 MintHost systemd[1]: FAHClient.service: Failed with result 'exit
apr 10 10:50:39 MintHost systemd[1]: Failed to start LSB: Folding@home Client.


And the latter command

Code: Select all
journalctl -xe


Gave a monstrously long wall of text, long enough to make me not want to post it here.
Lingon
 
Posts: 10
Joined: Sat Mar 30, 2019 12:52 pm

Re: FAH will not connect properly

Postby foldy » Wed Apr 10, 2019 11:55 am

FAH Installation looks corrupted. Did you try to uninstall FAH and install it again?
foldy
 
Posts: 1362
Joined: Sat Dec 01, 2012 3:43 pm

Re: FAH will not connect properly

Postby Lingon » Wed Apr 10, 2019 6:35 pm

I did, yes. A couple of times at that. FAH only keeps data on the drive it is installed to, right?

But, I suspect since I had a freeze during the first install that something went wrong and it perhaps did not manage to recover from there. How would I go about wiping the entire install for sure, without a hard drive reformat?
Lingon
 
Posts: 10
Joined: Sat Mar 30, 2019 12:52 pm

Re: FAH will not connect properly

Postby Theodore » Fri Apr 12, 2019 10:42 pm

I don't have a lot of Linux knowledge, but I remember trying to install fah as well on other Linux machines, and found that the installer (apt or apt-get) doesn't install the dependencies.
Since then, I use a built in installer from the GUI, so I don't need the command to force-install the dependencies.

If you don't have the GUI, I would recommend to completely remove fah, and follow the manual.

Try to repeat the command on the main page (advanced Linux install)here, using --force-depends:

https://foldingathome.org/support/faq/i ... -advanced/

And make sure to replace the Deb version with the one you downloaded from the main page, (as the manual isn't updated recently and uses an older version of fah).
Theodore
 
Posts: 71
Joined: Sun Feb 10, 2019 2:07 pm

Re: FAH will not connect properly

Postby Lingon » Sun Apr 14, 2019 2:23 pm

Theodore wrote:I don't have a lot of Linux knowledge, but I remember trying to install fah as well on other Linux machines, and found that the installer (apt or apt-get) doesn't install the dependencies.
Since then, I use a built in installer from the GUI, so I don't need the command to force-install the dependencies.

If you don't have the GUI, I would recommend to completely remove fah, and follow the manual.

Try to repeat the command on the main page (advanced Linux install)here, using --force-depends:

https://foldingathome.org/support/faq/i ... -advanced/

And make sure to replace the Deb version with the one you downloaded from the main page, (as the manual isn't updated recently and uses an older version of fah).


I was prompted to install dependencies in the regular installation method, which all completed without error. So unfortunately, this does not seem to be my problem.
Lingon
 
Posts: 10
Joined: Sat Mar 30, 2019 12:52 pm

Re: FAH will not connect properly

Postby MeeLee » Sun Apr 14, 2019 4:21 pm

foldy wrote:
Code: Select all
sudo apt-get install ocl-icd-libopencl1
sudo apt-get install ocl-icd-opencl-dev

Just double checking,
This command is for AMD cards, not Nvidia, right?
MeeLee
 
Posts: 84
Joined: Tue Feb 19, 2019 10:16 pm

Re: FAH will not connect properly

Postby toTOW » Sun Apr 14, 2019 4:59 pm

I'd say both ...
Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.

FAH-Addict : latest news, tests and reviews about Folding@Home project.

Image
User avatar
toTOW
Site Moderator
 
Posts: 8639
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France

Previous

Return to New Donors start here

Who is online

Users browsing this forum: No registered users and 2 guests

cron