Page 1 of 1

Folding with mixed Nvidia GPU's

PostPosted: Thu Apr 18, 2013 2:19 am
by Xantac
Well I used to fold on an EVGA Classified 3 motherboard with a gtx680 and a couple gtx280's, and I remember briefly how to get it going, I know that to find which gpu is in which pci slot you must monitor them while changing the gpu-index. On my Asus rampage IV extreme the top PCI-E slot(gtx680) I changed the gpu-index to 1 , and the 2nd PCI-E from top(260) I changed the index to 0.
To get my 680 folding again I use these settings

GTX 680 top slot on motherboard.
gpu-index set at 1
opencl-index set to 0
Cuda-index set to 0

GTX 260 2nd from the top pci-e slot
gpu-index set at 0
opencl-index set to ???
Cuda-index set to ???

But I can't seem to get the 260 to fold

So how does opencl/cuda relate to how the card will fold once I have found the correct slot .I haven't found the opencl and cuda correct #'s to get my 260 folding yet.

Asus Rive
Dominator 2133 1.5v, 4x4gb
Seasonic X1250

Re: Folding with mixed Nvidia GPU's

PostPosted: Thu Apr 18, 2013 2:35 am
by Xantac
Windows 8 64bit, F@H version 7.3.6
I just wish I understood when and why I should change the opencl/cuda-index
Have some 460's coming over the next couple weeks, and Im hoping mixing 400 and 600 cards are not as hard as mixing 200's

Re: Folding with mixed Nvidia GPU's

PostPosted: Thu Apr 18, 2013 2:55 am
by PantherX
I was able to successfully get GTX 660 Ti and GTX 260 fold in the same system simultaneously. However, it was more of trial and error.

I got rid of the existing GPU Slots. Started two instances of GPU-Z, one for each GPU and switched to Sensors tab. I then added the first GPU Slot. FAH identified it as GTX 660 Ti but GPU-Z showed GTX 260 the load. I then edited the GPU Slot via FAHControl to have both index set to 0 and confirmed that GTX 660 Ti was correctly assigned. I then Paused it and added the second GPU Slot which identified itself as GTX 260. However, it showed that GTX 660 Ti was getting the load. Now, that's where things got buggy for me since the indexes of both slots were reverted to the default ones which were incorrect when I edited them from FAHControl. I then closed the F@H Client, and manually edited the config.xml file (C:\Users\PantherX\AppData\Roaming\FAHClient) with the correct values, in my case:
GTX 660 Ti (First Slot)
gpu-index = 1
opencl-index = 0
Cuda-index = 0

GTX 260 (Second Slot)
gpu-index = 0
opencl-index = 1
Cuda-index = 1

I saved the config.xml and then restarted F@H and it worked perfectly. Do note that editing the config.xml file isn't normally recommended and if done, care should be taken to ensure that the file doesn't get corrupted (like trying to modify it while F@H is running, etc).

AFAIK, mixing 400 Series and 600 Series will not be that significant issues since both GPU series can run the same FahCore version. However, with Pre-Fermi GPUs, a different FahCore was needed which is incompatible with the Fermi/Kepler GPUs, hence the issue. Moreover, IIRC, the indexes are done differently by some softwares like, Microsoft will view (enumerate) them differently than GPU-Z/CUDA-Z, etc. Hence a trial and error method is needed. Hopefully, the future F@H Clients will be better at this.

Re: Folding with mixed Nvidia GPU's

PostPosted: Thu Apr 18, 2013 3:41 am
by Xantac
Thank you with your settings some restarts, and a little toying around I now can fold on my 3930k,gtx680, and the gtx 260.

PantherX you da MAN!

Re: Folding with mixed Nvidia GPU's

PostPosted: Thu Apr 18, 2013 3:53 am
by PantherX
That's great to hear.

Just make sure that the CPU isn't being over-utilized, i.e. if you set SMP:8, and you perform normal tasks, you may want to check our SMP:7 or SMP:6 to see which one yields the highest PPD since interruptions to SMP will cause it to slow down in a non-linear fashion. Moreover, if the CPU is fully utilized, it may be "starving" the GPUs which would result in a lower PPD production form the GPUs. Hence you may find that tweaking the SMP:X value for your needs is the best option. Just be careful to not change the values mid-WU since it might cause the WU to error out. Better to set the slot to finish and then change the number to see what positive/negative effect it has.