GT 555M Won't Start WUs

If you're new to FAH and need help getting started or you have very basic questions, start here.

Moderators: Site Moderators, FAHC Science Team

GT 555M Won't Start WUs

Postby albrecd » Thu Apr 09, 2020 12:11 am

I'm just getting started folding. My CPU is folding well but I can't seem to get my GPU up and running.

I can see that the GPU is assigned WUs, but throws an error and returns each WU after a few seconds. It then sits in the "Ready" state until a new WU is assigned (when then throws the same error and so on).
The specific error that I'm seeing in the logs is "BAD_WORK_UNIT (114 = 0x72)". Full log is included below.

I searched around these forums for similar issues and have tried the following:
    - Restarted both client and computer multiple times.
    - Reinstalled client.
    - Set Folding Power slider to Full.
    - Limited CPU to use only 6/8 threads.
    - Updated latest drivers from NVidia website (Version 391.35 WHQL).
    - Verified that there is an entry for my GPU in the GPU.txt file.
    - Verified that my firewall is not blocking related traffic.

Thanks!
Danny

System Setup (taken at error time):
Code: Select all
CPU Intel(R) Core(TM) i7-2760QM CPU @ 2.40GHz
CPU ID GenuineIntel Family 6 Model 42 Stepping 7
CPUs 8
Memory 15.95GiB
Free Memory 13.52GiB
Threads WINDOWS_THREADS
OS Version 6.2
Has Battery true
On Battery false
UTC Offset -7
PID 11776
CWD C:\Users\...
OS Windows 10 Home
OS Arch AMD64
GPUs 1
GPU 0 Bus:1 Slot:0 Func:0 NVIDIA:2 GF106 [GeForce GT 555M (Dell)
CUDA Device 0 Platform:0 Device:0 Bus:1 Slot:0 Compute:2.1 Driver:9.1
OpenCL Device 0 Platform:0 Device:0 Bus:1 Slot:0 Compute:1.1 Driver:391.35
Win32 Service false


GPU Log:
Code: Select all
*********************** Log Started 2020-04-08T15:12:48Z ***********************
15:12:48:************************* Folding@home Client *************************
15:12:48:        Website: https://foldingathome.org/
15:12:48:      Copyright: (c) 2009-2018 foldingathome.org
15:12:48:         Author: Joseph Coffland <joseph@cauldrondevelopment.com>
15:12:48:           Args:
15:12:48:         Config: C:\Users\*****\AppData\Roaming\FAHClient\config.xml
15:12:48:******************************** Build ********************************
15:12:48:        Version: 7.5.1
15:12:48:           Date: May 11 2018
15:12:48:           Time: 13:06:32
15:12:48:     Repository: Git
15:12:48:       Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
15:12:48:         Branch: master
15:12:48:       Compiler: Visual C++ 2008
15:12:48:        Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
15:12:48:       Platform: win32 10
15:12:48:           Bits: 32
15:12:48:           Mode: Release
15:12:48:******************************* System ********************************
15:12:48:            CPU: Intel(R) Core(TM) i7-2760QM CPU @ 2.40GHz
15:12:48:         CPU ID: GenuineIntel Family 6 Model 42 Stepping 7
15:12:48:           CPUs: 8
15:12:48:         Memory: 15.95GiB
15:12:48:    Free Memory: 13.52GiB
15:12:48:        Threads: WINDOWS_THREADS
15:12:48:     OS Version: 6.2
15:12:48:    Has Battery: true
15:12:48:     On Battery: false
15:12:48:     UTC Offset: -7
15:12:48:            PID: 11776
15:12:48:            CWD: C:\Users\*****\AppData\Roaming\FAHClient
15:12:48:             OS: Windows 10 Home
15:12:48:        OS Arch: AMD64
15:12:48:           GPUs: 1
15:12:48:          GPU 0: Bus:1 Slot:0 Func:0 NVIDIA:2 GF106 [GeForce GT 555M (Dell)]
15:12:48:  CUDA Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:2.1 Driver:9.1
15:12:48:OpenCL Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:1.1 Driver:391.35
15:12:48:  Win32 Service: false
15:12:48:***********************************************************************
15:12:48:<config>
15:12:48:  <!-- Network -->
15:12:48:  <proxy v=':8080'/>
15:12:48:
15:12:48:  <!-- Slot Control -->
15:12:48:  <power v='full'/>
15:12:48:
15:12:48:  <!-- User Information -->
15:12:48:  <passkey v='********************************'/>
15:12:48:  <team v='*****'/>
15:12:48:  <user v='*****'/>
15:12:48:
15:12:48:  <!-- Folding Slots -->
15:12:48:  <slot id='0' type='CPU'>
15:12:48:    <cpus v='6'/>
15:12:48:  </slot>
15:12:48:  <slot id='1' type='GPU'/>
15:12:48:</config>
15:12:48:Trying to access database...
15:12:48:Successfully acquired database lock
15:12:48:Enabled folding slot 00: READY cpu:6
15:12:48:Enabled folding slot 01: READY gpu:0:GF106 [GeForce GT 555M (Dell)]



15:18:05:WU01:FS01:Connecting to 65.254.110.245:8080
15:18:05:WU01:FS01:Assigned to work server 40.114.52.201
15:18:06:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GF106 [GeForce GT 555M (Dell)] from 40.114.52.201
15:18:06:WU01:FS01:Connecting to 40.114.52.201:8080
15:18:14:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:18:17:WU00:FS00:0xa7:Completed 2500 out of 250000 steps (1%)
15:18:30:ERROR:Receive error: 10053: An established connection was aborted by the software in your host machine.
15:18:36:WU01:FS01:Downloading 29.70MiB
15:18:42:WU01:FS01:Download 55.35%
15:18:48:WU01:FS01:Download 82.29%
15:18:51:WU01:FS01:Download complete
15:18:51:WU01:FS01:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:11777 run:0 clone:11061 gen:11 core:0x22 unit:0x0000001a287234c95e7432bb5a80beb4
15:18:51:WU01:FS01:Starting
15:18:51:WU01:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\albrecd\AppData\Roaming\FAHClient\cores/cores.foldingathome.org/v7/win/64bit/Core_22.fah/FahCore_22.exe -dir 01 -suffix 01 -version 705 -lifeline 11776 -checkpoint 15 -gpu-vendor nvidia -opencl-platform 0 -opencl-device 0 -cuda-device 0 -gpu 0
15:18:51:WU01:FS01:Started FahCore on PID 10220
15:18:52:WU01:FS01:Core PID:12192
15:18:52:WU01:FS01:FahCore 0x22 started
15:18:52:WU01:FS01:0x22:*********************** Log Started 2020-04-08T15:18:52Z ***********************
15:18:52:WU01:FS01:0x22:*************************** Core22 Folding@home Core ***************************
15:18:52:WU01:FS01:0x22:       Type: 0x22
15:18:52:WU01:FS01:0x22:       Core: Core22
15:18:52:WU01:FS01:0x22:    Website: https://foldingathome.org/
15:18:52:WU01:FS01:0x22:  Copyright: (c) 2009-2018 foldingathome.org
15:18:52:WU01:FS01:0x22:     Author: John Chodera <john.chodera@choderalab.org> and Rafal Wiewiora
15:18:52:WU01:FS01:0x22:             <rafal.wiewiora@choderalab.org>
15:18:52:WU01:FS01:0x22:       Args: -dir 01 -suffix 01 -version 705 -lifeline 10220 -checkpoint 15
15:18:52:WU01:FS01:0x22:             -gpu-vendor nvidia -opencl-platform 0 -opencl-device 0 -cuda-device
15:18:52:WU01:FS01:0x22:             0 -gpu 0
15:18:52:WU01:FS01:0x22:     Config: <none>
15:18:52:WU01:FS01:0x22:************************************ Build *************************************
15:18:52:WU01:FS01:0x22:    Version: 0.0.2
15:18:52:WU01:FS01:0x22:       Date: Dec 6 2019
15:18:52:WU01:FS01:0x22:       Time: 21:30:31
15:18:52:WU01:FS01:0x22: Repository: Git
15:18:52:WU01:FS01:0x22:   Revision: abeb39247cc72df5af0f63723edafadb23d5dfbe
15:18:52:WU01:FS01:0x22:     Branch: HEAD
15:18:52:WU01:FS01:0x22:   Compiler: Visual C++ 2008
15:18:52:WU01:FS01:0x22:    Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
15:18:52:WU01:FS01:0x22:   Platform: win32 10
15:18:52:WU01:FS01:0x22:       Bits: 64
15:18:52:WU01:FS01:0x22:       Mode: Release
15:18:52:WU01:FS01:0x22:************************************ System ************************************
15:18:52:WU01:FS01:0x22:        CPU: Intel(R) Core(TM) i7-2760QM CPU @ 2.40GHz
15:18:52:WU01:FS01:0x22:     CPU ID: GenuineIntel Family 6 Model 42 Stepping 7
15:18:52:WU01:FS01:0x22:       CPUs: 8
15:18:52:WU01:FS01:0x22:     Memory: 15.95GiB
15:18:52:WU01:FS01:0x22:Free Memory: 12.57GiB
15:18:52:WU01:FS01:0x22:    Threads: WINDOWS_THREADS
15:18:52:WU01:FS01:0x22: OS Version: 6.2
15:18:52:WU01:FS01:0x22:Has Battery: true
15:18:52:WU01:FS01:0x22: On Battery: false
15:18:52:WU01:FS01:0x22: UTC Offset: -7
15:18:52:WU01:FS01:0x22:        PID: 12192
15:18:52:WU01:FS01:0x22:        CWD: C:\Users\albrecd\AppData\Roaming\FAHClient\work
15:18:52:WU01:FS01:0x22:         OS: Windows 10 Home
15:18:52:WU01:FS01:0x22:    OS Arch: AMD64
15:18:52:WU01:FS01:0x22:********************************************************************************
15:18:52:WU01:FS01:0x22:Project: 11777 (Run 0, Clone 11061, Gen 11)
15:18:52:WU01:FS01:0x22:Unit: 0x0000001a287234c95e7432bb5a80beb4
15:18:52:WU01:FS01:0x22:Reading tar file core.xml
15:18:52:WU01:FS01:0x22:Reading tar file integrator.xml
15:18:52:WU01:FS01:0x22:Reading tar file state.xml
15:18:53:WU01:FS01:0x22:Reading tar file system.xml
15:18:54:WU01:FS01:0x22:Digital signatures verified
15:18:54:WU01:FS01:0x22:Folding@home GPU Core22 Folding@home Core
15:18:54:WU01:FS01:0x22:Version 0.0.2
15:19:44:WU01:FS01:0x22:ERROR:exception: Error initializing context: clGetDeviceInfo (-5)
15:19:44:WU01:FS01:0x22:Saving result file ..\logfile_01.txt
15:19:44:WU01:FS01:0x22:Saving result file science.log
15:19:44:WU01:FS01:0x22:Folding@home Core Shutdown: BAD_WORK_UNIT
15:19:45:WARNING:WU01:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
15:19:45:WU01:FS01:Sending unit results: id:01 state:SEND error:FAULTY project:11777 run:0 clone:11061 gen:11 core:0x22 unit:0x0000001a287234c95e7432bb5a80beb4
15:19:45:WU01:FS01:Uploading 8.00KiB to 40.114.52.201
15:19:45:WU01:FS01:Connecting to 40.114.52.201:8080
albrecd
 
Posts: 2
Joined: Wed Apr 08, 2020 5:07 pm
Location: BC, Canada

Re: GT 555M Won't Start WUs

Postby Joe_H » Thu Apr 09, 2020 12:51 am

I see two possibilities. The first may be the GPU itself. It is listed as only supporting OpenCL 1.1, version 1.2 s often the minimum level. Some people with GPUs supporting 1.1 have reported success folding some WUs, and not others. A clear pattern has not emerged, it may just be that some projects are using different aspects of the OpenCL code.

Second is that from the hardware, CPU and GPU, this appears to be a laptop. There is a tech that uses the iGPU of the CPU for low power graphics usage and switches to the discrete GPU when more power is needed. For folding to work on such a system the iGPU needs to be disabled and the 550m set to work all of the time. The F@h software does not handle the switch between an unsupported Intel iGPU to the other GPU.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 6076
Joined: Tue Apr 21, 2009 5:41 pm
Location: W. MA

Re: GT 555M Won't Start WUs

Postby JimboPalmer » Thu Apr 09, 2020 1:01 am

Welcome to Folding@Home!

First I am going to advise you not to bother to try to get this to work.

https://www.techpowerup.com/gpu-specs/g ... 555m.c1494

Firstly, it does not support OpenCL 1.2 but some cards that don't do get work.

Secondly, it may not complete work in time for the deadlines, it was an entry level card 11 years ago.

Thirdly Nvidia uses a technology called Optimus, where an intel GPU runs until you hit work that requires more power, and starts the Nividia card. This saves battery life and heat. Sadly, F@H never supports Intel GPUs.

https://www.geforce.com/hardware/technology/optimus

Fourthly, your laptop will get hot!

Different generations had different work arounds, in the BIOS, in the Nvidia Control Panel, (supposedly in 3D settings), and by running utilities. viewtopic.php?f=61&t=34075
Tsar of all the Rushers
I tried to remain childlike, all I achieved was childish.
A friend to those who want no friends
JimboPalmer
 
Posts: 1767
Joined: Mon Feb 16, 2009 5:12 am
Location: Greenwood MS USA

Re: GT 555M Won't Start WUs

Postby bruce » Thu Apr 09, 2020 1:15 am

The server distributing 11777 is incorrectly distributing projects that require GPUSpecies 3 to devices that are GPUSpecies 2. (That's equivalent to WUs that require OpenCl 1.2 to devices that support only OpenCL1.1) I'll notify the owner of that server. Unfortunately that SHOULD mean that you won't be getting any more assignments. :(
bruce
 
Posts: 19083
Joined: Thu Nov 29, 2007 11:13 pm
Location: So. Cal.

Re: GT 555M Won't Start WUs

Postby albrecd » Thu Apr 09, 2020 2:30 am

Thanks for the replies (and the up-front advice)!
I might give it another go with the integrated graphics disabled to see if that works, but assuming it doesn't I'll stick to CPU folding.

Thanks again!
albrecd
 
Posts: 2
Joined: Wed Apr 08, 2020 5:07 pm
Location: BC, Canada

Re: GT 555M Won't Start WUs

Postby FoldingFodder » Sat Apr 11, 2020 8:17 pm

I've tried running FAH with a GT630M. It massively struggled. Watching it in task manager, the GPU would spike every other second. A quick Google highlighted that the GT630M was missing a few features and it shouldn't be folding. So i just removed the GPU slot and only have a CPU slot processing work units.

I have FAH running on a far more powerful computer and i've noticed that the work load placed on the CPU and GPU is pretty stable. If yours is also spiking, then i assume it's struggling just like mine. I'm also going to guess that if my ancient GPU is missing some features required, then your even older GPU will have them missing too.
FoldingFodder
 
Posts: 44
Joined: Sat Apr 04, 2020 7:07 pm

Re: GT 555M Won't Start WUs

Postby PantherX » Sun Apr 12, 2020 12:48 am

FYI, If you use Task Manager to view the GPU Usage, you have to ensure that you change the graph to CUDA for Nvidia GPUs. I am not sure what the AMD GPUs use.
ETA:
Now ↞ Very Soon ↔ Soon ↔ Soon-ish ↔ Not Soon ↠ End Of Time

Welcome To The F@H Support Forum Ӂ Troubleshooting Bad WUs Ӂ Troubleshooting Server Connectivity Issues
User avatar
PantherX
Site Moderator
 
Posts: 6142
Joined: Wed Dec 23, 2009 10:33 am
Location: Land Of The Long White Cloud

Re: GT 555M Won't Start WUs

Postby Rel25917 » Sun Apr 12, 2020 1:55 am

I think compute for amd and sometimes nvidia, just look through them all and you'll find one showing ~99%.
Rel25917
 
Posts: 297
Joined: Wed Aug 15, 2012 3:31 am


Return to New Donors start here

Who is online

Users browsing this forum: No registered users and 3 guests

cron