Reversed GPU 0/GPU 1 designations?

Moderators: Site Moderators, PandeGroup

Re: Reversed GPU 0/GPU 1 designations?

Postby chessmc » Sat Jul 16, 2011 3:01 pm

The gpu-index in my system info doesn't correspond with the results of -gpu x
Code: Select all
 GPUs: 2
   OS: Microsoft Windows 7 Professional
08:43:58:          CPU: Intel(R) Core(TM) i7 CPU 930 @ 2.80GHz
08:43:58:       CPU ID: GenuineIntel Family 6 Model 26 Stepping 5
08:43:58:         CPUs: 8
08:43:58:       Memory: 5.99GiB
08:43:58:  Free Memory: 1.34GiB
08:43:58:      Threads: WINDOWS_THREADS
08:43:58:         GPUs: 2
08:43:58:        GPU 0: FERMI:1 GF104 [GeForce GTX 460]
08:43:58:        GPU 1: FERMI:1 GF110 [Geforce GTX 570]
08:43:58:         CUDA: 2.0
08:43:58:  CUDA Driver: 4000

-gpu 0 runs on the GTX570.
-gpu 1 runs on the GTX460.
chessmc
 
Posts: 5
Joined: Sat Jul 16, 2011 2:43 pm

Re: Reversed GPU 0/GPU 1 designations?

Postby 7im » Sat Jul 16, 2011 8:02 pm

Hello chessmc, welcome to the forum.

Yes, as you must have read in the previous posts in this forum topic already (hence the topic title), the V7 client gpu order is displayed differently than in the v6 client.

This is only a concern if only folding on one of the two GPUs, and the first one is not the one you want to use. If folding on both, it doesn't really matter since both cards are Fermi cards.
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.
User avatar
7im
 
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Location: Arizona

Re: Reversed GPU 0/GPU 1 designations?

Postby MikeBerlin » Fri Oct 12, 2012 11:03 pm

I had the same problem, but I haven´t two fermi cards, so that every GPU starts with the wrong core!
GPU0 : GTX 660 TI
GPU1: GTX 260 (non fermi!)
but the FAHControl said:
GPU0: GTX 260 (non fermi!)
GPU1 : GTX 660 TI
I´ve solved the problem:
Configure -> Slots -> Folding Slots -> GPU (ID x) -> Edit -> gpu-index = 1; opencl-index = 0; cuda-index = 0; extra-slot-option -> add -> client-type:beta -> OK (for the GTX 660 TI; fermi-core)
-> GPU (ID y) -> Edit -> gpu-index = 0; opencl-index = 1; cuda-index = 1 -> OK (for the GTX 260)
Hope, this is helpful.
Anyone who can read has a unique advantage.
MikeBerlin
 
Posts: 7
Joined: Thu Oct 11, 2012 6:45 pm

Re: Reversed GPU 0/GPU 1 designations?

Postby wiz486 » Fri Nov 02, 2012 1:12 am

^^^ The above post fixed my very frustrating issue of attempting to mix a GTX 260 with a GTX 670. I know the GPUs were being indexed backwards but couldn't fix it!

Thanks!
wiz486
 
Posts: 2
Joined: Fri Nov 02, 2012 1:10 am

Previous

Return to V7.1.52 Windows/Linux

Who is online

Users browsing this forum: No registered users and 2 guests

cron