V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Moderators: Site Moderators, PandeGroup

V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby morphus » Wed Oct 12, 2011 1:22 pm

Hello,

Just installed V7.1.38, and it detect a SMP and 2 GPU.
SMP is working fine
For the 2 GPU however, they always generate the following error message
13:20:44:FahCore, running Unit 00, returned: UNKNOWN_ENUM (-10 = 0xfffffff6)
13:20:44:FahCore, running Unit 01, returned: UNKNOWN_ENUM (-10 = 0xfffffff6)

If any body have an idea it would be appreciate

under SYSTEM
GPU 0 ATI:3 M92 (Mobility Radeon HD 4500 Series)
GPU 1 ATI:3 RV710/730

here is the log
Code: Select all
13:20:29:Unit 00:
13:20:29:Unit 00:*------------------------------*
13:20:29:Unit 00:Folding@Home GPU Core - Beta
13:20:29:Unit 00:Version 1.24 (Mon Feb 9 11:00:12 PST 2009)
13:20:29:Unit 00:
13:20:29:Unit 00:Compiler  : Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 14.00.50727.762 for 80x86
13:20:29:Unit 00:Build host: amoeba
13:20:29:Unit 00:Board Type: AMD
13:20:29:Unit 00:Core      :
13:20:29:Unit 00:Preparing to commence simulation
13:20:29:Unit 00:- Ensuring status. Please wait.
13:20:29:Unit 01:
13:20:29:Unit 01:*------------------------------*
13:20:29:Unit 01:Folding@Home GPU Core - Beta
13:20:29:Unit 01:Version 1.24 (Mon Feb 9 11:00:12 PST 2009)
13:20:29:Unit 01:
13:20:29:Unit 01:Compiler  : Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 14.00.50727.762 for 80x86
13:20:29:Unit 01:Build host: amoeba
13:20:29:Unit 01:Board Type: AMD
13:20:29:Unit 01:Core      :
13:20:29:Unit 01:Preparing to commence simulation
13:20:29:Unit 01:- Ensuring status. Please wait.
13:20:38:Unit 00:- Looking at optimizations...
13:20:38:Unit 00:- Working with standard loops on this execution.
13:20:38:Unit 00:- Previous termination of core was improper.
13:20:38:Unit 00:- Going to use standard loops.
13:20:38:Unit 00:- Files status OK
13:20:38:Unit 00:- Expanded 96711 -> 489152 (decompressed 505.7 percent)
13:20:38:Unit 00:Called DecompressByteArray: compressed_data_size=96711 data_size=489152, decompressed_data_size=489152 diff=0
13:20:38:Unit 00:- Digital signature verified
13:20:38:Unit 00:
13:20:38:Unit 00:Project: 5736 (Run 3, Clone 554, Gen 766)
13:20:38:Unit 00:
13:20:38:Unit 00:Entering M.D.
13:20:38:Unit 01:- Looking at optimizations...
13:20:38:Unit 01:- Working with standard loops on this execution.
13:20:38:Unit 01:- Previous termination of core was improper.
13:20:38:Unit 01:- Going to use standard loops.
13:20:38:Unit 01:- Files status OK
13:20:38:Unit 01:- Expanded 96691 -> 489152 (decompressed 505.8 percent)
13:20:38:Unit 01:Called DecompressByteArray: compressed_data_size=96691 data_size=489152, decompressed_data_size=489152 diff=0
13:20:38:Unit 01:- Digital signature verified
13:20:38:Unit 01:
13:20:38:Unit 01:Project: 5737 (Run 4, Clone 580, Gen 765)
13:20:38:Unit 01:
13:20:38:Unit 01:Entering M.D.
13:20:44:FahCore, running Unit 00, returned: UNKNOWN_ENUM (-10 = 0xfffffff6)
13:20:44:FahCore, running Unit 01, returned: UNKNOWN_ENUM (-10 = 0xfffffff6)


Thank

ML

Mod Edit: Added Code Tags - PantherX
morphus
 
Posts: 1
Joined: Wed Oct 12, 2011 1:18 pm

Re: V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby 7im » Wed Oct 12, 2011 5:30 pm

Hello morphus, welcome to the forum.

-10 error usually means a driver problem. Try the regular ATI driver instead of the mobility driver. If regular drivers do not work for that card, try modding the mobility drivers. There is a thread on modding mobility drivers in the forum.

See also: http://fahwiki.net/index.php/CoreStatus_codes#FFFFFFF6_.28-10.29_or_0xfffffff6
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.
User avatar
7im
 
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Location: Arizona

Re: V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby gwildperson » Wed Oct 12, 2011 7:54 pm

I was experimenting with the limits of overclocking my GPU recently and rather than getting a UNSTABLE_MACHINE error, I got an UNKNOWN_ENUM(-10). There must be more than one cause for that error message.
gwildperson
 
Posts: 726
Joined: Tue Dec 04, 2007 8:36 pm

Re: V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby 7im » Wed Oct 12, 2011 10:30 pm

Morphus, please post your hardware config, and overclock settings.
User avatar
7im
 
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Location: Arizona

Re: V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby Eagle » Sun Oct 30, 2011 12:02 am

Hmm, seems like I get a familiar problem - but since I didn't know if it's worth to start a new thread, I chose to answer right here.

First of all, my log:
Code: Select all
23:49:31:Requesting new work unit for slot 00: READY gpu:0:"Radeon HD 5870 (Cypress)" from 171.64.65.56
23:49:31:Connecting to 171.64.65.56:8080
23:49:31:Server responded WORK_QUIT (404)
23:49:31:WARNING: Server did not like results, dumping
23:49:31:Cleaning up Unit 02
23:49:32:Slot 00: Downloading 43.99KiB
23:49:33:Slot 00: Download complete
23:49:33:Received Unit: id:00 state:DOWNLOAD error:OK project:11294 run:3 clone:201 gen:19 core:0x16 unit:0x000000160a3b1e5c4d9a1c740ead8b86
23:49:33:Starting Unit 00
23:49:33:Running core: "X:/PATH TO FAH/Folding At Home/cores/www.stanford.edu/~pande/Win32/AMD64/ATI/R600/Core_16.fah/FahCore_16.exe" -dir 00 -suffix 01 -lifeline 4740 -version 701 -checkpoint 15 -gpu 0 -forceasm
23:49:33:Started core on PID 3268
23:49:33:FahCore 0x16 started
23:49:33:Unit 00:
23:49:33:Unit 00:*------------------------------*
23:49:33:Unit 00:Folding@Home GPU Core
23:49:33:Unit 00:Version 2.11 (Thu Dec 9 15:00:14 PST 2010)
23:49:33:Unit 00:
23:49:33:Unit 00:Compiler  : Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 15.00.30729.01 for 80x86
23:49:33:Unit 00:Build host: user-f6d030f24f
23:49:33:Unit 00:Board Type: AMD/OpenCL
23:49:33:Unit 00:Core      : x=16
23:49:33:Unit 00: Window's signal control handler registered.
23:49:33:Unit 00:Preparing to commence simulation
23:49:33:Unit 00:- Assembly optimizations manually forced on.
23:49:33:Unit 00:- Not checking prior termination.
23:49:33:Unit 00:sizeof(CORE_PACKET_HDR) = 512 file=<>
23:49:33:Unit 00:- Expanded 44538 -> 169787 (decompressed 381.2 percent)
23:49:33:Unit 00:Called DecompressByteArray: compressed_data_size=44538 data_size=169787, decompressed_data_size=169787 diff=0
23:49:33:Unit 00:- Digital signature verified
23:49:33:Unit 00:
23:49:33:Unit 00:Project: 11294 (Run 3, Clone 201, Gen 19)
23:49:33:Unit 00:
23:49:33:Unit 00:Assembly optimizations on if available.
23:49:33:Unit 00:Entering M.D.
23:49:35:Unit 00:Tpr hash 00/wudata_01.tpr:  2947654244 1417649432 1506866261 2179788700 830893598
23:49:35:Unit 00:Working on PEPTIDE (1-42)
23:49:35:Unit 00:Client config unavailable.
23:49:38:FahCore, running Unit 00, returned: UNKNOWN_ENUM (-1073740777 = 0xc0000417)
23:49:38:Starting Unit 00
23:49:38:Running core: "X:/PATH TO FAH/Folding At Home/cores/www.stanford.edu/~pande/Win32/AMD64/ATI/R600/Core_16.fah/FahCore_16.exe" -dir 00 -suffix 01 -lifeline 4740 -version 701 -checkpoint 15 -gpu 0 -forceasm
23:49:38:Started core on PID 3232
23:49:38:FahCore 0x16 started
23:49:39:Unit 00:
23:49:39:Unit 00:*------------------------------*
23:49:39:Unit 00:Folding@Home GPU Core
23:49:39:Unit 00:Version 2.11 (Thu Dec 9 15:00:14 PST 2010)
23:49:39:Unit 00:
23:49:39:Unit 00:Compiler  : Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 15.00.30729.01 for 80x86
23:49:39:Unit 00:Build host: user-f6d030f24f
23:49:39:Unit 00:Board Type: AMD/OpenCL
23:49:39:Unit 00:Core      : x=16
23:49:39:Unit 00: Window's signal control handler registered.
23:49:39:Unit 00:Preparing to commence simulation
23:49:39:Unit 00:- Ensuring status. Please wait.
23:49:48:Unit 00:- Assembly optimizations manually forced on.
23:49:48:Unit 00:- Not checking prior termination.
23:49:48:Unit 00:sizeof(CORE_PACKET_HDR) = 512 file=<>
23:49:48:Unit 00:- Expanded 44538 -> 169787 (decompressed 381.2 percent)
23:49:48:Unit 00:Called DecompressByteArray: compressed_data_size=44538 data_size=169787, decompressed_data_size=169787 diff=0
23:49:48:Unit 00:- Digital signature verified
23:49:48:Unit 00:
23:49:48:Unit 00:Project: 11294 (Run 3, Clone 201, Gen 19)
23:49:48:Unit 00:
23:49:48:Unit 00:Assembly optimizations on if available.
23:49:48:Unit 00:Entering M.D.
23:49:50:Unit 00:Tpr hash 00/wudata_01.tpr:  2947654244 1417649432 1506866261 2179788700 830893598
23:49:50:Unit 00:Working on PEPTIDE (1-42)
23:49:50:Unit 00:Client config unavailable.
23:49:53:FahCore, running Unit 00, returned: UNKNOWN_ENUM (-1073740777 = 0xc0000417)
23:51:30:Downloading core from http://www.stanford.edu/~pande/Win32/AMD64/ATI/R600/Core_16.fah
23:51:30:Connecting to www.stanford.edu:80
23:51:30:FahCore 16: Downloading 1.04MiB
23:51:36:FahCore 16: 75.65%
23:51:37:FahCore 16: Download complete
23:51:37:Valid core signature
23:51:37:WARNING: FahCore has not changed since last download, aborting core update
23:51:37:Starting Unit 00
23:51:37:Running core: "X:/PATH TO FAH/Folding At Home/cores/www.stanford.edu/~pande/Win32/AMD64/ATI/R600/Core_16.fah/FahCore_16.exe" -dir 00 -suffix 01 -lifeline 4740 -version 701 -checkpoint 15 -gpu 0 -forceasm
23:51:37:Started core on PID 4884
23:51:37:FahCore 0x16 started
23:51:38:Unit 00:
23:51:38:Unit 00:*------------------------------*
23:51:38:Unit 00:Folding@Home GPU Core
23:51:38:Unit 00:Version 2.11 (Thu Dec 9 15:00:14 PST 2010)
23:51:38:Unit 00:
23:51:38:Unit 00:Compiler  : Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 15.00.30729.01 for 80x86
23:51:38:Unit 00:Build host: user-f6d030f24f
23:51:38:Unit 00:Board Type: AMD/OpenCL
23:51:38:Unit 00:Core      : x=16
23:51:38:Unit 00: Window's signal control handler registered.
23:51:38:Unit 00:Preparing to commence simulation
23:51:38:Unit 00:- Ensuring status. Please wait.
23:51:47:Unit 00:- Assembly optimizations manually forced on.
23:51:47:Unit 00:- Not checking prior termination.
23:51:47:Unit 00:sizeof(CORE_PACKET_HDR) = 512 file=<>
23:51:47:Unit 00:- Expanded 44538 -> 169787 (decompressed 381.2 percent)
23:51:47:Unit 00:Called DecompressByteArray: compressed_data_size=44538 data_size=169787, decompressed_data_size=169787 diff=0
23:51:47:Unit 00:- Digital signature verified
23:51:47:Unit 00:
23:51:47:Unit 00:Project: 11294 (Run 3, Clone 201, Gen 19)
23:51:47:Unit 00:
23:51:47:Unit 00:Assembly optimizations on if available.
23:51:47:Unit 00:Entering M.D.
23:51:49:Unit 00:Tpr hash 00/wudata_01.tpr:  2947654244 1417649432 1506866261 2179788700 830893598
23:51:49:Unit 00:Working on PEPTIDE (1-42)
23:51:49:Unit 00:Client config unavailable.
23:52:03:Unit 00:Starting GUI Server
23:52:03:FahCore, running Unit 00, returned: UNKNOWN_ENUM (-1073740777 = 0xc0000417)
23:53:14:Starting Unit 00
23:53:14:Running core: "X:/PATH TO FAH/Folding At Home/cores/www.stanford.edu/~pande/Win32/AMD64/ATI/R600/Core_16.fah/FahCore_16.exe" -dir 00 -suffix 01 -lifeline 4740 -version 701 -checkpoint 15 -gpu 0 -forceasm
23:53:14:Started core on PID 1560
23:53:14:FahCore 0x16 started
23:53:15:Unit 00:
23:53:15:Unit 00:*------------------------------*
23:53:15:Unit 00:Folding@Home GPU Core
23:53:15:Unit 00:Version 2.11 (Thu Dec 9 15:00:14 PST 2010)
23:53:15:Unit 00:
23:53:15:Unit 00:Compiler  : Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 15.00.30729.01 for 80x86
23:53:15:Unit 00:Build host: user-f6d030f24f
23:53:15:Unit 00:Board Type: AMD/OpenCL
23:53:15:Unit 00:Core      : x=16
23:53:15:Unit 00: Window's signal control handler registered.
23:53:15:Unit 00:Preparing to commence simulation
23:53:15:Unit 00:- Ensuring status. Please wait.
23:53:24:Unit 00:- Assembly optimizations manually forced on.
23:53:24:Unit 00:- Not checking prior termination.
23:53:24:Unit 00:sizeof(CORE_PACKET_HDR) = 512 file=<>
23:53:24:Unit 00:- Expanded 44538 -> 169787 (decompressed 381.2 percent)
23:53:24:Unit 00:Called DecompressByteArray: compressed_data_size=44538 data_size=169787, decompressed_data_size=169787 diff=0
23:53:24:Unit 00:- Digital signature verified
23:53:24:Unit 00:
23:53:24:Unit 00:Project: 11294 (Run 3, Clone 201, Gen 19)
23:53:24:Unit 00:
23:53:24:Unit 00:Assembly optimizations on if available.
23:53:24:Unit 00:Entering M.D.
23:53:26:Unit 00:Tpr hash 00/wudata_01.tpr:  2947654244 1417649432 1506866261 2179788700 830893598
23:53:26:Unit 00:Working on PEPTIDE (1-42)
23:53:26:Unit 00:Client config unavailable.
23:53:43:Unit 00:Starting GUI Server
23:53:44:FahCore, running Unit 00, returned: UNKNOWN_ENUM (-1073740777 = 0xc0000417)


I don't know why or what this says, because the wiki-page doesn't talk about that 417 error.

Additionally, I don't understand, why R600 is chosen, since it's a 5870 and therefore R700 would be correct, I believe?!
Lastly, I don't get why it keeps saying "Client config unavailable" - the config-file is there, because clicking "Configure" or "Preferences" gives my saved config-details.

As always: any help would be greatly appreciated!

Thanks in advance,
Martin
Michael Jordan: “I can accept failure — But I can’t accept not trying.”
Image
User avatar
Eagle
 
Posts: 157
Joined: Sun Feb 17, 2008 1:06 am
Location: » Earth » Europe » Germany

Re: V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby 7im » Mon Oct 31, 2011 3:43 pm

Don't know about the 417 error.

R600 is correct as far as V7 goes. It refers to the hardware level of the fahcore, not of your hardware. R700 hardware can run R600 fahcores without issue. There is no R700 fahcore at present.

Not sure about the missing config either. I'd need to see the ***System*** section of the fahlog to make a better guess. Wild guess is the non-standard install locations you've selected (X: drive?).
User avatar
7im
 
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Location: Arizona

Re: V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby codysluder » Mon Oct 31, 2011 4:33 pm

Are you using "extra-core-args"? The -forceasm came from somewhere and it doesn't mean anything for a gpu. What other args are you using? When you post the system section of your log, be sure to include the part of your log that echos the non-default changes that you've made to your configuration, along with a simple explanation of why you made those changes.

The UNKNOWN_ENUM is probably because you're trying to force a gpu to run in some way that's not supported.
codysluder
 
Posts: 2128
Joined: Sun Dec 02, 2007 12:43 pm

Re: V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby Eagle » Mon Oct 31, 2011 10:17 pm

Good evening guys,

I'm sorry for not getting back to you sooner - personal issues prevented me from doing so. But that's solved now :)
So, let's get straight to it:

- R600 suits well R700 in case of V7, understood. :)

- That "*** System ***" section is right here:
Code: Select all
16:29:44:******************************* System ********************************
16:29:44:          CPU: AMD Phenom(tm) II X4 955 Processor
16:29:44:       CPU ID: AuthenticAMD Family 16 Model 4 Stepping 2
16:29:44:         CPUs: 4
16:29:44:       Memory: 16.00GiB
16:29:44:  Free Memory: 10.01GiB
16:29:44:      Threads: WINDOWS_THREADS
16:29:44:   On Battery: false
16:29:44:   UTC offset: 1
16:29:44:          PID: 4972
16:29:44:          CWD: X:/Projects/Folding At Home
16:29:44:           OS: Windows 7 Ultimate
16:29:44:      OS Arch: AMD64
16:29:44:         GPUs: 1
16:29:44:        GPU 0: ATI:4 Radeon HD 5870 (Cypress)
16:29:44:         CUDA: Not detected
16:29:44:Win32 Service: false
16:29:44:***********************************************************************


- Yes, FAH is installed on a different drive, to spare my SSD, i. e. reduce wear-leveling. It's a 2 TB Western Digital Caviar Black and the drive's letter is X.
I just "blurred" the path due to privacy concerns. However, you see the real path in the section above.

- Yes, extra-core-args are used. Here's the config.xml-content:
Code: Select all
<config>
  <!-- Folding Slot Configuration -->
  <client-type v='advanced'/>
  <extra-core-args v='-forceasm'/>
  <gpu v='true'/>

  <!-- Logging -->
  <log-rotate-max v='5'/>

  <!-- Network -->
  <proxy v=':8080'/>

  <!-- User Information -->
  <passkey v=''/>
  <team v='34361'/>
  <user v='Eagle3386'/>

  <!-- Folding Slots -->
  <slot id='0' type='GPU'/>
  <slot id='1' type='SMP'/>
</config>


- The "-forceasm"-switch was added, because I used it in the "old" days, i. e. in my pre-V7 time to avoid the GPU-/SMP-cores to fall back to the (AFAIK slower) standard optimizations (I believe, the log called it so; correct me, if I'm wrong). And IIRC, it did have an impact on the GPU2/3-client?!

- I chose "advanced" to get bigger packets (though not the beta-big packets, because I'm on a Phenom II X4 955 BE and not an i7/FX-8150..).
If that was wrong, any suggestion is greatly appreciated to increase WU count and help, reach FAH's goals faster - PPD isn't of any relevance for me, but successful WU-returns are, because my grandpa is ill with Parkinson disease.

- Additionally, I do have those environment variables still set. Should they be removed or are they needed, but there values should be different?

Thanks in advance!

Kind regards,
Martin
User avatar
Eagle
 
Posts: 157
Joined: Sun Feb 17, 2008 1:06 am
Location: » Earth » Europe » Germany

Re: V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby bruce » Tue Nov 01, 2011 5:32 pm

In V7.1.38, "-forceasm" is still useful for FahCore_78 if you're running the uniprocessor client. It has never served a purpose for the GPU client. There has been a debate about whether it ever served a purpose for SMP, but it's certainly not applicable to the newer FahCore_a4 which seems to be quite common now for projects assigned to machines with one through four cores. According to Ticket #563 the whole issue will be resolved in the next update for V7.

There is no long-term pattern for "advanced" such as getting bigger packets or more points or whatever. All new projects are considered "advanced" until they've run long enough to be considered adequately stable. If new projects happen to have bigger packets this week/month then next week's/month's new projects will probably have smaller packets. The only certainty related to advanced is that you'll get newer projects when they come out and regular projects when there are no projects for your hardware which are designated as new.

When a new core comes out, and with it, new projects, either the projects or the core can cause the "advanced" designation. I'm not sure of the current status of FahCore_16 which is the OpenCL core that's supporting ATI GPUs 5000 and above. It's possible that all projects for that core are still considered advanced but maybe not. (I'm quite sure that somebody who knows will supply that information below.) With that GPU, you certainly should prefer projects for FahCore_16 rather than FahCore_11 if you can get them. but as with all assignments, there's never a guarantee that designated projects will be available when you want them.

None of this explains the UNKNOWN_ENUM, of course. Which version of the ATI drivers are you running? They've been improving their support for OpenCL over an extended time-period, along with a lot of other changes which probably don't matter for FAH.
bruce
 
Posts: 22617
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby Eagle » Tue Nov 01, 2011 11:21 pm

Ok, removed "-forceasm" and now my config looks like this:
Code: Select all
23:14:15:Saving configuration to config.xml
23:14:15:<config>
23:14:15:  <!-- Folding Slot Configuration -->
23:14:15:  <client-type v='advanced'/>
23:14:15:
23:14:15:  <!-- Logging -->
23:14:15:  <log-rotate-max v='5'/>
23:14:15:
23:14:15:  <!-- Network -->
23:14:15:  <proxy v=':8080'/>
23:14:15:
23:14:15:  <!-- User Information -->
23:14:15:  <passkey v='********************************'/>
23:14:15:  <team v='34361'/>
23:14:15:  <user v='Eagle3386'/>
23:14:15:
23:14:15:  <!-- Folding Slots -->
23:14:15:  <slot id='0' type='GPU'/>
23:14:15:  <slot id='1' type='SMP'/>
23:14:15:</config>


Environment variables are still set (no one of you, the more experienced users, said anything against it).
However, my log looks like this:
Code: Select all
23:14:54:Unit 00:
23:14:54:Unit 00:*------------------------------*
23:14:54:Unit 00:Folding@Home Gromacs GB Core
23:14:54:Unit 00:Version 2.27 (Dec. 15, 2010)
23:14:54:Unit 00:
23:14:54:Unit 00:Preparing to commence simulation
23:14:54:Unit 00:- Ensuring status. Please wait.
23:14:54:News: Welcome to Folding@Home
23:14:54:Assigned to work server 171.64.65.56
23:14:54:Requesting new work unit for slot 00: READY gpu:0:"Radeon HD 5870 (Cypress)" from 171.64.65.56
23:14:54:Connecting to 171.64.65.56:8080
23:14:55:Slot 00: Downloading 44.15KiB
23:14:56:Slot 00: Download complete
23:14:56:Received Unit: id:01 state:DOWNLOAD error:OK project:11294 run:10 clone:368 gen:39 core:0x16 unit:0x000000280a3b1e5c4d9a1d884d417e0d
23:14:56:Downloading core from http://www.stanford.edu/~pande/Win32/AMD64/ATI/R600/Core_16.fah
23:14:56:Connecting to www.stanford.edu:80
23:14:56:FahCore 16: Downloading 1.04MiB
23:14:57:Server connection id=1 on 0.0.0.0:36330 from 127.0.0.1
23:15:02:FahCore 16: 78.29%
23:15:03:FahCore 16: Download complete
23:15:03:Valid core signature
23:15:03:WARNING: FahCore has not changed since last download, aborting core update
23:15:03:Starting Unit 01
23:15:03:Running core: "M:/Eigene Projekte/Folding At Home/cores/www.stanford.edu/~pande/Win32/AMD64/ATI/R600/Core_16.fah/FahCore_16.exe" -dir 01 -suffix 01 -lifeline 4648 -version 701 -checkpoint 15 -gpu 0
23:15:03:Started core on PID 7628
23:15:03:FahCore 0x16 started
23:15:03:Unit 00:- Looking at optimizations...
23:15:03:Unit 00:- Working with standard loops on this execution.
23:15:03:Unit 00:- Created dyn
23:15:03:Unit 00:- Files status OK
23:15:03:Unit 00:- Expanded 338935 -> 644556 (decompressed 190.1 percent)
23:15:03:Unit 00:Called DecompressByteArray: compressed_data_size=338935 data_size=644556, decompressed_data_size=644556 diff=0
23:15:03:Unit 00:- Digital signature verified
23:15:03:Unit 00:
23:15:03:Unit 00:Project: 7611 (Run 1, Clone 81, Gen 22)
23:15:03:Unit 00:
23:15:03:Unit 00:Entering M.D.
23:15:04:Unit 01:
23:15:04:Unit 01:*------------------------------*
23:15:04:Unit 01:Folding@Home GPU Core
23:15:04:Unit 01:Version 2.11 (Thu Dec 9 15:00:14 PST 2010)
23:15:04:Unit 01:
23:15:04:Unit 01:Compiler  : Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 15.00.30729.01 for 80x86
23:15:04:Unit 01:Build host: user-f6d030f24f
23:15:04:Unit 01:Board Type: AMD/OpenCL
23:15:04:Unit 01:Core      : x=16
23:15:04:Unit 01: Window's signal control handler registered.
23:15:04:Unit 01:Preparing to commence simulation
23:15:04:Unit 01:- Looking at optimizations...
23:15:04:Unit 01:DeleteFrameFiles: successfully deleted file=01/wudata_01.ckp
23:15:04:Unit 01:- Created dyn
23:15:04:Unit 01:- Files status OK
23:15:04:Unit 01:sizeof(CORE_PACKET_HDR) = 512 file=<>
23:15:04:Unit 01:- Expanded 44696 -> 169787 (decompressed 379.8 percent)
23:15:04:Unit 01:Called DecompressByteArray: compressed_data_size=44696 data_size=169787, decompressed_data_size=169787 diff=0
23:15:04:Unit 01:- Digital signature verified
23:15:04:Unit 01:
23:15:04:Unit 01:Project: 11294 (Run 10, Clone 368, Gen 39)
23:15:04:Unit 01:
23:15:04:Unit 01:Assembly optimizations on if available.
23:15:04:Unit 01:Entering M.D.
23:15:05:Unit 01:Tpr hash 01/wudata_01.tpr:  3517111142 935307128 2875938241 2685776633 1089384537
23:15:05:Unit 01:Working on PEPTIDE (1-42)
23:15:05:Unit 01:Client config unavailable.
23:15:06:Unit 01:Starting GUI Server
23:15:09:Unit 00:Mapping NT from 4 to 4
23:15:09:Unit 00:Completed 0 out of 2000000 steps  (0%)
23:15:24:FahCore, running Unit 01, returned: UNKNOWN_ENUM (-1073740777 = 0xc0000417)
23:15:24:Starting Unit 01
23:15:24:Running core: "M:/Eigene Projekte/Folding At Home/cores/www.stanford.edu/~pande/Win32/AMD64/ATI/R600/Core_16.fah/FahCore_16.exe" -dir 01 -suffix 01 -lifeline 4648 -version 701 -checkpoint 15 -gpu 0
23:15:24:Started core on PID 7916
23:15:24:FahCore 0x16 started
23:15:24:Unit 01:
23:15:24:Unit 01:*------------------------------*
23:15:24:Unit 01:Folding@Home GPU Core
23:15:24:Unit 01:Version 2.11 (Thu Dec 9 15:00:14 PST 2010)
23:15:24:Unit 01:
23:15:24:Unit 01:Compiler  : Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 15.00.30729.01 for 80x86
23:15:24:Unit 01:Build host: user-f6d030f24f
23:15:24:Unit 01:Board Type: AMD/OpenCL
23:15:24:Unit 01:Core      : x=16
23:15:24:Unit 01: Window's signal control handler registered.
23:15:24:Unit 01:Preparing to commence simulation
23:15:24:Unit 01:- Ensuring status. Please wait.
23:15:33:Unit 01:- Looking at optimizations...
23:15:33:Unit 01:- Working with standard loops on this execution.
23:15:33:Unit 01:- Previous termination of core was improper.
23:15:33:Unit 01:- Files status OK
23:15:33:Unit 01:sizeof(CORE_PACKET_HDR) = 512 file=<>
23:15:33:Unit 01:- Expanded 44696 -> 169787 (decompressed 379.8 percent)
23:15:33:Unit 01:Called DecompressByteArray: compressed_data_size=44696 data_size=169787, decompressed_data_size=169787 diff=0
23:15:33:Unit 01:- Digital signature verified
23:15:33:Unit 01:
23:15:33:Unit 01:Project: 11294 (Run 10, Clone 368, Gen 39)
23:15:33:Unit 01:
23:15:33:Unit 01:Entering M.D.
23:15:36:Unit 01:Tpr hash 01/wudata_01.tpr:  3517111142 935307128 2875938241 2685776633 1089384537
23:15:36:Unit 01:Working on PEPTIDE (1-42)
23:15:36:Unit 01:Client config unavailable.
23:15:42:FahCore, running Unit 01, returned: UNKNOWN_ENUM (-1073740777 = 0xc0000417)
23:16:24:Starting Unit 01
23:16:24:Running core: "M:/Eigene Projekte/Folding At Home/cores/www.stanford.edu/~pande/Win32/AMD64/ATI/R600/Core_16.fah/FahCore_16.exe" -dir 01 -suffix 01 -lifeline 4648 -version 701 -checkpoint 15 -gpu 0
23:16:24:Started core on PID 6640
23:16:24:FahCore 0x16 started
23:16:25:Unit 01:
23:16:25:Unit 01:*------------------------------*
23:16:25:Unit 01:Folding@Home GPU Core
23:16:25:Unit 01:Version 2.11 (Thu Dec 9 15:00:14 PST 2010)
23:16:25:Unit 01:
23:16:25:Unit 01:Compiler  : Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 15.00.30729.01 for 80x86
23:16:25:Unit 01:Build host: user-f6d030f24f
23:16:25:Unit 01:Board Type: AMD/OpenCL
23:16:25:Unit 01:Core      : x=16
23:16:25:Unit 01: Window's signal control handler registered.
23:16:25:Unit 01:Preparing to commence simulation
23:16:25:Unit 01:- Ensuring status. Please wait.
23:16:34:Unit 01:- Looking at optimizations...
23:16:34:Unit 01:- Working with standard loops on this execution.
23:16:34:Unit 01:- Previous termination of core was improper.
23:16:34:Unit 01:- Going to use standard loops.
23:16:34:Unit 01:- Files status OK
23:16:34:Unit 01:sizeof(CORE_PACKET_HDR) = 512 file=<>
23:16:34:Unit 01:- Expanded 44696 -> 169787 (decompressed 379.8 percent)
23:16:34:Unit 01:Called DecompressByteArray: compressed_data_size=44696 data_size=169787, decompressed_data_size=169787 diff=0
23:16:34:Unit 01:- Digital signature verified
23:16:34:Unit 01:
23:16:34:Unit 01:Project: 11294 (Run 10, Clone 368, Gen 39)
23:16:34:Unit 01:
23:16:34:Unit 01:Entering M.D.
23:16:36:Unit 01:Tpr hash 01/wudata_01.tpr:  3517111142 935307128 2875938241 2685776633 1089384537
23:16:36:Unit 01:Working on PEPTIDE (1-42)
23:16:36:Unit 01:Client config unavailable.
23:16:54:Unit 01:Starting GUI Server
23:16:54:FahCore, running Unit 01, returned: UNKNOWN_ENUM (-1073740777 = 0xc0000417)
23:17:10:Slot 00 paused[/quote]

As you can see, the GPU-core crashes again and again.
Having "-forceasm" removed, I get [code]23:16:34:Unit 01:- Looking at optimizations...
23:16:34:Unit 01:- Working with standard loops on this execution.
23:16:34:Unit 01:- Previous termination of core was improper.
23:16:34:Unit 01:- Going to use standard loops.

which - at least to me - sounds like the core is using less optimized routines for that run.
That's why I thought "-forceasm" has/had an impact on SMP- _and_ GPU-folding.

Additionally, although the configuration was saved successfully and FAHControl was shut down and restarted properly, the line "23:16:36:Unit 01:Client config unavailable" still occurs.

What am I doing wrong? I just don't get it! :(
Could someone help me, please?

Thanks in advance,
Martin
User avatar
Eagle
 
Posts: 157
Joined: Sun Feb 17, 2008 1:06 am
Location: » Earth » Europe » Germany

Re: V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby bruce » Tue Nov 01, 2011 11:50 pm

To repeat:
bruce wrote:Which version of the ATI drivers are you running? They've been improving their support for OpenCL over an extended time-period, along with a lot of other changes which probably don't matter for FAH.


It's unclear whether those Env Vars work with OpenCL or not. The were designed for older drivers and the older Brook-based core. You can try removing them but I don't know if it will make a difference. Try removing them if the updated driver doesn't help.
bruce
 
Posts: 22617
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby Eagle » Wed Nov 02, 2011 7:11 am

Sorry, Bruce - I just read over that passage.
Here are the details right from the "AMD Vision Engine Control Center" (O.o):
Code: Select all
Driver Packaging Version   8.892-110914m-125030C-ATI   
Catalyst Version   11.9   
Provider   ATI Technologies Inc.   
2D Driver Version   8.01.01.1186   
2D Driver File Path   /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/CLASS/{4D36E968-E325-11CE-BFC1-08002BE10318}/0000   
Direct3D Version   7.14.10.0860   
OpenGL Version   6.14.10.11079   
AMD VISION Engine Control Center Version   2011.0908.1355.23115   
AMD Audio Driver Version   7.12.0.7702


According to the update-function, there's no newer version available. So, should I remove those Env Vars? :)
User avatar
Eagle
 
Posts: 157
Joined: Sun Feb 17, 2008 1:06 am
Location: » Earth » Europe » Germany

Re: V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby Eagle » Wed Nov 16, 2011 1:48 pm

I'm still stuck with the error and I posted the information just as you requested, though. :(

So, Bruce, can you help me, please?
User avatar
Eagle
 
Posts: 157
Joined: Sun Feb 17, 2008 1:06 am
Location: » Earth » Europe » Germany

Re: V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby jcoffland » Thu Nov 17, 2011 7:19 pm

The title of this thread is misleading. The UNKNOWN_ENUM has little if anything to do with the client version. This is a sign that the folding core crashed. This is mostly likely caused by a combination of the project, the core and possibly the hardware it's running on. The crash would occur regardless of the client version. This should be taken up with the core guys and the project owner.
Cauldron Development LLC
http://cauldrondevelopment.com/
User avatar
jcoffland
Pande Group Member
 
Posts: 1011
Joined: Fri Oct 10, 2008 6:42 pm
Location: San Jose, CA

Re: V7.1.38 cause UNKNOWN_ENUM (-10 = 0xfffffff6) on ATI

Postby Eagle » Thu Nov 17, 2011 7:23 pm

If I can help in any way, please let me know - this issue is still happening and I'm in fear of getting banned from FAH due to sending back bad WUs.. :(
User avatar
Eagle
 
Posts: 157
Joined: Sun Feb 17, 2008 1:06 am
Location: » Earth » Europe » Germany

Next

Return to V7.1.52 Windows/Linux

Who is online

Users browsing this forum: No registered users and 2 guests

cron