Page 2 of 2

Re: V7 client installation problem

PostPosted: Mon May 07, 2012 8:35 pm
by Not_IT_Tech
The shortcut is available Only in admin. I have it uninstalled right now but have tried installing from within the admin account (for all users) and no difference. I'll reinstall if you think there is a solution, otherwise I am getting pretty frustrated lol. I'm not a noob but this program is getting the best of me.

Re: V7 client installation problem

PostPosted: Mon May 07, 2012 8:36 pm
by Not_IT_Tech
I do Not want to have to run it in the admin account, I do not use admin for daily activities.

Re: V7 client installation problem

PostPosted: Mon May 07, 2012 9:02 pm
by Not_IT_Tech
reinstalled from within the non admin account and there is no shortcut, however going to the Admin account there is a shortcut and points to "C:\Program Files (x86)\FAHClient\FAHControl.exe" I can make the same shortcut in the non admin and run it as admin and I get a non running GUI that is not fully decked out.

I'm giving up, to much time spent with the MANY un/installs and retrys. Take care and thanks for your time and effort

Re: V7 client installation problem

PostPosted: Mon May 07, 2012 10:35 pm
by 7im
Sorry Bruce, I've grown impatient. I knew it was going to be a problem 2 weeks ago. I was just too busy until now. I guess you are too.

I created a Standard User in a Windows 7 VM I have. I tried installing to the standard user account, and was prompted for Admin access to install the software. Installation continued. Program files were installed in the correct location. However, the Data files and shortcut were installed under the Admin account. FAHControl starts only once in the Standard User, as that account has no shortcuts.

Created a new priority ticket: https://fah-web.stanford.edu/projects/FAHClient/ticket/889


Even when I manually selected the Data folder location for the standard user account, the FAH Installer still puts the startup shortcut under the Admin account. I don't know if this is a new issue with just v.52, or has been there all along. I don't have the time to test every release version, nor do I think that would help. Joe just needs to fix this going forward... :e?:

Re: V7 client installation problem

PostPosted: Wed Jun 06, 2012 12:08 pm
by hompa
I encountered similar problems but eventually managed to get it to work on my computer (WinVista64, multiple non-admin accounts) - at least to some extent.
I asked the installer to use a directory on the user account side for data (C:\Users\userXxx\AppData\Roaming\FAHClient) and installed it to start automatically.
After that I experienced many of the problems that are described in this thread (doesn't work after a restart, appears dead).

When checking the properties of the FAHControl entry in the Startup folder (Start button > All Programs > Startup > FAHControl) I noticed that the "Start in" information under the Shortcut tab was not set to the data directory I had selected. It was set to start in some directory on the admin side (this was ~2 weeks ago - the exact details have faded). I changed it to match my selected data directory (see above).
After that it "worked". It still doesn't start automatically after login - instead I always get a notification about "Blocked startup programs".
But when I manually select the FAHControl item (in the Startup folder mentioned above) and provide the Admin password (grumble...) then it starts to fold properly.

Definitely some issues left to fix for this FAH client version, though.
I don't really want to have to provide the Admin password after every user login when starting FAHControl but...I don't know of any alternatives right now.

Re: V7 client installation problem

PostPosted: Mon Oct 01, 2012 10:57 pm
by BABackman
hompa wrote:When checking the properties of the FAHControl entry in the Startup folder (Start button > All Programs > Startup > FAHControl) I noticed that the "Start in" information under the Shortcut tab was not set to the data directory I had selected. It was set to start in some directory on the admin side (this was ~2 weeks ago - the exact details have faded). I changed it to match my selected data directory (see above).
After that it "worked". It still doesn't start automatically after login - instead I always get a notification about "Blocked startup programs".
But when I manually select the FAHControl item (in the Startup folder mentioned above) and provide the Admin password (grumble...) then it starts to fold properly.


I found that the data directory created by the installer was owned by the Adminstrators group. Once I re-assigned ownership to my regular user, FAHControl would start up without requiring the admin password.

Changing ownership isn't blindingly obvious (maybe to keep it out of the way of the unwary): go to the folder containing the data folder (in my case c:\ProgramData), right click on the FAHClient folder, select Properties, select the Security tab, click the Advanced button, select the Owner tab, click the Edit button, click Other Users or Groups, type your regular username in the big box at the bottom, click Check Names and should expand to Machine\User and be underlined, click OK, at the bottom of the Advanced Security Settings dialog you've just returned to check the "Replace owner on subcontainers and objects" checkbox, OK, OK, OK. If you're a belt-and-suspenders type, you can repeat the first few steps up to the Owner tab to confirm that the FAHClient folder (and its subfolders) now belong to your regular user.