#893 Debian Squeeze 6.0.5 install fails

Moderators: Site Moderators, PandeGroup

Re: install on Debian Wheezy fails

Postby smoking2000 » Tue Jun 05, 2012 9:39 pm

Regarding apt-get -f versus dpkg -i --force-depends, the latter is preferred because it only forcefully ignores dependency errors (and treats them as warnings instead) for the package being installed, whereas apt-get -f ignores dependency errors for all package marked for installation (or upgrade) which may have unintended consequences. The dpkg command is the safe choice.
User avatar
smoking2000
 
Posts: 571
Joined: Mon Dec 03, 2007 6:20 am
Location: Amsterdam

Re: install on Debian Wheezy fails

Postby derrickmcc » Wed Jun 13, 2012 8:05 pm

derrickmcc wrote:...
I have therefore done a manual install:
Code: Select all
sudo dpkg -i --force-depends fahclient_7.1.52_amd64.deb

Selecting previously unselected package fahclient.
(Reading database ... 109156 files and directories currently installed.)
Unpacking fahclient (from fahclient_7.1.52_amd64.deb) ...
Adding system user fahclient...done
dpkg: fahclient: dependency problems, but configuring anyway as you requested:
 fahclient depends on libssl0.9.8; however:
  Package libssl0.9.8 is not installed.
Setting up fahclient (7.1.52) ...
update-rc.d: using dependency based boot sequencing
Starting fahclient. . .OK

Unfortunately, any time I need to install a new package, I am forced to remove FAHClient because of the dependency problems.

I then install the new package and manually re-install FAHClient using:
sudo dpkg -i --force-depends fahclient_7.1.52_amd64.deb

as above.

The main downside of this is that I lose the current WU in the process.
User avatar
derrickmcc
 
Posts: 329
Joined: Fri Jul 24, 2009 12:30 am
Location: Malvern, UK

Re: #893 Debian Squeeze 6.0.5 install fails

Postby smoking2000 » Wed Jun 13, 2012 8:23 pm

If you really want to keep using the fahclient package despite this bug, let's work around it by hacking the package to use the correct libssl dependency:

Code: Select all
$ dpkg-deb -f fahclient_7.1.52_amd64.deb Depends
debconf | debconf-2.0, libc6, bzip2, zlib1g, libexpat1, libssl0.9.8
$ dpkg-deb -R fahclient_7.1.52_amd64.deb pkg/
$ sed -i 's/libssl0.9.8/libssl1.0.0/' pkg/DEBIAN/control
$ dpkg-deb -b pkg/ fahclient_7.1.52_amd64.deb
dpkg-deb: building package `fahclient' in `fahclient_7.1.52_amd64.deb'.
$ dpkg-deb -f fahclient_7.1.52_amd64.deb Depends
debconf | debconf-2.0, libc6, bzip2, zlib1g, libexpat1, libssl1.0.0

You should now be able to install the package with just `dpkg -i` :eugeek:
User avatar
smoking2000
 
Posts: 571
Joined: Mon Dec 03, 2007 6:20 am
Location: Amsterdam

Re: #893 Debian Squeeze 6.0.5 install fails

Postby ponley » Fri Aug 10, 2012 2:45 am

Is it possible to configure the package to accept any libssl greater than or equal to libssl0.9.8? I know I have seen this on the screen as I install packages where a dependency is called out as >=. Then the package would work with 0.9.8 or 1.0.0 or whatever else might become the 'standard'. Obviously this package was built when Wheezy was using 0.9.8 but before Wheezy froze that changed to 1.0.0.

BTW there is an even easier way if you are comfortable with command line editors.

http://ubuntuforums.org/showthread.php?t=636724

You get to actually edit the dependency info, I never could get my head around sed and awk.
ponley
 
Posts: 20
Joined: Wed Dec 14, 2011 10:14 pm

Re: #893 Debian Squeeze 6.0.5 install fails

Postby 7im » Fri Aug 10, 2012 3:32 am

That's the 2 old guys from the Muppets, right? :lol:
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.
User avatar
7im
 
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Location: Arizona

Re: #893 Debian Squeeze 6.0.5 install fails

Postby ponley » Fri Aug 10, 2012 11:59 pm

7.1.52 depends on libssl0.9.8 but when Wheezy froze they had apparently moved to libssl1.0.0. I first tried the --force-depends but run into the problem that apt-get did not like the result and would remove the fahclient anytime you wanted to install another package. SoI edited the 7.1.52 package to depend on libssl1.0.0 and it installed and ran with no problem and apt was happy.

ThereforeI think the best approach here is to update the package to depend on libssl >=0.9.8 so that anything newer than 0.9.8 will work and everyone will be happy.
ponley
 
Posts: 20
Joined: Wed Dec 14, 2011 10:14 pm

Re: #893 Debian Squeeze 6.0.5 install fails

Postby markohuttunen » Wed Oct 03, 2012 8:03 pm

Any updates on getting a working v7.1 for debian amd64 which only requires libssl0.9.8 and not libssl1.0.0?
markohuttunen
 
Posts: 1
Joined: Wed Oct 03, 2012 7:19 pm

Re: #893 Debian Squeeze 6.0.5 install fails

Postby bruce » Wed Oct 03, 2012 9:18 pm

In Ticket #893 jcoffland wrote:(Changed 2 weeks ago)
■milestone changed from Upcoming Release to v7.2.4


There's no way to predict when V7.2.x will be available.
bruce
 
Posts: 22709
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: #893 Debian Squeeze 6.0.5 install fails

Postby 7im » Wed Oct 03, 2012 9:20 pm

Hello markohuttunen, welcome to the folding forum.

While it is not appropriate to talk about unreleased software in the public forum (forum rules), you might want to watch the trac system for tickets related to your question about libssl.

Edit: Oh, I see bruce beat me to the punch.
User avatar
7im
 
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Location: Arizona

Previous

Return to V7.1.52 Windows/Linux

Who is online

Users browsing this forum: No registered users and 1 guest

cron