Page 1 of 2

Installation clarification?

PostPosted: Tue Jul 24, 2012 8:19 pm
by bs_texas
OK, I have been running FAH 6.34 on this Ubuntu machine, version 10.04 LTS, but it is has all of the available updates installed along the way.

I want to stop using 6.34 and move to FAH 7.1.52. I found the fahclient and the fahcontrol .deb packages and downloaded them from the folding.stanford.edu website. I double clicked and install the fahclient and then the fahcontrol. When I open FAHControl from the Applications / Science menu the thing launches but just sits there saying 'Connecting' and never proceeds.

This machine is a 64bit Ubuntu machine with a Q9400 quad core processor. And I just want to run the SMP client.

I don't know what I'm missing to get past the 'Connecting' indication.

Re: Installation clarification?

PostPosted: Wed Aug 01, 2012 4:43 am
by Jesse_V
The fahcontrol connects to the fahclient. The "Connecting" stall shows that the two aren't communicating somehow.

Are you still having this problem?

Re: Installation clarification?

PostPosted: Wed Aug 01, 2012 4:56 am
by gwildperson
Is fahclient running or not?

I'm not familiar with the ubuntu install defaults. Fahclient may start automatically when you reboot or it may start when fahcontrol tells it to or it may be waiting for you to start it manually

In the preferences panel, there's a setting to start the local client. Is it set or not?

If you start fahclient manually, does that solve the problem or do you get a message about not being able to lock the db? (That's designed to prevent two copies from running.)

Re: Installation clarification?

PostPosted: Wed Aug 01, 2012 4:59 am
by bs_texas
I haven't had a chance to get back to it. But I will soon.

I blew a breaker in my folding room and also got my latest $347 electric bill! Gotta get a new strategy. But, I like closing in on 3 million points in a month!

This is for jesse_v. The other post just came in and I'll have to check it out.

Re: Installation clarification?

PostPosted: Wed Aug 01, 2012 5:03 am
by bs_texas
I did go in and click on the Start client button you mentioned (or whatever it's called. I'm not currently at that Ubuntu machine) .
I have to move some of my computers out of this room before I proceed.
Thanks for the replies.

Re: Installation clarification?

PostPosted: Wed Aug 01, 2012 5:13 am
by Jesse_V
bs_texas wrote:I like closing in on 3 million points in a month!

That is a truly remarkable and outstanding achievment! Well done!

Re: Installation clarification?

PostPosted: Wed Aug 01, 2012 6:42 am
by 7im
Since you used the .deb packages to install, the fahclient is already running as a service. No need to start fahclient. And if a restart of the system doesn't help, I'll fire up my 10.04 vm tomorrow and try to help some more. ;)

Re: Installation clarification?

PostPosted: Thu Aug 02, 2012 12:37 am
by 7im
I had 7.1.43 running on my 10.04 build.

I purged the old client and tried to get 7.1.52 running. No luck yet.

There isn't much if any difference in these linux versions. The most recent updates were mostly all for Windows. .43 should get you going. If not, .38 works too.

Re: Installation clarification?

PostPosted: Thu Aug 02, 2012 12:47 am
by bs_texas
Thanks 7im. I won't have time to get back to this until this weekend. Gotta make some moves here so I don't blow that breaker.

Re: Installation clarification?

PostPosted: Fri Aug 17, 2012 1:47 am
by bs_texas
Ok, I'm back. (Dang... Tempus sure is a Fugitin'...) Got my 4 other Windows 7 machines with SMP and GPU running. No problems so far. To bad the Linux stuff can't be as simple.

Ok, as before, I have a new Science option in the Applications drop down. The thing in Science is FAH Control. There is no mention of FAH Client and there is no fahclient or FAHclient (or anything like that) process running. There is an FAHControl process running.

I went back to the download folder and re-installed fahclient_7.1.52_amd64.deb. But, still I don't see any place to launch it. There's a /etc/fahclient folder that has the config.xml file with my passkey, etc. There's a folder /var/lib/fahclient, but there's nothing in it. I just don't see an executable.

If I go to Science and click on FAHControl, the fahcontrol@home client control window opens and that's were it just sits there saying 'connecting'. If I click on configure and then click on Start under local client, I get this:

Image

Clicking yes is just an endless loop.

I don't see where to get the older versions, other than the old 6.34.

Oh, I just realized from that image that there's a /home/bs/.FAHClient folder. :? But, unfortunately, there is only an FAHControl.db file in there.

Thanks...

Re: Installation clarification?

PostPosted: Fri Aug 17, 2012 2:03 am
by jimerickson
click on Preferences, check the Autostart box under Local Client. click Save. click Quit. reopen FAHControl and it should automatically start the client. the binary for FAHClient may be in /usr/local/bin.

Re: Installation clarification?

PostPosted: Fri Aug 17, 2012 2:26 am
by bs_texas
Thanks for the input. Autostart is already checked. Nothing in /usr/local/bin, but I did discover FAHClient in /usr/bin. All of the x bits are on, but if I try ./FAHClient I get some folder can't be found error.

I'm thinking about installing Windows 7 on there!! :twisted:

Edit: Heheh.. now take a deep breath (I say to myself) and look at this : http://www.bennie-smith.net/cpm/albums/userpics/IMG_1881.JPG

My home for 6 years in the Marshall Island where we had 56K dial-up to the internet!

Re: Installation clarification?

PostPosted: Fri Aug 17, 2012 2:45 am
by jimerickson
try "cd /usr/bin" in the terminal. then try ./FAHClient again. ./ means to look in the current directory. of course maybe you already did that.

Re: Installation clarification?

PostPosted: Fri Aug 17, 2012 2:53 am
by 7im
FAHClient runs as a service by default in Ubuntu. No need to start it. FAHClient starts on boot up. You can confirm using the Terminal app, using the top command, and looking for the fah* processes.


This setup uses /etc/fahclient/config.xml and runs in /var/lib/fahclient/
Do not run FAHClient directly when the service is running.

The FAHClient can be started and stopped via the service script in /etc/init.d/FAHClient but usually isn't needed (per service auto starting).

sudo /etc/init.d/FAHClient start
sudo /etc/init.d/FAHClient stop

Re: Installation clarification?

PostPosted: Tue Sep 04, 2012 4:55 am
by bs_texas
Well, it's hard to find time these days to tweak on linux, but I got around to doing an in-place upgrade of Ubuntu 10.04 to 12.04. After it was upgraded, of course, the GUI was completely different and I could no longer find my Folding stuff to launch. But, just on a whim, I did a ps -A | grep FAH and then fah and discovered that fahcore_a4 was a running process and FAHClient was a running process. I ran top and there was fahcore_a4 at the top and FAHClient just a few process below. I did -nothing- to launch them. And I have no idea where they launch automatically as processes. Of course, I saw them running there, but there was no way to tell anything about what they were doing. Then, as I mentioned, I couldn't find where to launch FAHControl anymore so I searched on it and found it in /usr/bin. Incidentally, as someone mentioned above, FAHClient is in there too. So I launched it with ./FAHControl and there it was... I had 7.1.52 running and viewable.

And just to be clear, no folding processes were running in 10.04 any time I rebooted. So, who knows why or how that works now, but it does.

I also haven't discovered where to launch System Monitor yet, but I'm sure I'll find it in there somewhere.

Only Sept 3rd and and I'm already up to 384,000 points. Maybe I can hit over 3,000,000 this month with this Ubuntu machine doing some SMP processing. Let's see, I have 9 machines folding, with the windows machines doing GPU as well and one PS3 that just sits there and runs happily...