Page 1 of 1

Radeon 4670 issue [HD4000 too old]

PostPosted: Tue Aug 21, 2012 7:22 am
by iamcreasy
I have followed the instruction of installing GPUs.txt, but still gpu processing isn't starting.

My gpu is Radeon 4670.

Log ::
Code: Select all

*********************** Log Started 2012-08-21T06:16:44Z ***********************
06:16:44:************************* Folding@home Client *************************
06:16:44:      Website: http://folding.stanford.edu/
06:16:44:    Copyright: (c) 2009-2012 Stanford University
06:16:44:       Author: Joseph Coffland <joseph@cauldrondevelopment.com>
06:16:44:         Args: --lifeline 7672 --command-port=36330
06:16:44:       Config: C:/FAHClient/config.xml
06:16:44:******************************** Build ********************************
06:16:44:      Version: 7.1.52
06:16:44:         Date: Mar 20 2012
06:16:44:         Time: 19:37:42
06:16:44:      SVN Rev: 3515
06:16:44:       Branch: fah/trunk/client
06:16:44:     Compiler: Intel(R) C++ MSVC 1500 mode 1200
06:16:44:      Options: /TP /nologo /EHa /Qdiag-disable:4297,4103,1786,279 /Ox -arch:SSE
06:16:44:               /QaxSSE2,SSE3,SSSE3,SSE4.1,SSE4.2 /Qopenmp /Qrestrict /MT
06:16:44:     Platform: win32 XP
06:16:44:         Bits: 32
06:16:44:         Mode: Release
06:16:44:******************************* System ********************************
06:16:44:          CPU: Intel(R) Core(TM)2 Duo CPU E4500 @ 2.20GHz
06:16:44:       CPU ID: GenuineIntel Family 6 Model 15 Stepping 13
06:16:44:         CPUs: 2
06:16:44:       Memory: 4.00GiB
06:16:44:  Free Memory: 2.03GiB
06:16:44:      Threads: WINDOWS_THREADS
06:16:44:   On Battery: false
06:16:44:   UTC offset: 7
06:16:44:          PID: 6652
06:16:44:          CWD: C:/FAHClient
06:16:44:           OS: Windows 7 Ultimate
06:16:44:      OS Arch: AMD64
06:16:44:         GPUs: 1
06:16:44:        GPU 0: ATI:3 RV730XT [Radeon HD 4670]
06:16:44:         CUDA: Not detected
06:16:44:Win32 Service: false
06:16:44:***********************************************************************
06:16:44:<config>
06:16:44:  <!-- Folding Slot Configuration -->
06:16:44:  <gpu v='true'/>
06:16:44:
06:16:44:  <!-- Network -->
06:16:44:  <proxy v=':8080'/>
06:16:44:
06:16:44:  <!-- User Information -->
06:16:44:  <passkey v='********************************'/>
06:16:44:  <user v='iamcreasy'/>
06:16:44:
06:16:44:  <!-- Folding Slots -->
06:16:44:  <slot id='0' type='GPU'/>
06:16:44:  <slot id='1' type='SMP'/>
06:16:44:</config>
06:16:44:Trying to access database...
06:16:44:Successfully acquired database lock
06:16:44:Enabled folding slot 00: READY gpu:0:"RV730XT [Radeon HD 4670]"
06:16:44:Enabled folding slot 01: READY smp:2
06:16:44:WU01:FS01:Starting
06:16:44:WU01:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:/FAHClient/cores/www.stanford.edu/~pande/Win32/AMD64/Core_a4.fah/FahCore_a4.exe -dir 01 -suffix 01 -version 701 -lifeline 6652 -checkpoint 15 -np 2
06:16:45:WU01:FS01:Started FahCore on PID 7108
06:16:45:WU01:FS01:Core PID:3056
06:16:45:WU01:FS01:FahCore 0xa4 started
06:16:45:WU00:FS00:Connecting to assign-GPU.stanford.edu:80
06:16:45:WU01:FS01:0xa4:
06:16:45:WU01:FS01:0xa4:*------------------------------*
06:16:45:WU01:FS01:0xa4:Folding@Home Gromacs GB Core
06:16:45:WU01:FS01:0xa4:Version 2.27 (Dec. 15, 2010)
06:16:45:WU01:FS01:0xa4:
06:16:45:WU01:FS01:0xa4:Preparing to commence simulation
06:16:45:WU01:FS01:0xa4:- Looking at optimizations...
06:16:45:WU01:FS01:0xa4:- Files status OK
06:16:45:WU01:FS01:0xa4:- Expanded 967855 -> 2213132 (decompressed 228.6 percent)
06:16:45:WU01:FS01:0xa4:Called DecompressByteArray: compressed_data_size=967855 data_size=2213132, decompressed_data_size=2213132 diff=0
06:16:45:WU01:FS01:0xa4:- Digital signature verified
06:16:45:WU01:FS01:0xa4:
06:16:45:WU01:FS01:0xa4:Project: 8049 (Run 573, Clone 19, Gen 27)
06:16:45:WU01:FS01:0xa4:
06:16:45:WU01:FS01:0xa4:Assembly optimizations on if available.
06:16:45:WU01:FS01:0xa4:Entering M.D.
06:16:46:WU00:FS00:News: Welcome to Folding@Home
06:16:46:WARNING:WU00:FS00:Failed to get assignment from 'assign-GPU.stanford.edu:80': Empty work server assignment
06:16:46:WU00:FS00:Connecting to assign-GPU.stanford.edu:8080
06:16:47:Server connection id=1 on 0.0.0.0:36330 from 127.0.0.1
06:16:47:WU00:FS00:News: Welcome to Folding@Home
06:16:47:WARNING:WU00:FS00:Failed to get assignment from 'assign-GPU.stanford.edu:8080': Empty work server assignment
06:16:47:ERROR:WU00:FS00:Exception: Could not get an assignment
06:16:47:WU00:FS00:Connecting to assign-GPU.stanford.edu:80
06:16:48:WU00:FS00:News: Welcome to Folding@Home
06:16:48:WARNING:WU00:FS00:Failed to get assignment from 'assign-GPU.stanford.edu:80': Empty work server assignment
06:16:48:WU00:FS00:Connecting to assign-GPU.stanford.edu:8080
06:16:49:WU00:FS00:News: Welcome to Folding@Home
06:16:49:WARNING:WU00:FS00:Failed to get assignment from 'assign-GPU.stanford.edu:8080': Empty work server assignment
06:16:49:ERROR:WU00:FS00:Exception: Could not get an assignment
06:16:51:WU01:FS01:0xa4:Using Gromacs checkpoints
06:16:51:WU01:FS01:0xa4:Mapping NT from 2 to 2
06:16:52:WU01:FS01:0xa4:Resuming from checkpoint
06:16:52:WU01:FS01:0xa4:Verified 01/wudata_01.log
06:16:52:WU01:FS01:0xa4:Verified 01/wudata_01.trr
06:16:52:WU01:FS01:0xa4:Verified 01/wudata_01.xtc
06:16:52:WU01:FS01:0xa4:Verified 01/wudata_01.edr
06:16:52:WU01:FS01:0xa4:Completed 44200 out of 250000 steps  (17%)
06:17:48:WU00:FS00:Connecting to assign-GPU.stanford.edu:80
06:17:48:WU00:FS00:News: Welcome to Folding@Home
06:17:48:WARNING:WU00:FS00:Failed to get assignment from 'assign-GPU.stanford.edu:80': Empty work server assignment
06:17:49:WU00:FS00:Connecting to assign-GPU.stanford.edu:8080
06:17:50:WU00:FS00:News: Welcome to Folding@Home
06:17:50:WARNING:WU00:FS00:Failed to get assignment from 'assign-GPU.stanford.edu:8080': Empty work server assignment
06:17:50:ERROR:WU00:FS00:Exception: Could not get an assignment

Re: Radeon 4670 issue

PostPosted: Tue Aug 21, 2012 8:28 am
by artoar_11
From several months PG stop issuing WUs for Radeon 4xxx. PG stopped maintaining of old code. Now is used OpenCL, which is supported by Radeon 5/6/7xxx.

Re: Radeon 4670 issue

PostPosted: Tue Aug 21, 2012 9:35 am
by P5-133XL
If you happen to get an old WU that runs on a 4xxx series it will fold it, but those are now rare and only likely to get less frequent for no new projects are going to be created for pre-5xxx series video cards.

http://folding.typepad.com/news/2011/03 ... -gpus.html

Re: Radeon 4670 issue

PostPosted: Tue Aug 21, 2012 2:45 pm
by Joe_H
I came across mention of this statement showing up in the V7 Windows install guide, http://folding.stanford.edu/English/WinGuide#ntoc4, after a recent edit:

The end of support for ATI/AMD 4xxx series and below was announced in March 2011, and scheduled to end in September 2011. The last of the Fahcore_11 (GPU2) work units actually lasted until June 2012, more than a year after the original announcement.


I don't know if there are any stragglers left to be assigned, but if they are they will be rare as mentioned.

Re: Radeon 4670 issue

PostPosted: Wed Aug 22, 2012 2:03 am
by iamcreasy
I tried installing ATI Stream, now knows as ATI APP SDK, this usually enables OpenCl support, but its not working with this product.

Anyway, I guess I should just fold using gpu then.

Re: Radeon 4670 issue

PostPosted: Wed Aug 22, 2012 2:09 am
by 7im
No amount of software installations will fix that fact that there are no more work units for the 4xxx series GPUs. Sorry.

Re: Radeon 4670 issue

PostPosted: Wed Aug 22, 2012 6:33 am
by Joe_H
iamcreasy wrote:I tried installing ATI Stream, now knows as ATI APP SDK, this usually enables OpenCl support, but its not working with this product.

Anyway, I guess I should just fold using gpu then.


You need support for a later version of OpenCL than the 4000 series cards support. You will have to stay with using your CPU.

Re: Radeon 4670 issue

PostPosted: Wed Aug 22, 2012 1:38 pm
by Dark Pulse
Correct. You need at least a 5xxx series card to fold on it. Essentially, the 4xxx cards are too old and no longer supported.

Re: Radeon 4670 issue

PostPosted: Sat Sep 22, 2012 8:33 am
by [WHGT]Cyberman
P5-133XL wrote:If you happen to get an old WU that runs on a 4xxx series it will fold it, but those are now rare and only likely to get less frequent for no new projects are going to be created for pre-5xxx series video cards.

http://folding.typepad.com/news/2011/03 ... -gpus.html


I suppose that's the reason why I get no WU for my Radeon HD 4850 .

After reading the link above, I even understand it. Still I have to ask why the client doesn't tell me so? All I get is "ERROR:WU00:FS00:Exception: Could not get an assignment".
Even if those old cards are rare (I'm on my backup-computer), it wouldn't hurt to actually tell the people that the hardware isn't supported. It would save a lot of trouble and time wasted...

Re: Radeon 4670 issue [HD4000 too old]

PostPosted: Sat Sep 22, 2012 6:53 pm
by Joe_H
[WHGT]Cyberman wrote:After reading the link above, I even understand it. Still I have to ask why the client doesn't tell me so? All I get is "ERROR:WU00:FS00:Exception: Could not get an assignment".


All of the current clients that have been released were created before the work ran out for the 4000 and earlier Radeons. So at the time they were listed as "supported". I would expect that at some point a later client version will report the card as unsupported, and not configure the client to fold on it.

As for notification, there has been several postings outside the client and this forum on the coming end to work availability for these cards. That initial announcement dates back 18 months. Even the Windows installation guide now mentions that 5000 series cards are the minimum and work is no longer available for 4000 and prior as I posted farther back in this topic.

Re: Radeon 4670 issue [HD4000 too old]

PostPosted: Sat Sep 22, 2012 9:45 pm
by [WHGT]Cyberman
Joe_H wrote:So at the time they were listed as "supported".

I see.

Even the Windows installation guide now mentions that 5000 series cards are the minimum and work is no longer available for 4000 and prior as I posted farther back in this topic.

I did not see that, though.

I don't read much in this forum or on the website - apparently not enough in the installation guides either...

Does the WU server know the card is outdated? Perhaps it could send a informative message back to the client instead of just "no work for you" (or whatever it does send back). So the logs could explain the reason for the problem.

Re: Radeon 4670 issue [HD4000 too old]

PostPosted: Sun Sep 23, 2012 12:07 am
by P5-133XL
I really don't think the servers or the clients know that the cards are outdated. The client requests a WU and all the server just knows that there isn't anything to give them so all you get is a message say there's no work for you...

With the v7client it would not be unreasonable to blacklist the 4xxx series cards so the client wouldn't even make a GPU slot for it and the system portion of the log would list the card as unsupported.

Re: Radeon 4670 issue [HD4000 too old]

PostPosted: Sun Sep 23, 2012 3:31 am
by bruce
A lot depends on the intent of the researchers. Will there ever be any more projects that can be done by older AMD GPUs? I don't know the answer, but I'll ask.

Re: Radeon 4670 issue [HD4000 too old]

PostPosted: Wed Sep 26, 2012 6:02 am
by iamcreasy
How fast is GPU folding? comparing with CPU?.

Re: Radeon 4670 issue [HD4000 too old]

PostPosted: Wed Sep 26, 2012 6:12 am
by Jesse_V
iamcreasy wrote:How fast is GPU folding? comparing with CPU?.

It depends on the GPU, the CPU, the algorithms used, the compiler, the drivers, the protein, etc. As a rough answer, computationally GPUs can be orders of magnitude faster than CPUs, but last I heard they are more limited in the types of calculations they can do, and there are other pros and cons to each platform. See http://folding.stanford.edu/English/FAQ-highperformance, http://folding.stanford.edu/English/FAQ-NVIDIA-GPU3, and http://en.wikipedia.org/wiki/Folding@ho ... sing_units