Page 1 of 1

server did not like results

PostPosted: Mon Sep 10, 2012 12:06 am
by Bozo
22:50:09:WU01:FS00:0xa4:Completed 0 out of 10000000 steps (0%)
22:50:33:WU00:FS00:Upload 3.57%
22:50:33:WARNING:WU00:FS00:Exception: Failed to send results to work server: Transfer failed
22:50:33:WU00:FS00:Trying to send results to collection server
22:50:33:WU00:FS00:Uploading 1.75MiB to 129.74.85.16
22:50:33:WU00:FS00:Connecting to 129.74.85.16:8080
22:50:39:WU00:FS00:Upload 25.01%
22:50:45:WU00:FS00:Upload 50.01%
22:50:51:WU00:FS00:Upload 75.02%
22:50:56:WU00:FS00:Upload complete
22:50:56:WU00:FS00:Server responded WORK_QUIT (404)
22:50:56:WARNING:WU00:FS00:Server did not like results, dumping

22:50:56:WU00:FS00:Cleaning up

Can anybody elaborate on what his message means?
Never had a problem before so not too concerned but I am wondering if there was problem with sending (in which case should it retry) or bad workunit . I take it I wont get any points for this at all?

project had run its full course and next unit downloaded as expected.

Re: server did not like results

PostPosted: Mon Sep 10, 2012 5:48 am
by bruce
In the past, we've always said that the "Server did not like results, dumping" message meant that the WU had gotten corrupted -- perhaps due to a disk error or something like that -- espceially if the WU was paused and resumed. There can be a variety of causes, though, and there's really no way to prove what happened in your case.

Your log does raise a new possibility, though. There's also no explanation for why the transfer failed after uploading more than 3%. Do you know what happened then? Whether you do or not, there may have been some interaction between the failed upload to the Work Server and the semi-successful upload to the Collection Server. I probably won't be able to answer your question in any more detail but I will check a couple more things. Unfortunately you didn't post the information from the first upload attempt (just before the clip of the log that you posted), including the project/run/clone/gen numbers an the Work Server IP address so I've got nothing to go on.

Re: server did not like results

PostPosted: Mon Sep 10, 2012 8:32 am
by Bozo
To be honest i didn't think the rest of the log would be of that much use as i think that piece I posted was where it first showed it had gone wrong. If it helps at all pretty sure project that failed was 1008x One of the units base credit 600 expected credit around 4500+ I was at the PC at the time because I was in two minds whether to let it download another unit or not (I dont run 24/7 unfortunately) no problems at my end that I am aware of, internet was working, no noises from pc to indicate any sort of disk error. I did however click the fold button to let it get another unit (latest version of folding client).

How I work is I tend to get a unit and if it getting late in the day click finish - I then decide when unit is due to finish whether to get another or not depending on how long I think PC is likely to be on for. I have always done this as and I have never had problem occur before.

Re: server did not like results

PostPosted: Mon Sep 10, 2012 3:30 pm
by 7im
The experts might see something in the log you do not. What does it hurt to post it?