Page 1 of 1

configuration of the client

PostPosted: Sat Sep 15, 2012 6:27 am
by tmillic
Hello.
I just realized that the fahclient was running on this machine (running CentOS). I had installed it several days ago and attempted to install fahcontrol. I failed and also didn't realize that the client is set to run as a service by default.
How do I configure the client to not start automatically or add the one-unit flag?
I found the config.xml file, but I don't know what needs to be entered or what the syntax is.
I keep getting the following with my attempts at configuring the client.
Code: Select all
[tom@localhost init.d]$ sudo /etc/init.d/FAHClient start --configure
Syntax: /etc/init.d/FAHClient [OPTIONS] <COMMAND> [-- [OPTIONS]]
COMMANDS:
        start          Start client
        stop           Stop client
        restart        Full stop then restart client
        reload         Respawn client process
        status         Print client status
        log            Tail the client log
OPTIONS:
        -u <user>      Run as this user.
        -h <home>      Run in this directory.
        -v             Be verbose.  Show WS output

Any options after a '--' will be passed on to the client.
Invalid argument '--configure'
[tom@localhost init.d]$

Re: configuration of the client

PostPosted: Sat Sep 15, 2012 7:41 am
by 7im
The init.d is only for starting and stoping the service. It cannot be configured that way.

Uninstalling the client removes the setting to run as a service.

Then install the command line only version if you want to run manual settings like -oneunit (which no longer exists in V7, uses a different name).

The FAH Linux install guide covers both of these procedures.

Re: configuration of the client

PostPosted: Sat Sep 15, 2012 10:12 am
by bollix47

Re: configuration of the client

PostPosted: Sat Sep 15, 2012 9:53 pm
by tmillic
On the installation instruction page, it seems that it says that both methods will run the client as a service by default and/or depend on FAHControl for configuration. I can't install FAHControl for some reason. It's in the applications menu, but I'm not finding the command to launch it from the terminal. (Nothing happens when trying to launch it from the GUI menu.) That leaves me with a client that starts automatically and can't be configured. I may just revert back to version 6. The computer is often loaded with other demanding tasks, so I'd rather not have a work unit start that it won't have the free resources to complete on time. Hence, the ability to just open a terminal or screen and let it run one unit when it won't have much to do for a couple of days would be nice.

Re: configuration of the client

PostPosted: Sat Sep 15, 2012 10:14 pm
by 7im
I mentioned a third method, installing as command line only, so no fahcontrol.

What version of Centos? Any dependency error messages when installing?

Re: configuration of the client

PostPosted: Mon Sep 17, 2012 12:43 am
by tmillic
Ahh. I was mistaking the section called "Terminal installation for RedHat / CentOS / Fedora" on the install guide page as the terminal client. I scrolled down further and found the tarball as you described. the information given by the --help flag on the configuration options helps a lot. It's running. We'll see if it stops at the end.
Thanks.