Page 1 of 1

Stuck at connecting

PostPosted: Tue Sep 18, 2012 7:24 am
by iceman1992
Brand new ubuntu 12.04 installation on VMWare player, installed fahclient, fahcontrol, and fahviewer 7.1.52..
I started fahcontrol, and it stays at "Client: local Connecting Inactive".. What do I do?

Re: Stuck at connecting

PostPosted: Tue Sep 18, 2012 7:33 am
by Jesse_V
Make sure the option to autostart the client is checked under the Preferences window.

Re: Stuck at connecting

PostPosted: Tue Sep 18, 2012 7:37 am
by iceman1992
oh right.. thanks! I unchecked it, I thought it was an option to start the client on boot..

Re: Stuck at connecting

PostPosted: Tue Sep 18, 2012 3:06 pm
by Jesse_V
iceman1992 wrote:oh right.. thanks! I unchecked it, I thought it was an option to start the client on boot..

I made a similar mistake a few days ago, it's all good. :)

Re: Stuck at connecting

PostPosted: Tue Sep 18, 2012 5:01 pm
by iceman1992
I noticed something that may be a bug.. When I installed fahclient, the installer asked for my username, team number, and passkey.. But then when I start fahcontrol, my username/team/passkey is Anonymous/0/blank..

That happened too when I installed fah on ubuntu virtualbox..

Re: Stuck at connecting

PostPosted: Tue Sep 18, 2012 5:19 pm
by 7im
Jesse_V wrote:Make sure the option to autostart the client is checked under the Preferences window.



This may work in Windows, but has nothing to do with Linux. In Linux, the fahclient is run as a service, and starts at boot automatically.

Also, the autostart box in preferences is unchecked by default, as it doesn't apply.

I've installed on several VMs, and have not had a problem getting the user name, etc. passed from the .DEB package installer to the client.

How exactly did you install fah?

Re: Stuck at connecting

PostPosted: Tue Sep 18, 2012 5:31 pm
by iceman1992
7im wrote:In Linux, the fahclient is run as a service, and starts at boot automatically.
My fah client is not installed as a service, I unchecked the autostart option during installation..

7im wrote:How exactly did you install fah?
Downloaded the file, then ran it, which brought up ubuntu software center, and I clicked install

Re: Stuck at connecting

PostPosted: Tue Sep 18, 2012 6:02 pm
by 7im
My mistake. I hadn't seen the new option to not autostart that Joe added. And I can confirm it is broken. When you don't autostart, the user info isn't passed through to the config. Client starts as Anonymous on team 0. New ticket is imminent.

#933 - User info not passed to config when no autostart in Ubuntu from .DEB package

Re: Stuck at connecting

PostPosted: Tue Sep 18, 2012 6:27 pm
by iceman1992
Okay thanks :D