Page 1 of 1

v7 on Win Srver 08 issues

PostPosted: Mon Oct 01, 2012 4:58 pm
by patonb
Switching my client from v6 to v7 on my server 08 machine, but have run into errors when running fahclient

Code: Select all
Activation context generation failed for "C:\Program Files (x86)\FAHClient\FAHControl.exe". Dependent Assembly Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8" could not be found. Please use sxstrace.exe for detailed diagnosis.


Any help?

Thanks

Re: v7 on Win Srver 08 issues

PostPosted: Mon Oct 01, 2012 5:06 pm
by bruce
I think that one is fixed by installing the 2007 C++ library from Microsoft. There are several V7 tickets faulting it for not checking for prerequisites.

Re: v7 on Win Srver 08 issues

PostPosted: Mon Oct 01, 2012 9:47 pm
by patonb
Yup, you are correct... BUT it's the x86 version it needs, not the x64.

Thanks a bunch

Re: v7 on Win Srver 08 issues

PostPosted: Tue Oct 02, 2012 3:49 am
by bruce
Sorry: It's the 2008 Visual C++ redist (not 2007)
See https://fah-web.stanford.edu/projects/F ... ticket/662

You also need .net 2.0 which can only be found if you look for .net 3.5
See https://fah-web.stanford.edu/projects/F ... ticket/754

Re: v7 on Win Srver 08 issues

PostPosted: Tue Oct 02, 2012 8:22 am
by 7im
.net only needs to be added to winxp to run fah (which you would already have if you kept current with win updates). Win vista and above do not need .net added.