Page 1 of 1

Can't run F@H on my non-admin user, why?

PostPosted: Sat Oct 13, 2012 11:20 pm
by Treq

I have been folding for years, mainly on Linux machines.
Now I wanted to set up the Windows client on my Win7 Ultimate x64 laptop, but can't get it to work properly.

The thing is that my regular user on the laptop is not an admin. I have two users on the laptop, admin (which I never log into) and my regular user.
If I install something or do some system-maintainence, Win7 prompts me for the password for the single admin user account, and off we go.
This works great for everything but F@H.

It installs ok, but it becomes unusable from my regular account.
1. No matter if I choose install for me or for all, there is no start-menu item installed for my regular user, only the admin user. (Not a big deal, but still)
2. No matter if I let it go ahead and put it's datafiles into "c:\users\admin\appdata\roaming", which it would like to do, even though I called it from my regular user, or if I set the datafiles to be in "c:\users\regular\appdata\roaming\", it will not work from the regular user.

Running fahcontrol as regular user or with "run as administrator" gives me the fahcontrol window, forever trying to connect to the local client.
Running fahclient from the command-line as regular user gives me:
Code: Select all
C:\Program Files (x86)\FAHClient>fahclient
22:01:14:************************* Folding@home Client *************************

22:01:14:      Website:
22:01:14:    Copyright: (c) 2009-2012 Stanford University
22:01:14:       Author: Joseph Coffland <>
22:01:14:         Args:
22:01:14:       Config: <none>
22:01:14:******************************** Build ********************************

22:01:14:      Version: 7.1.52
22:01:14:         Date: Mar 20 2012
22:01:14:         Time: 19:37:42
22:01:14:      SVN Rev: 3515
22:01:14:       Branch: fah/trunk/client
22:01:14:     Compiler: Intel(R) C++ MSVC 1500 mode 1200
22:01:14:      Options: /TP /nologo /EHa /Qdiag-disable:4297,4103,1786,279 /Ox -
22:01:14:               /QaxSSE2,SSE3,SSSE3,SSE4.1,SSE4.2 /Qopenmp /Qrestrict /M
22:01:14:     Platform: win32 XP
22:01:14:         Bits: 32
22:01:14:         Mode: Release
22:01:14:******************************* System ********************************

22:01:14:          CPU: Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz
22:01:14:       CPU ID: GenuineIntel Family 6 Model 42 Stepping 7
22:01:14:         CPUs: 8
22:01:14:       Memory: 7.78GiB
22:01:14:  Free Memory: 4.84GiB
22:01:14:      Threads: WINDOWS_THREADS
22:01:14:   On Battery: false
22:01:14:   UTC offset: 2
22:01:14:          PID: 3556
22:01:14:          CWD: C:/Program Files (x86)/FAHClient
22:01:14:           OS: Windows 7 Ultimate
22:01:14:      OS Arch: AMD64
22:01:14:         GPUs: 0
22:01:14:         CUDA: Not detected
22:01:14:Win32 Service: false

22:01:14:  <!-- Folding Slots -->
22:01:14:Trying to access database...
22:01:14:Successfully acquired database lock
22:01:14:Enabled folding slot 00: READY smp:8
22:01:14:WU00:FS00:Downloading core from
22:01:14:WU00:FS00:Connecting to
22:01:15:WU00:FS00:FahCore a4: Downloading 2.89MiB
22:01:21:WU00:FS00:FahCore a4: 30.30%
22:01:27:WU00:FS00:FahCore a4: 62.76%
22:01:33:WU00:FS00:FahCore a4: 93.06%
22:01:34:WU00:FS00:FahCore a4: Download complete
22:01:34:WU00:FS00:Valid core signature
22:01:34:ERROR:WU00:FS00:Exception: Failed to open 'cores/
e/Win32/AMD64/Core_a4.fah/FahCore_a4.exe': Failed to open 'cores/www.stanford.ed
u/~pande/Win32/AMD64/Core_a4.fah/FahCore_a4.exe': Access is denied.
22:01:34:ERROR:WU00:FS00:: Access is denied.
22:01:54:WARNING:Console control signal 0 on PID 3556
22:01:54:Exiting, please wait. . .
22:01:55:Clean exit

In the case above, both "C:\Users\admin\AppData\Roaming\FAHClient" as well as "C:\Users\regular\AppData\Roaming\FAHClient" exists. But for some reason it always tries to access admin's data, even if it is called by regular.

Now, running fahclient as admin-user works, but it seems that since fahcontrol didn't start fahclient, it connect to it but can't control it. Meaning that I can't set fahcontrol to stop fahclient when I pull out the power from the laptop.

Is there anything to do apart from changing my useraccount to an admin-user?

Re: Can't run F@H on my non-admin user, why?

PostPosted: Sun Oct 14, 2012 7:09 am
by Napoleon
Yes, there is, but it may require some extra steps (FAH custom install). I've followed the steps below myself. There probably are better and simpler ways, but this has worked for me. I'm guessing that the installer will be improved sooner or later, though.
  1. Create a custom folder for FAH, e.g C:\FAH
  2. Make sure that regular account(s) on which you want to run FAH have sufficient permissions for that folder (I gave full access to the regular account I normally use)
  3. Choose custom installation of FAH and specify the client and data destination directories yourself, for example C:\FAH\Client and C:\FAH\Data
  4. Find out where the FAH installer put the start menu shortcuts. In your case they're probably found at "C:\Users\admin\Appdata\Roaming\Microsoft\Windows\Start Menu\Programs"
  5. Copy the FAH shortcuts to "C:\Users\regular\Appdata\Roaming\Microsoft\Windows\Start Menu\Programs"
BTW, if you're going to reinstall FAH, you could try the v7.2.9 open beta client.

Re: Can't run F@H on my non-admin user, why?

PostPosted: Sun Oct 14, 2012 7:11 am
by bruce
Welcome to, Treq.

When FAH is installed on Windows, if you install as the user who will be running FAHClient and accept the default settings when you install ("only for me" and the default directories) it will work correctly. (You'll get a pop-up asking for admin rights to install the software in Program Files.) In the beta version, some other choices work and others do not. There are several open tickets where you folks have run into permission problems such as the only you have. It's much easier to reinstall with the options that work than to try to fix the install that you have.

Re: Can't run F@H on my non-admin user, why?

PostPosted: Sun Oct 14, 2012 7:23 am
by Napoleon
Hmm, I still had to copy the shortcuts from admin account's start menu. I prefer the custom approach simply because I feel more comfortable tinkering with permissions of a fresh folder. Plus, if I ever see any need to give folding access to more than one regular account, I only need to copy the shortcuts and add permissions to the custom directory. Kind of handmade "install for some users" choice between "all users" and "only for me".

Re: Can't run F@H on my non-admin user, why?

PostPosted: Fri Oct 19, 2012 8:46 am
by Treq
There is definately something not quite right with the logic in the installer when it comes to this.
If a non-admin user installs FAHClient with the "Automatically start with FAHControl", then it just doesn't work. Have tried both on my laptop as well as my home PC (Both win64/ultimate)

However, something that does work is to choose "Start as a system service at boot time".
Still the installer will not put the FAHClient/Control shortcuts on the start-menu, but at least FAHControl(run as administrator) is able to control the FAHClient and everything works.

Re: Can't run F@H on my non-admin user, why?

PostPosted: Fri Oct 19, 2012 1:25 pm
by P5-133XL
It has been accepted as a major (priority 3) bug #889.

Re: Can't run F@H on my non-admin user, why?

PostPosted: Sat Oct 27, 2012 8:36 am
by Treq
Ok, this is nice.

Another thing is that my laptop is constantly running in standard loops because the client is never shut down gracefully when I move from plugged in over to battery:

Code: Select all
07:23:59:WU00:FS00:0xa4:Preparing to commence simulation
07:23:59:WU00:FS00:0xa4:- Ensuring status. Please wait.
07:24:08:WU00:FS00:0xa4:- Looking at optimizations...
07:24:08:WU00:FS00:0xa4:- Working with standard loops on this execution.
07:24:08:WU00:FS00:0xa4:Examination of work files indicates 8 consecutive improper terminations of core.
07:24:08:WU00:FS00:0xa4:- Expanded 547210 -> 847748 (decompressed 154.9 percent)
07:24:08:WU00:FS00:0xa4:Called DecompressByteArray: compressed_data_size=547210 data_size=847748, decompressed_data_size=847748 diff=0
07:24:08:WU00:FS00:0xa4:- Digital signature verified
07:24:08:WU00:FS00:0xa4:Project: 7645 (Run 312, Clone 0, Gen 10)
07:24:08:WU00:FS00:0xa4:Entering M.D.
07:24:14:WU00:FS00:0xa4:Using Gromacs checkpoints
07:24:15:WU00:FS00:0xa4:Mapping NT from 8 to 8
07:24:17:WU00:FS00:0xa4:Resuming from checkpoint
07:24:17:WU00:FS00:0xa4:Verified 00/wudata_01.log
07:24:20:WU00:FS00:0xa4:Verified 00/wudata_01.trr
07:24:20:WU00:FS00:0xa4:Verified 00/wudata_01.xtc
07:24:20:WU00:FS00:0xa4:Verified 00/wudata_01.edr
07:24:22:WU00:FS00:0xa4:Completed 1868580 out of 2500000 steps  (74%)
07:25:35:FS00:Shutting core down
07:25:35:WARNING:FS00:FahCore not accepting gentle shutdown, killing
07:25:35:WARNING:FS00:Killing WU00
07:25:35:WU00:FS00:FahCore terminated

This gets old fast as well. Is there a workaround for this perhaps?

Re: Can't run F@H on my non-admin user, why?

PostPosted: Sat Oct 27, 2012 8:43 am
by Napoleon
Do you notice any performance difference between standard loops and SSE? I'm under the impression that this only makes a difference on old FahCore_78. AFAIK, all other fahcores have SSE hardcoded in them. If it's merely a cosmetic thing, I don't think there's any particular hurry to fix it.

Re: Can't run F@H on my non-admin user, why?

PostPosted: Sat Oct 27, 2012 5:33 pm
by 7im
Cosmetic only!