Limiting CPU usage not working?

Moderators: Site Moderators, FAHC Science Team

Limiting CPU usage not working?

Postby Destructo1 » Sat Nov 03, 2012 5:16 am

So, I set the client to only use 75% cpu usage (through the configure - advanced settings) and it was still running at 80-90%. So then I dropped it down to 55 and then 15% but taskmanager still says that the core is using 80-90% of my cpu. Why is it ignoring my settings?
Destructo1
 
Posts: 4
Joined: Sat Nov 03, 2012 5:06 am

Re: Limiting CPU usage not working?

Postby bruce » Sat Nov 03, 2012 6:00 am

Welcome to foldingforum.org, Destructo1.

Are you running the Windows V6.23 uniprocessor client like the forum title suggests or are you running something else?

Please copy and paste the first several pages of the FAH log into your next post so we can see what's going on.

The CPU setting is pretty dependable when you're actually configured for a Uniprocessor assignment but if you're configured for SMP or for a GPU, that's an entirely different story.
bruce
 
Posts: 20140
Joined: Thu Nov 29, 2007 11:13 pm
Location: So. Cal.

Re: Limiting CPU usage not working?

Postby Destructo1 » Sat Nov 03, 2012 7:12 pm

Is this the log you are talking about because this was under the log tab, and I just decided to limit the cpu using windows power options and that has seemed to work so i set the cpu usage back up to 100%

04:24:34:Saving configuration to config.xml
04:24:34:<config>
04:24:34: <!-- Folding Slot Configuration -->
04:24:34: <gpu v='true'/>
04:24:34:
04:24:34: <!-- Network -->
04:24:34: <proxy v=':8080'/>
04:24:34:
04:24:34: <!-- Slot Control -->
04:24:34: <pause-on-battery v='true'/>
04:24:34:
04:24:34: <!-- User Information -->
04:24:34: <passkey v='********************************'/>
04:24:34: <team v='212997'/>
04:24:34: <user v='Destructo1'/>
04:24:34:
04:24:34: <!-- Folding Slots -->
04:24:34: <slot id='0' type='SMP'/>
04:24:34:</config>
04:25:18:WU00:FS00:0xa4:Completed 50000 out of 500000 steps (10%)
04:38:23:WU00:FS00:0xa4:Completed 55000 out of 500000 steps (11%)
04:51:48:WU00:FS00:0xa4:Completed 60000 out of 500000 steps (12%)
05:02:17:WU00:FS00:0xa4:Completed 65000 out of 500000 steps (13%)
05:13:31:WU00:FS00:0xa4:Completed 70000 out of 500000 steps (14%)
05:26:10:WU00:FS00:0xa4:Completed 75000 out of 500000 steps (15%)
05:40:20:WU00:FS00:0xa4:Completed 80000 out of 500000 steps (16%)
05:54:36:WU00:FS00:0xa4:Completed 85000 out of 500000 steps (17%)
06:08:36:WU00:FS00:0xa4:Completed 90000 out of 500000 steps (18%)
06:23:37:WU00:FS00:0xa4:Completed 95000 out of 500000 steps (19%)
06:38:50:WU00:FS00:0xa4:Completed 100000 out of 500000 steps (20%)
06:53:22:WU00:FS00:0xa4:Completed 105000 out of 500000 steps (21%)
07:07:33:WU00:FS00:0xa4:Completed 110000 out of 500000 steps (22%)
07:21:57:WU00:FS00:0xa4:Completed 115000 out of 500000 steps (23%)
07:36:43:WU00:FS00:0xa4:Completed 120000 out of 500000 steps (24%)
07:51:07:WU00:FS00:0xa4:Completed 125000 out of 500000 steps (25%)
08:06:46:WU00:FS00:0xa4:Completed 130000 out of 500000 steps (26%)
08:31:49:WU00:FS00:0xa4:Completed 135000 out of 500000 steps (27%)
******************************** Date: 03/11/12 ********************************
09:11:41:WU00:FS00:0xa4:Completed 140000 out of 500000 steps (28%)
09:38:48:WU00:FS00:0xa4:Completed 145000 out of 500000 steps (29%)
09:54:57:WU00:FS00:0xa4:Completed 150000 out of 500000 steps (30%)
10:17:28:WU00:FS00:0xa4:Completed 155000 out of 500000 steps (31%)
10:38:02:WU00:FS00:0xa4:Completed 160000 out of 500000 steps (32%)
10:53:41:WU00:FS00:0xa4:Completed 165000 out of 500000 steps (33%)
11:08:30:WU00:FS00:0xa4:Completed 170000 out of 500000 steps (34%)
11:24:44:WU00:FS00:0xa4:Completed 175000 out of 500000 steps (35%)
11:41:11:WU00:FS00:0xa4:Completed 180000 out of 500000 steps (36%)
11:54:41:WU00:FS00:0xa4:Completed 185000 out of 500000 steps (37%)
12:08:20:WU00:FS00:0xa4:Completed 190000 out of 500000 steps (38%)
12:23:12:WU00:FS00:0xa4:Completed 195000 out of 500000 steps (39%)
12:37:54:WU00:FS00:0xa4:Completed 200000 out of 500000 steps (40%)
12:53:05:WU00:FS00:0xa4:Completed 205000 out of 500000 steps (41%)
13:09:24:WU00:FS00:0xa4:Completed 210000 out of 500000 steps (42%)
13:24:38:WU00:FS00:0xa4:Completed 215000 out of 500000 steps (43%)
13:38:50:WU00:FS00:0xa4:Completed 220000 out of 500000 steps (44%)
13:53:47:WU00:FS00:0xa4:Completed 225000 out of 500000 steps (45%)
14:09:10:WU00:FS00:0xa4:Completed 230000 out of 500000 steps (46%)
14:24:57:WU00:FS00:0xa4:Completed 235000 out of 500000 steps (47%)
14:39:29:WU00:FS00:0xa4:Completed 240000 out of 500000 steps (48%)
14:55:23:WU00:FS00:0xa4:Completed 245000 out of 500000 steps (49%)
******************************** Date: 03/11/12 ********************************
15:15:57:WU00:FS00:0xa4:Completed 250000 out of 500000 steps (50%)
15:29:12:WU00:FS00:0xa4:Completed 255000 out of 500000 steps (51%)
15:42:27:WU00:FS00:0xa4:Completed 260000 out of 500000 steps (52%)
15:55:53:WU00:FS00:0xa4:Completed 265000 out of 500000 steps (53%)
16:09:13:WU00:FS00:0xa4:Completed 270000 out of 500000 steps (54%)
16:22:40:WU00:FS00:0xa4:Completed 275000 out of 500000 steps (55%)
16:35:55:WU00:FS00:0xa4:Completed 280000 out of 500000 steps (56%)
16:49:22:WU00:FS00:0xa4:Completed 285000 out of 500000 steps (57%)
17:02:41:WU00:FS00:0xa4:Completed 290000 out of 500000 steps (58%)
17:15:55:WU00:FS00:0xa4:Completed 295000 out of 500000 steps (59%)
17:28:47:WU00:FS00:0xa4:Completed 300000 out of 500000 steps (60%)
17:40:28:WU00:FS00:0xa4:Completed 305000 out of 500000 steps (61%)
17:57:12:WU00:FS00:0xa4:Completed 310000 out of 500000 steps (62%)
Destructo1
 
Posts: 4
Joined: Sat Nov 03, 2012 5:06 am

Re: Limiting CPU usage not working?

Postby P5-133XL » Sat Nov 03, 2012 8:16 pm

The CPU limiter is basically limited to uniprocessor slots. You have an SMP slot configured so it won't work well (It is limited to a single core and you have multiples. If you want to limit the amount of CPU usage for an SMP slot then what you do is reconfigure the SMP slot to use fewer cores.

You can do that in either expert or advanced mode (upper right hand corner of FAHControl). Then press the configure button and click on the slots tab. Highlight your SMP slot and click the edit button (Lower right). From there you can pick the number of CPU threads (cores) to be used. The only caveat is do not choose 7 (some WU's will crash if you pick large prime numbers and 7 qualifies)
Image
P5-133XL
 
Posts: 2948
Joined: Sun Dec 02, 2007 5:36 am
Location: Salem. OR USA

Re: Limiting CPU usage not working?

Postby bruce » Sat Nov 03, 2012 8:46 pm

I'm moving this topic from "v6.23 Windows Classic (Uniprocessor) Client" to the topic on the V7 client. [The two are VERY different].

The best way to limit CPU usage with a SMP slot is to allow it to use fewer processors but I'd need to know how many CPUs you have to make a rational recommendation. That would have been at the top of the log if you had done a refresh. You didn't do that so I don't see the first page of the log where it shows your hardware configuration and I'll have to guess whether you're running V7.1.52 or V7.2.9 since both have been on the download page within the last several days. We're a lot closer to the right answer, though, with what you posted.
bruce
 
Posts: 20140
Joined: Thu Nov 29, 2007 11:13 pm
Location: So. Cal.

Re: Limiting CPU usage not working?

Postby Destructo1 » Sat Nov 03, 2012 11:28 pm

Oh, so this is what you needed? and because it said I had 4 CPUs I set the CPUs for the smp to use down to 2 (I put the log entry for this below the first log), but it still isn't letting me throttle. I no matter what percent I set it to use it uses all available CPU power. And sorry I just downloaded this and I wasn't sure what version I had
*********************** Log Started 2012-11-03T02:49:02Z ***********************
02:49:02:************************* Folding@home Client *************************
02:49:02: Website: http://folding.stanford.edu/
02:49:02: Copyright: (c) 2009-2012 Stanford University
02:49:02: Author: Joseph Coffland <joseph@cauldrondevelopment.com>
02:49:02: Args: --lifeline 14092 --command-port=36330
02:49:02: Config: C:/Users/Andy/AppData/Roaming/FAHClient/config.xml
02:49:02:******************************** Build ********************************
02:49:02: Version: 7.2.9
02:49:02: Date: Oct 3 2012
02:49:02: Time: 18:05:48
02:49:02: SVN Rev: 3578
02:49:02: Branch: fah/trunk/client
02:49:02: Compiler: Intel(R) C++ MSVC 1500 mode 1200
02:49:02: Options: /TP /nologo /EHa /Qdiag-disable:4297,4103,1786,279 /Ox -arch:SSE
02:49:02: /QaxSSE2,SSE3,SSSE3,SSE4.1,SSE4.2 /Qopenmp /Qrestrict /MT /Qmkl
02:49:02: Platform: win32 XP
02:49:02: Bits: 32
02:49:02: Mode: Release
02:49:02:******************************* System ********************************
02:49:02: CPU: Intel(R) Core(TM) i3 CPU M 370 @ 2.40GHz
02:49:02: CPU ID: GenuineIntel Family 6 Model 37 Stepping 5
02:49:02: CPUs: 4
02:49:02: Memory: 3.68GiB
02:49:02: Free Memory: 680.68MiB
02:49:02: Threads: WINDOWS_THREADS
02:49:02: On Battery: false
02:49:02: UTC offset: -4
02:49:02: PID: 12940
02:49:02: CWD: C:/Users/Andy/AppData/Roaming/FAHClient
02:49:02: OS: Windows 7 Home Premium
02:49:02: OS Arch: AMD64
02:49:02: GPUs: 0
02:49:02: CUDA: Not detected
02:49:02:Win32 Service: false
02:49:02:***********************************************************************
02:49:02:<config>
02:49:02: <!-- Folding Slot Configuration -->
02:49:02: <gpu v='true'/>
02:49:02:
02:49:02: <!-- User Information -->
02:49:02: <team v='212997'/>
02:49:02: <user v='Destructo1'/>
02:49:02:
02:49:02: <!-- Folding Slots -->
02:49:02:</config>


This is after I set the smp to only use 2 CPUs
22:08:17:WU00:FS00:0xa4:Completed 410000 out of 500000 steps (82%)
22:14:53:WU00:FS00:0xa4:Completed 415000 out of 500000 steps (83%)
22:17:08:Saving configuration to config.xml
22:17:08:<config>
22:17:08: <!-- FahCore Control -->
22:17:08: <cpu-usage v='90'/>
22:17:08:
22:17:08: <!-- Folding Slot Configuration -->
22:17:08: <gpu v='true'/>
22:17:08:
22:17:08: <!-- Network -->
22:17:08: <proxy v=':8080'/>
22:17:08:
22:17:08: <!-- Slot Control -->
22:17:08: <pause-on-battery v='true'/>
22:17:08:
22:17:08: <!-- User Information -->
22:17:08: <passkey v='********************************'/>
22:17:08: <team v='212997'/>
22:17:08: <user v='Destructo1'/>
22:17:08:
22:17:08: <!-- Folding Slots -->
22:17:08: <slot id='0' type='SMP'>
22:17:08: <cpus v='2'/>
22:17:08: </slot>
22:17:08:</config>
22:21:17:WU00:FS00:0xa4:Completed 420000 out of 500000 steps (84%)
Destructo1
 
Posts: 4
Joined: Sat Nov 03, 2012 5:06 am

Re: Limiting CPU usage not working?

Postby Destructo1 » Sat Nov 03, 2012 11:36 pm

Nevermind, I restarted the program and now everything works.

Thank You very much
Destructo1
 
Posts: 4
Joined: Sat Nov 03, 2012 5:06 am

Re: Limiting CPU usage not working?

Postby Napoleon » Sat Nov 03, 2012 11:55 pm

Might as well return the FAH CPU usage slider back to default 100%.

Note that the 50% CPU utilization shown by Task Manager with SMP:2 is misleading because you have a HyperThreaded CPU with two real cores and 4 CPU threads. In reality SMP:2 will still be using both real FPUs and running at about 80% power, but hopefully that's just the right amount in order to meet your CPU usage goals.
Win7 64bit, FAH v7, OC'd
2C/4T Atom330 3x667MHz - GT430 2x832.5MHz - ION iGPU 3x466.7MHz
NaCl - Core_15 - display
User avatar
Napoleon
 
Posts: 887
Joined: Wed May 26, 2010 3:31 pm
Location: Finland


Return to V7.1.52 Windows/Linux

Who is online

Users browsing this forum: No registered users and 2 guests

cron