Page 1 of 1

Core A7 switched from AVX back to SSE2

PostPosted: Sat Oct 12, 2019 3:50 am
by _r2w_ben
I noticed sse2 mentioned in the startup of the most recent a7 work unit on a machine that supports AVX. I searched through the logs folder and the client switched from using AVX to SSE2 between July 1st and 2nd. Were there assignment or work server code changes that would have affected CPU detection and instructed the client to use SSE2? Anyone that is currently running a7 work units, could you check your logs to see what SIMD method is in use and indicate whether your CPU supports AVX, AVX2, or AVX-512?

Log entries for work unit startups are below.

Last A7 work unit using AVX version of Core_a7 version 0.0.17:
Code: Select all
16:08:53:WU03:FS00:Connecting to
16:08:53:WU03:FS00:Assigned to work server
16:08:53:WU03:FS00:Requesting new work unit for slot 00: RUNNING cpu:2 from
16:08:53:WU03:FS00:Connecting to
16:08:54:WU03:FS00:Downloading 966.25KiB
16:08:55:WU03:FS00:Download complete
16:08:55:WU03:FS00:Received Unit: id:03 state:DOWNLOAD error:NO_ERROR project:14104 run:13 clone:30 gen:57 core:0xa7 unit:0x000000480002894b5c929afb03673de4
16:09:01:WU03:FS00:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\[snip]\AppData\Roaming\FAHClient\cores/ -dir 03 -suffix 01 -version 705 -lifeline 928 -checkpoint 15 -np 2
16:09:01:WU03:FS00:Started FahCore on PID 4312
16:09:01:WU03:FS00:Core PID:3504
16:09:01:WU03:FS00:FahCore 0xa7 started
16:09:01:WU03:FS00:0xa7:*********************** Log Started 2019-07-01T16:09:01Z ***********************
16:09:01:WU03:FS00:0xa7:************************** Gromacs Folding@home Core ***************************
16:09:01:WU03:FS00:0xa7:       Type: 0xa7
16:09:01:WU03:FS00:0xa7:       Core: Gromacs
16:09:01:WU03:FS00:0xa7:    Website:
16:09:01:WU03:FS00:0xa7:  Copyright: (c) 2009-2018
16:09:01:WU03:FS00:0xa7:     Author: Joseph Coffland <>
16:09:01:WU03:FS00:0xa7:       Args: -dir 03 -suffix 01 -version 705 -lifeline 4312 -checkpoint 15 -np 2
16:09:01:WU03:FS00:0xa7:     Config: <none>
16:09:01:WU03:FS00:0xa7:************************************ Build *************************************
16:09:01:WU03:FS00:0xa7:    Version: 0.0.17
16:09:01:WU03:FS00:0xa7:       Date: Apr 27 2018
16:09:01:WU03:FS00:0xa7:       Time: 16:19:36
16:09:01:WU03:FS00:0xa7: Repository: Git
16:09:01:WU03:FS00:0xa7:   Revision: 21359963583d09ec2063ef946399441c4df4ccd7
16:09:01:WU03:FS00:0xa7:     Branch: master
16:09:01:WU03:FS00:0xa7:   Compiler: Visual C++ 2008
16:09:01:WU03:FS00:0xa7:    Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
16:09:01:WU03:FS00:0xa7:   Platform: win32 10
16:09:01:WU03:FS00:0xa7:       Bits: 64
16:09:01:WU03:FS00:0xa7:       Mode: Release
16:09:01:WU03:FS00:0xa7:       SIMD: avx_256
16:09:01:WU03:FS00:0xa7:************************************ System ************************************
16:09:01:WU03:FS00:0xa7:        CPU: Unknown
16:09:01:WU03:FS00:0xa7:     CPU ID:
16:09:01:WU03:FS00:0xa7:       CPUs: 4
16:09:01:WU03:FS00:0xa7:     Memory: 6.94GiB
16:09:01:WU03:FS00:0xa7:Free Memory: 5.42GiB
16:09:01:WU03:FS00:0xa7:    Threads: WINDOWS_THREADS
16:09:01:WU03:FS00:0xa7: OS Version: 6.2
16:09:01:WU03:FS00:0xa7:Has Battery: false
16:09:01:WU03:FS00:0xa7: On Battery: false
16:09:01:WU03:FS00:0xa7: UTC Offset: -4
16:09:01:WU03:FS00:0xa7:        PID: 3504
16:09:01:WU03:FS00:0xa7:        CWD: C:\Users\[snip]\AppData\Roaming\FAHClient\work
16:09:01:WU03:FS00:0xa7:         OS: Windows 8.1
16:09:01:WU03:FS00:0xa7:    OS Arch: AMD64
16:09:01:WU03:FS00:0xa7:Project: 14104 (Run 13, Clone 30, Gen 57)

Next A7 work unit using SSE2 version of Core_a7 version 0.0.17:
Code: Select all
18:28:44:WU02:FS00:Connecting to
18:28:44:WU02:FS00:Assigned to work server
18:28:44:WU02:FS00:Requesting new work unit for slot 00: RUNNING cpu:2 from
18:28:44:WU02:FS00:Connecting to
18:28:44:WU02:FS00:Downloading 8.14MiB
18:28:46:WU02:FS00:Download complete
18:28:46:WU02:FS00:Received Unit: id:02 state:DOWNLOAD error:NO_ERROR project:13825 run:139 clone:2 gen:41 core:0xa7 unit:0x0000002c80fccb095c95661e0f788341
18:28:46:WU02:FS00:Downloading core from
18:28:46:WU02:FS00:Connecting to
18:28:47:WU02:FS00:FahCore a7: Downloading 5.10MiB
18:28:48:WU02:FS00:FahCore a7: Download complete
18:28:48:WU02:FS00:Valid core signature
18:28:48:WU02:FS00:Unpacked 15.36MiB to cores/
18:28:49:WU02:FS00:Unpacked 2.07MiB to cores/
18:28:49:WU02:FS00:Unpacked 105.50KiB to cores/
18:28:50:WU02:FS00:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\[snip]\AppData\Roaming\FAHClient\cores/ -dir 02 -suffix 01 -version 705 -lifeline 928 -checkpoint 15 -np 2
18:28:50:WU02:FS00:Started FahCore on PID 6140
18:28:50:WU02:FS00:Core PID:5564
18:28:50:WU02:FS00:FahCore 0xa7 started
18:28:50:WU02:FS00:0xa7:*********************** Log Started 2019-07-02T18:28:50Z ***********************
18:28:50:WU02:FS00:0xa7:************************** Gromacs Folding@home Core ***************************
18:28:50:WU02:FS00:0xa7:       Type: 0xa7
18:28:50:WU02:FS00:0xa7:       Core: Gromacs
18:28:50:WU02:FS00:0xa7:    Website:
18:28:50:WU02:FS00:0xa7:  Copyright: (c) 2009-2018
18:28:50:WU02:FS00:0xa7:     Author: Joseph Coffland <>
18:28:50:WU02:FS00:0xa7:       Args: -dir 02 -suffix 01 -version 705 -lifeline 6140 -checkpoint 15 -np 2
18:28:50:WU02:FS00:0xa7:     Config: <none>
18:28:50:WU02:FS00:0xa7:************************************ Build *************************************
18:28:50:WU02:FS00:0xa7:    Version: 0.0.17
18:28:50:WU02:FS00:0xa7:       Date: Apr 25 2018
18:28:50:WU02:FS00:0xa7:       Time: 11:02:26
18:28:50:WU02:FS00:0xa7: Repository: Git
18:28:50:WU02:FS00:0xa7:   Revision: fd11abfb405c921e66db1226933e9dd2d18d2acc
18:28:50:WU02:FS00:0xa7:     Branch: master
18:28:50:WU02:FS00:0xa7:   Compiler: Visual C++ 2008
18:28:50:WU02:FS00:0xa7:    Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
18:28:50:WU02:FS00:0xa7:   Platform: win32 10
18:28:50:WU02:FS00:0xa7:       Bits: 32
18:28:50:WU02:FS00:0xa7:       Mode: Release
18:28:50:WU02:FS00:0xa7:       SIMD: sse2
18:28:50:WU02:FS00:0xa7:************************************ System ************************************
18:28:50:WU02:FS00:0xa7:        CPU: Unknown
18:28:51:WU02:FS00:0xa7:     CPU ID:
18:28:51:WU02:FS00:0xa7:       CPUs: 4
18:28:51:WU02:FS00:0xa7:     Memory: 6.94GiB
18:28:51:WU02:FS00:0xa7:Free Memory: 5.37GiB
18:28:51:WU02:FS00:0xa7:    Threads: WINDOWS_THREADS
18:28:51:WU02:FS00:0xa7: OS Version: 6.2
18:28:51:WU02:FS00:0xa7:Has Battery: false
18:28:51:WU02:FS00:0xa7: On Battery: false
18:28:51:WU02:FS00:0xa7: UTC Offset: -4
18:28:51:WU02:FS00:0xa7:        PID: 5564
18:28:51:WU02:FS00:0xa7:        CWD: C:\Users\[snip]\AppData\Roaming\FAHClient\work
18:28:51:WU02:FS00:0xa7:         OS: Windows 8.1
18:28:51:WU02:FS00:0xa7:    OS Arch: AMD64
18:28:51:WU02:FS00:0xa7:Project: 13825 (Run 139, Clone 2, Gen 41)

Most recent A7 work unit using SSE2 version of Core_a7 version 0.0.17:
Code: Select all
21:24:24:WU02:FS00:Connecting to
21:24:24:WU02:FS00:Assigned to work server
21:24:24:WU02:FS00:Requesting new work unit for slot 00: RUNNING cpu:2 from
21:24:24:WU02:FS00:Connecting to
21:24:24:WU02:FS00:Downloading 8.14MiB
21:24:26:WU02:FS00:Download complete
21:24:26:WU02:FS00:Received Unit: id:02 state:DOWNLOAD error:NO_ERROR project:13830 run:745 clone:0 gen:12 core:0xa7 unit:0x0000000c80fccb095d693ca6598541c8
21:24:49:WU02:FS00:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\[snip]\AppData\Roaming\FAHClient\cores/ -dir 02 -suffix 01 -version 705 -lifeline 2856 -checkpoint 15 -np 2
21:24:49:WU02:FS00:Started FahCore on PID 6004
21:24:50:WU02:FS00:Core PID:5620
21:24:50:WU02:FS00:FahCore 0xa7 started
21:24:51:WU02:FS00:0xa7:*********************** Log Started 2019-10-11T21:24:51Z ***********************
21:24:51:WU02:FS00:0xa7:************************** Gromacs Folding@home Core ***************************
21:24:51:WU02:FS00:0xa7:       Type: 0xa7
21:24:51:WU02:FS00:0xa7:       Core: Gromacs
21:24:51:WU02:FS00:0xa7:    Website:
21:24:51:WU02:FS00:0xa7:  Copyright: (c) 2009-2018
21:24:51:WU02:FS00:0xa7:     Author: Joseph Coffland <>
21:24:51:WU02:FS00:0xa7:       Args: -dir 02 -suffix 01 -version 705 -lifeline 6004 -checkpoint 15 -np 2
21:24:51:WU02:FS00:0xa7:     Config: <none>
21:24:51:WU02:FS00:0xa7:************************************ Build *************************************
21:24:51:WU02:FS00:0xa7:    Version: 0.0.17
21:24:51:WU02:FS00:0xa7:       Date: Apr 25 2018
21:24:51:WU02:FS00:0xa7:       Time: 11:02:26
21:24:51:WU02:FS00:0xa7: Repository: Git
21:24:51:WU02:FS00:0xa7:   Revision: fd11abfb405c921e66db1226933e9dd2d18d2acc
21:24:51:WU02:FS00:0xa7:     Branch: master
21:24:51:WU02:FS00:0xa7:   Compiler: Visual C++ 2008
21:24:51:WU02:FS00:0xa7:    Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
21:24:51:WU02:FS00:0xa7:   Platform: win32 10
21:24:51:WU02:FS00:0xa7:       Bits: 32
21:24:51:WU02:FS00:0xa7:       Mode: Release
21:24:51:WU02:FS00:0xa7:       SIMD: sse2
21:24:51:WU02:FS00:0xa7:************************************ System ************************************
21:24:51:WU02:FS00:0xa7:        CPU: Unknown
21:24:51:WU02:FS00:0xa7:     CPU ID:
21:24:51:WU02:FS00:0xa7:       CPUs: 4
21:24:51:WU02:FS00:0xa7:     Memory: 6.94GiB
21:24:51:WU02:FS00:0xa7:Free Memory: 4.35GiB
21:24:51:WU02:FS00:0xa7:    Threads: WINDOWS_THREADS
21:24:51:WU02:FS00:0xa7: OS Version: 6.2
21:24:51:WU02:FS00:0xa7:Has Battery: false
21:24:51:WU02:FS00:0xa7: On Battery: false
21:24:51:WU02:FS00:0xa7: UTC Offset: -4
21:24:51:WU02:FS00:0xa7:        PID: 5620
21:24:51:WU02:FS00:0xa7:        CWD: C:\Users\[snip]\AppData\Roaming\FAHClient\work
21:24:51:WU02:FS00:0xa7:         OS: Windows 8.1
21:24:51:WU02:FS00:0xa7:    OS Arch: AMD64
21:24:51:WU02:FS00:0xa7:Project: 13830 (Run 745, Clone 0, Gen 12)

Code: Select all
*********************** Log Started 2019-10-05T19:18:29Z ***********************
19:18:29:************************* Folding@home Client *************************
19:18:29:        Website:
19:18:29:      Copyright: (c) 2009-2018
19:18:29:         Author: Joseph Coffland <>
19:18:29:           Args:
19:18:29:         Config: C:\Users\[snip]\AppData\Roaming\FAHClient\config.xml
19:18:29:******************************** Build ********************************
19:18:29:        Version: 7.5.0
19:18:29:           Date: May 9 2018
19:18:29:           Time: 15:53:41
19:18:29:     Repository: Git
19:18:29:       Revision: 4eeb97b083f151f185efd9470dd703b6e2761bb5
19:18:29:         Branch: master
19:18:29:       Compiler: Visual C++ 2008
19:18:29:        Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
19:18:29:       Platform: win32 10
19:18:29:           Bits: 32
19:18:29:           Mode: Release
19:18:29:******************************* System ********************************
19:18:29:            CPU: AMD A8-7600 Radeon R7, 10 Compute Cores 4C+6G
19:18:29:         CPU ID: AuthenticAMD Family 21 Model 48 Stepping 1
19:18:29:           CPUs: 4
19:18:29:         Memory: 6.94GiB
19:18:29:    Free Memory: 5.58GiB
19:18:29:        Threads: WINDOWS_THREADS
19:18:29:     OS Version: 6.2
19:18:29:    Has Battery: false
19:18:29:     On Battery: false
19:18:29:     UTC Offset: -4
19:18:29:            PID: 2856
19:18:29:            CWD: C:\Users\[snip]\AppData\Roaming\FAHClient
19:18:29:             OS: Windows 8.1
19:18:29:        OS Arch: AMD64
19:18:29:           GPUs: 2
19:18:29:          GPU 0: Bus:0 Slot:1 Func:0 AMD:5 Kaveri [Radeon R7]
19:18:29:          GPU 1: Bus:1 Slot:0 Func:0 AMD:5 Baffin XT [Radeon RX 460]
19:18:29:           CUDA: Not detected: Failed to open dynamic library 'nvcuda.dll': The
19:18:29:                 specified module could not be found.
19:18:29:OpenCL Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:1.2 Driver:2348.4
19:18:29:OpenCL Device 1: Platform:0 Device:1 Bus:0 Slot:1 Compute:1.2 Driver:2348.4
19:18:29:  Win32 Service: false
19:18:29:  <!-- Network -->
19:18:29:  <proxy v=':8080'/>
19:18:29:  <!-- User Information -->
19:18:29:  <passkey v='********************************'/>
19:18:29:  <team v='11108'/>
19:18:29:  <user v='_r2w_ben'/>
19:18:29:  <!-- Work Unit Control -->
19:18:29:  <next-unit-percentage v='100'/>
19:18:29:  <!-- Folding Slots -->
19:18:29:  <slot id='0' type='CPU'>
19:18:29:    <client-type v='advanced'/>
19:18:29:    <cpus v='2'/>
19:18:29:  </slot>
19:18:29:  <slot id='1' type='GPU'>
19:18:29:    <client-type v='advanced'/>
19:18:29:    <gpu-index v='1'/>
19:18:29:  </slot>
19:18:29:  <slot id='2' type='GPU'>
19:18:29:    <gpu-index v='0'/>
19:18:29:    <opencl-index v='1'/>
19:18:29:  </slot>

Re: Core A7 switched from AVX back to SSE2

PostPosted: Sat Oct 12, 2019 3:25 pm
by X-Wing
My A7 core is running SSE2, and my Core i3-8350K supports AVX and AVX-2.

Re: Core A7 switched from AVX back to SSE2

PostPosted: Sat Oct 12, 2019 4:41 pm
by Joe_H
X-Wing wrote:My A7 core is running SSE2, and my Core i3-8350K supports AVX and AVX-2.

What version of the client are you running, and are your running in a VM?

@_r2w_ben You are running a beta version of the client:
Code: Select all
19:18:29:******************************** Build ********************************
19:18:29:        Version: 7.5.0
19:18:29:           Date: May 9 2018

Any reason for that? I don't recall the bugs, but there were some with that version and the release version, 7.5.1, was created to fix those.

Re: Core A7 switched from AVX back to SSE2

PostPosted: Sat Oct 12, 2019 7:04 pm
by X-Wing
I'm running 7.5.1, not on a VM.

Code: Select all
*********************** Log Started 2019-10-12T14:20:22Z ***********************
14:20:22:************************* Folding@home Client *************************
14:20:22:        Website:
14:20:22:      Copyright: (c) 2009-2018
14:20:22:         Author: Joseph Coffland <>
14:20:22:           Args:
14:20:22:         Config: C:\Users\suyda\AppData\Roaming\FAHClient\config.xml
14:20:22:******************************** Build ********************************
14:20:22:        Version: 7.5.1
14:20:22:           Date: May 11 2018
14:20:22:           Time: 13:06:32
14:20:22:     Repository: Git
14:20:22:       Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
14:20:22:         Branch: master
14:20:22:       Compiler: Visual C++ 2008
14:20:22:        Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
14:20:22:       Platform: win32 10
14:20:22:           Bits: 32
14:20:22:           Mode: Release
14:20:22:******************************* System ********************************
14:20:22:            CPU: Intel(R) Core(TM) i3-8350K CPU @ 4.00GHz
14:20:22:         CPU ID: GenuineIntel Family 6 Model 158 Stepping 11
14:20:22:           CPUs: 4
14:20:22:         Memory: 7.92GiB
14:20:22:    Free Memory: 4.70GiB
14:20:22:        Threads: WINDOWS_THREADS
14:20:22:     OS Version: 6.2
14:20:22:    Has Battery: false
14:20:22:     On Battery: false
14:20:22:     UTC Offset: -5
14:20:22:            PID: 13704
14:20:22:            CWD: C:\Users\suyda\AppData\Roaming\FAHClient
14:20:22:             OS: Windows 10 Enterprise
14:20:22:        OS Arch: AMD64
14:20:22:           GPUs: 1
14:20:22:          GPU 0: Bus:1 Slot:0 Func:0 NVIDIA:7 TU116 [GeForce GTX 1660 Ti]
14:20:22:  CUDA Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:7.5 Driver:10.1
14:20:22:OpenCL Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:1.2 Driver:436.30
14:20:22:  Win32 Service: false
14:20:22:  <!-- Network -->
14:20:22:  <proxy v=':8080'/>
14:20:22:  <!-- Slot Control -->
14:20:22:  <power v='full'/>
14:20:22:  <!-- User Information -->
14:20:22:  <passkey v='********************************'/>
14:20:22:  <team v='111605'/>
14:20:22:  <user v='NewGPU'/>
14:20:22:  <!-- Folding Slots -->
14:20:22:  <slot id='0' type='CPU'/>
14:20:22:  <slot id='1' type='GPU'/>
14:20:22:Trying to access database...
14:20:22:Successfully acquired database lock
14:20:22:Enabled folding slot 00: READY cpu:3
14:20:22:Enabled folding slot 01: READY gpu:0:TU116 [GeForce GTX 1660 Ti]
14:20:22:WU01:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\suyda\AppData\Roaming\FAHClient\cores/ -dir 01 -suffix 01 -version 705 -lifeline 13704 -checkpoint 15 -gpu-vendor nvidia -opencl-platform 0 -opencl-device 0 -cuda-device 0 -gpu 0
14:20:22:WU01:FS01:Started FahCore on PID 13816
14:20:22:WU01:FS01:Core PID:13840
14:20:22:WU01:FS01:FahCore 0x21 started
14:20:23:WU01:FS01:0x21:*********************** Log Started 2019-10-12T14:20:22Z ***********************
14:20:23:WU01:FS01:0x21:Project: 14180 (Run 2, Clone 681, Gen 11)
14:20:23:WU01:FS01:0x21:Unit: 0x000000180002894c5d3b54887a3ab252
14:20:23:WU01:FS01:0x21:CPU: 0x00000000000000000000000000000000
14:20:23:WU01:FS01:0x21:Machine: 1
14:20:23:WU01:FS01:0x21:Digital signatures verified
14:20:23:WU01:FS01:0x21:Folding@home GPU Core21 Folding@home Core
14:20:23:WU01:FS01:0x21:Version 0.0.20
14:20:23:WU01:FS01:0x21:  Found a checkpoint file
14:20:23:WU00:FS00:Connecting to
14:20:24:WU00:FS00:Assigned to work server
14:20:24:WU00:FS00:Requesting new work unit for slot 00: READY cpu:3 from
14:20:24:WU00:FS00:Connecting to
14:20:25:ERROR:WU00:FS00:Exception: Server did not assign work unit
14:20:25:WU00:FS00:Connecting to
14:20:26:WU00:FS00:Assigned to work server
14:20:26:WU00:FS00:Requesting new work unit for slot 00: READY cpu:3 from
14:20:26:WU00:FS00:Connecting to
14:20:26:WU00:FS00:Downloading 8.14MiB
14:20:27:WU01:FS01:0x21:Completed 1500000 out of 12500000 steps (12%)
14:20:27:WU01:FS01:0x21:Temperature control disabled. Requirements: single Nvidia GPU, tmax must be < 110 and twait >= 900
14:20:28:WU00:FS00:Download complete
14:20:28:WU00:FS00:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:13831 run:559 clone:0 gen:7 core:0xa7 unit:0x0000000880fccb095d693ad86d2fdabd
14:20:28:WU00:FS00:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\suyda\AppData\Roaming\FAHClient\cores/ -dir 00 -suffix 01 -version 705 -lifeline 13704 -checkpoint 15 -np 3
14:20:28:WU00:FS00:Started FahCore on PID 14308
14:20:29:WU00:FS00:Core PID:12568
14:20:29:WU00:FS00:FahCore 0xa7 started
14:20:29:WU00:FS00:0xa7:*********************** Log Started 2019-10-12T14:20:29Z ***********************
14:20:29:WU00:FS00:0xa7:************************** Gromacs Folding@home Core ***************************
14:20:29:WU00:FS00:0xa7:       Type: 0xa7
14:20:29:WU00:FS00:0xa7:       Core: Gromacs
14:20:29:WU00:FS00:0xa7:    Website:
14:20:29:WU00:FS00:0xa7:  Copyright: (c) 2009-2018
14:20:29:WU00:FS00:0xa7:     Author: Joseph Coffland <>
14:20:29:WU00:FS00:0xa7:       Args: -dir 00 -suffix 01 -version 705 -lifeline 14308 -checkpoint 15 -np
14:20:29:WU00:FS00:0xa7:             3
14:20:29:WU00:FS00:0xa7:     Config: <none>
14:20:29:WU00:FS00:0xa7:************************************ Build *************************************
14:20:29:WU00:FS00:0xa7:    Version: 0.0.17
14:20:29:WU00:FS00:0xa7:       Date: Apr 25 2018
14:20:29:WU00:FS00:0xa7:       Time: 11:02:26
14:20:29:WU00:FS00:0xa7: Repository: Git
14:20:29:WU00:FS00:0xa7:   Revision: fd11abfb405c921e66db1226933e9dd2d18d2acc
14:20:29:WU00:FS00:0xa7:     Branch: master
14:20:29:WU00:FS00:0xa7:   Compiler: Visual C++ 2008
14:20:29:WU00:FS00:0xa7:    Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
14:20:29:WU00:FS00:0xa7:   Platform: win32 10
14:20:29:WU00:FS00:0xa7:       Bits: 32
14:20:29:WU00:FS00:0xa7:       Mode: Release
14:20:29:WU00:FS00:0xa7:       SIMD: sse2
14:20:29:WU00:FS00:0xa7:************************************ System ************************************
14:20:29:WU00:FS00:0xa7:        CPU: Unknown
14:20:29:WU00:FS00:0xa7:     CPU ID:
14:20:29:WU00:FS00:0xa7:       CPUs: 4
14:20:29:WU00:FS00:0xa7:     Memory: 7.92GiB
14:20:29:WU00:FS00:0xa7:Free Memory: 4.49GiB
14:20:29:WU00:FS00:0xa7:    Threads: WINDOWS_THREADS
14:20:29:WU00:FS00:0xa7: OS Version: 6.2
14:20:29:WU00:FS00:0xa7:Has Battery: false
14:20:29:WU00:FS00:0xa7: On Battery: false
14:20:29:WU00:FS00:0xa7: UTC Offset: -5
14:20:29:WU00:FS00:0xa7:        PID: 12568
14:20:29:WU00:FS00:0xa7:        CWD: C:\Users\suyda\AppData\Roaming\FAHClient\work
14:20:29:WU00:FS00:0xa7:         OS: Windows 10 Enterprise
14:20:29:WU00:FS00:0xa7:    OS Arch: AMD64

Re: Core A7 switched from AVX back to SSE2

PostPosted: Sat Oct 12, 2019 7:46 pm
by _r2w_ben
Joe_H wrote:@_r2w_ben You are running a beta version of the client:
Code: Select all
19:18:29:******************************** Build ********************************
19:18:29:        Version: 7.5.0
19:18:29:           Date: May 9 2018

Any reason for that? I don't recall the bugs, but there were some with that version and the release version, 7.5.1, was created to fix those.

I didn't encounter any of the bugs fixed in 7.5.1 so I hadn't upgraded. I was minutes away from completing an a7 so I set it to Finish and installed 7.5.1. The new a7 work unit post-upgrade is using SSE2.

Code: Select all
*********************** Log Started 2019-10-12T18:39:27Z ***********************
18:39:27:************************* Folding@home Client *************************
18:39:27:        Website:
18:39:27:      Copyright: (c) 2009-2018
18:39:27:         Author: Joseph Coffland <>
18:39:27:           Args:
18:39:27:         Config: C:\Users\[snip]\AppData\Roaming\FAHClient\config.xml
18:39:27:******************************** Build ********************************
18:39:27:        Version: 7.5.1
18:39:27:           Date: May 11 2018
18:39:27:           Time: 13:06:32
18:39:27:     Repository: Git
18:39:27:       Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
18:39:27:         Branch: master
18:39:27:       Compiler: Visual C++ 2008
18:39:27:        Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
18:39:27:       Platform: win32 10
18:39:27:           Bits: 32
18:39:27:           Mode: Release
18:39:27:******************************* System ********************************
18:39:27:            CPU: AMD A8-7600 Radeon R7, 10 Compute Cores 4C+6G
18:39:27:         CPU ID: AuthenticAMD Family 21 Model 48 Stepping 1
18:39:27:           CPUs: 4
18:39:27:         Memory: 6.94GiB
18:39:27:    Free Memory: 5.69GiB
18:39:27:        Threads: WINDOWS_THREADS
18:39:27:     OS Version: 6.2
18:39:27:    Has Battery: false
18:39:27:     On Battery: false
18:39:27:     UTC Offset: -4
18:39:27:            PID: 896
18:39:27:            CWD: C:\Users\[snip]\AppData\Roaming\FAHClient
18:39:27:             OS: Windows 8.1
18:39:27:        OS Arch: AMD64
18:39:27:           GPUs: 2
18:39:27:          GPU 0: Bus:0 Slot:1 Func:0 AMD:5 Kaveri [Radeon R7]
18:39:27:          GPU 1: Bus:1 Slot:0 Func:0 AMD:5 Baffin XT [Radeon RX 460]
18:39:27:           CUDA: Not detected: Failed to open dynamic library 'nvcuda.dll': The
18:39:27:                 specified module could not be found.
18:39:27:OpenCL Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:1.2 Driver:2348.4
18:39:27:OpenCL Device 1: Platform:0 Device:1 Bus:0 Slot:1 Compute:1.2 Driver:2348.4
18:39:27:  Win32 Service: false
18:39:28:  <!-- Network -->
18:39:28:  <proxy v=':8080'/>
18:39:28:  <!-- User Information -->
18:39:28:  <passkey v='********************************'/>
18:39:28:  <team v='11108'/>
18:39:28:  <user v='_r2w_ben'/>
18:39:28:  <!-- Work Unit Control -->
18:39:28:  <next-unit-percentage v='100'/>
18:39:28:  <!-- Folding Slots -->
18:39:28:  <slot id='0' type='CPU'>
18:39:28:    <client-type v='advanced'/>
18:39:28:    <cpus v='2'/>
18:39:28:  </slot>
18:39:28:  <slot id='1' type='GPU'>
18:39:28:    <client-type v='advanced'/>
18:39:28:    <gpu-index v='1'/>
18:39:28:    <paused v='true'/>
18:39:28:  </slot>
18:39:28:  <slot id='2' type='GPU'>
18:39:28:    <gpu-index v='0'/>
18:39:28:    <opencl-index v='1'/>
18:39:28:    <paused v='true'/>
18:39:28:  </slot>
18:39:28:Trying to access database...
18:39:28:Successfully acquired database lock
18:39:28:Enabled folding slot 00: READY cpu:2
18:39:28:Enabled folding slot 01: PAUSED gpu:1:Baffin XT [Radeon RX 460] (by user)
18:39:28:Enabled folding slot 02: PAUSED gpu:0:Kaveri [Radeon R7] (by user)
18:39:28:WU01:FS00:Connecting to
18:39:29:WU01:FS00:Assigned to work server
18:39:29:WU01:FS00:Requesting new work unit for slot 00: READY cpu:2 from
18:39:29:WU01:FS00:Connecting to
18:39:29:WU01:FS00:Downloading 8.14MiB
18:39:31:WU01:FS00:Download complete
18:39:31:WU01:FS00:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:13829 run:223 clone:2 gen:8 core:0xa7 unit:0x0000000c80fccb095d66d4626590a726
18:39:31:WU01:FS00:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\[snip]\AppData\Roaming\FAHClient\cores/ -dir 01 -suffix 01 -version 705 -lifeline 896 -checkpoint 15 -np 2
18:39:31:WU01:FS00:Started FahCore on PID 1892
18:39:32:WU01:FS00:Core PID:1684
18:39:32:WU01:FS00:FahCore 0xa7 started
18:39:33:WU01:FS00:0xa7:*********************** Log Started 2019-10-12T18:39:32Z ***********************
18:39:33:WU01:FS00:0xa7:************************** Gromacs Folding@home Core ***************************
18:39:33:WU01:FS00:0xa7:       Type: 0xa7
18:39:33:WU01:FS00:0xa7:       Core: Gromacs
18:39:33:WU01:FS00:0xa7:    Website:
18:39:33:WU01:FS00:0xa7:  Copyright: (c) 2009-2018
18:39:33:WU01:FS00:0xa7:     Author: Joseph Coffland <>
18:39:33:WU01:FS00:0xa7:       Args: -dir 01 -suffix 01 -version 705 -lifeline 1892 -checkpoint 15 -np 2
18:39:33:WU01:FS00:0xa7:     Config: <none>
18:39:33:WU01:FS00:0xa7:************************************ Build *************************************
18:39:33:WU01:FS00:0xa7:    Version: 0.0.17
18:39:33:WU01:FS00:0xa7:       Date: Apr 25 2018
18:39:33:WU01:FS00:0xa7:       Time: 11:02:26
18:39:33:WU01:FS00:0xa7: Repository: Git
18:39:33:WU01:FS00:0xa7:   Revision: fd11abfb405c921e66db1226933e9dd2d18d2acc
18:39:33:WU01:FS00:0xa7:     Branch: master
18:39:33:WU01:FS00:0xa7:   Compiler: Visual C++ 2008
18:39:33:WU01:FS00:0xa7:    Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
18:39:33:WU01:FS00:0xa7:   Platform: win32 10
18:39:33:WU01:FS00:0xa7:       Bits: 32
18:39:33:WU01:FS00:0xa7:       Mode: Release
18:39:33:WU01:FS00:0xa7:       SIMD: sse2
18:39:33:WU01:FS00:0xa7:************************************ System ************************************
18:39:33:WU01:FS00:0xa7:        CPU: Unknown
18:39:33:WU01:FS00:0xa7:     CPU ID:
18:39:33:WU01:FS00:0xa7:       CPUs: 4
18:39:33:WU01:FS00:0xa7:     Memory: 6.94GiB
18:39:33:WU01:FS00:0xa7:Free Memory: 5.61GiB
18:39:33:WU01:FS00:0xa7:    Threads: WINDOWS_THREADS
18:39:33:WU01:FS00:0xa7: OS Version: 6.2
18:39:33:WU01:FS00:0xa7:Has Battery: false
18:39:33:WU01:FS00:0xa7: On Battery: false
18:39:33:WU01:FS00:0xa7: UTC Offset: -4
18:39:33:WU01:FS00:0xa7:        PID: 1684
18:39:33:WU01:FS00:0xa7:        CWD: C:\Users\[snip]\AppData\Roaming\FAHClient\work
18:39:33:WU01:FS00:0xa7:         OS: Windows 8.1
18:39:33:WU01:FS00:0xa7:    OS Arch: AMD64
18:39:33:WU01:FS00:0xa7:Project: 13829 (Run 223, Clone 2, Gen 8)
18:39:33:WU01:FS00:0xa7:Unit: 0x0000000c80fccb095d66d4626590a726
18:39:33:WU01:FS00:0xa7:Reading tar file core.xml
18:39:33:WU01:FS00:0xa7:Reading tar file frame8.tpr
18:39:33:WU01:FS00:0xa7:Digital signatures verified
18:39:33:WU01:FS00:0xa7:Calling: mdrun -s frame8.tpr -o frame8.trr -x frame8.xtc -cpt 15 -nt 2
18:39:33:WU01:FS00:0xa7:Steps: first=1000000 total=125000
18:39:40:WU01:FS00:0xa7:Completed 1 out of 125000 steps (0%)

Re: Core A7 switched from AVX back to SSE2

PostPosted: Sat Oct 12, 2019 7:54 pm
by _r2w_ben
There's a log from an AMD Ryzen 2700X that supports AVX2 here that is using the SSE2 version of the core.

Re: Core A7 switched from AVX back to SSE2

PostPosted: Sat Oct 12, 2019 11:01 pm
by jcoffland
This should be fixed now. It was a configuration problem on the AS. Thanks for pointing this out.

Re: Core A7 switched from AVX back to SSE2

PostPosted: Sun Oct 13, 2019 1:08 am
by FaaR
My client wants to update core now, but is unable to:

Code: Select all
23:58:47:WU02:FS00:Downloading core from
23:58:47:WU02:FS00:Connecting to
23:58:47:ERROR:WU02:FS00:Exception: Failed reading core package header.
00:00:24:WU02:FS00:Downloading core from
00:00:24:WU02:FS00:Connecting to
00:00:24:ERROR:WU02:FS00:Exception: Failed reading core package header.
00:03:01:WU02:FS00:Downloading core from
00:03:01:WU02:FS00:Connecting to
00:03:02:ERROR:WU02:FS00:Exception: Failed reading core package header.

It doesn't really say much in the log, I bumped Verbosity up to 5 to see if that adds any more details... Anyhow, my client is now stuck bumping its head on a wall, it doesn't want to fold anything right now...

Re: Core A7 switched from AVX back to SSE2

PostPosted: Sun Oct 13, 2019 3:27 am
by bruce
Don't bump the verbosity. That just confuses the log.

Pause all CPU slots that are using FAHCore_a7. Now unpause ONE of them and let the core finish downloading. Then unpause the other slots.

How many slots are you running and how many CPUs are assigned to each one?

Re: Core A7 switched from AVX back to SSE2

PostPosted: Sun Oct 13, 2019 6:37 am
by rickoic
Having this problem with Core_a7.fah on 2 machines at present (both with 10 cores) all being used for 1 folding slot.
Tried pausing and restarting with no good results.
Deleted cpu and let it fold without for a couple of minutes and then reentered cpu to fold and got this same problem.

28:18:WU00:FS00:Connecting to
05:28:18:WU00:FS00:Assigned to work server
05:28:18:WU00:FS00:Requesting new work unit for slot 00: READY cpu:10 from
05:28:18:WU00:FS00:Connecting to
05:28:19:WU00:FS00:Downloading 8.14MiB
05:28:25:WU00:FS00:Download 72.96%
05:28:28:WU00:FS00:Download complete
05:28:28:WU00:FS00:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:13828 run:947 clone:2 gen:8 core:0xa7 unit:0x0000000a80fccb095d657eac83953e34
05:28:28:WU00:FS00:Downloading core from ... ore_a7.fah
05:28:28:WU00:FS00:Connecting to
05:28:28:ERROR:WU00:FS00:Exception: Failed reading core package header.
05:28:36:Removing old file 'configs/config-20191011-205931.xml'
05:28:36:Saving configuration to config.xml

Re: Core A7 switched from AVX back to SSE2

PostPosted: Sun Oct 13, 2019 12:41 pm
by FaaR
bruce wrote:How many slots are you running and how many CPUs are assigned to each one?

I have just one CPU/one folding slot using CPU.

Anyhow, the issue fixed itself overnight! Whee! So thanks to whomever worked some magic to straighten out the problem. Now my CPU folds with AVX(2?) and gets at least 50% higher PPD than before. I'm not sure how much more yet because AVX multiplier was set too low, so all cores clocked down to 3.6GHz... Now they're back at 4.1, but the previously slower speed might still be affecting the score average, I dunno. I will see for sure come next WU in about 10 mins.

Would be cool to see if I could get AVX512 WUs too - as I have an i9 7900X - and see what score I could get with those. Currently I'm peaking at over 180k with 16 threads folding (I want to reserve some of the chip for myself as this is also my personal workstation.)

Cheers and thanks. :)

Re: Core A7 switched from AVX back to SSE2

PostPosted: Sun Oct 13, 2019 8:18 pm
by bruce
GROMACS added support for AVX and the release notes commented that there was really very little difference between basic AVX and AVX2. I'm not sure about AVX512 or other vector processing instruction enhancements. In theory, they probably do, but a lot depends on the size of your CPU's cache and how the instructions move data to/from main RAM.