Error initializing context: clGetDeviceIDs

If you think it might be a driver problem, see viewforum.php?f=79

Moderators: Site Moderators, PandeGroup

Error initializing context: clGetDeviceIDs

Postby Jahus » Tue May 09, 2017 1:44 pm

Hello

I am trying to fold with my AMD HD 6950 but I'm getting `Error initializing context: clGetDeviceIDs` and `BAD_WORK_UNIT` errors:

> Graphic card: Sapphir HD 6950
> Drivers: Legacy 16.2 (beta) (exact same error happens with 13.12 drivers I was using for cryptocurrency mining purpose)
> System: Windows 7 SP1 x86

Here's the log:

Code: Select all
    :WU00:FS01:0x21:*********************** Log Started 2017-05-07TZ ***********************
    :WU00:FS01:0x21:Project: 11429 (Run 1, Clone 235, Gen 58)
    :WU00:FS01:0x21:Unit: 0x000000468ca304f158af65f4dbedfd29
    :WU00:FS01:0x21:CPU: 0x00000000000000000000000000000000
    :WU00:FS01:0x21:Machine: 1
    :WU00:FS01:0x21:Reading tar file core.xml
    :WU00:FS01:0x21:Reading tar file system.xml
    :WU00:FS01:0x21:Reading tar file integrator.xml
    :WU00:FS01:0x21:Reading tar file state.xml
    :WU00:FS01:0x21:Digital signatures verified
    :WU00:FS01:0x21:Folding@home GPU Core21 Folding@home Core
    :WU00:FS01:0x21:Version 0.0.18
    :WU00:FS01:0x21:ERROR:exception: Error initializing context: clGetDeviceIDs (-1)
    :WU00:FS01:0x21:Saving result file logfile_01.txt
    :WU00:FS01:0x21:Saving result file log.txt
    :WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
    :WU00:FS01:Sending unit results: id:00 state:SEND error:FAULTY project:11429 run:1 clone:235 gen:58 core:0x21 unit:0x000000468ca304f158af65f4dbedfd29
    :WU00:FS01:Uploading 2.33KiB to 140.163.4.241
    :WU00:FS01:Connecting to 140.163.4.241:8080
    :WU00:FS01:Upload complete
    :WU01:FS01:Connecting to 171.67.108.45:80
    :WU00:FS01:Server responded WORK_ACK (400)
    :WU00:FS01:Cleaning up
    :WU01:FS01:Assigned to work server 140.163.4.245
    :WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:Cayman PRO [Radeon 6900 Series] from 140.163.4.245
    :WU01:FS01:Connecting to 140.163.4.245:8080
    :WU01:FS01:Downloading 14.50MiB
    :WU01:FS01:Download 3.88%
    :WU01:FS01:Download 6.47%
    :WU01:FS01:Download 9.05%
    :WU01:FS01:Download 11.64%
Jahus
 
Posts: 1
Joined: Tue May 09, 2017 1:33 pm

Re: Error initializing context: clGetDeviceIDs

Postby Joe_H » Tue May 09, 2017 3:47 pm

Welcome to the folding support forum.

Code: Select all
    :WU00:FS01:0x21:ERROR:exception: Error initializing context: clGetDeviceIDs (-1)

This error message usually indicates a missing component from the video driver install, the OpenCL support. This often happens with drivers supplied by either MS or other sources other than AMD in the case of cards from them, or nVidia for their GPU's. Did you get your drivers from AMD?

It is also possible that you need a more recent driver version. Someone who has a 6950 or similar GPU may be able to comment on that. The last version released for that series of cards is 15.7.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Super Moderator
 
Posts: 3737
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: Error initializing context: clGetDeviceIDs

Postby Joe_H » Tue May 09, 2017 4:00 pm

One additional note, the current GPU folding core - 21, has been reported to work better on AMD GCN based GPU's. I don't know if that applies to the error you are seeing, but the performance on the older Terascale architecture your 6950 is based on will not be as good.
Joe_H
Super Moderator
 
Posts: 3737
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA


Return to GPU Projects and FahCores

Who is online

Users browsing this forum: No registered users and 1 guest

cron