Open CL card not found, but card found easily. Linux

If you think it might be a driver problem, see viewforum.php?f=79

Moderators: Site Moderators, PandeGroup

Open CL card not found, but card found easily. Linux

Postby markfw » Sat Aug 25, 2018 9:12 pm

So I install Linux Mint 19, and then I followed the same procedure that I have done on my other 10 folding boxes. Below is that section
----------------------------------
wget http://launchpadlibrarian.net/109052632 ... 15_all.deb

sudo dpkg -i python-support_1.0.15_all.deb

sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt-get update

sudo apt-get dist-upgrade

sudo apt-get install nvidia-390 (or if it appears on the linix home page drivers list, you can do it from there.

sudo apt-get install nvidia-opencl-icd-390

sudo apt-get install libcuda1-390

sudo apt-get -y install python-gnome2 mesa-common-dev freeglut3-dev nvidia-settings gedit
--------------------------------------------------
Then install the FAH client and fahcontrol
--------------------------------------------------
cd /var/lib/fahclient

sudo wget http://fah-web.stanford.edu/file-releas ... c/GPUs.txt
--------------------------------------------------
Then fire up fahcontrol and add the GPU client(will show under education in the menu), and maybe also the remote access by adding ,192.168.1.1-192.168.1.255 to the two IP places
--------------------------------------------------
sudo service FAHClient stop
sudo service FAHClient start

But then this happens:

02:04:10:ERROR:WU00:FS00:Failed to start core: OpenCL device matching slot 0 not found, try setting 'opencl-index' manually

Help !!!
markfw
 
Posts: 131
Joined: Mon Feb 04, 2008 3:32 pm

Re: Open CL card not found, but card found easily. Linux

Postby bollix47 » Sat Aug 25, 2018 9:35 pm

I always install the following:

Code: Select all
sudo apt install ocl-icd-opencl-dev


If that doesn't help then, using FAHControl, go into the configure > slots > gpu and change the opencl-index from -1 to 1.

Do you have an on-board GPU that hasn't been disabled? If so, the above should help.

What does your log show for the following:
Code: Select all
23:57:02:           GPUs: 1
23:57:02:          GPU 0: Bus:2 Slot:0 Func:0 NVIDIA:7 GM200 [GeForce GTX 980 Ti] 5632
23:57:02:  CUDA Device 0: Platform:0 Device:0 Bus:2 Slot:0 Compute:5.2 Driver:9.1
23:57:02:OpenCL Device 0: Platform:0 Device:0 Bus:2 Slot:0 Compute:1.2 Driver:390.48
Last edited by bollix47 on Sat Aug 25, 2018 9:38 pm, edited 1 time in total.
bollix47
 
Posts: 3443
Joined: Sun Dec 02, 2007 5:04 am
Location: Canada

Re: Open CL card not found, but card found easily. Linux

Postby markfw » Sat Aug 25, 2018 9:38 pm

Nope, the CPU is an AMD 2990WX, no onboard GPU, I will try the other
markfw
 
Posts: 131
Joined: Mon Feb 04, 2008 3:32 pm

Re: Open CL card not found, but card found easily. Linux

Postby bollix47 » Sat Aug 25, 2018 9:41 pm

You may have another opencl device ... try changing the index anyway.
bollix47
 
Posts: 3443
Joined: Sun Dec 02, 2007 5:04 am
Location: Canada

Re: Open CL card not found, but card found easily. Linux

Postby markfw » Sat Aug 25, 2018 9:44 pm

OK, after changing the cl index to 1, now I get WU stalled, 127 error
markfw
 
Posts: 131
Joined: Mon Feb 04, 2008 3:32 pm

Re: Open CL card not found, but card found easily. Linux

Postby bollix47 » Sat Aug 25, 2018 9:46 pm

Please provide the log section as shown in my edited post above.

Also, did you restart the client after changing the index?
bollix47
 
Posts: 3443
Joined: Sun Dec 02, 2007 5:04 am
Location: Canada

Re: Open CL card not found, but card found easily. Linux

Postby markfw » Sat Aug 25, 2018 9:55 pm

Doing :

sudo apt install ocl-icd-opencl-dev

And stop and restart the client worked, thanks,.
markfw
 
Posts: 131
Joined: Mon Feb 04, 2008 3:32 pm

Re: Open CL card not found, but card found easily. Linux

Postby bruce » Sun Aug 26, 2018 4:46 am

It would be interesting to figure out what is actually going on so the client can avoid this error for others -- or at least tell the Donor what to fix.

Please find the recent logs in the logs subdirectory in FAH's working directory and show what changed in the section displayed by bollix47 above when you installed ocl-icd-opencl-dev.
bruce
 
Posts: 21697
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Open CL card not found, but card found easily. Linux

Postby Aurum » Fri Oct 05, 2018 5:17 pm

Here's how I install F@H 7.5.1 on a new Linux 19 Mint computer. Upgrading from Linux 18 to 19 too littered with bugs and problems. Do a fresh Linux 19 install.
It's easier than it used to be:
1. Install Linux 19 iso (v2 or later, v1 has bugs). Reboot.
(If Linux 19 already installed then remove any older drivers. sudo apt-get purge nvidia-*)
2. First thing open Driver Manager and install latest (396.54) Nvidia driver.
3. sudo apt install ocl-icd-opencl-dev
4. sudo reboot
5. Open Synaptic Package Manager & select Consider recommended packages as dependencies.
6. Let Update Manager install all updates.
7. Go to https://foldingathome.org/start-folding/ & Save fahclient_7.5.1_amd64.deb & fahcontrol_7.5.1-1_all.deb.
8. Doubleclick fahclient_7.5.1_amd64.deb
9. Doubleclick fahcontrol_7.5.1-1_all.deb
10. Open FAHControl & configure. Slots/delete CPU or if you leave it F@H won't automatically install GPUs. Expert/delete anon & gpu false.
11. Sudo reboot. FAHClient automatically assigns all CPU & GPUs.
Image Image
User avatar
Aurum
 
Posts: 298
Joined: Sat Oct 03, 2015 3:15 pm
Location: The Great Basin


Return to GPU Projects and FahCores

Who is online

Users browsing this forum: No registered users and 2 guests

cron