FahCore returned: BAD_WORK_UNIT (114 = 0x72) with 960M

If you think it might be a driver problem, see viewforum.php?f=79

Moderators: Site Moderators, PandeGroup

How does the GPU folding works, and how to make it work

Postby Monok » Sat Dec 26, 2015 2:00 pm

Hello, I'm Monok and I'm a totally newbie here. I've downloaded the FAH softwares one hour ago, and started to use the 8 cores of my CPU for my very first WU. It works pretty well, but I own a computer with a very good GPU (nVidia GeForce GTX 960M), so I was wondering about how to fold it, and how to make it work.

I tried going Configure -> Slots, and tried adding the GPU with "-1" in 'GPU Index' to let the software do the whole work, but it didn't do anything. Nothing newer appeared under "Folding Slots", so I guess it didn't work...? So I tried adding the GPU again, putting "0" this time, but once again, no fold applied...

Am I missing something? Do I have to download and install something else? I'm currently using Linux Mint Cinnamon, 64-bit. My GPU is a nVidia GeForce GTX 960M. What should I do?
Monok
 
Posts: 12
Joined: Sat Dec 26, 2015 1:53 pm

Re: How does the GPU folding works, and how to make it work

Postby Joe_H » Sat Dec 26, 2015 3:19 pm

Welcome to folding support forum.

GPU folding on Linux requires using the proprietary drivers distributed by nVidia instead of the generic drivers included with Linux distributions. Both the video driver itself and the OpenCL support need to be installed. Some packages provide the OpenCL support separately. With these properly installed installed, your GPU should show up in the system configuration portion of the folding client as supported with CUDA support as well. Links to directions and tip topics are given in the Linux Install guide - http://folding.stanford.edu/home/guide/ ... all-guide/.

With the drivers installed and your GPU detected, you should not need to do anything with the GPU Index setting. The client software may require a reinstallation.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 3892
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: How does the GPU folding works, and how to make it work

Postby Monok » Sat Dec 26, 2015 3:45 pm

After some personal research I found out what to do, but thanks anyway for the answer. I've got another question, though: how do I know which drivers are 'good' and which drivers are not? Because the guide I found on this forum talks about a different video card, and I'm not sure about using those drivers, because I think they are made for a different video card, but maybe I'm wrong...?

EDIT: Checked if the drivers could be installed with my GPU...and they are not supported. How do I find the right driver, then?
Monok
 
Posts: 12
Joined: Sat Dec 26, 2015 1:53 pm

Re: How does the GPU folding works, and how to make it work

Postby toTOW » Sat Dec 26, 2015 6:27 pm

Grab the Linux driver from this page : http://www.nvidia.com/Download/index.aspx
Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.

FAH-Addict : latest news, tests and reviews about Folding@Home project.

Image
User avatar
toTOW
Site Moderator
 
Posts: 8329
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France

Re: How does the GPU folding works, and how to make it work

Postby Monok » Tue Dec 29, 2015 4:47 pm

Ok, I've installed the drivers after tons of troubles: now the GPU is not detected, I guess. Whenever I try to add a folding slot for the GPU it gives me an error, saying that it could not find a GPU...what's wrong with that, this time? What can I do?
Monok
 
Posts: 12
Joined: Sat Dec 26, 2015 1:53 pm

Re: How does the GPU folding works, and how to make it work

Postby foldy » Tue Dec 29, 2015 6:17 pm

Check this guide
viewtopic.php?f=80&t=27040

I also had to run this to allow it to recognize my GTX 970.
wget http://fah-web.stanford.edu/file-releas ... c/GPUs.txt
sudo mv GPUs.txt /var/lib/fahclient/
sudo service FAHClient restart
foldy
 
Posts: 966
Joined: Sat Dec 01, 2012 3:43 pm

Re: How does the GPU folding works, and how to make it work

Postby Monok » Tue Dec 29, 2015 8:32 pm

I know the whole guide you told me to check, I've spent the past days on it, writing and trying to understand how to make it work with all the problems I had about, ahahah :) Drivers are ok, I've updated them, and now they are the latest and installed.
Also, thanks a lot for the 'GPUs.txt' file, I totally forgot to add it...my bad. >.<

Now the GPU is detected, and it says it's ready, but I found out it doesn't work. It gives me FahCore errors, I don't know anything about, so I guess I will open a thread on the right section of this forum this time. This thread may be closed. Again, thank you all for the support! :D
Monok
 
Posts: 12
Joined: Sat Dec 26, 2015 1:53 pm

FahCore returned: BAD_WORK_UNIT (114 = 0x72) with 960M

Postby Monok » Tue Dec 29, 2015 8:49 pm

I've just finished to update and install the latest drivers (they are working, installed, latest version...), put the GPUs.txt file in place, and finally my GPU is detected and I can fold with it. Welp...I could, if only I didn't get that error. Everytime I press the 'Fold' button (right click on GPU slot -> Fold), it downloads a WU, tries to start, gets this error, and then...crashes the folding, I guess? I don't know how to call it. By the way, it stops, restart the folding, and tries with another WU. Till now, not a single WU worked, so I guess it's a configuration problem or stuff.

Here is the log. Please, let me know if it's a bad log, and how to improve, since it's my very first and I'm not totally sure it will be ok for you to be helpful enough to help me (and sorry for the pun, lol).

Code: Select all
*********************** Log Started 2015-12-29T20:19:42Z ***********************
20:19:42:************************* Folding@home Client *************************
20:19:42:    Website: http://folding.stanford.edu/
20:19:42:  Copyright: (c) 2009-2014 Stanford University
20:19:42:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
20:19:42:       Args: --child --lifeline 5560 /etc/fahclient/config.xml --run-as
20:19:42:             fahclient --pid-file=/var/run/fahclient.pid --daemon
20:19:42:     Config: /etc/fahclient/config.xml
20:19:42:******************************** Build ********************************
20:19:42:    Version: 7.4.4
20:19:42:       Date: Mar 4 2014
20:19:42:       Time: 12:02:38
20:19:42:    SVN Rev: 4130
20:19:42:     Branch: fah/trunk/client
20:19:42:   Compiler: GNU 4.4.7
20:19:42:    Options: -std=gnu++98 -O3 -funroll-loops -mfpmath=sse -ffast-math
20:19:42:             -fno-unsafe-math-optimizations -msse2
20:19:42:   Platform: linux2 3.2.0-1-amd64
20:19:42:       Bits: 64
20:19:42:       Mode: Release
20:19:42:******************************* System ********************************
20:19:42:        CPU: Intel(R) Core(TM) i7-4720HQ CPU @ 2.60GHz
20:19:42:     CPU ID: GenuineIntel Family 6 Model 60 Stepping 3
20:19:42:       CPUs: 8
20:19:42:     Memory: 7.69GiB
20:19:42:Free Memory: 5.36GiB
20:19:42:    Threads: POSIX_THREADS
20:19:42: OS Version: 3.19
20:19:42:Has Battery: false
20:19:42: On Battery: false
20:19:42: UTC Offset: 1
20:19:42:        PID: 5562
20:19:42:        CWD: /var/lib/fahclient
20:19:42:         OS: Linux 3.19.0-32-generic x86_64
20:19:42:    OS Arch: AMD64
20:19:42:       GPUs: 1
20:19:42:      GPU 0: NVIDIA:4 GM107 [GeForce GTX 960M]
20:19:42:       CUDA: Not detected
20:19:42:***********************************************************************
20:19:42:<config>
20:19:42:  <!-- Client Control -->
20:19:42:  <fold-anon v='true'/>
20:19:42:
20:19:42:  <!-- Folding Slot Configuration -->
20:19:42:  <gpu v='false'/>
20:19:42:
20:19:42:  <!-- Network -->
20:19:42:  <proxy v=':8080'/>
20:19:42:
20:19:42:  <!-- Slot Control -->
20:19:42:  <power v='full'/>
20:19:42:
20:19:42:  <!-- User Information -->
20:19:42:  <passkey v='********************************'/>
20:19:42:  <team v='229996'/>
20:19:42:  <user v='Monok'/>
20:19:42:
20:19:42:  <!-- Folding Slots -->
20:19:42:  <slot id='0' type='CPU'/>
20:19:42:</config>
20:19:42:Switching to user fahclient
20:19:42:Trying to access database...
20:19:45:Successfully acquired database lock
20:19:45:Enabled folding slot 00: READY cpu:8
20:19:45:WU01:FS00:Starting
20:19:45:WU01:FS00:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/Core_a4.fah/FahCore_a4 -dir 01 -suffix 01 -version 704 -lifeline 5562 -checkpoint 15 -np 8
20:19:45:WU01:FS00:Started FahCore on PID 5573
20:19:45:WU01:FS00:Core PID:5577
20:19:45:WU01:FS00:FahCore 0xa4 started
20:19:45:WU01:FS00:0xa4:
20:19:45:WU01:FS00:0xa4:*------------------------------*
20:19:45:WU01:FS00:0xa4:Folding@Home Gromacs GB Core
20:19:45:WU01:FS00:0xa4:Version 2.27 (Dec. 15, 2010)
20:19:45:WU01:FS00:0xa4:
20:19:45:WU01:FS00:0xa4:Preparing to commence simulation
20:19:45:WU01:FS00:0xa4:- Looking at optimizations...
20:19:45:WU01:FS00:0xa4:- Files status OK
20:19:45:WU01:FS00:0xa4:- Expanded 118828 -> 270464 (decompressed 227.6 percent)
20:19:45:WU01:FS00:0xa4:Called DecompressByteArray: compressed_data_size=118828 data_size=270464, decompressed_data_size=270464 diff=0
20:19:45:WU01:FS00:0xa4:- Digital signature verified
20:19:45:WU01:FS00:0xa4:
20:19:45:WU01:FS00:0xa4:Project: 6398 (Run 10, Clone 5, Gen 351)
20:19:45:WU01:FS00:0xa4:
20:19:45:WU01:FS00:0xa4:Assembly optimizations on if available.
20:19:45:WU01:FS00:0xa4:Entering M.D.
20:19:51:WU01:FS00:0xa4:Using Gromacs checkpoints
20:19:51:WU01:FS00:0xa4:Resuming from checkpoint
20:19:51:WU01:FS00:0xa4:Verified 01/wudata_01.log
20:19:51:WU01:FS00:0xa4:Verified 01/wudata_01.trr
20:19:51:WU01:FS00:0xa4:Verified 01/wudata_01.xtc
20:19:51:WU01:FS00:0xa4:Verified 01/wudata_01.edr
20:19:51:WU01:FS00:0xa4:Completed 1303690 out of 5000000 steps  (26%)
20:20:04:Adding folding slot 01: READY gpu:0:GM107 [GeForce GTX 960M]
20:20:04:Saving configuration to /etc/fahclient/config.xml
20:20:04:<config>
20:20:04:  <!-- Client Control -->
20:20:04:  <fold-anon v='true'/>
20:20:04:
20:20:04:  <!-- Folding Slot Configuration -->
20:20:04:  <gpu v='false'/>
20:20:04:
20:20:04:  <!-- Network -->
20:20:04:  <proxy v=':8080'/>
20:20:04:
20:20:04:  <!-- Slot Control -->
20:20:04:  <power v='full'/>
20:20:04:
20:20:04:  <!-- User Information -->
20:20:04:  <passkey v='********************************'/>
20:20:04:  <team v='229996'/>
20:20:04:  <user v='Monok'/>
20:20:04:
20:20:04:  <!-- Folding Slots -->
20:20:04:  <slot id='0' type='CPU'/>
20:20:04:  <slot id='1' type='GPU'/>
20:20:04:</config>
20:20:04:FS00:Shutting core down
20:20:05:WU01:FS00:0xa4:Client no longer detected. Shutting down core.
20:20:05:WU01:FS00:0xa4:
20:20:05:WU01:FS00:0xa4:Folding@home Core Shutdown: CLIENT_DIED
20:20:07:WU00:FS01:Connecting to 171.67.108.45:80
20:20:07:WU01:FS00:FahCore returned: INTERRUPTED (102 = 0x66)
20:20:07:WU01:FS00:Starting
20:20:07:WARNING:WU01:FS00:Changed SMP threads from 8 to 7 this can cause some work units to fail
20:20:07:WU01:FS00:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/Core_a4.fah/FahCore_a4 -dir 01 -suffix 01 -version 704 -lifeline 5562 -checkpoint 15 -np 7
20:20:07:WU01:FS00:Started FahCore on PID 5595
20:20:07:WU01:FS00:Core PID:5599
20:20:07:WU01:FS00:FahCore 0xa4 started
20:20:08:WU01:FS00:0xa4:
20:20:08:WU01:FS00:0xa4:*------------------------------*
20:20:08:WU01:FS00:0xa4:Folding@Home Gromacs GB Core
20:20:08:WU01:FS00:0xa4:Version 2.27 (Dec. 15, 2010)
20:20:08:WU01:FS00:0xa4:
20:20:08:WU01:FS00:0xa4:Preparing to commence simulation
20:20:08:WU01:FS00:0xa4:- Looking at optimizations...
20:20:08:WU01:FS00:0xa4:- Files status OK
20:20:08:WU01:FS00:0xa4:- Expanded 118828 -> 270464 (decompressed 227.6 percent)
20:20:08:WU01:FS00:0xa4:Called DecompressByteArray: compressed_data_size=118828 data_size=270464, decompressed_data_size=270464 diff=0
20:20:08:WU01:FS00:0xa4:- Digital signature verified
20:20:08:WU01:FS00:0xa4:
20:20:08:WU01:FS00:0xa4:Project: 6398 (Run 10, Clone 5, Gen 351)
20:20:08:WU01:FS00:0xa4:
20:20:08:WU01:FS00:0xa4:Assembly optimizations on if available.
20:20:08:WU01:FS00:0xa4:Entering M.D.
20:20:09:WU00:FS01:Assigned to work server 171.67.108.160
20:20:09:WU00:FS01:Requesting new work unit for slot 01: READY gpu:0:GM107 [GeForce GTX 960M] from 171.67.108.160
20:20:09:WU00:FS01:Connecting to 171.67.108.160:8080
20:20:12:FS01:Paused
20:20:13:WU01:FS00:0xa4:Using Gromacs checkpoints
20:20:13:WU01:FS00:0xa4:mdrun returned 255
20:20:13:WU01:FS00:0xa4:Going to send back what have done -- stepsTotalG=5000000
20:20:13:WU01:FS00:0xa4:Work fraction=1507533520896.0000 steps=5000000.
20:20:17:WU01:FS00:0xa4:logfile size=30984 infoLength=30984 edr=25 trr=1
20:20:17:WU01:FS00:0xa4:logfile size: 30984 info=30984 bed=25 hdr=1
20:20:17:WU01:FS00:0xa4:- Writing 31522 bytes of core data to disk...
20:20:17:WU01:FS00:0xa4:Done: 31010 -> 6689 (compressed to 21.5 percent)
20:20:17:WU01:FS00:0xa4:  ... Done.
20:20:19:WU00:FS01:Downloading 8.72MiB
20:20:21:WU01:FS00:0xa4:
20:20:21:WU01:FS00:0xa4:Folding@home Core Shutdown: UNSTABLE_MACHINE
20:20:21:WARNING:WU01:FS00:FahCore returned: UNSTABLE_MACHINE (122 = 0x7a)
20:20:21:WU01:FS00:Sending unit results: id:01 state:SEND error:FAULTY project:6398 run:10 clone:5 gen:351 core:0xa4 unit:0x0000019c0002894b5462caa76e775908
20:20:21:WU01:FS00:Uploading 7.03KiB to 155.247.166.219
20:20:21:WU01:FS00:Connecting to 155.247.166.219:8080
20:20:22:WU02:FS00:Connecting to 171.67.108.45:8080
20:20:22:WU01:FS00:Upload complete
20:20:23:WU01:FS00:Server responded WORK_ACK (400)
20:20:23:WU01:FS00:Cleaning up
20:20:24:WU02:FS00:Assigned to work server 171.64.65.124
20:20:24:WU02:FS00:Requesting new work unit for slot 00: READY cpu:7 from 171.64.65.124
20:20:24:WU02:FS00:Connecting to 171.64.65.124:8080
20:20:25:WU00:FS01:Download 5.73%
20:20:28:WU02:FS00:Downloading 806.14KiB
20:20:31:WU00:FS01:Download 10.03%
20:20:37:WU00:FS01:Download 15.04%
20:20:39:FS01:Unpaused
20:20:41:WU02:FS00:Download 7.94%
20:20:43:WU00:FS01:Download 20.77%
20:20:46:Saving configuration to /etc/fahclient/config.xml
20:20:46:<config>
20:20:46:  <!-- Client Control -->
20:20:46:  <fold-anon v='true'/>
20:20:46:
20:20:46:  <!-- Folding Slot Configuration -->
20:20:46:  <gpu v='false'/>
20:20:46:
20:20:46:  <!-- Network -->
20:20:46:  <proxy v=':8080'/>
20:20:46:
20:20:46:  <!-- Slot Control -->
20:20:46:  <power v='full'/>
20:20:46:
20:20:46:  <!-- User Information -->
20:20:46:  <passkey v='********************************'/>
20:20:46:  <team v='229996'/>
20:20:46:  <user v='Monok'/>
20:20:46:
20:20:46:  <!-- Folding Slots -->
20:20:46:  <slot id='0' type='CPU'/>
20:20:46:  <slot id='1' type='GPU'/>
20:20:46:</config>
20:20:49:WU02:FS00:Download 15.88%
20:20:49:WU00:FS01:Download 27.22%
20:20:55:WU00:FS01:Download 30.80%
20:20:56:WU02:FS00:Download 31.76%
20:21:01:WU00:FS01:Download 35.82%
20:21:02:WU02:FS00:Download 55.57%
20:21:08:WU00:FS01:Download 39.40%
20:21:08:WU02:FS00:Download 79.39%
20:21:12:WU02:FS00:Download complete
20:21:12:WU02:FS00:Received Unit: id:02 state:DOWNLOAD error:NO_ERROR project:9017 run:64 clone:3 gen:24 core:0xa4 unit:0x00000025ab40417c55b26db7618cc2fe
20:21:12:WU02:FS00:Starting
20:21:12:WU02:FS00:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/Core_a4.fah/FahCore_a4 -dir 02 -suffix 01 -version 704 -lifeline 5562 -checkpoint 15 -np 7
20:21:12:WU02:FS00:Started FahCore on PID 5644
20:21:12:WU02:FS00:Core PID:5648
20:21:12:WU02:FS00:FahCore 0xa4 started
20:21:13:WU02:FS00:0xa4:
20:21:13:WU02:FS00:0xa4:*------------------------------*
20:21:13:WU02:FS00:0xa4:Folding@Home Gromacs GB Core
20:21:13:WU02:FS00:0xa4:Version 2.27 (Dec. 15, 2010)
20:21:13:WU02:FS00:0xa4:
20:21:13:WU02:FS00:0xa4:Preparing to commence simulation
20:21:13:WU02:FS00:0xa4:- Looking at optimizations...
20:21:13:WU02:FS00:0xa4:- Created dyn
20:21:13:WU02:FS00:0xa4:- Files status OK
20:21:13:WU02:FS00:0xa4:- Expanded 824973 -> 1397756 (decompressed 169.4 percent)
20:21:13:WU02:FS00:0xa4:Called DecompressByteArray: compressed_data_size=824973 data_size=1397756, decompressed_data_size=1397756 diff=0
20:21:13:WU02:FS00:0xa4:- Digital signature verified
20:21:13:WU02:FS00:0xa4:
20:21:13:WU02:FS00:0xa4:Project: 9017 (Run 64, Clone 3, Gen 24)
20:21:13:WU02:FS00:0xa4:
20:21:13:WU02:FS00:0xa4:Assembly optimizations on if available.
20:21:13:WU02:FS00:0xa4:Entering M.D.
20:21:14:WU00:FS01:Download 42.98%
20:21:19:WU02:FS00:0xa4:Completed 0 out of 250000 steps  (0%)
20:21:20:WU00:FS01:Download 47.28%
20:21:26:WU00:FS01:Download 50.86%
20:21:33:WU00:FS01:Download 53.73%
20:21:39:WU00:FS01:Download 61.61%
20:21:45:WU00:FS01:Download 70.92%
20:21:51:WU00:FS01:Download 80.23%
20:21:57:WU00:FS01:Download 85.96%
20:22:03:WU00:FS01:Download 88.83%
20:22:09:WU00:FS01:Download 93.12%
20:22:15:WU00:FS01:Download 98.85%
20:22:17:WU00:FS01:Download complete
20:22:17:WU00:FS01:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:9852 run:11 clone:3 gen:1 core:0x21 unit:0x00000001ab436ca056609bdf9b1f4e3a
20:22:17:WU00:FS01:Downloading core from http://web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_21.fah
20:22:17:WU00:FS01:Connecting to web.stanford.edu:80
20:22:18:WU00:FS01:FahCore 21: Downloading 3.23MiB
20:22:24:WU00:FS01:FahCore 21: 25.17%
20:22:30:WU00:FS01:FahCore 21: 56.15%
20:22:36:WU00:FS01:FahCore 21: 91.00%
20:22:37:WU00:FS01:FahCore 21: Download complete
20:22:37:WU00:FS01:Valid core signature
20:22:37:WU00:FS01:Unpacked 7.94MiB to cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21
20:22:37:WU00:FS01:Starting
20:22:37:WU00:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21 -dir 00 -suffix 01 -version 704 -lifeline 5562 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
20:22:37:WU00:FS01:Started FahCore on PID 5706
20:22:37:WU00:FS01:Core PID:5710
20:22:37:WU00:FS01:FahCore 0x21 started
20:22:38:WU00:FS01:0x21:*********************** Log Started 2015-12-29T20:22:37Z ***********************
20:22:38:WU00:FS01:0x21:Project: 9852 (Run 11, Clone 3, Gen 1)
20:22:38:WU00:FS01:0x21:Unit: 0x00000001ab436ca056609bdf9b1f4e3a
20:22:38:WU00:FS01:0x21:CPU: 0x00000000000000000000000000000000
20:22:38:WU00:FS01:0x21:Machine: 1
20:22:38:WU00:FS01:0x21:Reading tar file core.xml
20:22:38:WU00:FS01:0x21:Reading tar file integrator.xml
20:22:38:WU00:FS01:0x21:Reading tar file state.xml
20:22:39:WU00:FS01:0x21:Reading tar file system.xml
20:22:40:WU00:FS01:0x21:Digital signatures verified
20:22:40:WU00:FS01:0x21:Folding@home GPU Core21 Folding@home Core
20:22:40:WU00:FS01:0x21:Version 0.0.17
20:22:40:WU00:FS01:0x21:ERROR:Bad platformId size.
20:22:40:WU00:FS01:0x21:Saving result file logfile_01.txt
20:22:40:WU00:FS01:0x21:Saving result file log.txt
20:22:40:WU00:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
20:22:41:WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
20:22:41:WU00:FS01:Sending unit results: id:00 state:SEND error:FAULTY project:9852 run:11 clone:3 gen:1 core:0x21 unit:0x00000001ab436ca056609bdf9b1f4e3a
20:22:41:WU00:FS01:Uploading 1.98KiB to 171.67.108.160
20:22:41:WU00:FS01:Connecting to 171.67.108.160:8080
20:22:42:WU01:FS01:Connecting to 171.67.108.45:80
20:22:42:WU00:FS01:Upload complete
20:22:42:WU00:FS01:Server responded WORK_ACK (400)
20:22:42:WU00:FS01:Cleaning up
20:22:43:WU01:FS01:Assigned to work server 171.64.65.58
20:22:43:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GM107 [GeForce GTX 960M] from 171.64.65.58
20:22:43:WU01:FS01:Connecting to 171.64.65.58:8080
20:22:44:WU01:FS01:Downloading 881.36KiB
20:22:49:WU01:FS01:Download complete
20:22:49:WU01:FS01:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:9412 run:299 clone:2 gen:20 core:0x18 unit:0x0000001cab40413a5535e3a8caae3a58
20:22:49:WU01:FS01:Downloading core from http://web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_18.fah
20:22:49:WU01:FS01:Connecting to web.stanford.edu:80
20:22:50:WU01:FS01:FahCore 18: Downloading 2.77MiB
20:22:56:WU01:FS01:FahCore 18: 9.04%
20:23:02:WU01:FS01:FahCore 18: 27.12%
20:23:02:WU02:FS00:0xa4:Completed 2500 out of 250000 steps  (1%)
20:23:08:WU01:FS01:FahCore 18: 67.80%
20:23:13:WU01:FS01:FahCore 18: Download complete
20:23:13:WU01:FS01:Valid core signature
20:23:13:WU01:FS01:Unpacked 7.68MiB to cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_18.fah/FahCore_18
20:23:13:WU01:FS01:Starting
20:23:13:WU01:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_18.fah/FahCore_18 -dir 01 -suffix 01 -version 704 -lifeline 5562 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
20:23:13:WU01:FS01:Started FahCore on PID 5713
20:23:13:WU01:FS01:Core PID:5717
20:23:13:WU01:FS01:FahCore 0x18 started
20:23:13:WARNING:WU01:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
20:23:13:WU01:FS01:Sending unit results: id:01 state:SEND error:FAULTY project:9412 run:299 clone:2 gen:20 core:0x18 unit:0x0000001cab40413a5535e3a8caae3a58
20:23:13:WU01:FS01:Uploading 1.87KiB to 171.64.65.58
20:23:13:WU01:FS01:Connecting to 171.64.65.58:8080
20:23:14:WU01:FS01:Upload complete
20:23:15:WU00:FS01:Connecting to 171.67.108.45:80
20:23:16:WU01:FS01:Server responded WORK_ACK (400)
20:23:16:WU01:FS01:Cleaning up
20:23:17:WU00:FS01:Assigned to work server 140.163.4.244
20:23:17:WU00:FS01:Requesting new work unit for slot 01: READY gpu:0:GM107 [GeForce GTX 960M] from 140.163.4.244
20:23:17:WU00:FS01:Connecting to 140.163.4.244:8080
20:23:18:WU00:FS01:Downloading 2.54MiB
20:23:24:WU00:FS01:Download 39.33%
20:23:31:WU00:FS01:Download 54.08%
20:23:37:WU00:FS01:Download 68.83%
20:23:43:WU00:FS01:Download 86.04%
20:23:48:WU00:FS01:Download complete
20:23:48:WU00:FS01:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:10490 run:316 clone:0 gen:22 core:0x18 unit:0x0000001c8ca304f45537e90d2a91a55a
20:23:48:WU00:FS01:Starting
20:23:48:WU00:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_18.fah/FahCore_18 -dir 00 -suffix 01 -version 704 -lifeline 5562 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
20:23:48:WU00:FS01:Started FahCore on PID 5721
20:23:48:WU00:FS01:Core PID:5725
20:23:48:WU00:FS01:FahCore 0x18 started
Monok
 
Posts: 12
Joined: Sat Dec 26, 2015 1:53 pm

Re: FahCore returned: BAD_WORK_UNIT (114 = 0x72) with 960M

Postby bruce » Tue Dec 29, 2015 9:17 pm

The information in your log indicates there's still a problem with the driver.

Some sources of drivers include CUDA and others do not. Either your installation is not complete or you're not actually running the drivers from NVidia. Note the last two lines below:
Code: Select all
07:23:05:        CWD: /var/lib/fahclient
07:23:05:         OS: Linux 3.16.0-55-generic x86_64
07:23:05:    OS Arch: AMD64
07:23:05:       GPUs: 1
07:23:05:      GPU 0: NVIDIA:4 GM107 [GeForce GTX 750 Ti]
07:23:05:       CUDA: 5.0
07:23:05:CUDA Driver: 7050
07:23:05:***********************************************************************


It should be noted that some of FAH's projects actually require CUDA ... others do not, but you certainly do need to fix this problem.

I'm going to merge your previous discussion with this new topic, just to keep it all in one place.
bruce
 
Posts: 20828
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: FahCore returned: BAD_WORK_UNIT (114 = 0x72) with 960M

Postby Monok » Tue Dec 29, 2015 11:50 pm

Emh...ok? So...what can I do, about? I've tried downloading the CUDA Toolkit, installed, rebooted and everything: still not detected. Googled a little bit, but I can't seem to find any "special driver with CUDA", so...how do you all get them?
Monok
 
Posts: 12
Joined: Sat Dec 26, 2015 1:53 pm

Re: FahCore returned: BAD_WORK_UNIT (114 = 0x72) with 960M

Postby bruce » Wed Dec 30, 2015 12:11 am

I run Ubuntu and I was able to add PPA: xorg-edgers to my search list. Once added, I can find a variety of versions under "Additonal Drivers" and they all install painlessly, somehow being smart enough to bypass all the hassles with X. I used to install the CUDA toolkit but I no longer need to do that.

I have no idea if this might be helpful if you don't run Ubunty.
bruce
 
Posts: 20828
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: FahCore returned: BAD_WORK_UNIT (114 = 0x72) with 960M

Postby davidcoton » Wed Dec 30, 2015 12:31 am

Which driver did you install? I assume direct from nVidia? 355.06 works for me (Ubuntu 15.04). During the install, watch the questions carefully and make sure you allow all the "extras" it asks about.
Image
davidcoton
 
Posts: 940
Joined: Wed Nov 05, 2008 3:19 pm
Location: Cambridge, UK

Re: FahCore returned: BAD_WORK_UNIT (114 = 0x72) with 960M

Postby bruce » Wed Dec 30, 2015 12:55 am

The edgers are not rewriting a proprietary driver, they're packaging it with a script that does a painless instal, but No, they're not "direct" from NVidia.

It has worked fine for me on 14.04 LTS and I've used several versions until I installed a GTX650 Ti in the same system with a GTX750 Ti. That's a combination that NV does not support, and although i can choose the best driver for either one, it's less that perfect on the other one. (Read the NV driver support website.) I need to move one of those GPUs to another system.
bruce
 
Posts: 20828
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: FahCore returned: BAD_WORK_UNIT (114 = 0x72) with 960M

Postby 7im » Wed Dec 30, 2015 12:57 am

Is the same computer from your other thread where the Bumblebee drivers were installed?
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.
User avatar
7im
 
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Location: Arizona

Re: FahCore returned: BAD_WORK_UNIT (114 = 0x72) with 960M

Postby mmonnin » Wed Dec 30, 2015 1:42 am

Drivers straight from the NV website have worked for me in Ubuntu 14.04 LTS. I just have to remove the default drivers prior to the official NV driver install. OK/Yes to everything, even the 32bit stuff.
mmonnin
 
Posts: 331
Joined: Wed Dec 05, 2007 1:27 am

Next

Return to GPU Projects and FahCores

Who is online

Users browsing this forum: No registered users and 1 guest

cron