Core 21 failing almost immediately

If you think it might be a driver problem, see viewforum.php?f=79

Moderators: Site Moderators, PandeGroup

Core 21 failing almost immediately

Postby Therandomness » Tue Oct 31, 2017 10:05 pm

So, as said in the title, any time my graphics card (a HD 6950 1GB) tries to run a WU, it'll just either fail it outright or immediately send it off. I've tried reinstalling the client, reinstalling drivers and underclocking and overvolting the card. Here is the log for 2 examples:

Code: Select all
21:55:03:WU02:FS01:Started FahCore on PID 5172
21:55:04:WU02:FS01:Core PID:10304
21:55:04:WU02:FS01:FahCore 0x21 started
21:55:04:WU02:FS01:0x21:*********************** Log Started 2017-10-31T21:55:04Z ***********************
21:55:04:WU02:FS01:0x21:Project: 9431 (Run 498, Clone 2, Gen 10)
21:55:04:WU02:FS01:0x21:Unit: 0x00000010ab436c9d586fdd37803763cd
21:55:04:WU02:FS01:0x21:CPU: 0x00000000000000000000000000000000
21:55:04:WU02:FS01:0x21:Machine: 1
21:55:04:WU02:FS01:0x21:Reading tar file core.xml
21:55:04:WU02:FS01:0x21:Reading tar file integrator.xml
21:55:04:WU02:FS01:0x21:Reading tar file state.xml
21:55:04:WU02:FS01:0x21:Reading tar file system.xml
21:55:04:WU02:FS01:0x21:Digital signatures verified
21:55:04:WU02:FS01:0x21:Folding@home GPU Core21 Folding@home Core
21:55:04:WU02:FS01:0x21:Version 0.0.18
21:55:07:WU02:FS01:0x21:ERROR:NaNs detected in forces. 0 0
21:55:07:WU02:FS01:0x21:Saving result file logfile_01.txt
21:55:07:WU02:FS01:0x21:Saving result file log.txt
21:55:07:WU02:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
21:55:08:WARNING:WU02:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
21:55:08:WU02:FS01:Sending unit results: id:02 state:SEND error:FAULTY project:9431 run:498 clone:2 gen:10 core:0x21 unit:0x00000010ab436c9d586fdd37803763cd
21:55:08:WU02:FS01:Uploading 7.00KiB to 171.67.108.157
21:55:08:WU02:FS01:Connecting to 171.67.108.157:8080
21:55:08:WU01:FS01:Connecting to 171.67.108.45:80
21:55:08:WU02:FS01:Upload complete
21:55:09:WU02:FS01:Server responded WORK_ACK (400)
21:55:09:WU02:FS01:Cleaning up
21:55:09:WU01:FS01:Assigned to work server 171.67.108.157
21:55:09:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:Cayman PRO [Radeon 6900 Series] from 171.67.108.157
21:55:09:WU01:FS01:Connecting to 171.67.108.157:8080
21:55:10:WU01:FS01:Downloading 5.15MiB
21:55:16:WU01:FS01:Download 82.55%
21:55:17:WU01:FS01:Download complete
21:55:17:WU01:FS01:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:9415 run:1196 clone:4 gen:53 core:0x21 unit:0x0000003aab436c9d585e06d35c67e223
21:55:17:WU01:FS01:Starting
21:55:17:WU01:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:/Users/rando/AppData/Roaming/FAHClient/cores/fahwebx.stanford.edu/cores/Win32/AMD64/ATI/R600/Core_21.fah/FahCore_21.exe -dir 01 -suffix 01 -version 704 -lifeline 10940 -checkpoint 15 -gpu 0 -gpu-vendor ati
21:55:17:WU01:FS01:Started FahCore on PID 5028
21:55:17:WU01:FS01:Core PID:11324
21:55:17:WU01:FS01:FahCore 0x21 started
21:55:17:WU01:FS01:0x21:*********************** Log Started 2017-10-31T21:55:17Z ***********************
21:55:17:WU01:FS01:0x21:Project: 9415 (Run 1196, Clone 4, Gen 53)
21:55:17:WU01:FS01:0x21:Unit: 0x0000003aab436c9d585e06d35c67e223
21:55:17:WU01:FS01:0x21:CPU: 0x00000000000000000000000000000000
21:55:17:WU01:FS01:0x21:Machine: 1
21:55:17:WU01:FS01:0x21:Reading tar file core.xml
21:55:17:WU01:FS01:0x21:Reading tar file integrator.xml
21:55:17:WU01:FS01:0x21:Reading tar file state.xml
21:55:17:WU01:FS01:0x21:Reading tar file system.xml
21:55:17:WU01:FS01:0x21:Digital signatures verified
21:55:17:WU01:FS01:0x21:Folding@home GPU Core21 Folding@home Core
21:55:17:WU01:FS01:0x21:Version 0.0.18
21:55:20:WU01:FS01:0x21:ERROR:NaNs detected in forces. 0 0
21:55:20:WU01:FS01:0x21:Saving result file logfile_01.txt
21:55:20:WU01:FS01:0x21:Saving result file log.txt
21:55:20:WU01:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
21:55:20:WARNING:WU01:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
21:55:20:WU01:FS01:Sending unit results: id:01 state:SEND error:FAULTY project:9415 run:1196 clone:4 gen:53 core:0x21 unit:0x0000003aab436c9d585e06d35c67e223
21:55:20:WU01:FS01:Uploading 7.00KiB to 171.67.108.157
21:55:20:WU01:FS01:Connecting to 171.67.108.157:8080
21:55:20:WU02:FS01:Connecting to 171.67.108.45:80
21:55:21:WU01:FS01:Upload complete
21:55:21:WU01:FS01:Server responded WORK_ACK (400)
21:55:21:WU01:FS01:Cleaning up


I am running Windows 10 Pro 64 bit, with AMD Crimson 16.2.1 drivers.

Mod edit: Please use Code tags for logs instead of Quote - j
Therandomness
 
Posts: 2
Joined: Tue Oct 31, 2017 9:52 pm

Re: Core 21 failing almost immediately

Postby bruce » Tue Oct 31, 2017 10:18 pm

It would be helpful if you posted the first couple pages of your log.

I've see a number of folks who have had troubles with the Crimson drivers. Can you find a Catalyst driver that works with this hardware?
bruce
 
Posts: 20833
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Core 21 failing almost immediately

Postby JimboPalmer » Wed Nov 01, 2017 12:42 am

A HD 6950 is a 7 year old VLIW4 microarcheture, (terascale 3) that supports OpenCL 1.2 I am not sure Core_21 works on any AMD card that is not GCN.
Tsar of all the Rushers
I tried to remain childlike, all I achieved was childish.
A friend to those who want no friends
JimboPalmer
 
Posts: 534
Joined: Mon Feb 16, 2009 4:12 am
Location: Greenwood MS USA

Re: Core 21 failing almost immediately

Postby bruce » Wed Nov 01, 2017 5:25 am

The Cayman Pro was once supported but it may have been excluded from the active projects because of its poor performance compared to later devices. In fact, when using a GPU of that era, it shares the processing load with the CPU -- and configuring the FAH Client to fold with the CPU gives almost the same throughput.

In any case, you can try it with the Catalyst driver.

In any case, we need to see the first few pages of FAH's log. (See the signature block of my first post here.)
bruce
 
Posts: 20833
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Core 21 failing almost immediately

Postby Therandomness » Wed Nov 01, 2017 8:24 pm

JimboPalmer wrote:A HD 6950 is a 7 year old VLIW4 microarcheture, (terascale 3) that supports OpenCL 1.2 I am not sure Core_21 works on any AMD card that is not GCN.
Ah I see. But I mean.. every little bit counts, right?
bruce wrote:It would be helpful if you posted the first couple pages of your log.

I've see a number of folks who have had troubles with the Crimson drivers. Can you find a Catalyst driver that works with this hardware?
Just to make sure I don't post something you don't need, you mean basically everything from the start of the log file in %appdata%? Also, yes, I'm going to try catalyst drivers now.

EDIT: Yeah I just installed Catalyst drivers and it's now folding properly. Hey, it can match my 6600k when that's folding a7 WUs at least :P And thanks for the help.
Therandomness
 
Posts: 2
Joined: Tue Oct 31, 2017 9:52 pm

Re: Core 21 failing almost immediately

Postby bruce » Wed Nov 01, 2017 9:16 pm

You can right-click on FAHClient's Folding Slot on the Status screen and select Finish to finish one and leave the other running. It takes quite a bit of time for the PPD to stabilize.

You might try running either slot by itself until the PPD stabilizes and then try both. I expect that running both will slow both of the others down some, so the total may or may not be better than either one by itself. A few days of experimenting may help you make the proper choices.
bruce
 
Posts: 20833
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Core 21 failing almost immediately

Postby toTOW » Wed Nov 01, 2017 9:52 pm

Therandomness wrote:So, as said in the title, any time my graphics card (a HD 6950 1GB) tries to run a WU, it'll just either fail it outright or immediately send it off. I've tried reinstalling the client, reinstalling drivers and underclocking and overvolting the card.

[...]
I am running Windows 10 Pro 64 bit, with AMD Crimson 16.2.1 drivers.

I have the same issue on my 6950.

For such an old GPU, the latest drivers you used AMD (Crimson 16.2.1 beta) doesn't provide OpenCL support.

To be able to fold, you need to stick to the previous release (Catalyst 15.7.1).
Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.

FAH-Addict : latest news, tests and reviews about Folding@Home project.

Image
User avatar
toTOW
Site Moderator
 
Posts: 8329
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France


Return to GPU Projects and FahCores

Who is online

Users browsing this forum: No registered users and 1 guest

cron