Run both graphics subsystems at the same time

It seems that a lot of GPU problems revolve around specific versions of drivers. Though NVidia has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, PandeGroup

Run both graphics subsystems at the same time

Postby 900i » Sun Jun 04, 2017 9:22 am

Hi, 1st post on this forum.

Is it possible to run F@H on Nvidia card with monitor running on Intel HD IGPU,

I'm sure this would have been covered already but are there any howto's relating to this subject.

Jerry.
Image
900i
 
Posts: 4
Joined: Sun Jun 04, 2017 8:54 am

Re: Run both graphics subsystems at the same time

Postby Joe_H » Sun Jun 04, 2017 2:16 pm

Welcome t the folding support forum.

Yes it is possible to do this. The first step is determining whether your logic board supports this. Many disable the integrated video when a video card is added. On some logic boards it is possible to enable both through a setting in the BIOS or UEFI, but not in all cases. If use of both can be enabled, then all you should need to do is attach your monitor to the video port on the logic board for the integrated video from the Intel CPU, and install drivers for both Intel video and the nVidia card. The folding client will not attempt to use the iGPU as it is not supported for folding anyways.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3
Joe_H
Site Admin
 
Posts: 3757
Joined: Tue Apr 21, 2009 4:41 pm
Location: W. MA

Re: Run both graphics subsystems at the same time

Postby 900i » Sun Jun 04, 2017 3:05 pm

Thanks Joe_H. I have found this solution on the Nvidia forum and it is not as straight forward as you would think.

https://devtalk.nvidia.com/default/topi ... possible-/

I have previously tried what you suggested but it was not as easy as I first thought.

I will try again at some point, and post back as to whether it works or not.

Thanks again Joe_H for your response.

Jerry.
900i
 
Posts: 4
Joined: Sun Jun 04, 2017 8:54 am

Re: Run both graphics subsystems at the same time

Postby jrweiss » Sun Jun 04, 2017 9:34 pm

I successfully run Virtu D-mode on my system with a Z87 motherboard; the Z77 system doesn't fully recognize it, even though the drivers seem to load.

I did a few tests when my system was new and found a slight increase in Folding performance with Virtu enabled. I don't know what processes make use of the Intel onboard GPU, but it apparently does a little work...
i4770K/AMD RX460 (CPU6+GPU), i7-3770S/AMD7750 (CPU6+GPU), Win7-64 Pro
User avatar
jrweiss
 
Posts: 1180
Joined: Tue Dec 04, 2007 6:56 am
Location: Gotta guess!

Re: Run both graphics subsystems at the same time

Postby bruce » Mon Jun 05, 2017 5:24 am

The integrated GPUs are fine to drive a monitor provided you can follow the procedures noted above.

Though you didn't ask, I'll add a bit of off-topic information related to your question.

Integrated GPUs, whether from Intel or AMD, produce a munch lower number of GFLOPS than almost any discrete GPU. Therefore they would fold MUCH slower if you did actually try to do so. Recent integrated GPUs from AMD can accept the regular AMD drivers, and technically speaking, they could fold, but they're so slow that they generally won't meet FAH's deadlines. FAH does not support the Intel HD drivers for folding although it might be possible on the latest models. Nevertheleess, they'd also fail to meet the deadlines so there has been no reason for FAH to support them as a folding device.
bruce
 
Posts: 21175
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Run both graphics subsystems at the same time

Postby snapshot » Mon Jun 05, 2017 8:32 am

900i wrote:Thanks Joe_H. I have found this solution on the Nvidia forum and it is not as straight forward as you would think.

https://devtalk.nvidia.com/default/topi ... possible-/

I have previously tried what you suggested but it was not as easy as I first thought.

I will try again at some point, and post back as to whether it works or not.

Thanks again Joe_H for your response.

Jerry.
Did you notice that that link is about Linux, not Windows? For Windows, it is exactly as easy as Joe_H says. Just set the BIOS to initialise the on-board graphics (IGP rather than PEG) and that's it. I have an ancient B75 motherboard which has the monitor connected to the on-board DVI and is folding on a GTX 1050 with no monitor attached.
User avatar
snapshot
 
Posts: 89
Joined: Thu Apr 09, 2009 7:25 pm
Location: Wiltshire, UK

Re: Run both graphics subsystems at the same time

Postby 900i » Mon Jun 05, 2017 8:47 am

Thanks Snapshot for the pointer to Windows. Unfortunately it's not a Windows rig. Linux only.

Jerry.
900i
 
Posts: 4
Joined: Sun Jun 04, 2017 8:54 am

Re: Run both graphics subsystems at the same time

Postby jrweiss » Mon Jun 05, 2017 5:27 pm

bruce wrote:The integrated GPUs are fine to drive a monitor provided you can follow the procedures noted above.

Using Virtu D-mode ("Discrete"), your monitor cable is connected to the add-in GPU, and that primarily drives the monitor.

If you want the integrated GPU to primarily drive the monitor, you have to set your BIOS to Virtu I-mode ("Integrated"), and connect the monitor cable to the motherboard video output. Note: I have not tried GPU Folding in I-mode, so I don't know the effects. However, if the add-in card is detected by the OS, F@HClient should also detect and be able to use it.
User avatar
jrweiss
 
Posts: 1180
Joined: Tue Dec 04, 2007 6:56 am
Location: Gotta guess!

Re: Run both graphics subsystems at the same time

Postby bruce » Mon Jun 05, 2017 11:31 pm

On subtle gotcha is the OpenCL limitation. OpenCL is needed for whatever GPU you want to use for FAH.

It would be nice to have your iGPU render your screen and your videos, leaving the dGPU exclusively for FAH, but that would require all FAHCores to use CUDA. Most NV cores use OpenCL and you'd still have a problem with AMD GPUs which only use OpenCL.
bruce
 
Posts: 21175
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Run both graphics subsystems at the same time

Postby QuintLeo » Sat Jun 17, 2017 6:11 am

For Windows, it's trivial - AMD or Intel iGPU doesn't matter.
This is one of the VERY FEW things Windows does noticeably better than LINUX does.

On Linux, you have to install the drivers for the iGPU first, then manually install the NVidia drivers using the "--no-open-glfiles" option, and you generally end up having to manually edit your xorg.conf to add the card entries, screen entries, and "dummy" monitor entries for each card (along with coolbits to the applicable spots to enable fan control etc).

It's a lovely thing once you get it working the first time - then you can usually "clone" the setup with at most changing the PCI assignments in xorg.conf for each GPU and the iGPU if needed.

AMD iGPUs do nicely on some BOINC projects like Moo Wrapper or Yoyo, running at the same time as your CPU is keeping your Folding GPUs humming away.
Intel iGPUs are ... meh, Intel Graphics has never been competative with AMD/ATI or Nvidia - but will still save you some GPU cycles running the desktop on the IGU instead of one of your folding GPUs.
QuintLeo
 
Posts: 22
Joined: Sat Jun 17, 2017 5:43 am

Re: Run both graphics subsystems at the same time

Postby LazyDev » Tue Jul 04, 2017 1:57 pm

I tried some sort of solution a couple of days ago, using Nvidia Optimus.

F@H kept giving this:
17:07:41:WU01:FS01:0x21:ERROR:126: Bad platformId size.

Edit:
More details on this post.
https://forums.linuxmint.com/viewtopic. ... d#p1336226
LazyDev
 
Posts: 3
Joined: Tue Aug 30, 2016 7:28 pm

Re: Run both graphics subsystems at the same time

Postby bruce » Tue Jul 04, 2017 2:52 pm

For us to help, you need to post the log showing the problem. (See the signature block of this post.)

I'm not registered at linuxmint.com so I can't see what's there. I hope they can solve it, but there's important information in the preamble to FAH's log ... which also can be obtained with FAHBench as well as GPU-Z. Do both graphics systems have driver support for OpenCL?
bruce
 
Posts: 21175
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Run both graphics subsystems at the same time

Postby LazyDev » Tue Jul 04, 2017 3:42 pm

Wasn't aware that you had to be registered to view the content. I'll duplicate my post.

Code: Select all
17:07:41:WU01:FS01:0x21:Project: 11402 (Run 13, Clone 33, Gen 145)
17:07:41:WU01:FS01:0x21:Unit: 0x000000bc8ca304f255ed4ee4c5e9469a
17:07:41:WU01:FS01:0x21:CPU: 0x00000000000000000000000000000000
17:07:41:WU01:FS01:0x21:Machine: 1
17:07:41:WU01:FS01:0x21:Reading tar file core.xml
17:07:41:WU01:FS01:0x21:Reading tar file system.xml
17:07:41:WU01:FS01:0x21:Reading tar file integrator.xml
17:07:41:WU01:FS01:0x21:Reading tar file state.xml
17:07:41:WU01:FS01:0x21:Digital signatures verified
17:07:41:WU01:FS01:0x21:Folding@home GPU Core21 Folding@home Core
17:07:41:WU01:FS01:0x21:Version 0.0.18

17:07:41:WU01:FS01:0x21:ERROR:126: Bad platformId size. <--------------------

17:07:41:WU01:FS01:0x21:Saving result file logfile_01.txt
17:07:41:WU01:FS01:0x21:Saving result file log.txt
17:07:41:WU01:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
17:07:42:WARNING:WU01:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
17:07:42:WU01:FS01:Sending unit results: id:01 state:SEND error:FAULTY project:11402 run:13 clone:33 gen:145 core:0x21 unit:0x000000bc8ca304f255ed4ee4c5e9469a
17:07:42:WU01:FS01:Uploading 1.97KiB to 140.163.4.242


Image

Code: Select all
user@user-MS-7851 ~/Downloads $ optirun nvidia-smi
Sun Jul  2 17:55:17 2017       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 381.22                 Driver Version: 381.22                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 106...  Off  | 0000:01:00.0     Off |                  N/A |
| 40%   24C    P0    28W / 120W |      6MiB /  6072MiB |      2%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID  Type  Process name                               Usage      |
|=============================================================================|
|    0      7033    G   /usr/lib/xorg/Xorg                               6MiB |
+-----------------------------------------------------------------------------+


I've since reset my config. Still looking to get a solution, tho.
LazyDev
 
Posts: 3
Joined: Tue Aug 30, 2016 7:28 pm

Re: Run both graphics subsystems at the same time

Postby bruce » Tue Jul 04, 2017 4:21 pm

Per the notes in the sig of my previous post, we need the first couple of pages of the log. (Your screenshot shows most of that.)

Looking at the screenshot, it appears you're running LInux, that you have some version of drivers which provide support for CUDA but there's no mention of support for OpenCL. FAH is seeing a single CUDA GPU ... a GTX 1060 ... and no alternate GPU. What does something like CPU-Z say about OpenCL and about the alternate GPU?

What happens if you plug a monitor into the iGPU?

This doesn't really look like an issue that's specific to FAH but rather with the Linux drivers.
bruce
 
Posts: 21175
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Run both graphics subsystems at the same time

Postby LazyDev » Tue Jul 04, 2017 4:50 pm

I've since reset everything, so my IGP is currently disabled until I can find a solid solid solution.

All I know is, that I was very close. Their are guides out there, but non I've seen are up to date, or provide a detailed, solid, solution.

My system (At the time):
Linux Mint
Cinnamon 18.1
Kernal 4.4.0-53-generic x86_64

The log from the final attempt:
Code: Select all
*********************** Log Started 2017-07-02T17:33:25Z ***********************
17:33:25:************************* Folding@home Client *************************
17:33:25:    Website: http://folding.stanford.edu/
17:33:25:  Copyright: (c) 2009-2014 Stanford University
17:33:25:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
17:33:25:       Args: --child --lifeline 14386 /etc/fahclient/config.xml --run-as
17:33:25:             fahclient --pid-file=/var/run/fahclient.pid --daemon
17:33:25:     Config: /etc/fahclient/config.xml
17:33:25:******************************** Build ********************************
17:33:25:    Version: 7.4.4
17:33:25:       Date: Mar 4 2014
17:33:25:       Time: 12:02:38
17:33:25:    SVN Rev: 4130
17:33:25:     Branch: fah/trunk/client
17:33:25:   Compiler: GNU 4.4.7
17:33:25:    Options: -std=gnu++98 -O3 -funroll-loops -mfpmath=sse -ffast-math
17:33:25:             -fno-unsafe-math-optimizations -msse2
17:33:25:   Platform: linux2 3.2.0-1-amd64
17:33:25:       Bits: 64
17:33:25:       Mode: Release
17:33:25:******************************* System ********************************
17:33:25:        CPU: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
17:33:25:     CPU ID: GenuineIntel Family 6 Model 60 Stepping 3
17:33:25:       CPUs: 8
17:33:25:     Memory: 15.60GiB
17:33:25:Free Memory: 13.91GiB
17:33:25:    Threads: POSIX_THREADS
17:33:25: OS Version: 4.4
17:33:25:Has Battery: false
17:33:25: On Battery: false
17:33:25: UTC Offset: 1
17:33:25:        PID: 14388
17:33:25:        CWD: /var/lib/fahclient
17:33:25:         OS: Linux 4.4.0-53-generic x86_64
17:33:25:    OS Arch: AMD64
17:33:25:       GPUs: 1
17:33:25:      GPU 0: NVIDIA:7 GP106 [GeForce GTX 1060 6GB] 4372
17:33:25:       CUDA: 6.1
17:33:25:CUDA Driver: 8000
17:33:25:***********************************************************************
17:33:25:<config>
17:33:25:  <!-- Client Control -->
17:33:25:  <fold-anon v='true'/>
17:33:25:
17:33:25:  <!-- Network -->
17:33:25:  <proxy v=':8080'/>
17:33:25:
17:33:25:  <!-- Remote Command Server -->
17:33:25:  <password v='******'/>
17:33:25:
17:33:25:  <!-- Slot Control -->
17:33:25:  <power v='full'/>
17:33:25:
17:33:25:  <!-- User Information -->
17:33:25:  <passkey v='********************************'/>
17:33:25:  <team v='76140'/>
17:33:25:  <user v='LazyDev'/>
17:33:25:
17:33:25:  <!-- Folding Slots -->
17:33:25:  <slot id='0' type='CPU'>
17:33:25:    <cpus v='3'/>
17:33:25:    <paused v='true'/>
17:33:25:  </slot>
17:33:25:  <slot id='1' type='GPU'>
17:33:25:    <paused v='true'/>
17:33:25:  </slot>
17:33:25:</config>
17:33:25:Switching to user fahclient
17:33:25:Trying to access database...
17:33:25:Successfully acquired database lock
17:33:25:Enabled folding slot 00: PAUSED cpu:3 (by user)
17:33:25:Enabled folding slot 01: PAUSED gpu:0:GP106 [GeForce GTX 1060 6GB] 4372 (by user)
17:33:37:FS01:Unpaused
17:33:37:WU00:FS01:Connecting to 171.67.108.45:80
17:33:38:WU00:FS01:Assigned to work server 140.163.4.242
17:33:38:WU00:FS01:Requesting new work unit for slot 01: READY gpu:0:GP106 [GeForce GTX 1060 6GB] 4372 from 140.163.4.242
17:33:38:WU00:FS01:Connecting to 140.163.4.242:8080
17:33:38:WU00:FS01:Downloading 4.22MiB
17:33:40:WU00:FS01:Download complete
17:33:40:WU00:FS01:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:11403 run:6 clone:41 gen:348 core:0x21 unit:0x000001fa8ca304f255ed4f70d0db6983
17:33:40:WU00:FS01:Starting
17:33:40:WU00:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/fahwebx.stanford.edu/cores/Linux/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21 -dir 00 -suffix 01 -version 704 -lifeline 14388 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
17:33:40:WU00:FS01:Started FahCore on PID 14408
17:33:40:WU00:FS01:Core PID:14412
17:33:40:WU00:FS01:FahCore 0x21 started
17:33:40:WU00:FS01:0x21:*********************** Log Started 2017-07-02T17:33:40Z ***********************
17:33:40:WU00:FS01:0x21:Project: 11403 (Run 6, Clone 41, Gen 348)
17:33:40:WU00:FS01:0x21:Unit: 0x000001fa8ca304f255ed4f70d0db6983
17:33:40:WU00:FS01:0x21:CPU: 0x00000000000000000000000000000000
17:33:40:WU00:FS01:0x21:Machine: 1
17:33:40:WU00:FS01:0x21:Reading tar file core.xml
17:33:40:WU00:FS01:0x21:Reading tar file system.xml
17:33:40:WU00:FS01:0x21:Reading tar file integrator.xml
17:33:40:WU00:FS01:0x21:Reading tar file state.xml
17:33:41:WU00:FS01:0x21:Digital signatures verified
17:33:41:WU00:FS01:0x21:Folding@home GPU Core21 Folding@home Core
17:33:41:WU00:FS01:0x21:Version 0.0.18
17:33:41:WU00:FS01:0x21:ERROR:126: Bad platformId size.
17:33:41:WU00:FS01:0x21:Saving result file logfile_01.txt
17:33:41:WU00:FS01:0x21:Saving result file log.txt
17:33:41:WU00:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
17:33:41:WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
17:33:41:WU00:FS01:Sending unit results: id:00 state:SEND error:FAULTY project:11403 run:6 clone:41 gen:348 core:0x21 unit:0x000001fa8ca304f255ed4f70d0db6983
17:33:41:WU00:FS01:Uploading 1.97KiB to 140.163.4.242
17:33:41:WU00:FS01:Connecting to 140.163.4.242:8080
17:33:41:WU01:FS01:Connecting to 171.67.108.45:80
17:33:41:WU00:FS01:Upload complete
17:33:41:WU00:FS01:Server responded WORK_ACK (400)
17:33:41:WU00:FS01:Cleaning up
17:33:42:WU01:FS01:Assigned to work server 140.163.4.245
17:33:42:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GP106 [GeForce GTX 1060 6GB] 4372 from 140.163.4.245
17:33:42:WU01:FS01:Connecting to 140.163.4.245:8080
17:33:42:WU01:FS01:Downloading 14.48MiB
17:33:44:WU01:FS01:Download complete
17:33:44:WU01:FS01:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:10496 run:185 clone:12 gen:105 core:0x21 unit:0x000000878ca304f556bbb32e2317ac7b
17:33:44:WU01:FS01:Starting
17:33:44:WU01:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/fahwebx.stanford.edu/cores/Linux/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21 -dir 01 -suffix 01 -version 704 -lifeline 14388 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
17:33:44:WU01:FS01:Started FahCore on PID 14415
17:33:44:WU01:FS01:Core PID:14419
17:33:44:WU01:FS01:FahCore 0x21 started
17:33:45:WU01:FS01:0x21:*********************** Log Started 2017-07-02T17:33:44Z ***********************
17:33:45:WU01:FS01:0x21:Project: 10496 (Run 185, Clone 12, Gen 105)
17:33:45:WU01:FS01:0x21:Unit: 0x000000878ca304f556bbb32e2317ac7b
17:33:45:WU01:FS01:0x21:CPU: 0x00000000000000000000000000000000
17:33:45:WU01:FS01:0x21:Machine: 1
17:33:45:WU01:FS01:0x21:Reading tar file core.xml
17:33:45:WU01:FS01:0x21:Reading tar file system.xml
17:33:45:WU01:FS01:0x21:Reading tar file integrator.xml
17:33:45:WU01:FS01:0x21:Reading tar file state.xml
17:33:46:WU01:FS01:0x21:Digital signatures verified
17:33:46:WU01:FS01:0x21:Folding@home GPU Core21 Folding@home Core
17:33:46:WU01:FS01:0x21:Version 0.0.18
17:33:46:WU01:FS01:0x21:ERROR:126: Bad platformId size.
17:33:46:WU01:FS01:0x21:Saving result file logfile_01.txt
17:33:46:WU01:FS01:0x21:Saving result file log.txt
17:33:46:WU01:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
17:33:47:WARNING:WU01:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
17:33:47:WU01:FS01:Sending unit results: id:01 state:SEND error:FAULTY project:10496 run:185 clone:12 gen:105 core:0x21 unit:0x000000878ca304f556bbb32e2317ac7b
17:33:47:WU01:FS01:Uploading 1.98KiB to 140.163.4.245
17:33:47:WU01:FS01:Connecting to 140.163.4.245:8080
17:33:47:WU00:FS01:Connecting to 171.67.108.45:80
17:33:47:WU01:FS01:Upload complete
17:33:47:WU01:FS01:Server responded WORK_ACK (400)
17:33:47:WU01:FS01:Cleaning up
17:33:47:WU00:FS01:Assigned to work server 171.67.108.160
17:33:47:WU00:FS01:Requesting new work unit for slot 01: READY gpu:0:GP106 [GeForce GTX 1060 6GB] 4372 from 171.67.108.160
17:33:47:WU00:FS01:Connecting to 171.67.108.160:8080
17:33:50:WU00:FS01:Downloading 2.02MiB
17:33:51:WU00:FS01:Download complete
17:33:51:WU00:FS01:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:9839 run:1 clone:11 gen:370 core:0x21 unit:0x0000019dab436ca05890cac663ace62f
17:33:51:WU00:FS01:Starting
17:33:51:WU00:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/fahwebx.stanford.edu/cores/Linux/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21 -dir 00 -suffix 01 -version 704 -lifeline 14388 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
17:33:51:WU00:FS01:Started FahCore on PID 14422
17:33:51:WU00:FS01:Core PID:14426
17:33:51:WU00:FS01:FahCore 0x21 started
17:33:52:WU00:FS01:0x21:*********************** Log Started 2017-07-02T17:33:51Z ***********************
17:33:52:WU00:FS01:0x21:Project: 9839 (Run 1, Clone 11, Gen 370)
17:33:52:WU00:FS01:0x21:Unit: 0x0000019dab436ca05890cac663ace62f
17:33:52:WU00:FS01:0x21:CPU: 0x00000000000000000000000000000000
17:33:52:WU00:FS01:0x21:Machine: 1
17:33:52:WU00:FS01:0x21:Reading tar file core.xml
17:33:52:WU00:FS01:0x21:Reading tar file integrator.xml
17:33:52:WU00:FS01:0x21:Reading tar file state.xml
17:33:52:WU00:FS01:0x21:Reading tar file system.xml
17:33:52:WU00:FS01:0x21:Digital signatures verified
17:33:52:WU00:FS01:0x21:Folding@home GPU Core21 Folding@home Core
17:33:52:WU00:FS01:0x21:Version 0.0.18
17:33:52:WU00:FS01:0x21:ERROR:126: Bad platformId size.
17:33:52:WU00:FS01:0x21:Saving result file logfile_01.txt
17:33:52:WU00:FS01:0x21:Saving result file log.txt
17:33:52:WU00:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
17:33:52:WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
17:33:52:WU00:FS01:Sending unit results: id:00 state:SEND error:FAULTY project:9839 run:1 clone:11 gen:370 core:0x21 unit:0x0000019dab436ca05890cac663ace62f
17:33:52:WU00:FS01:Uploading 1.99KiB to 171.67.108.160
17:33:52:WU00:FS01:Connecting to 171.67.108.160:8080
17:33:52:WU01:FS01:Connecting to 171.67.108.45:80
17:33:53:WU00:FS01:Upload complete
17:33:53:WU00:FS01:Server responded WORK_ACK (400)
17:33:53:WU00:FS01:Cleaning up
17:33:53:WU01:FS01:Assigned to work server 140.163.4.242
17:33:53:WU01:FS01:Requesting new work unit for slot 01: READY gpu:0:GP106 [GeForce GTX 1060 6GB] 4372 from 140.163.4.242
17:33:53:WU01:FS01:Connecting to 140.163.4.242:8080
17:33:53:WU01:FS01:Downloading 4.22MiB
17:33:54:FS01:Paused
17:33:55:WU01:FS01:Download complete
17:33:55:WU01:FS01:Received Unit: id:01 state:DOWNLOAD error:NO_ERROR project:11403 run:12 clone:38 gen:171 core:0x21 unit:0x000000d68ca304f255ed4fbd58216afa
17:37:13:Lost lifeline PID 14386, exiting
17:37:14:Clean exit


For comparison, F@H currently working log:
Code: Select all
*********************** Log Started 2017-07-02T17:50:49Z ***********************
17:50:49:************************* Folding@home Client *************************
17:50:49:    Website: http://folding.stanford.edu/
17:50:49:  Copyright: (c) 2009-2014 Stanford University
17:50:49:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
17:50:49:       Args: --child --lifeline 1976 /etc/fahclient/config.xml --run-as
17:50:49:             fahclient --pid-file=/var/run/fahclient.pid --daemon
17:50:49:     Config: /etc/fahclient/config.xml
17:50:49:******************************** Build ********************************
17:50:49:    Version: 7.4.4
17:50:49:       Date: Mar 4 2014
17:50:49:       Time: 12:02:38
17:50:49:    SVN Rev: 4130
17:50:49:     Branch: fah/trunk/client
17:50:49:   Compiler: GNU 4.4.7
17:50:49:    Options: -std=gnu++98 -O3 -funroll-loops -mfpmath=sse -ffast-math
17:50:49:             -fno-unsafe-math-optimizations -msse2
17:50:49:   Platform: linux2 3.2.0-1-amd64
17:50:49:       Bits: 64
17:50:49:       Mode: Release
17:50:49:******************************* System ********************************
17:50:49:        CPU: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
17:50:49:     CPU ID: GenuineIntel Family 6 Model 60 Stepping 3
17:50:49:       CPUs: 8
17:50:49:     Memory: 15.60GiB
17:50:49:Free Memory: 15.14GiB
17:50:49:    Threads: POSIX_THREADS
17:50:49: OS Version: 4.4
17:50:49:Has Battery: false
17:50:49: On Battery: false
17:50:49: UTC Offset: 1
17:50:49:        PID: 1978
17:50:49:        CWD: /var/lib/fahclient
17:50:49:         OS: Linux 4.4.0-53-generic x86_64
17:50:49:    OS Arch: AMD64
17:50:49:       GPUs: 1
17:50:49:      GPU 0: NVIDIA:7 GP106 [GeForce GTX 1060 6GB] 4372
17:50:49:       CUDA: 6.1
17:50:49:CUDA Driver: 8000
17:50:49:***********************************************************************
17:50:49:<config>
17:50:49:  <!-- Client Control -->
17:50:49:  <fold-anon v='true'/>
17:50:49:
17:50:49:  <!-- Network -->
17:50:49:  <proxy v=':8080'/>
17:50:49:
17:50:49:  <!-- Remote Command Server -->
17:50:49:  <password v='******'/>
17:50:49:
17:50:49:  <!-- Slot Control -->
17:50:49:  <power v='full'/>
17:50:49:
17:50:49:  <!-- User Information -->
17:50:49:  <passkey v='********************************'/>
17:50:49:  <team v='76140'/>
17:50:49:  <user v='LazyDev'/>
17:50:49:
17:50:49:  <!-- Folding Slots -->
17:50:49:  <slot id='0' type='CPU'>
17:50:49:    <cpus v='3'/>
17:50:49:    <paused v='true'/>
17:50:49:  </slot>
17:50:49:  <slot id='1' type='GPU'>
17:50:49:    <paused v='true'/>
17:50:49:  </slot>
17:50:49:</config>
17:50:49:Switching to user fahclient
17:50:49:Trying to access database...
17:50:49:Successfully acquired database lock
17:50:49:Enabled folding slot 00: PAUSED cpu:3 (by user)
17:50:49:Enabled folding slot 01: PAUSED gpu:0:GP106 [GeForce GTX 1060 6GB] 4372 (by user)
17:51:11:FS01:Unpaused
17:51:12:WU01:FS01:Starting
17:51:12:WU01:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/fahwebx.stanford.edu/cores/Linux/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21 -dir 01 -suffix 01 -version 704 -lifeline 1978 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
17:51:12:WU01:FS01:Started FahCore on PID 2752
17:51:12:WU01:FS01:Core PID:2756
17:51:12:WU01:FS01:FahCore 0x21 started
17:51:12:WU01:FS01:0x21:*********************** Log Started 2017-07-02T17:51:12Z ***********************
17:51:12:WU01:FS01:0x21:Project: 11403 (Run 12, Clone 38, Gen 171)
17:51:12:WU01:FS01:0x21:Unit: 0x000000d68ca304f255ed4fbd58216afa
17:51:12:WU01:FS01:0x21:CPU: 0x00000000000000000000000000000000
17:51:12:WU01:FS01:0x21:Machine: 1
17:51:12:WU01:FS01:0x21:Reading tar file core.xml
17:51:12:WU01:FS01:0x21:Reading tar file system.xml
17:51:12:WU01:FS01:0x21:Reading tar file integrator.xml
17:51:12:WU01:FS01:0x21:Reading tar file state.xml
17:51:12:WU01:FS01:0x21:Digital signatures verified
17:51:12:WU01:FS01:0x21:Folding@home GPU Core21 Folding@home Core
17:51:12:WU01:FS01:0x21:Version 0.0.18
17:51:17:WU01:FS01:0x21:Completed 0 out of 5000000 steps (0%)
17:51:17:WU01:FS01:0x21:Temperature control disabled. Requirements: single Nvidia GPU, tmax must be < 110 and twait >= 900
17:51:35:FS00:Unpaused
17:51:35:FS00:Finishing
17:51:36:WU02:FS00:Starting
17:51:36:WU02:FS00:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/fahwebx.stanford.edu/cores/Linux/AMD64/Core_a4.fah/FahCore_a4 -dir 02 -suffix 01 -version 704 -lifeline 1978 -checkpoint 15 -np 3
17:51:36:WU02:FS00:Started FahCore on PID 2827
17:51:36:WU02:FS00:Core PID:2831
17:51:36:WU02:FS00:FahCore 0xa4 started
17:51:36:WU02:FS00:0xa4:
17:51:36:WU02:FS00:0xa4:*------------------------------*
17:51:36:WU02:FS00:0xa4:Folding@Home Gromacs GB Core
17:51:36:WU02:FS00:0xa4:Version 2.27 (Dec. 15, 2010)
17:51:36:WU02:FS00:0xa4:
17:51:36:WU02:FS00:0xa4:Preparing to commence simulation
17:51:36:WU02:FS00:0xa4:- Looking at optimizations...
17:51:36:WU02:FS00:0xa4:- Files status OK
17:51:36:WU02:FS00:0xa4:- Expanded 1952101 -> 6261824 (decompressed 320.7 percent)
17:51:36:WU02:FS00:0xa4:Called DecompressByteArray: compressed_data_size=1952101 data_size=6261824, decompressed_data_size=6261824 diff=0
17:51:36:WU02:FS00:0xa4:- Digital signature verified
17:51:36:WU02:FS00:0xa4:
17:51:36:WU02:FS00:0xa4:Project: 11660 (Run 20, Clone 2, Gen 205)
17:51:36:WU02:FS00:0xa4:
17:51:36:WU02:FS00:0xa4:Assembly optimizations on if available.
17:51:36:WU02:FS00:0xa4:Entering M.D.
17:51:42:WU02:FS00:0xa4:Using Gromacs checkpoints
17:51:42:WU02:FS00:0xa4:Resuming from checkpoint
17:51:42:WU02:FS00:0xa4:Verified 02/wudata_01.log
17:51:42:WU02:FS00:0xa4:Verified 02/wudata_01.trr
17:51:42:WU02:FS00:0xa4:Verified 02/wudata_01.xtc
17:51:42:WU02:FS00:0xa4:Verified 02/wudata_01.edr
17:51:43:WU02:FS00:0xa4:Completed 21040 out of 1250000 steps  (1%)
17:51:50:Removing old file 'configs/config-20170702-022335.xml'
17:51:50:Saving configuration to /etc/fahclient/config.xml
17:51:50:<config>
17:51:50:  <!-- Client Control -->
17:51:50:  <fold-anon v='true'/>
17:51:50:
17:51:50:  <!-- Network -->
17:51:50:  <proxy v=':8080'/>
17:51:50:
17:51:50:  <!-- Remote Command Server -->
17:51:50:  <password v='******'/>
17:51:50:
17:51:50:  <!-- Slot Control -->
17:51:50:  <power v='full'/>
17:51:50:
17:51:50:  <!-- User Information -->
17:51:50:  <passkey v='********************************'/>
17:51:50:  <team v='76140'/>
17:51:50:  <user v='LazyDev'/>
17:51:50:
17:51:50:  <!-- Folding Slots -->
17:51:50:  <slot id='0' type='CPU'>
17:51:50:    <cpus v='3'/>
17:51:50:  </slot>
17:51:50:  <slot id='1' type='GPU'/>
17:51:50:</config>
17:54:42:WU02:FS00:0xa4:Completed 25000 out of 1250000 steps  (2%)
17:55:11:WU01:FS01:0x21:Completed 50000 out of 5000000 steps (1%)
17:59:06:WU01:FS01:0x21:Completed 100000 out of 5000000 steps (2%)
18:02:58:WU01:FS01:0x21:Completed 150000 out of 5000000 steps (3%)
18:04:12:WU02:FS00:0xa4:Completed 37500 out of 1250000 steps  (3%)
18:06:35:WU01:FS01:0x21:Completed 200000 out of 5000000 steps (4%)
18:10:12:WU01:FS01:0x21:Completed 250000 out of 5000000 steps (5%)
18:12:57:WU02:FS00:0xa4:Completed 50000 out of 1250000 steps  (4%)
18:13:50:WU01:FS01:0x21:Completed 300000 out of 5000000 steps (6%)
LazyDev
 
Posts: 3
Joined: Tue Aug 30, 2016 7:28 pm


Return to Problems with NVidia drivers

Who is online

Users browsing this forum: No registered users and 1 guest

cron